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Chapter 1: Introduction
Moho is a complete animation system for creating 2D anime and cartoons. This 
document is the user’s manual, containing useful information to get you started, as 
well as a detailed reference to all of Moho’s features.

If you’re just getting started using Moho, the best place to begin is with the quick 
start tutorials, which appear in “Quick Start” on page 2 in your Moho Tutorial 
Manual. Choose Help > Tutorials to open the manual in PDF format. This section will 
give you a quick overview of how Moho works, and what you can do with it. Even if 
you’ve used Moho in the past, you might want to give the tutorials a quick read to 
see what’s changed in this version.

If you’ve been using Moho for a while now, and you want more information on some 
specific feature or interface element, choose the section that interests you from the 
table of contents.

Finally, if you’re having a problem that just isn’t answered in this document, please 
see “Appendix B: Technical Support” on page 534. We want to do everything we 
can to make using Moho a fun and productive experience.

Demo Limitations
If you haven’t purchased a copy of Moho, then the program will be running in 
demo mode. While in demo mode, Moho still allows you access to all features of the 
program. Anything you can do in the full version you can do in the demo. Also, any 
files you create with the demo version of Moho will still work fine if you purchase the 
full version.

The demo version has just three limitations: First, you can only run the demo version 
of Moho for 30 days. Second, you cannot import any external file formats including 
images and movies. Third, you cannot export your animations to other formats 
(QuickTime, AVI, Flash, etc.).

To purchase Moho, go to http://mohoanimation.com.

What’s New in Moho 13.5
Anime Studio has been renamed to Moho. Document types associated with Moho 
13.5 are as follows:

• .moho: The compressed project file extension (formerly .anime)

Anime Studio 11 will not recognize documents created with the 
.moho or .mohoproj extensions. You will get an error when 

trying to open a .moho document in the modern format.
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Legacy moho documents created in older versions of Anime 
Studio will generate an error message when you try to 

open them in Moho 13.5. To open them, change the file of the 
legacy moho document to anme. Moho 13.5 will then treat it as a 
legacy Anime Studio document and will prompt you to update it to 
the new format.

• .mohoproj: The uncompressed project file within the above-mentioned .moho 
project (formerly .animeproj)

• .mohobrush: Brushes saved from the Brush Settings dialog will be saved with this 
extension.

• .mohostyle: Styles that are exported with the File > Export Styles command

• .mohoaction: Actions that are exported from the Actions window.

New in Moho Debut and Pro
• Tool Improvements: The Freehand, Blob Brush, and Paint Bucket tools have 

improved smoothing algorithms and allow you to specify the amount of 
smoothing each tool will perform. See “Freehand” on page 49, “Blob Brush” 
on page 54, and “Paint Bucket” on page 67.

• New GUI: The Moho interface has been enhanced with new cleaner look, 
and includes easier options for personalization. Improvements have been 
implemented for both standard and ultra high resolution monitors.

• Switch Selection window: Switch layers can be selected more quickly and 
easily through the use of a separate window. See “Using the Switch Selection 
Window” on page 193.

• Auto-Freeze keys: Adds a keyframe for every bone in a character when any 
part is adjusted. See “Auto-Freeze Keyframes” on page 472.

• Pin Bones: The Bone tool now allows you to add “Pin Bones” (bones that have a 
zero length). See “More about Pin Bones” on page 90.

• Auto colored bones: Points are automatically colored to match the bone that 
they are bound to. See “Bind Points” on page 100 for more information.

• More bone and layer colors: Moho allows you to assign one of eleven different 
colors to the layers in your projects. See “Using Layer Colors” on page 177.

• New library: The Moho library has a new interface, displaying content 
information in several different user-definable columns. A search pane allows 
you to find content more easily. For more information, see “Chapter 14: The 
Library Window” on page 289. 

• New Layers window: The Layers window has been enhanced with columns that 
can be shown or hidden by preference. Content can be sorted in forward or 
reverse order by clicking a column header. For more information about the new 
Layers window, see “Chapter 10: Layers Window” on page 165
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• Absolute and relative path for file handling: All paths saved in a document are 
saved with a relative path and a full path whenever possible. Relative paths 
are relative to locations known by the application at runtime. If Moho is run on 
another machine that uses the same locations, Moho will be able to resolve the 
relative paths and find content, even though the full paths are different on both 
machines.

New in Moho Pro only
• Bezier handles for vectors: Moho now supports Bezier handles (found in 

programs such as Adobe Illustrator). Bezier handles are editable in Pro only, but 
are readable in Moho Debut. For more information, see “Editing Bezier Curves 
(Pro only)” on page 34.

• Smart Warp for images and vectors: Allows you to specify a triangulated vector 
layer that can be used to warp another vector or image layer. Because Moho 
now supports Bezier handles (found in programs such as Adobe Illustrator), 
vector import is improved because SVG files can now be imported without 
having to approximate curves. See “Smart Warp Layers (Pro only)” on page 
236.

• Vector Export: Moho now allows you to export sequential SVG files that can 
be edited in vector editing software (such as Adobe Illustrator). See “Exporting 
Sequential SVG Files (Pro only)” on page 417.

• Edit multiple layers in the timeline: Multiple layers can be displayed in 
the timeline, and they will all be displayed in the timeline along with their 
designated color labels (if applicable). See “Editing Multiple Layers” on page 
205 and “Displaying Multiple Layers in the Timeline” on page 362.

• Mute Channels: Animation channels can be muted in the timeline so that you 
can focus on the areas you want to work on. See “Muting Animation Channels 
(Pro only)” on page 363.

• Separate channel dimensions: You can now separate several types of 
channels so that you can work with each individually. For more information, see 
“Separating Timeline Channels (Pro only)” on page 121.

• Import/Export actions: The Actions window allows you to import and export 
actions so that you can share them between [rojects. See “Actions Window (Pro 
Only)” on page 366.

• Transform action to relative: A context menu in the Actions list includes a 
Convert to Relative command, which helps refit skeletons to characters with 
entirely different proportions. See “The Actions List Context Menu” on page 
368.

• Smart actions naming: If you have a bone selected before creating a smart 
bone, Moho 13.5 automatically names the action the same as the bone that is 
selected. See “Creating a Smart Bone Action” on page 105 and “Creating a 
Second Smart Bone Action” on page 108.

• Ignore IK constraint: The “Ignored by Inverse Kinematics” bone constraint 
option allows you to specify bones that will be ignored by the IK solver. For more 
information, see “Ignoring Inverse Kinematics (Pro only)” on page 88.
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• Personalize workspace templates: The File > New Workspace command allows 
you to choose a workspace template as a starting point for your new project. 
See “New Workspace (Pro Only)” on page 379.

• XMP metadata for projects and assets: Metadata such as tags, comments, and 
other categories can be added to project files and library items. The library 
allows searching for items based on these metadata strings. See  “Adding 
Metadata (Pro Only)” on page 302, and “Other Settings” on page 390.

• Add personalized root folders to the library: Use the Location Menu in the Library 
to add custom locations to your library. Folders beneath that custom location 
will be assigned relative paths so that files can easily be located on two different 
computers. For more information, see “Adding Custom Locations (Pro only)” on 
page 292.

• Moho Exporter: The Batch Exporter from previous versions of Anime Studio has 
been renamed to Moho Exporter, and offers an easier to use interface. Projects, 
layer comps, and actions can be added to the export queue directly from the 
Library as well as dragged and dropped from Windows Explorer or Mac Finder. 
For more information, see “Moho Exporter” on page 420.. 

• Comments and tags for layers: Comments and tags can be added to one or 
more selected layers in the General tab of the Layer Settings dialog. 

• Filters for easy layer search: The Search feature in the Library allows you 
to search and filter items based on several different types of metadata. 
See“Metadata Searches (Pro Only)” on page 295,

• Realistic motion blur: Motion blur has been enhanced to more accurately 
produce motion blurs that you get from a real world camera. Legacy motion 
blur is also provided as an option. See “Enhanced Motion Blur (Pro Only)” on 
page 223. 

• Export with Previous Settings: Save time with re-rendering animations by using 
the File > Export Animation with Previous Settings command to render an 
animation using the same settings as previously used. See “Export Animation 
with Previous Settings” on page 418.

System Requirements
Windows: 

• Windows ® 10

• 64-bit OS required

• 2.0 GHz Intel Core i3 or higher 

• 4 GB RAM or higher

• 1.6 Gb free hard drive space or higher

• OpenGL 4.1 supported graphics card required (1920x1080 recommended) **

• Online connection required to perform online activation
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Macintosh: 

• macOS® X 10.15, 10.16 or higher 

• 64-bit OS required

• 2.0 GHz Intel Core i3 or higher

• 4 GB RAM or higher

• 1.6 GB free hard drive space or higher

• OpenGL 4.1 supported graphics card required (1920x1080 recommended) **

• Online connection required to perform online activation

** For high pixel density displays, minimum resolution will vary according to the 
operating system recommended scaling level. For example, if the OS recommends 
a scaling level of 200%, the minimum requirement may be as high as 2736x1824 
resolution. Or if the OS recommends a scaling level of 150%, the minimum 
requirement may be as high as 2160x1440 resolution.

During installation, the Moho installer checks to see if a previous 
installation of the same installer exists on your system. 

The installer will prompt you to uninstall the previous version before 
continuing (recommended).

Installing Moho
Windows Installation
1. Start the Moho installation executable file. 

2. The Welcome to the Moho Setup Wizard screen appears. Click Next to 
continue.

3. The License Agreement screen appears. After you read the license agreement, 
click I accept the agreement. Then click Next to continue.

4. The Select Destination Location screen appears. The 64-bit version of Moho is 
automatically selected for installation by default. You can optionally install the 
32-bit version by checking Install 32-bit files. After you confirm or select your 
installation folders, click Next to continue.

 � The default installation location for the 64-bit version of Moho is c:\Program 
Files\Moho 13.5. Click the Browse button to select another folder on your 
hard drive, if desired.

 � The default installation location for the 32-bit version of Moho is c:\Program 
Files\Moho 13.5. Click the Browse button to select another folder on your 
hard drive, if desired.

5. The Select Start Menu Folder screen appears. By default, Moho files are placed 
in the Lost Marble\Moho 13.5 startup folder. Click Browse to choose another 
folder of your choosing. After you make your choice, click Next to continue.
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6. The Select Additional Tasks screen prompts you to choose whether or not you 
want to create a desktop icon. After you make your choice, click Next to 
continue.

7. The Ready to Install screen displays a summary of your choices. You can click 
the Back button to make changes to your settings. After you verify your choices, 
click Install to copy the installation files to your system as specified. 

8. After the files are installed, you will be prompted to restart the computer. 
Choose Yes to restart the computer, or No to restart later. Then click Finish.

Macintosh Installation
1. Double-click the installer package to open the Moho installer.

2. The Introduction screen appears. Click Continue.

3. The installer displays the readme file, which contains updated information about 
Moho 13.5. After you read, print, or save the document, click Continue.

4. The End User License agreement appears. If you click Continue, you will be 
prompted to agree to the license before installation is completed. Click Agree.

5. The Installation Type screen appears. You will be notified how much space the 
installation will require.Click Install to continue.

6. If you have user control enabled in OSX, you will be prompted to enter your 
username and password to authorize installation on your system. After entering 
the information, click Install Software.

7. After the files are written to your hard disk, you will be notified that installation is 
complete. Click Close to exit the dialog.

Activating Moho
After installing Moho, you will need to activate within a seven day grace period. If 
you do not activate Moho during the seven day grace period, it will not start until 
activated. You will need to reactivate in order to use the product.

If you try to run Moho after the seven day grace period has 
expired without activation, the application will not run. 

You will need to enter your serial number again when prompted to 
activate the application. 

Moho Debut and Moho Pro have been unified into the same 
application. Initially, Moho will run as Moho Debut, until 

it is licensed to use Moho Pro features. After licensing as Moho Pro, 
the application will relaunch with Pro features enabled.
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If you initially purchase Moho Debut 13.5 and later upgrade to 
Moho Pro 13.5, you can use the Help > Update License 

command to enter your Pro serial number and enable the Moho Pro 
features.

There are two modes of activation:

• If you have installed Moho on a computer that has an internet connection, see 
“Automatic Activation” on page 8.

• If you have installed Moho on a computer without an internet connection, see 
“Manual Activation” on page 9.

Automatic Activation
If your computer has an Internet connection, Moho can be activated as follows.

1. Start Moho. If the program is running in demo mode you will see the Moho 
demo dialog, which presents the following options.

 Moho Demo screen.

 � Buy Now: Opens your web browser to the Lost Marble online store, where 
you can purchase a licensed copy of Moho.

 � Insert Serial Number: Click this button to open the Product Activation 
screen. Note that serial numbers do not contain the letter O, but instead 
use the number 0.

 � Continue Using Demo: If the trial period has not been exceeded, click this 
button to continue using Moho in demo mode. The button will be disabled 
if the trial period has been exceeded.

 � Quit: Click this button to exit the Moho Demo screen and quit the 
application.

If you do not want to activate Moho when the Product 
Activation screen appears, click Activate Later.

2. In the Product Activation screen, enter your Registration Name, Registration 
Email, and Moho Serial Number (along with your Previous Serial Number (if 
upgrading). Note that serial numbers do not contain the letter O, but instead 
use the number 0.
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 Product Activation screen.

3. Check or uncheck other options such as receiving product announcements or 
allowing analytics information to be sent to Lost Marble.

4. Click Activate to activate your copy of Moho.

Manual Activation
1. Start Moho. If the program is running in demo mode you will see the Moho 

demo dialog, which presents the following options.

 Moho Demo screen.

 � Buy Now: Opens your web browser to the Lost Marble online store, where 
you can purchase a licensed copy of Moho.

 � Insert Serial Number: Click this button to open the Product Activation 
screen. Note that serial numbers do not contain the letter O, but instead 
use the number 0.
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 � Continue Using Demo: If the trial period has not been exceeded, click this 
button to continue using Moho in demo mode. The button will be disabled 
if the trial period has been exceeded.

 � Quit: Click this button to exit the Moho Demo screen and quit the 
application.

If you do not want to activate Moho when the Product 
Activation screen appears, click Activate Later.

2. In the Product Activation screen, enter your Registration Name, Registration 
Email, and Moho Serial Number (along with your Previous Serial Number (if 
upgrading). Note that serial numbers do not contain the letter O, but instead 
use the number 0.

 Product Activation screen.

3. Check or uncheck other options such as receiving product announcements or 
allowing analytics information to be sent to Lost Marble.

4. Click Activate to activate your copy of Moho. If an Internet connection is not 
detected, a dialog will prompt you to Try Again (used if you fixed an issue with 
an Internet connection that was temporarily not working); to Activate Later 
(which will exit the activation process), or to Activate Manually if you want to 
proceed with the activation process.
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 If an Internet connection is not detected, click Activate Manually.

5. The Manual Product Activation dialog appears. Click the Create Activation 
Request button to generate a text file named Moho_ActivationRequest.txt. This 
file contains the necessary activation information.

 Manual Product Activation screen.

6. Locate a folder and click Save to save the info.

It is recommended that you leave the Manual Product 
Activation dialog open while you generate the activation 

certificate on a computer that has an Internet connection. 

Use the Copy Activation URL button to copy the activation URL 
to your clipboard. The URL will navigate you to the 

Offline Activation Page at http://lostmarble.com/activation. Then 
create a new text file, and save it to your flash drive under a different 
filename (such as ActivationURL.txt). You can use this text file to 
retrieve the URL on your other computer.

7. Copy the activation request file that you saved in Step 6 onto a flash drive, 
so you can transfer it to a computer that does have an internet connection. 
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Transfer the files from the flash drive to the hard disk on a computer with an 
internet connection.

8. Open your web browser and go to the www.lostmarble.com web page.

9. From the Activation page, click the button to activate Moho.

10. From the Moho Offline Activation page, click the Choose File button to open 
the File Upload dialog. Locate the Activation Request file on your computer’s 
flash drive and click Open to return to the Activation web page.

11. Click the Submit button on the Activation web page. An activation_certificate.
txt file will be downloaded to your computer.

12. Copy the activation certificate file onto the flash drive, and then copy it back to 
the computer that doesn’t have an internet connection.

13. In the Manual Activation screen, click the Activate button to select the 
activation certificate file.

 Completing manual activation.

14. After you return to the Manual Product Activation dialog, click Activate.

Deactivating Moho
Activated licenses of Moho can also be deactivated automatically (see “Automatic 
Deactivation” on page 13), or manually (see “Manual Deactivation” on page 
13). Typical reasons for deactivation include the following:

• If you are planning on upgrading your operating system, we recommend that 
you deactivate Moho before the upgrade.

• If you have exceeded the number of activations per license (three)  you will 
need to deactivate one of the installations in order to install and activate it on 
another computer.
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After you deactivate your license, Moho will then display a dialog that tells you that 
your license is deactivated and that your copy of Moho will shut down.

Automatic Deactivation
If Moho is installed on a computer that has an internet connection, proceed as 
follows:

1. Choose Help > Deactivate License.

2. A dialog informs you that you are about to deactivate the license on your 
current computer. 

 � Choose Cancel to return to Moho without deactivating:

 � Choose Deactivate to deactivate your license. A dialog informs you that 
deactivation has occurred, and that Moho will shut down. Click OK to exit 
Moho.

 Completing automatic deactivation.

Manual Deactivation
If Moho is installed on a computer that does not have an internet connection, you 
will need to use the manual deactivation, as follows:

1. Choose Help > Deactivate License. Moho reminds you that you will need to 
reactivate Moho if you want to use it on the same computer. If you are sure you 
want to deactivate. Click Deactivate to continue.

2. You are again asked to confirm your decision. Click OK to continue. 

3. Moho displays a dialog if it detects that you are not connected to the Internet. 
Click Deactivate Manually to continue.
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 Click Deactivate Manually to continue.

4. The Manual Product Deactivation dialog appears. Click the Create Deactivation 
Request button to generate a text file named Moho_DeactivationRequest.txt. 
This file contains the necessary deactivation information.

 Create Deactivation Request button.

5. Locate a folder and click Save to save the deactivation request file.

Use the Copy Deactivation URL button to copy the 
deactivation URL to your clipboard. This saves a link 

that takes you to the Offline Deactivation page at http://lostmarble.
com/deactivation. Then create a new text file, and save it to your 
flash drive under a different filename (such as DeactivationURL.txt). 
You can use this text file to retrieve the URL on your other computer.

It is recommended that you leave the Manual Product 
Deactivation dialog open while you complete the process on a 

computer that has an Internet connection. 

6. Copy the Moho Pro_DeactivationRequest.txt file onto a flash drive, so you can 
transfer it to a computer that does have an internet connection. Transfer the 
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files from the flash drive to the hard disk of a computer that has an internet 
connection.

7. Open your web browser and go to the www.lostmarble.com web page.

8. From the Deactivation page, click the icon to deactivate Moho.

9. From the Moho Deactivation page, click the Choose File button to open the 
File Upload dialog. Locate the Moho_DeactivationRequest.txt file on your 
computer’s hard drive and click Open to return to the Deactivation web page.

You can use the Remove All Activations link on the bottom of 
the Offline Deactivation web page to deactivate your 

Moho license on every computer on which it is in use.

10. After the file is uploaded, click the Submit button on the Deactivation web 
page. You will receive a message when deactivation is successful.

11. Return to the Manual Product Deactivation dialog on the original computer and 
click Done. Deactivation is complete.

Activation and Analytics Logging
Generally, it is not necessary or beneficial to create a verbose log file. This data is 
beneficial for developers that are trying to diagnose problems. Verbose logging 
should only be done when requested by technical support.

To send the file to technical support, first launch Moho to reproduce the issue. After 
you quit Moho, go to the folder that is applicable for your version of Moho. Zip the 
.log file and send to technical support.

You can enable verbose activation or analytics error logging by placing a dummy 
text file named enable activation log.txt in the same folder where your 
activation license data is saved. Remove or rename the .txt file to disable verbose 
logging.

Locations are as follows:

• Windows: C:\ProgramData\Lost Marble\Moho Pro\13

• Mac: /Users/Shared/Library/Application Support/Lost Marble/Moho/13/License

When Moho launches, it will delete any files that have a .log extension at these 
locations. If the folder contains an Enable Activation Log.txt file, Moho will enable 
verbose logging for the activation/analytics library.

Getting Started
After you install Moho, you might want to familiarize yourself with the many features 
contained in the program.

When you start Moho, a splash screen presents the following options:

• Introductory Tutorial: Opens the Tutorial Manual, which you can also open using 
the Help > Tutorial Manual command from the Moho menu.
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• Join the Moho Forum: The Moho community is one of its biggest advantages. It’s 
full of great users and it’s growing bigger everyday. You can learn from other 
peoples’ experiences, ask for help and feedback, share your work and ideas 
and contribute with the knowledge! The developers are also very active in the 
Official Forum. Visit it here: www.lostmarble.com/forum

• Moho Social Networks: Get the latest news on Moho and Lost Marble and share 
your creations in the official Moho Facebook, Instagram, Twitter and YouTube 
channels. Find like minded animators and keep the conversation going!

• Buy Add-ons: Save design time and fuel your creative power with characters, 
props, scenery, brushes and more, created specifically for use within Moho.

• Don’t Show This Again: Choose this command to prevent the splash screen from 
opening each time you start Moho.

 Splash Screen (Moho Pro shown)

Creating a Content Folder
When you first start a serialized installation of Moho, you will be asked if you want to 
create a folder to store your custom content. 

When you select the location for your custom content folder 
and Moho finds an existing content folder named 

Anime Studio Debut or Moho Pro, Moho will offer to rename the 
folders to Moho Debut or Moho Pro, depending on your licensed 
version.

After the content folder is created, a hierarchy of folders appears beneath it. Any 
content stored in these locations will appear in the “My ...” folders in the Library (such 
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as “My Characters” in the Characters library and so on. This allows you to store user-
created word balloons, brushes, and other custom items that you can use in Moho.

The content library folder structure is as follows:
Moho Debut (or Moho Pro)
 brushes
 Character Wizard
 Extra Files
 Library
 Media Presets
 readme 12.0
 Render Cache
 Samples
 Scatter Brushes
 scripts
 Shared Resources
 Startup
 swatches
 Templates
 Tutorials
 Word Balloons
 Workspace Templates (Pro Only)

The Moho support files are also furnished in a similar version-
specific folder structure as listed above. Common files 

will be located in Resources/Support/common, Debut support files in 
Resources/Support/debut, and Pro support files in Resources/Support/
pro. Lua scripters that call the AppDir() function will need to update 
their scripts because the method now requires the Boolean 
parameter const char* AppDir(bool variantDir). If you pass true, you 
will get a path to the variant support folder for the version of Moho 
that is running (Debut or Pro). If you pass false you will get a path to 
the common support file (Support/common). You may need to scan 
both folders to suit the work of your script.

The Custom Content folder also serves other important functions:

• The support files for the Tutorial manual are found in the Custom Content 
Tutorials folders.

• Autosave information and files are stored in the Autosave subfolder. If you do 
not create a custom content folder, autosave information will not be stored.

• If you open a file in Moho that contains a reference to a project file that is not 
found in its original location, Moho will look in your Custom Content location 
to try to find a file of the same name in its Shared Resources folder, or one of 
its subfolders. These folders must exist at launch, or when the Custom Content 
folder is included in your search paths. If there are multiple files of the same 
name in your Shared Resources folder or subfolder, Moho will match against the 
first one it finds.

When Moho prompts you to create a custom content folder, the choices are as 
follows:
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 Choosing a content folder.

• Choose: Select this option to browse to the folder that you want to use for your 
Moho content. After you select/create the folder, choose OK.

If you choose to never show the dialog that prompts you to 
create a content folder, you can specify its location at any 

time to in the General tab of the Preferences dialog. See “General 
Tab” on page 435 for more information.

• Not Now: Choose this option if you want to set up the folder at a later time. You 
will be prompted with this dialog the next time you start Moho.

• Never: Choose this option if you do not want to set up a folder, and no longer 
want to receive this prompt when you start Moho.

When the User Content folder is created or updated, Moho 
appends the version number of the application to the name of 

the Readme folder.

Choosing Your Startup Mode (Debut 
Only)
You can also switch to and from Beginner Mode by checking or unchecking the 
Beginner Mode option in the upper-right corner of the Moho user interface. When 
you check that option, the tool box on the left side displays the most commonly 
used tools as shown in the next figure.

 Beginner Mode option

Standard Mode
If you choose Standard mode, various tools appear in the tool bar at the left side 
of the interface. If the number of tools feels overwhelming to you as a new user of 
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Moho, you can configure Moho to display the most commonly used tools, along with 
introductory videos that show you how to use them.

 Standard UI

Beginner Mode
If you are new to Moho, you may find that the beginner’s interface will be a good 
place to start.

 Beginner Mode UI

When in the Beginner Mode, the tool box displays the following:
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• Draw Tools: Displays the Select Points, Transform Points, Add Point, Freehand, 
Draw Shape and Delete Edge tools. For more information on these tools, see 
“Chapter 3: The Draw Tools” on page 32.

• Fill Tools: Displays the Select Shape, Create Shape, and Paint Bucket tools, all 
discussed in “Chapter 4: Fill Tools” on page 62.

• Bone Tool: Displays the Manipulate Bones tool, discussed in “Chapter 5: Bone 
Tools” on page 82.

• Layer Tools: Displays the Transform Layer tool, discussed in “Chapter 6: Layer 
Tools” on page 117.

• Workspace Tools: Displays the Pan tool, discussed in “Chapter 7: Camera and 
Workspace Tools” on page 138.

• Tool Tip: As you hover the mouse over any tool, a Tool Tip displays the name of 
the tool, along with a keyboard shortcut that you can use to select the tool at 
any time.

• Tool Help: When a tool is selected, an extended description of the tool 
appears in the lower section of the tool box. The description also includes basic 
instructions on how to use the selected tool.

• Video Button: Click the Video button in the extended description area to watch 
a video that shows you how to use the selected tool.

 Beginner Mode Tools



Moho 13.5
Users Manual 

21

Chapter 1: Introduction

Automatic Update Checking
If you want to configure Moho to automatically check for updates, you can open 
the Preferences dialog, and check the Automatically check for updates option 
in the General tab. To manually check for updates, choose the Help > Check for 
Updates command.
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Chapter 2: License
Moho Debut 13.5

Moho Pro 13.5

End User License Agreement and 
Limited Warranty
PLEASE READ THIS END USER LICENSE AGREEMENT (“EULA”) CAREFULLY BEFORE 
INSTALLING AND USING THE SOFTWARE. BY CLICKING THE “AGREE” BUTTON WHEN 
INSTALLING THE SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS 
EULA. IF YOU DO NOT AGREE TO THE TERMS OF THIS EULA, CLICK ON THE “DISAGREE” 
BUTTON. IF YOU DO NOT AGREE TO THE TERMS OF THIS EULA, YOU MAY NOT USE 
OR ACCESS THE SOFTWARE. USING OR ACCESSING ANY PART OF THE SOFTWARE 
INDICATES THAT YOU AGREE TO THE TERMS OF THIS EULA.

This EULA is between you (both the individual installing the Software and any single 
legal entity on behalf of which such individual is acting) (“you” or “your”) and Lost 
Marble LLC and/or its affiliates (collectively or individually, “LOST MARBLE”).

1. General
You agree to use the Software, Documentation and Content only for lawful 
purposes. You are not permitted to use the Software, Documentation or Content 
other than as expressly granted in this EULA.  LOST MARBLE maintains an ongoing 
EULA enforcement program. Violation of any provision of this EULA automatically 
terminates this EULA. LOST MARBLE reserves all other rights that it may have for 
violation of this EULA.

2. Definitions
“Content” means animations, characters, clothing, faces, hair, geometries, images, 
documentation, materials, meshes, morphs, motion files, props, scripts, textures, 
bump maps, transparencies, and similar files and data created or modified with the 
intent of being used within the Software and/or third party applications.

“Documentation” means all written material in any form for installation and use 
of the Software provided by or made available by LOST MARBLE, or its authorized 
representatives or agents.

“Legitimate Uses” means (a) creating tutorials, books, or other educational 
materials using images of the Software interface or Content for sale, distribution, 
public display, or public performance, provided such materials are intended to 
educate users  as to use of the Software; (b) creating original Content for sale, 
distribution, public display, or public performance; (c) creating materials for use 
with either Restricted Content or Other Content; (d) modification, distribution and 
selling of scripts; (e) creating rendered animations or rendered still images based on 
Restricted Content contained in the library or with the “Character Wizard” feature 
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of the Software; or (f) creating characters or props based on Restricted Content in 
proprietary file formats (meaning, MOHO, ANME and any subsequent/ compressed 
formats), where the original (or modified) art, texture or other Restricted Content 
files are not distributed with such characters or props. When in doubt with respect to 
legitimate uses, contact Lost Marble LLC, at legal@lostmarble.com.

“Other Content” means Content that is not Restricted Content or Unrestricted 
Content. Other Content may be subject to license terms imposed by the Other 
Content’s original creator.

“Restricted Content” means all Content included with or part of the Software that 
is not Unrestricted Content, including without limitation mesh objects (geometry) 
in any format, files in proprietary file formats (meaning, MOHO, ANME, and any 
subsequent/compressed formats), images, materials, texture, transparency maps, 
Documentation, vector-based content, and LOST MARBLE’s proprietary data. Except 
as otherwise expressly permitted by this EULA, Restricted Content extracted or 
exported from the Software remains Restricted Content. Except as authorized in this 
EULA, Restricted Content may only be used exclusively on one (1) computer.

“Software” means the LOST MARBLE computer software and associated files (e.g. 
Content) delivered via the accompanying physical media or electronic media. 
“Software” also includes any upgrades, updates, bug fixes or modified versions or 
backup copies of the Software supplied to you by LOST MARBLE or an LOST MARBLE 
authorized representative or agent (whether or not for a fee). “Software” does not 
include TPS (defined below).

“Unrestricted Content” means Content included with or part of the Software that 
is specifically identified in the Documentation or listed in this EULA as Unrestricted 
Content. This version of the Software contains no Unrestricted Content.

3. Software License
A) Subject to the terms and conditions of this EULA and your payment of the 
applicable license fee, LOST MARBLE grants you a limited, personal, nontransferable 
and non-exclusive license (without right to sublicense): (i) to use a single copy of the 
Software (except as expressly permitted in the Documentation) solely for your own 
internal use on a single computer (as set forth in Subsection E below of this Section 
3) either loaded in the temporary memory (i.e., RAM) of a computer, or installed on 
the permanent memory of a computer (e.g., hard disk and compact disk) or, on a 
temporary basis, on a backup system if such equipment is inoperative, consistent 
with the limitations specified or referenced in this EULA and the Documentation; (ii) 
to use the Documentation provided with the Software in support of your authorized 
use of the Software; and (iii) to copy the Software to make one (1) archival copy 
of the Software for your personal archival or backup purposes, and to make 
sufficient number of copies for Legitimate Uses or the intended use described in the 
Documentation, provided that all titles and trademark, copyright and restricted 
rights notices are reproduced on all such copies. Any other uses of the Software, 
including without limitation the Software interface, other than those granted in this 
EULA must be expressly pre-approved by LOST MARBLE in writing. The terms of this 
EULA will govern any upgrades and updates, unless accompanied by a separate 
license, in which case, the terms of that separate license agreement will govern 
accordingly.
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B) The Software is protected by copyright and other intellectual property laws and 
international treaties. As an express condition of this EULA, you must reproduce 
on the backup copy the LOST MARBLE copyright notice in the following format: 
“Copyright (C) 2004-2021 Lost Marble LLC All Rights Reserved.” This express condition 
extends to any further updates, software patches, or bug fixes made available to 
you by LOST MARBLE, whether distributed on floppy disk, compact disk, or in an 
electronic format via download, BBS, forum, FTP, e-mail, etc.

C) The Software (not including the media on which the Software may be provided) is 
licensed to you, not sold. You expressly acknowledge that LOST MARBLE, Lost Marble, 
Inc., and/or their respective licensor(s) have a valuable proprietary interest in both 
the Software and the Documentation. All title, ownership, interest and rights in and 
to the patent, copyright, trademark, trade secret and any other intellectual property 
rights in the Software (and any derivative works thereof) and the Documentation 
(and any derivative works thereof) not expressly granted to you by this EULA remain 
with LOST MARBLE and/or their respective licensor(s). You do not acquire any other 
rights, express or implied, in the Software (and any derivative works thereof) and 
the Documentation (and any derivative works thereof) other than those rights 
expressly granted under this EULA. Without limiting the generality of the foregoing, 
LOST MARBLE and/or their respective licensor(s) retain all title, ownership, interest 
and rights in and to the patent, copyright, trademark, trade secret and any other 
intellectual property rights in the copy of the Software contained on your archival 
media, and all of the terms of this EULA apply to such archival copy as if it were the 
original LOST MARBLE-produced copy of the Software that was furnished to you 
when you paid the licensing fee.

D) Portions of the Software include third party software and other copyrighted 
material (collectively, “TPS”). Acknowledgements, licensing terms, restrictions and 
disclaimers of such TPS are contained in the “About Box” of the Software and your 
use of such TPS is governed by such respective terms. Any terms of this EULA that 
differs from the terms of any TPS are offered by LOST MARBLE alone, and not by any 
third party.

E) xcept as otherwise expressly permitted in the Documentation, you will only use the 
Software on a single computer at any given time, meaning that you must treat the 
Software “like a book.” “Like a book” means that the Software may be used by any 
number of people and may be installed and activated on up to three (3) computers 
so long as no possibility exists of the Software being used at more than one (1) 
computer at any given time. More than one person at a time cannot read the same 
copy of a book, and this restriction applies to the Software.

F) The licenses granted in this EULA do not allow you to use the Software on a 
computer that you do not own or control, and you may not distribute or make the 
Software available over a network where it could be used by multiple computers or 
devices at the same time.

4. Restrictions
A) You will not, and will not permit any third party to, use, copy, modify, derive, 
or transfer the Software or Documentation, or any copy, modification, derivation, 
or merged portion thereof, in whole or in part via any means or for any purpose 
whatsoever except as expressly permitted in this EULA or the Documentation. You 
will not, and will not permit any third party to, modify, adapt, translate, rent, lease, 
loan, resell for profit, or create derivative works based upon the Software or any 
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part thereof. The Software contains trade secrets in its human readable form and, to 
protect them, you will not, and will not permit any third party to, reverse engineer, 
decompile, disassemble, or otherwise reduce the Software to any human readable 
form without the express prior written consent of LOST MARBLE or except to the 
extent expressly permitted by applicable law. You will not relicense, sublicense, 
rent, lease, or lend the Software for third-party training, commercial time-sharing 
or service bureau use. You will not, and will not permit any third party to, debug, 
bypass, circumvent or defeat any security features of, or interfere with the normal 
functionality and operation of the Software for any reason whatsoever without 
the express prior written consent of LOST MARBLE or except to the extent expressly 
permitted by applicable law. If the Software is an upgrade to a previous version of 
the Software, you must possess and maintain a valid license to such previous version 
in order to use the upgrade.

B) You, your employees, and/or authorized agents must protect the Software’s 
confidentiality and act to enforce your obligations under this EULA. You cannot 
distribute or otherwise make the Software or Documentation available to any third 
party via any means whatsoever, public or private, for any purpose, commercial or 
not, unless explicitly allowed by this EULA.

C) You assume full responsibility for your selection of the Software to achieve 
your intended results and for the installation, use, and results you obtain from 
the Software. LOST MARBLE has no obligation to provide support, maintenance, 
upgrades, modifications or new releases under this EULA.

5. Content License
A) Subject to the terms and conditions of this EULA and your payment of the license 
fee, LOST MARBLE grants you a limited, personal, nontransferable and non-exclusive 
license (without the right to sublicense):

1) To reproduce, prepare derivative works based upon, distribute, publicly 
display and publicly perform the Unrestricted Content for any lawful purpose 
other than to create a product which is intended to compete with the Software 
or to create new content which is intended to compete with the Restricted 
Content.

2) To prepare derivative works based upon the Restricted Content solely for 
Legitimate Uses and lawful uses.

3) To reproduce, prepare derivative works based upon, distribute, publicly 
display, and publicly perform content you create using Restricted Content, 
provided that such use of Restricted Content shall be solely for Legitimate Uses 
and lawful uses.

B) Notwithstanding the foregoing, nothing shall limit LOST MARBLE’s right to 
independently create, develop, own, market, distribute, license, sublicense, import, 
export, sell, or otherwise exploit any content or materials similar to any derivative 
works based upon the Content.

C) Other Content included with the Software and Documentation is subject to 
third-party rights and is copyrighted and owned by the Other Content’s original 
creator(s). You may use the Other Content in accordance with all applicable 
license terms imposed by the Other Content’s original creator(s). LOST MARBLE 
makes no representations as to the quality, suitability, functionality, or legality of 
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the Other Content and you hereby waive any claim you might have against LOST 
MARBLE with respect to the Other Content.

D) You will not, and will not permit any third party to, use, copy, modify, derive, sell, 
distribute, transfer or sublicense the Restricted Content, the Unrestricted Content,  
or the Other Content or any copy, modification, derivation, or portion thereof, in  
whole or in part via any means or for any purpose whatsoever, except as expressly 
permitted in this EULA or the Documentation.

E) You expressly acknowledge that LOST MARBLE and/or their respective licensor(s) 
have a valuable proprietary interest in the Restricted Content and the Unrestricted 
Content. All title, ownership, interest and rights in and to the patent, copyright, 
trademark, trade secret and any other intellectual property rights in the Restricted 
Content (and any derivative works thereof) and the Unrestricted Content (and 
any derivative works thereof) not expressly granted to you by this EULA remain with 
LOST MARBLE and their respective licensor(s). You do not acquire any other rights, 
express or implied, in the Restricted Content (and any derivative works thereof) and 
the Unrestricted Content (and any derivative works thereof) other than those rights 
expressly granted under this EULA.

F) Except as otherwise expressly permitted in the Documentation or unless otherwise 
provided for herein, you will only use the Content on up to one (1) computer at 
any given time (the same as the Software license allows), meaning that you must 
treat the Content “like a book.” LOST MARBLE is pleased to offer site licenses (“Site 
License”) for multiple simultaneous users. Please contact LOST MARBLE at the address 
below for details. If you purchased a Site License, you may distribute the Restricted 
Content between all computers containing valid copies of the Software, other LOST 
MARBLE products, and/or other software able to process Restricted Content.

6. Collection and Use of Your Information
A) Activation of the Software is REQUIRED in order to use the Software.  You must 
have a valid serial number in order to complete the activation process of the 
Software. Upon your first installation of the Software, you will be prompted to 
activate the Software, and the Software will attempt to automatically connect to 
the Internet. Please be sure you have an Internet connection when initially installing 
the Software in order to activate the Software. The Software includes instructions 
regarding activation if you are not connected to (or unable to connect to) the 
Internet when attempting to complete the activation process of the Software. To 
complete the activation process, you will need to provide your name, valid e-mail 
address and applicable valid serial number for activating the Software.

B) As part of the activation process you will have the option to “opt-in” to receive 
product announcements and offers from LOST MARBLE.  In addition, as part 
of the activation process, you will have the option to “opt-in” to participate in 
LOST MARBLE’s efforts to  improve the usability, experience, functionality and 
performance of its products and services. Your participation to allow LOST MARBLE 
to collect such usage statistics is voluntary and you may “opt out” at any time. If 
you choose to participate, LOST MARBLE may collect and use certain information 
related to the Software and your use of the Software that include information about: 
(i) your computer, such as Operation System, screen resolution, RAM capacity, CPU 
frequency, number of monitors; (ii) data about the Software, such as abnormal 
terminations, number of runs, program version; and (iii) information about separate 
feature usage, such as menu options or buttons selected. The information described 
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in (i) – (iii) above will be combined and utilized in an anonymous manner to help 
LOST MARBLE’s efforts as noted above. If you are not comfortable sharing the 
foregoing described information, please choose not to participate.

C) LOST MARBLE is very concerned with the privacy and security of the information 
end users provide as part of the registration, activation and opt-in processes 
described above. Any information collected described above is done and utilized 
in accordance with LOST MARBLE’s Privacy Policy. Your election to use the Software 
indicates your acceptance of the terms of the LOST MARBLE Privacy Policy, so 
please review the policy carefully and check our website at the following URL to 
review updates: www.lostmarble.com. Further, if you are located in the European 
Economic Area (EEA), your use of the Software constitutes consent by you to LOST 
MARBLE’s and/or its affiliates’ to the transfer of such information to a location outside 
the EEA..

7. Term; Termination
A) This EULA remains in full force and effect until terminated. You may terminate this 
EULA at any time by returning or destroying both the Software and Documentation, 
together with all copies, modifications, and merged portions of the Software and 
the Documentation in any form. LOST MARBLE is in no way obliged to issue refunds. 
LOST MARBLE may terminate this EULA at any time upon your breach of any of the 
provisions hereof.

B) Upon termination, you will immediately cease all use of the Software, and you 
must return or destroy the Software, Documentation, and all copies, modifications, 
and merged portions of the Software and the Documentation in any form and 
certify in writing your compliance of this paragraph to LOST MARBLE. Termination of 
this EULA for any reason in no way limits LOST MARBLE’s right to continue enforcing 
all rights provided by law and does not entitle you to a refund of your license fees, 
except as provided herein. All provisions of this EULA that protect LOST MARBLE’s 
proprietary rights continue in full force and effect after termination.

8. Export Law Assurances
Export and re-export of this Software and Documentation is governed by the laws, 
restrictions and regulations of the United States and applicable export and import 
laws, restrictions and regulations of certain other countries (collectively, “Export 
Laws”). You will comply with all such Export Laws. Export or re-export of this Software 
and/or Documentation (including any direct product thereof) to any entity on 
the Denied Parties List and other lists promulgated by various agencies of the 
United States Federal Government is strictly prohibited. In addition, if the Software 
is identified as an export controlled item under the Export Laws, you represent and 
warrant that you are not a citizen of, or located within, an embargoed or otherwise 
restricted nation (e.g., Iran, Syria, Sudan, Cuba and North Korea) and that you are 
not otherwise prohibited under the Export Laws from receiving the Software.

9. Limited Warranty and Disclaimer
A) LOST MARBLE warrants that any media on which the Software may be provided 
will be free from defects in materials and workmanship under normal use for 
a period of ninety (90) days from the date of original purchase. Your exclusive 
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remedy and LOST MARBLE’s entire liability under this limited warranty will be for LOST 
MARBLE, at its option, to replace the Software media or refund the purchase price 
of such Software media. This limited warranty is offered solely by LOST MARBLE and 
does not apply to any third party product, software, content or service offerings. 
THE ABOVE WARRANTIES ON MEDIA ARE EXCLUSIVE AND IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, AND LOST MARBLE EXPRESSLY DISCLAIMS ALL 
OTHER WARRANTIES, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF 
MERCHANTABILITY, SATISFACTORY QUALITY, FITNESS FOR A PARTICULAR PURPOSE, OR 
NON-INFRINGEMENT.

B) TO THE EXTENT NOT PROHIBITED BY APPLICABLE LAW, THE SOFTWARE, RESTRICTED 
CONTENT, UNRESTRICTED CONTENT, AND DOCUMENTATION ARE LICENSED TO YOU 
“AS IS” WITH ALL FAULTS, WITHOUT WARRANTY, CONDITION OR REPRESENTATION, 
EXPRESS OR IMPLIED, OF ANY KIND, INCLUDING WITHOUT LIMITATION, 
MERCHANTABILITY, PERFORMANCE, SECURITY, SATISFACTORY QUALITY, NON- 
INFRINGEMENT OF THIRD PARTY RIGHTS, OR FITNESS FOR A PARTICULAR PURPOSE.

C) YOU ACKNOWLEDGE THAT THE SOFTWARE MAY NOT (I) SATISFY ALL YOUR 
REQUIREMENTS, (II) BE FREE FROM DEFECTS, OR (III) OPERATE WITHOUT INTERRUPTION 
OR ERRORS. IN ADDITION, DUE TO CONTINUAL DEVELOPMENT OF NEW TECHNIQUES 
FOR INTRUDING UPON AND ATTACKING NETWORKS, LOST MARBLE DOES NOT 
WARRANT THAT THE SOFTWARE WILL BE FREE OF VULNERABILITY TO INTRUSION OR 
ATTACK.

D) THE FOREGOING LIMITED WARRANTY IS NEITHER A SERVICE NOR A SUPPORT 
CONTRACT. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY LOST 
MARBLE, ITS EMPLOYEES, DISTRIBUTORS, DEALERS, REPRESENTATIVES OR AGENTS SHALL 
INCREASE THE SCOPE OF THE ABOVE WARRANTIES OR CREATE ANY NEW WARRANTIES. 
YOU MAY HAVE ADDITIONAL WARRANTY RIGHTS UNDER LAW WHICH MAY NOT BE 
WAIVED OR DISCLAIMED. LOST MARBLE DOES NOT SEEK TO LIMIT YOUR WARRANTY 
RIGHTS TO ANY EXTENT NOT PERMITTED BY LAW. This Section 9 and Section 10, below, 
shall survive any termination of this EULA, howsoever caused, but this will not imply or 
create any continued right to use the Software after termination of this EULA.

10. Disclaimer of Liabilities
A) EXCEPT FOR THE EXCLUSIVE REMEDY OFFERED BY LOST MARBLE ABOVE AND 
REMEDIES  THAT CANNOT BE EXCLUDED OR LIMITED BY APPLICABLE LAW, IN NO EVENT 
WILL LOST MARBLE OR ITS DEVELOPERS, SUPPLIERS, DIRECTORS, OFFICERS, EMPLOYEES, 
OR SUBSIDIARIES OR AFFILIATES BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, 
INCIDENTAL OR  INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS 
PROFIT, BUSINESS INTERRUPTION, LOSS OF DATA AND/OR BUSINESS INFORMATION, 
AND THE LIKE), WHETHER FORESEEABLE OR UNFORESEEABLE, ARISING OUT OF THE 
USE OR INABILITY TO USE THE SOFTWARE OR DOCUMENTATION, REGARDLESS OF THE 
BASIS OF THE CLAIM, EVEN IF LOST MARBLE HAS BEEN ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGES OR FOR ANY CLAIM BY ANY OTHER PARTY. IN NO EVENT WILL LOST 
MARBLE’S AGGREGATE LIABILITY (OR THAT OF ITS DEVELOPERS, SUPPLIERS, DIRECTORS, 
OFFICERS, EMPLOYEES, OR SUBSIDIARIES OR AFFILIATES), UNDER OR IN CONNECTION 
WITH THIS EULA, EXCEED THE AMOUNT PAID BY YOU FOR THE SOFTWARE, IF ANY. 
THIS LIMITATION WILL APPLY EVEN IN THE EVENT OF A FUNDAMENTAL OR MATERIAL 
BREACH OR A BREACH OF THE FUNDAMENTAL OR MATERIAL TERMS OF THIS EULA.

B) The above limitations will apply even if any warranty or remedy provided under 
this EULA fails of its essential purpose. The above limitations will not apply in case 
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of personal injury (including death) only where and to the extent that applicable 
law requires such liability. Because some jurisdictions do not allow the exclusion or 
limitation of implied warranties or liabilities for consequential or incidental damages, 
the above limitations may not apply to you.

11. Indemnification
You will indemnify and hold harmless, and at LOST MARBLE’s request defend, 
LOST MARBLE and its affiliates, successors and assigns from and against any and 
all claims, losses, liabilities, damages, settlements, expenses and costs (including, 
without limitation, attorneys’ fees and court costs) which arise out of or relate to any 
third party claim or threat thereof that your use of the Software, Documentation or 
Content is unlawful or not otherwise permitted by this EULA. LOST MARBLE reserves 
the right, at its own expense, to assume the exclusive defense and control of any 
matter otherwise subject to indemnification hereunder.

12. U.S. Government Restricted Rights
The Software and Documentation are provided with RESTRICTED RIGHTS. The 
use, duplication, or disclosure by the United States Government is subject to 
restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and 
Computer Software Clause at DFARS 252.227-7013 or subparagraph (c)(1) and (2)  
of the Commercial Computer Software Restricted Rights at 48 CFR 52.227-19, as 
applicable. The Manufacturer is Lost Marble LLC, 2605 Camino Tassajara, #2594, 
Danville, CA 94526.

13. Applicable Law
This EULA shall be governed by the laws of the State of California, without giving 
effect to any choice of law principles. This EULA will not be governed by the 
United Nations Convention on Contracts for the International Sales of Goods, the 
application of which is expressly excluded. Exclusive jurisdiction over and venue of 
any suit arising out of or relating to this EULA will be in the state and federal courts of 
Contra Costa County, California. If for any reason a court of competent jurisdiction 
finds any provision, or portion thereof, to be invalid or unenforceable, the remainder 
of this EULA shall continue in full force and effect. The waiver by either party of any 
default or breach of this EULA will not constitute a waiver of any other or subsequent 
default or breach. You may not assign, sell, transfer, delegate or otherwise dispose 
of, whether voluntarily or involuntarily, by operation of law or otherwise, this EULA or 
any rights or obligations under this EULA without LOST MARBLE’s prior written consent. 
Any purported assignment, transfer or delegation by you will be null and void. This 
EULA constitutes the entire agreement between the parties and supersedes all prior 
or contemporaneous agreements or representations, written or oral, concerning the 
subject matter of this EULA.

14. Other Services and Materials
This Software may enable access to LOST MARBLE and/or third party services and 
websites (individually and collectively referred to as “Services”). This EULA does 
not apply to any Services. You acknowledge and agree that nothing in this EULA 
guarantees availability or continued availability or uptime of any Services. LOST 
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MARBLE has no control over any third party Services. Any terms, conditions, privacy 
policies, warranties, or representations associated with any third party Services are 
solely between you and such third party. LOST MARBLE makes no representations 
or warranties as to the quality, suitability, functionality, or legality of any third party 
Services, and You hereby waive any claim you might have against LOST MARBLE 
regarding any use of any third party Services.

You understand that by using any of the Services, You may encounter content that 
may be deemed offensive, indecent, or objectionable, which content may or may 
not be identified as having explicit language, and that the results of any search or 
entering of a particular URL may automatically and unintentionally generate links or 
references to objectionable material. In addition, you agree not to use the Software 
to create content that may be deemed offensive, indecent, or objectionable; 
hateful, threatening, or pornographic; incites violence; or contains nudity or graphic 
or gratuitous violence. Nevertheless, you agree to use the Services at your sole 
risk and that the LOST MARBLE shall not have any liability to you for content that 
may be found to be offensive, indecent, or objectionable; hateful threatening or 
pornographic; incites violence; or contains nudity or graphic or gratuitous violence.

15. Contact Information
If you have questions concerning this EULA or need to contact Customer Service, 
please contact LOST MARBLE at this address: Lost Marble LLC, 2605 Camino 
Tassajara, #2594, Danville, CA 94526; Customer Support (returns, warranty): support@
lostmarble.com; and Legal (EULA questions, illegal activity reporting): legal@
lostmarble.com.

16. Copyright & Trademark Notice
Lost Marble, Anime Studio, Moho, Moho Debut and Moho Pro are trademarks 
of Lost Marble LLC. All other product names mentioned in the Software, the 
Documentation, or other documentation are used for identification purposes only 
and may be trademarks or registered trademarks of their respective companies. 
Registered and unregistered trademarks used herein are the exclusive property 
of their respective owners. For purposes of Japan law regarding unregistered 
trademarks (e.g., a pending trademark application), the right in and to a trademark 
in Japan may not be exclusive until it is validly registered. You may not remove, 
modify, alter, cover or deface any trademark, trade names, product names, logo, 
copyright or other proprietary notices, legends, symbols or labels in the Software 
and Documentation. This EULA does not authorize you to use LOST MARBLE’s or its 
licensors’ names or respective trademarks. Further, any reference to any third party 
commercial products, processes or services by trade name, trademark, logo, and 
company and/or product/service names mentioned or displayed in the Software 
(and in any of its related Documentation and materials in any form) does not 
constitute or imply LOST MARBLE’s endorsement, recommendation or favoring by 
LOST MARBLE or any of its suppliers/ licensors.

Version: 20210209-Moho Debut/Moho Pro
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Moho Tools
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Chapter 3: The Draw Tools
Draw tools are used to draw and modify vector artwork. The following tools are 
available when you’re working with a vector layer. Most of these tools are used by 
selecting them from the toolbar then clicking and dragging in the working area 
of the main window - a few are used simply by clicking on them, and this is noted 
below. If you hold the mouse over a tool, a tooltip will appear with the name of the 
tool if you need a quick reminder. Also, most tools have a shortcut key that can be 
used to activate them. If a tool has such a shortcut, this will show up in the tooltip as 
well.

 Draw Tools (Moho Debut)

 Draw Tools (Moho Pro)

Moho has a smart tool palette, which shows and hides tools 
based on their need. The position of the tool shown in 

the screenshots may differ, depending on the selected layer in the 
Layers Window, and the current time in the timeline.

Click the tool icon in the properties bar to display a submenu. 
Choose Reset Tool to reset the current tool to its default 

settings. Choose Reset All Tools to reset all tools to their default 
settings.

Reset tool options.

When drawing with the draw tools, you can manually choose to use legacy curves 
(such as those used in Anime Studio 6 and earlier) in the Layer Settings dialog. Select 
the layer you want to change in the Layers Window, and open the Layer Settings 
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dialog to the Vectors tab. In Moho Pro, you can check the Legacy Curves option to 
use the old method of rendering curves.

 You can choose legacy curves in Moho Pro for compatibility with older scenes 
created in Anime Studio 6 and earlier.

 Normal curves (left) vs Legacy curves (right).
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Working with Bezier Curves
Previous versions of Moho have always worked with Bezier curves behind the scenes, 
but the control handles have been hidden. Moho 13.5 offers improved support of 
Bezier Curves. Bezier curves improve the appearance of vector and text objects 
because they are more accurate and use fewer points. The Freehand, Blob Brush, 
and Paint Bucket tools use a new algorithm that utilizes Bezier curve technology to 
create less points on each stroke. 

Bezier handles are read-only in Moho Debut. Moho Pro allows 
you to read and edit bezier curves.

Bezier curves are read-only in Moho Debut 13.5. You will be able to see the curve, 
but you will not be able to modify it because the handles will not be visible. The 
vector creation tools in Moho Debut 13.5 will remain the same as those found in 
Anime Studio 11, and you will still be allowed to increase or decrease the curvatures.

Editing Bezier Curves (Pro only)
Beginning in Moho Pro 13.5, you can display the Bezier handles to modify the shapes 
of the curves. When you import vector formats such as SVG, the number of points 
in the imported object are reduced because Moho uses the Bezier curves from the 
objects that you are importing.

 You can choose legacy curves for compatibility with older scenes created in Anime 
Studio 6 and earlier.

Two Bezier handles options appear with the Add Point tool (described in “Add Point” 
on page 45) and the Transform Points tool (described in “Transform Points” on 
page 41).

• Show Bezier Handles: Displays the Bezier Handles so that you can manipulate 
them. Note that whenever you move a point in a curve, the Bezier handles 
automatically adjust to reshape the curve. 
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 � You will need to click the Show Bezier Handles button in order to edit the 
curves. 

 � After displaying the handles, use the Transform Points tool to tweak the 
position of the handles. 

You can also use the Curvature tool to reshape the end 
handles on the Bezier curve.

 � Drag the center point in the handle to reposition the point. The handles at 
the end of the bezier curve will automatically adjust as necessary to create 
a smooth curve. 

 Drag the center point in the handle to reposition the point.

 � Drag either end of the handle to reshape the curve directly.

 Drag the end point in the handle to reshape the curve.

 � Press the Alt key while moving one of the bezier handles to create a curve 
that has a corner point. This allows you to create curves that previously 
were impossible to create with three points in earlier versions of Anime 
Studio.
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 Press the Alt key while dragging to create a sharp point in the curve.

 � You can edit the shapes of a Bezier curve on one frame, and then move to 
a later frame to reshape the curve. Moho will animate those changes over 
time.

• Fixed Bezier Handles: 

 � When Fixed Bezier Handles is off, Moho will automatically adjust the shapes 
of the handles when you move a point (in a circle, for example). This in turn 
changes the shape of the object. This option is generally more desirable 
if you want to reshape the handles for animation. When you move points 
with Fixed Bezier Handles off, the shape is more blobby and the handles 
automatically adjust to maintain the  shape of the object. 

 � When Fixed Bezier Handles is on, the Bezier handles work more like those in 
Adobe Illustrator. When you move one point, it tries not to move the other 
points in the shape, to keep their shapes relatively unchanged. It is more 
difficult to animate curves with Fixed Bezier Handles on, because you can 
create shapes that appear distorted. If you add points to a curve that has 
Fixed Bezier Handles on, Moho preserves the shapes of the other curves 
much better. You can add and transform a point with the Add Point tool to 
reshape a single segment.
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 With Fixed Bezer Handles off, curves 1 and 2 adjust to maintain a smooth shape. When 
on, curves 1 and 2 maintain their shape.

Creating Boolean Shapes
Because Moho 13.5 has introduced improved handling of Bezier curves and handles, 
a side benefit is that it becomes much easier to create boolean shapes in Moho 
13.5. In addition, the Delete Edge tool has also gotten smarter. When you delete an 
edge, the shapes of the remaining curves are maintained.

To create boolean shapes in Moho 13.5, proceed as follows:

1. Create two shapes. In this example an oval and a rectangle are created on the 
same layer.
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 Start with an oval and a rectangle.

2. Select all of the points with the Select Points tool, and click the Weld Crossings 
button.

3. Now, choose the Delete Edge tool. Trim away the edges that you don’t want to 
keep.

 After welding corssings, extra edges are deleted.

4. You can continue to build upon this shape. Add another shape that crosses the 
previous result, and then repeat steps 2 and 3 to create another boolean of the 
two current shapes.
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 Repeat the process to add additional shapes.

Select Points
Shortcut: G

Many of the following tools work only on the currently selected points. This is 
the tool you use to select/de-select points. This tool can be used in a few 

different ways.

Select Points Tool Options

 Select Points options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Text Field: Assigns a name to the currently selected group of points.

• Create: Creates a group from the selected points.

• Delete: Deletes the currently selected group from the selection list.

 Select Points options

• Weld Crossings: Click the Weld Crossings button to weld points or curves 
together at points where they cross.
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• Simplify: Click the Simplify Curve button to reduce the number of unnecessary 
points in a curved shape. By default, points are reduced by a factor of 50%. You 
can change this value in the field provided.

• Split: Adds mid-point curve points to selected points. Select two or more points 
and then click the Split button.

You can also split curves using the Scripts > Draw > Split Curve 
command.

• Lasso Mode: When checked, allows you to draw a lasso around the points you 
want to select. When unchecked, selects a rectangular area.

• Flip Horizontally: Click this button to flip horizontally.

• Flip Vertically: Click this button to flip vertically.

Using the Select Points Tool
The most basic way to select points is to drag a rectangle around them. Also, using 
this tool you can click on a single point to select it. The third method of selection is 
to click on a curve to select the entire curve. Finally, clicking on a filled-in area will 
select an entire object. Each of these selection methods is illustrated below:

 Selection methods
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Click this link to view a brief video in your browser that shows 
the different methods of point selection.

Modifier keys:

• By holding the Shift key, you can add to a selection. Otherwise, you will always 
start a new selection when using this tool.

• Holding the Alt key will remove from the selection.

• If you hold down the Ctrl key (Windows) or Cmd key (Mac), this tool will work in 
lasso style. (You can also activate lasso style selection by turning on Lasso mode 
in the tool options area.)

The selection commands in the Edit menu are also very useful for managing 
selections. These are described in “Chapter 19: Edit Menu” on page 427.

The currently selected points may be deleted by pressing the Delete or Backspace 
keys.

Transform Points
Shortcut: T

Animatable: Yes

The Transform Points tool is used to move, scale, or rotate a group of selected 
points. It operates only on the currently selected points, unless fewer than 

two points are selected - then it operates on the nearest point to where you clicked.

It’s important to note that this tool, like most of the Moho drawing tools, modifies 
points, not curves. If you select all the points in an object and use this tool, the entire 
object will move, scale, or rotate. However, if you only select some of the points, 
then you’ll end up distorting the object (which can be very useful).

General Options
The following options appear in the left portion of the options toolbar when the 
Transform Points tool is selected:

 Transform Tool general options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

The following options appear in the right portion of the options toolbar when the 
Transform Points tool is selected:
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 Transform Tool general options

• Auto Weld: When checked, automatically welds a new point to an existing 
point. The existing point is highlighted when the mouse hovers over a point that 
can be welded.

• Auto Fill: When checked, automatically fills a closed shape when you create it.

• Auto Stroke: When checked, automatically creates a stroke around the shape 
that you create. Uncheck this option to create a shape that has no outline.

• Show Bezier Handles: Displays the Bezier Handles so that you can 
manipulate them. Note that whenever you move a point in a curve, 

the Bezier handles automatically adjust to reshape the curve. 

• Fixed Bezier Handles: When you move a point (in a circle, for example), 
Moho automatically adjust the shape of the handles, which in turn 

changes the shape of the object. When you check the Fixed Handles option, 
the Bezier handles work more like those in Adobe Illustrator. When you move 
one point, it tries not to move the other points in the shape.  

• Flip Horizontally: Click this button to flip horizontally.

• Flip Vertically: Click this button to flip vertically.

Translating Points
The following toolbar options are associated with translating points:

 Transform Points options for translating

• Position X: Allows you to numerically enter a value for the X coordinate.

• Position Y: Allows you to numerically enter a value for the Y coordinate.

In the pictures below, the selected points are highlighted in red. Notice the effect of 
using the Transform Points tool on these points.

• To constrain vertically or horizontally: Hold the Shift key while dragging the 
selected points left, right, up, or down.

• To nudge: You can nudge the selected point(s) by small increments by holding 
down the Ctrl key (Windows) or Cmd key (Mac) and pressing the arrow keys. 
Hold down Shift in addition to Ctrl/Cmd to nudge the point(s) by a greater 
increment.
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 Top circle fully selected. Bottom circle partially selected

 After translation

• To weld points: The steps differ depending on whether the Auto Weld option in 
the toolbar is enabled or disabled:

 � When Auto Weld is off: To weld two points together, use the Transform 
Points tool to drag one point on top of another (you must drag just one 
point to weld, not a group of points). While dragging the first point on top 
of the second, press the Enter key to weld them together into one point.
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Previous versions of Anime Studio used the Spacebar to 
manually weld points. If you prefer to use legacy 

shortcuts, open the Preferences dialog to the Tools tab and check 
the Classic point editing keyboard shortcuts option. This option is off 
by default in Moho.

 � When Auto Weld is on: Moho can automatically weld points for you. Only 
the endpoint of a curve can be automatically welded. To automatically 
weld the endpoint of a curve, just drag it on top of another point and 
let go of the mouse. Below is a movie demonstrating auto-welding. After 
dragging each endpoint into place, it becomes welded to the existing 
point, and the two can be moved around.

Click this link to view a brief video in your browser that shows 
examples of using transform points and auto-weld.

Scaling Points
The Transform Points tool also allows you to scale the currently selected group of 
points. Two or more points must be selected. 

The following toolbar options are associated with scaling points:

 Transform Points options for scaling

• Scale X: Allows you to enter a numeric value for scaling along the X axis.

• Scale Y: Allows you to enter a numeric value for scaling along the Y axis.

When this tool is active, a red box will appear around the currently selected group of 
points. The handles around the edges of this box allow you to resize the points. 

• Drag a corner handle in and out to scale the points while maintaining their 
proportions. Scaling will be relative to the opposite corner. Press the Shift key 
while dragging a corner to perform a non-proportional scale.

• Drag one of the side handles to change the horizontal scale, or the top or 
bottom handle to change the vertical scale.

• If you hold the Shift+Alt keys while dragging a side handle, Moho will resize the 
selected points in such a way to maintain the overall volume of the object - this 
can be useful for squash and stretch.

Rotating Points
The Transform Points tool can also rotate the currently selected group of points. Two 
or more points must be selected to use this tool. The following toolbar options are 
associated with rotating the selected points:
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 Transform Points options for rotating.

• Angle: Allows you to enter a numerical value for rotation.

Click near the outer boundary of the selected group of points. Next, drag the mouse 
in a circle around the selection to rotate the points. Holding the Shift key while using 
the Transform Points tool will constrain the rotation to 45 degree increments.

Bezier Handle Options
• Show Bezier Handles: Displays the Bezier Handles so that you can 

manipulate them. Note that whenever you move a point in a curve, 
the Bezier handles automatically adjust to reshape the curve. 

You can use the Transform Points tool to drag one of the 
handles to reshape the curve. 

Hold down the Alt key to drag one of the Bezier handles to 
make a corner sharper or smoother.

You can return the Bezier handles to their original shape by 
applying the Smooth command.

The Curvature tool also allows you to click and drag the end 
handles to adjust the curve shape.

• Fixed Bezier Handles: When you move a point (in a circle, for example), 
Moho automatically adjust the shape of the handles, which in turn 

changes the shape of the object. When you check the Fixed Handles option, 
the Bezier handles work more like those in Adobe Illustrator. When you move 
one point, it tries not to move the other points in the shape.  

Add Point
Shortcut: A

The Add Point tool is what you use to draw most curves in Moho. Just click 
and drag in the working area of the main window to create a new curve 

segment. There are four variations to using the Add Point tool - they differ in where 
the original click takes place.

• The first way to use this tool is to click in empty space and drag - this will start a 
new curve.

• The second technique is to click on the end of an existing curve to add another 
segment to that curve.
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• Third, click on a curve segment to add a point there, then drag it to the final 
desired position.

• Finally, click on a curve midpoint to add a new branching curve that is welded 
to the existing point. Each of these uses of the Add Point tool is shown below.

 Uses of the Add Point tool

The Add Point tool can also be used to weld two points. Click and drag in one of the 
ways described above to add a new point. Drag the new point on top of an existing 
point. If Auto Weld is enabled the new point will weld to the existing point. If Auto 
Weld is off, press the Enter key before releasing the mouse. An example is shown 
below. (This works just like the Transform Points tool, above. Read about that tool for 
more details on welding.)
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 Closing a curve

To prevent the Add Point tool from adding on to an existing curve regardless of 
where you click, hold the Alt key to force the tool to start a new line segment.

The movie below demonstrates the Add Point tool. Notice how clicking on different 
parts of an existing curve causes the new point to be added in different ways.

Click this link to view a brief video in your browser that shows 
examples of using the Add Point tool.

Add Point Tool Options

 Add Point Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Auto Weld: When checked, automatically welds a new point to an existing 
point. The existing point is highlighted when the mouse hovers over a point that 
can be welded.

• Auto Fill: When checked, automatically fills a closed shape when you create it.

• Auto Stroke: When checked, automatically creates a stroke around the shape 
that you create. Uncheck this option to create a shape that has no outline.
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• Sharp corners: When checked, creates sharp corners when changing the angle 
of a line. When unchecked, creates smooth transitions when changing the 
angle

• Show Bezier Handles: Displays the Bezier Handles so that you can 
manipulate them. Note that whenever you move a point in a curve, 

the Bezier handles automatically adjust to reshape the curve. 

• Fixed Bezier Handles: When you move a point (in a circle, for example), 
Moho automatically adjust the shape of the handles, which in turn 

changes the shape of the object. When you check the Fixed Handles option, 
the Bezier handles work more like those in Adobe Illustrator. When you move 
one point, it tries not to move the other points in the shape.  

If you hold down the Command key (Mac) or Ctrl key 
(Windows) while you add a new point, it will reverse the 

Sharp Corners option that you have selected in the Options toolbar. 
This allows you to change between peaked and smoothed points 
without interrupting your workflow.

Curvature
Shortcut: C

Animatable: Yes

This tool works on the currently selected points, or on the nearest point if less 
than two points are selected. It adjusts the level of smoothness of the curves 

passing through the selected points. Drag to the left to make the curves less smooth, 
and drag to the right to make the curves rounder.

Curvature Tool Options

 Curvature Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Curvature: Enter a positive or negative value for the amount of curvature that 
you want to apply to the selected curves.

• Peak: Creates a peaked (or hard) transition between the curves at the 
point that you click.

• Smooth: Smooths the transition between the curves at the point that you 
click.

• +/-: Click this button to toggle the value in the Curvature field between 
negative and positive values.

• Reset: Returns the Bezier handles and associated curves to their default shape.
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Freehand
Shortcut: F

The Freehand tool lets you draw complex shapes by just dragging the mouse 
around. Moho will attempt to simplify the curves that you draw with the 

Freehand tool, by removing unnecessary points. Straight lines will be preserved as 
accurately as possible.

While drawing with the Freehand tool, you can use the Trim Start and Trim End 
options to automatically delete unwanted dangling edges from the beginning or 
end of a line that crosses another line. 

After using the Freehand tool, you can also go back and use 
the Delete Edge tool to delete unwanted lines. For 

more information about the Delete Edge tool, see “Delete Edge” on 
page 53.

You can also use the Transform Points tool to modify the result, 
delete unnecessary points, and weld points together. 

If you have a drawing tablet, the Freehand tool can also use the pen pressure from 
your tablet to control the thickness of the lines you draw.

Press the Alt key while dragging the Freehand tool to resize the 
brush. 

When using the Freehand tool, you don’t have to draw shapes precisely. If you cross 
a line, the new line automatically welds to the line that is crossed if the Auto Weld 
option is selected. This allows you to quickly sketch out shapes without worrying 
about stopping your stroke at precise locations. When you’re using the Freehand 
tool, you are primarily interested in seeing an accurate display of what you are 
drawing. For this reason, control points are automatically hidden when Freehand 
tool is selected so that you can focus on your drawing. You’ll also see a more 
accurate preview of the strokes that you draw, especially when drawing wider 
strokes. When you release the mouse, you’ll notice the strokes change slightly due to 
automatic smoothing.

To display the control points, select one of the other tools, such 
as the Transform Points tool.

Freehand Tool Options

 Freehand Options (part 1)
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The Freehand tool has been improved to give much smoother 
looking curves. As you draw with the Freehand tool it 

looks like you are creating a lot of points, but as you let go it only 
keeps the points that are necessary to represent the curve smoothly.

You don’t have to be concerned with ending a line exactly on 
a point, or using the Transform Points tool to weld points 

together. Instead, sketch as you normally would sketch with a pencil. 
Any lines that cross will automatically weld together, easily allowing 
you to create closed shapes. You can then use the Delete Edge tool 
to delete the unwanted straggling ends that cross the lines you want 
to weld. This allows you to create closed shapes quite easily that you 
can fill later.

Click the Freehand Options button in the Options toolbar to display the Freehand 
Tool options dialog. The options are as follows:

• Freehand Options: Click this button to display the following options

 Freehand options

 � Variable line width: When set to None, does not vary line width between 
the start and end of the line. Use Pen Pressure varies line width based on 
pen pressure when using a pen tablet. Random varies line with randomly 
when using a mouse.

 � Width Variation: Controls the amount of difference between the narrowest 
part of the stroke and the widest part of the stroke.

 � Taper Start: When checked, tapers the start of the line. Enter the starting 
width of the line in the field provided.
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 � Taper End: When checked, tapers the end of the line. Enter the ending 
width of the line in the field provided.

Tapering is applied live, not just on mouse-up.

 � Smoothing: Use the Smoothing slider to increase or decrease the 
amount of smoothing that is applied to the curve. The default setting 
of 2 corresponds to the amount of smoothing used in Anime Studio 10. 
Decrease the setting to apply less smoothing, making the shape closer 
to the way it was originally drawn. Increase the setting to apply more 
smoothing. You will see some effects of the smoothing algorithm in real 
time while you draw.

 � Point Reduction: Allows you to enter a percentage value for point 
reduction. By default, points will be reduced by a factor of 50 percent.

 � Reset: If pressed at Frame 0, resets a layer back to its default value. If 
pressed at any other frame, resets the layer to the value or values set at 
frame 0.

• Auto Weld: When checked, automatically welds a new point to an existing 
point. The existing point is highlighted when the mouse hovers over a point that 
can be welded. When you draw two lines that cross, the point at which they 
cross will automatically be welded together when this option is on.

• Trim Start: When checked, dangling edges that are drawn before the stroke 
crosses another stroke will automatically be removed when you complete the 
stroke.

• Trim End: When checked, dangling edges that appear at the end of a stroke 
that crosses another stroke will automatically be removed when you complete 
the stroke.

 Freehand Options (part 2)

• Auto close: When unchecked, closes a shape when the cursor is released over 
the beginning of the shape. When checked, connects the shape from the 
current position to the start point when you release the mouse button.

• Auto Fill: When checked, automatically fills a closed shape when you create it.

• Auto-stroke: When checked, automatically creates a stroke around the shape 
that you create. Uncheck this option to create a shape that has no outline.

• Merge Strokes: Check this option to merge strokes made with the same brush, 
color, and stroke width into a single shape. All strokes that are made while the 
option is checked will be placed in a single object. Uncheck the option when 
your sketching is complete. 

• Hide auto-closed segment: When checked (default), the segment that 
automatically closes the curve in a Freehand shape is hidden.
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Draw Shape
Shortcut: E

The Draw Shape Tool provides a way to quickly draw commonly used 
shapes: squares, ovals/circles, triangles, stars, arrows, and spirals. Each of the 

shape options are shown later in this section.

Draw Shape Tool Options

 Draw Shape Options

• Auto Fill: When checked, automatically fills a closed shape when you create it.

• Auto-stroke: When checked, automatically creates a stroke around the shape 
that you create. Uncheck this option to create a shape that has no outline.

Rectangle
The Rectangle tool is a shortcut for creating a rectangular shape. Just click and 
drag to draw a rectangle. Hold the Shift key to constrain the shape to a square. 

Hold the Alt key to make the click point the center of the rectangle, instead of one 
of its corners. There’s nothing special about rectangles created with this tool - they’re 
just four points and four curve segments and can be manipulated just like anything 
else. You could create the same shape with the Add Point tool, but for a simple 
rectangle, this tool is quicker.

Oval
The Oval tool is a shortcut for creating an oval shape. Just click and drag to 
draw an oval. Hold the Shift key to constrain the shape to a circle. Hold the Alt 

key to make the click point the center of the circle. There’s nothing special about 
ovals created with this tool - they’re just four points and four curve segments and 
can be manipulated just like anything else. You could create the same shape with 
the Add Point tool, but for a simple oval, this tool is quicker.

Triangles
The Triangle tool is a shortcut for creating a triangle shape. Just click and drag 
to draw a triangle. Hold the Shift key to constrain the shape to an equilateral 

triangle.

Stars
The Stars tool is a shortcut for creating a star shape. Just click and drag to draw 
a star. The star will be drawn from the upper point of the star, and all five points 

of the star will be equal in size.
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Arrow
Click and drag to draw an arrow shape. Press the Shift key to constrain the 
arrow to a horizontal or vertical line.

Spirals
Click and drag to draw a spiral shape. The number of windings increase as you 
drag outward. By default the spiral radiates in a clockwise direction from the 

center. Press the Alt key to create a counter-clockwise spiral.

Grid
The Grid option allows you to easily draw grids, with defined horizontal and vertical 
segments. Enter the number of Horizontal and Vertical divisions in the grid in the fields 
provided. This will be useful in Moho Pro as the first step in setting up a Smart Warp 
layer. 

Grids are useful in Moho Pro as the first step in setting up a 
Smart Warp layer. For more information about the 

Smart Warp feature, see 

Delete Edge
Shortcut: D

It’s easy to delete points - just select them and press backspace or delete. 
However, sometimes you may want keep two points, but break the curve 

connecting them. To do this, use the Delete Edge tool. Just use it to click on the 
curve segment you want to delete and it will disappear.

You can use the Delete Edge tool to delete unwanted lines. For example, you can 
use the Freehand tool to quickly sketch out shapes, and the Freehand tool will 
automatically weld crossed lines together as you draw. You can then later clean up 
the shapes by deleting unwanted hanging lines with the Delete Edge tool.

If the edge you delete makes up part of the outline of a fill 
shape, that shape will also be deleted.

The Delete Edge tool is also useful when used in conjunction 
with the Freehand tool. Due to the improved welding 

capabilities of the Freehand tool, you can freely sketch a character 
without having to worry about exact placement of lines. Any lines 
that cross will be welded together. You can then use the Delete 
Edge tool to remove unwanted straggling ends, simply by clicking on 
them with the Delete Edge tool.
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Magnet (Pro Only)
Shortcut: X

Animatable: Yes

The Magnet tool is similar to the Transform Points tool - it is used to move 
points around. However, instead of moving the selected points, it moves 

points based on the strength of the magnet. When you click with this tool, the region 
of strength is displayed. Any points within this region will move with your mouse, but 
the points closer to the center of the mouse click will move the most. (The radius of 
the magnet’s strength region can be adjusted in the tool options area.)

This tool is most useful for artwork that has lots of points. For example, the Freehand 
tool can create curves with many points - the Magnet tool can then move them 
around smoothly. Imported Adobe Illustrator files and text objects can also be 
sources of many control points.

 Magnet Options

Magnet Tool Options
• Magnet Radius: Sets the radius of the magnet.

• Selected Points Only: When unchecked, the Magnet Tool will select and move 
points that are initially clicked with the Magnet tool. When checked, the 
Magnet will only affect points that are preselected.

Blob Brush
The Blob Brush tool allows you to block shapes out very quickly. Straight lines 
are preserved as accurately as possible, and quality of shapes are preserved 

as accurately as possible over multiple strokes.

For example, you can start by blocking in part of the character as shown below.

 The first pass of the Blob Brush Tool
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You can add additional strokes to refine or add to the shape. In the following 
example, additional strokes with different brush sizes add legs and arms to the 
previous shape.

If you change fill color, line color, line width, or other brush settings while you have 
the Blob brush selected, the currently selected shape will get deselected. The next 
stroke you add with the Blob brush will use the new properties.

 Additional passes of the Blob Brush Tool add to the previous shape.

You’ll get an accurate preview of the shape as you draw. When you release the 
mouse, a vector outline will be generated for the shape. Moho will attempt to 
simplify the curves by removing unnecessary points. When you choose this tool, a red 
circle gives you a preview of the brush size.

The following keyboard shortcuts can be used with the Blob Brush tool:

• You can adjust the size of the brush by using the Brush Radius setting in the tool 
options area, or by pressing the Alt key and dragging to resize the brush.

• If you hold down the Command/Ctrl key you can erase from the shape, or use 
the Eraser tool. See “Eraser” on page 56 for more information.

The brush tool can create a lot of extra points. You can use the 
new Point Reduction Tool to reduce the number of 

points. See “Point Reduction” on page 58 for more information.

You might notice the viewport jump at times when using the 
Blob Brush tool. This happens when you extend your 

drawing outside the boundary of the work area. The viewport resizes 
to bring that additional area into view to ensure that the object that 
you drew will fit on the screen.

Blob Brush Tool Options

 Brush Options (part 1)
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• Brush Radius: Sets the radius of the brush. A red circle gives you a preview of the 
brush size. You can also adjust the radius by pressing the Alt key and moving 
your mouse left or right.

• Use Pen Pressure: Check this option if you are using the brush with a pressure-
sensitive stylus and tablet.

• Auto Stroke: Check this option to automatically create strokes around the 
shapes that you create with the Blob brush.

 Brush Options (part 2)

• Point Reduction: Check this option to remove unnecessary points in the shapes 
that you draw while the option is checked. By default, points will be reduced by 
a factor of 50%. You can enter a different value in the Point Reduction field.

• Draw Behind Strokes: When this option is checked, the Blob brush will be allowed 
to draw behind existing stroke shapes. This is useful for frame-by-frame drawing.

• Merge Strokes: When checked, merges all strokes made with the Blob brush 
into a single object. Uncheck this option to create separate objects with each 
stroke. 

• Smoothing: Use the Smoothing slider to increase or decrease the amount of 
smoothing that is applied to the curve. Decrease the setting to apply less 
smoothing, making the shape closer to the way it was originally drawn. Increase 
the setting to apply more smoothing. You will see some effects of the smoothing 
algorithm in real time while you draw.

Eraser
The Eraser tool allows you to cut holes in any shape. If no filled shapes are 
selected, the first filled shape that you click on will become selected, and 

you can begin erasing immediately. You can also hold the Ctrl/Cmd key to go into 
selection mode and manually select the shapes you want to work with. Press the 
Shift key to select multiple shapes.

In the following example, the Eraser Tool is used to modify the shape of an animal’s 
tail.
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 The Eraser Tool is used to modify the shape of an animal’s tail. Before (top) and after 
(bottom)

You might notice the viewport jump at times when using the 
Eraser tool. This happens when you extend your 

drawing outside the boundary of the work area. The viewport resizes 
to bring that additional area into view to ensure that the object that 
you drew will fit on the screen.

Eraser Tool Options
• Eraser Radius: Sets the radius of the eraser. You can also adjust the radius of the 

brush by pressing the Alt key and moving your mouse left or right.

• Use Pen Pressure: Check this option if you are using the eraser with a pressure-
sensitive stylus and tablet.

 Eraser Options
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Point Reduction
The Blob Brush, Eraser, and Paint Bucket tools can generate a lot of extra and 
unnecessary points. The Point Reduction tool helps you reduce the point 

count in any vector object so that the shapes are easier to animate.

When the Point Reduction tool is selected, the red circle gives you a preview of the 
brush size. You can set the radius in the options toolbar, or press the Alt key while 
dragging to resize the brush.

To use the tool, simply paint along the area where you want to reduce the number 
of points. As you paint, the brush will leave a trail behind where you have painted. 
The areas that you paint over will be simplified.

 Before (top) and after (bottom) Point Reduction

Point Reduction Tool Options
• Brush Radius: Sets the radius of the brush.

• Tolerance Angle: If you want to reduce the number of points but not change 
the shape so much, reduce the tolerance angle. Lowering the tolerance angle 
will not remove as many points, but it will keep the shape closer to what you 
originally drew.
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 Point Reduction Options

Scatter Brush
The Scatter Brush allows you to spray shapes into your scene. There are a 
number of preset shapes, or you can also copy any shape to your clipboard 

and spray multiple copies of that shape into your scene. The Scatter Brush also 
scatters animated sample objects with animated point position, curvature and line 
widths. The animations in scattered objects is automatically cycled.

To use the Scatter Brush tool, try the following:

Copy a vector object into your clipboard, or select one of the preset options from 
the Preset menu.

1. Choose the vector layer that you want to paint into.

2. Set the Min and Max Width settings appropriately for the scale of the objects.

3. Set other options in the Scatter Brush Options panel if you want to increase 
or decrease variation in the angle, spacing, or color of the objects you are 
spraying.

Scatter Brush Tool Options

 Scatter Brush Options

• Scatter Brush Options: Click this button to display the following options

 � Angle Jitter: Specifies the maximum amount of angle variation in the 
objects that you spray.

 � Spacing: Specifies the minimum amount of space between the objects 
that you spray.

 � Fill Color Jitter: Specifies the maximum amount of color variation for the 
objects that you spray.

 � Stroke Color Jitter: Specifies the maximum amount of color variation for the 
objects that you spray.

 � Flip X: Check this option to flip the objects being sprayed along the X axis.

 � Flip Y: Check this option to flip the objects being sprayed along the Y axis.

• Preset Menu: Click the Preset menu to choose from a number of different 
presets that you can spray into your scene. If you choose Use Clipboard, the 
Scatter Brush tool sprays the contents of your clipboard into the scene.
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• Min Width and Max Width: Sets the minimum and maximum width of the objects 
that you spray. If you want all of the objects to be the same size, set both values 
the same. Higher values create larger objects.

Perspective Points (Pro Only)
Animatable: Yes

Click and drag side-to-side to add horizontal perspective to the selected 
group of points. Click and drag up and down to add vertical perspective to 

the selected group of points.

Although Moho is not a 3D program, the effect of this tool is similar to rotating the 
points around a vertical pivot, so that one half of the group rotates into the screen 
and the other half out of the screen. If you want to do a true 3D rotation, you should 
use the Rotate Layer Y tool to apply true 3D perspective to a layer.

Perspective Points Tool Options

 Perspective Points Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

Shear Points (Pro Only)
Animatable: Yes

This tool works on a group of two or more selected points. Click and drag left, 
right, up, or down to shear, or slant the group of points.

Shear Points Tool Options

 Shear Points Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.
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Bend Points (Pro Only)
Animatable: Yes

To use the Bend Points tool, drag your mouse up and down to bend the 
selected group of points up and down. For best results, the selected group of 

points should be wider than it is tall.

Drag your mouse side to side to bend the selected group of points side to side. For 
best results, the selected group of points should be taller than it is wide.

Tool Options

 Bend Points Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0:

Noise (Pro Only)
Shortcut: N

The Noise tool works on a group of selected points. Click and drag to move 
the points around in random directions. This tool can be used for example 

when you want to duplicate an object using Copy and Paste, but you don’t want 
the new object to look exactly like the original. Just use this tool to distort it a little bit.

Tool Options

 Noise Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.



Moho 13.5
Users Manual 

62

Chapter 4: Fill Tools

Chapter 4: Fill Tools
Using the Fill tools for vector layers, you take the drawings you created with the 
Draw tools, and you tell Moho which areas should be filled with color, where outlines 
should be placed, and what fill and line styles to use.

The drawings created with Draw tools are only guides. As far as Moho is concerned, 
they’re invisible and they won’t show up in the final rendered output. That’s where 
Fill tools come in. Draw tools define the shape of objects, while Fill tools define the 
appearance of those objects. Of course, you’re always free to switch back and forth 
between any of Moho’s editing tools at any time.

 Fill Tools (Debut)

 Fill Tools (Pro)

Moho has a smart tool palette, which shows and hides tools 
based on their need. The position of the tool shown in 

the screenshots may differ, depending on the selected layer in the 
Layers Window, and the current time in the timeline.

Click the tool icon in the properties bar to display a submenu. 
Choose Reset Tool to reset the current tool to its default 

settings. Choose Reset All Tools to reset all tools to their default 
settings.

Reset tool options.
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Select Shape
Shortcut: Q

This tool is used to select one or more existing shapes (fills or outlines).

To select a shape, just click on the desired shape and it will be selected.

• To select additional shapes, press the Shift key while you click and drag the 
mouse over each additional shape to add to the selection.

• To deselect a shape, press the Alt key while you click the shape(s) you want to 
remove from the selection.

After your shape or shapes are selected, you can press the Delete or Backspace 
keys to delete the shapes, or adjust their properties in the Style Window (see 
“Chapter 13: Style Window” on page 256). Options also appear in the properties 
bar to change the color of the fill or stroke in the selected shapes.

After clicking on a shape to select it, you then have the option to select shapes 
lower in the stacking order. Just hold down the Ctrl key (Windows) or Cmd key (Mac) 
and press the down arrow key to select the next shape lower down at the point you 
clicked the mouse. Hold Ctrl/Cmd and press the up arrow key to select the next 
shape higher in the stacking order at that same point.

When you change the properties of multiple selected shapes, the changes that you 
make will be applied to all selected shapes. For example, you can select shapes 
that have different color fills, and then change the fill color in the style window so 
that all of the shapes are filled with the same color.

To illustrate, the following figure shows four different shapes, each with different fill 
and stroke properties.

 Four different layers, each with objects that have different shape properties.

If you click on one of the shapes with the Select Shape tool, the Style window 
updates to display the fill and stroke properties of the shape that you clicked (color, 
stroke width, brush settings and effects, and so on).

If you hold down the Shift key while using the Select Shape tool, you can select 
multiple shapes. Pressing the Alt key will remove a shape from the selection.
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 Multiple shapes selected with the Select Shape tool.

The properties of the first shape that you selected will appear in the Style window. 
Any changes that you make in the Style window will be applied to all of the selected 
shapes. The preview window will update as you make your style selections.

 The preview updates as you make changes in the Style window.

Tool Options

 Create Shape Options

• Fill: Check this option to change the fill of the selected shape(s). 

• Fill Color: Click the color square to select a fill color for the selected shape(s). 
You can also use the Fill eyedropper to select a color from your scene, or from 
any other point on your screen.

• Stroke: Check this option to change the stroke of the selected shape(s).
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• Stroke Color: Click the color square to select a stroke color for the selected 
shape(s). You can also use the Stroke eyedropper to select a color from your 
scene, or from any other point on your screen.

• Width: Allows you to set a numerical value for the width of the stroke. Fractional 
values are allowed.

Create Shape
Shortcut: U

The Create Shape tool is used to select a region to be filled with color, or a 
set of edges to be drawn as an outline. It operates exactly like the Select 

Points tool described in “Select Points” on page 39.

Using the Create Shape tool, select all the points that form the outer border of the 
shape you wish to create. If you select a set of edges that completes an enclosed 
shape, a highlighted checkerboard will show you the extent of the region you are 
creating. Otherwise, you will just see a highlighted outline on the selected edges.

When you have the desired region selected, press the spacebar or press the Create 
Shape button in the status bar to actually create a shape from the selected edges. 
The Style Window (see “Chapter 13: Style Window” on page 256) can now be used 
to choose the shape’s color, line width, style, etc. This is a very important step - until 
you press the spacebar or use the Create Shape button, you are only preparing the 
selection. A shape is only created when the spacebar or button is pressed.

The picture below shows a selection in progress using the Create Shape tool. Note 
that the figure on the left is not filled with a checkerboard because its border points 
are not all selected. The checkerboard area indicates the region that would be 
filled if the user hit the spacebar at this particular moment. The left figure would only 
receive a partial outline and no fill, since then entire border has not been selected.

 Selecting the curves to make up a shape
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The next figure shows the result of pressing the spacebar to actually create the two 
shapes that were being prepared in the figure above.

 The two resulting shapes

After creating a shape, if you decide that you only want a fill, and not an outline, 
you can uncheck the Stroke box in the Style window. Similarly, uncheck the Fill box in 
the Style window to make your shape have only an outline, and no fill color.

Tool Options

 Create Shape Options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Create Shape: Press the Create Shape button to complete the shape. This is the 
same as pressing the Spacebar after your selection is made.

• Lasso Mode: The Create Shape tool selects a rectangular area by default. 
Check this option to select points by drawing a lasso around the desired area.

• Fill: Select this option if you only want to change the fill of the selected object(s).

• Stroke: Select this option if you only want to change the stroke of the selected 
objects(s).

• Both: Select this option if you want to change both the fill and stroke of the 
selected object(s).
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Paint Bucket
Shortcut: P

The Paint Bucket tool is used to fill a closed area with color. Just click inside a 
closed shape to fill it with the current combination of colors and styles. This 

can make it much easier and quicker to fill shapes than with the Create Shape tool, 
but keep in mind you’re still working with the same requirements - a shape must be 
completely closed in order to be filled.

The lines that create the closed shape do not have to be 
welded. For example, you can draw four overlapping 

lines with the Freehand tool with Auto Weld off, and then fill the 
inside of the lines with the Paint Bucket tool.

Below are some examples of sets of curves in Moho, where the user might click with 
the Paint Bucket tool, and the resulting fills. In each case, the shape on the left is the 
starting shape, the red X indicates the point where the user clicked with the Paint 
Bucket tool, and the result is the shape on the right:

 Filling a basic closed outline
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Clicking outside a closed outline (nothing happens - no fill).

 A more complex shape. There are some dead-end curves, but the overall shape is still 
closed.
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 A shape with a hole in it.

 Clicking inside the hole fills just the hole
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 The shape is not closed (close, but not good enough) - no fill is created

If part of the shape is cut off on the edge of the editing window, the viewport will 
change to display the entire filled shape after you fill it with the Paint Bucket.

 The viewport adjusts to display the entire filled shape after using the Paint Bucket.

You can also draw shapes that overlap, and use the Paint Bucket tool to fill within 
areas that overlap. This allows you to quickly create complex boolean shapes.
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 Two overlapping shapes are filled with the Paint Bucket to create a boolean shape.

Tool Options

 Paint Bucket Options

• Fill: Select this option to affect fill only.
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• Stroke: Select this option to affect stroke only.

• Both: Select this option to affect both fill and stroke.

• Point Reduction: Allows you to enter a percentage value for point reduction. 
Default setting is 0, for no point reduction.

Delete Shape
To use the Delete Shape tool, click on a fill or outline to delete it from the 
project. Remember, in Moho, the shape of an object is separate from its 

appearance. If you use this tool to delete a fill, the underlying points and curves will 
remain. If you want to delete those as well, go back to the Draw tools to work with 
the points and curves.

Line Width
Shortcut: W

The Line Width tool is used to adjust the width of a line as it passes through a 
particular point. Using this tool, you can create lines that taper at the ends, 

get thinner in the middle, or change width several times along their length.

Line widths are stored internally in Moho as percentage values. 
For example, a value of 100% represents the original 

line width, and a value of 200% represents double line width. The 
width of the line smoothly varies from the 100% (no custom width) 
value.

You can superimpose two strokes, each with a different line 
width, to create parts for characters that are made of 

very few points, making them much easier to animate. For more 
information refer to “Tutorial 2.4: Varying Line Widths” on page 65 
in your Moho Tutorial Manual.

To use it, just click on the point you want to adjust, and drag the mouse left and right 
to adjust line thickness. (Be sure you first either set up an outline through the point, or 
a fill shape with a non-zero line width - otherwise this tool won’t do you much good.)

You can adjust more than one point at a time by selecting multiple points with the 
Select Points tool from the Draw tool group.

Tool Options

 Line Width Options
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• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Width: Allows you to enter a numerical value for the line width.

You can also enable the Magnet Mode option and enter a radius that determines 
the area that the magnet will affect.

 Line Width Magnet Mode Options

• Magnet Mode: Check this option to display the cursor as a red semi-transparent 
circle.

• Magnet Radius: The points that appear within the red circle area will be 
affected when you use the Line Width tool. Use the Magnet Radius setting to 
increase or decrease the affected area.

 You can set a magnet radius to affect all vertices beneath the magnet.

Hide Edge
Shortcut: H

Sometimes, you will have the need to create a fill shape with only a partial 
outline. The Hide Edge tool makes it easy to accomplish this. After creating 

the fill shape and setting the desired line width, simply click on the edge(s) that you 
want to hide - those edges will simply disappear from the outline, without affecting 
the fill. Below is a before and after example:
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 The Hide Edge tool in action

Stroke Exposure (Pro Only)
The Stroke Exposure tool is located in the Fill section of the tool box. Normally, 
when you apply a stroke to a curve, you see the stroke along the entire 

curve. With the Stroke Exposure tool, you can click and drag on a curve that has a 
stroke and control where the curve starts and ends.

• Click and drag back and forth to set the end point of the stroke on the curve. 
Dragging toward the left exposes less of the curve’s end, while dragging toward 
the right exposes more of the curve’s end

• Alt-Click and drag back and forth to set the start point of the stroke on the 
curve. Drag toward the right to expose less of the curve’s end, and drag toward 
the left to expose more of the curve’s end.
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 Exposing less of the curve’s end

This parameter can be animated so that you can expose the curve over time, 
making this feature a good option for creating things like handwriting or water 
flowing through a pipe. Rounded end caps are also supported with the Stroke 
Exposure tool.

Tool Options

 Stroke Exposure options

• Select Group: Used to select a group that was previously created with the 
Select Points tool.

• Start Percentage: Allows you to enter a numerical value for the start of the 
curve, based on its distance from the start point

• End Percentage: Allows you to enter a numerical value for the end of the curve, 
based on its distance from the end point
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Curve Profile (Pro Only)
Curve profiles provide a way to add interesting detail to a shape. You use 
the Curve Profile tool to create these details on a shape. You select a shape 

on a layer. Additional curves that define the profile can appear on the same layer.

Curve profiles can be of any shape, but the start and end of the profile should be 
along the same horizontal line. While you can create profile curves with or without a 
stroke applied to them, it makes sense to draw them with Auto Stroke off, since you 
will be applying a different pattern to the circle based on the style of the curve.

 Shapes and curves are drawn on a single layer

After you select the shape you want to apply the profile to (a circle in this case, 
select the Curve Profile tool from the Fill section of the tool box. Then click on the 
curve that you want to use as the profile.

 A shape with a profile curve applied.
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Even though the resulting shape appears to have more detail, it still has the same 
number of control points as the original shape. For example, if you applied the curve 
profile to a circle, the resulting shape still has only the four original control points, 
even though it appears to have more. You can edit the shape by repositioning one 
or more of the original control points, and the curve profile will still be applied.

If you want to animate a shape that uses Curve Profiles you will 
need to animate the shape used for the profile. You 

cannot assign one profile shape on one frame in a timeline, and 
then reassign another profile shape on another point in the timeline. 
In addition, if you delete the curve that was originally used as a 
profile shape, the curve profile also gets deleted.

The Repeat Count setting in the options toolbar controls the number of times that the 
curve profile repeats along the path. You can increase or decrease this setting to 
add more or less detail to the shape.

 The Repeat Count controls the number of times that the profile curve repeats along 
the path

To remove the curve profile from the shape, select the Curve Profile tool from the Fill 
section of the tool box and click on an empty background area.

Tool Options
• Repeat Count: Used to control the number of times that the profile shape 

repeats along the path.

Working with Fills
To define a region to be filled, you must first select all the points along its boundary. 
That’s what defines a fill region - the set of points along its outer edge. We’ll take a 
look at some examples later. You can also create outlines using these tools. Outlines 
are less restrictive than fills - an outline is not a set of points along an outer boundary. 
Instead, an outline can be any set of points you choose. The curve segments 
between these selected points will form the outline.
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Fills and outlines are stacked on top of each other in the order you create them. This 
determines which fill or outline will be visible when two or more overlap. There are 
tools that allow you to change the stacking order of fills and outlines, but you’ll learn 
that you can save yourself a lot of time by planning ahead and creating fills in the 
proper order to begin with.

There are a number of different ways to fill shapes in Moho:

• Use the Select Shape tool to select the shape you want to change. The color 
and fill properties will be “picked up” in the Style window. You can then change 
the fill colors in the Style window.

• Use the Create Shape tool to fill closed outlines that do not have any fill. You will 
need to select the points in the outlines before you use the Create Shape tool.

• You can also use the Paint Bucket to fill shapes that do not yet have a fill. For 
example, you can use the Add Point or Freehand tool to create a shape that 
has a stroke only, and then later use the Paint Bucket tool to add a fill.

• You can also change colors with the Eyedropper. Use the Eyedropper to select 
a color from any of the shapes that use the color you want to apply. Then press 
the Alt key and click other objects with the Eyedropper to push the selected 
color to other shapes.

Color Picking
If the Select Shape or Create Shape tools are active and a shape is selected, you 
can quickly set the shape’s color by picking it from another shape in the current 
layer. Just hold down the Alt key and click on the shape you want to copy the color 
from. The color (and style) will instantly be applied to the currently selected shape.

You can also push a shape’s color and style onto other shapes. If you hold down 
Alt + Ctrl (Windows) or Alt + Cmd (Mac) and click on a second shape, the selected 
shape’s color will be pushed onto the shape you click on. This is an easy way to 
propagate one shape’s color and style onto several other shapes in the same layer.

There’s no limit to the kinds of shapes you can create this way. By adding more 
boundary curves, you can create more and more complex fills - feel free to 
experiment.

A Trick: Using Two Fills Instead of One
Sometimes you may want to create an object with parts that overlap in complex 
ways. Consider the image below:
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 Two interlocking rings

The red ring is in fact two objects - one behind the blue ring, and one in front of it. 
The next image shows the same object, but colored differently so that the two parts 
of the red ring stand out.

 The coloring shows three different shapes

It takes a little more work to set up an object when you have to split it into two (or 
more) parts, but sometimes it’s the only way to achieve a certain effect. The picture 
below shows the project in a Moho window, so that you can see the arrangement 
of points and curves. Note how the ring on the right has some extra curves set up so 
that it can be split into two fills.
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 Point and curve arrangement.

This technique is also useful in animation, for when you want an object to bend 
backwards and overlap itself. Normally, this would cause the fill that defined the 
object to get seriously distorted, or even to break holes in itself. However, by building 
the object out of two or more parts and stacking them properly, you can achieve 
this type of effect with no problem.

Color Points
The Color Points tool allows you to create a gradient-type fill for the objects, 
based on point positions. After selecting the point or points that you want to 

assign a color to, you use the Color Points tool options to assign a color to the 
selected points. The assigned colors will then blend across the surface of the shape.

To use the Color Points tool, follow these steps:

1. Use the Select Points tool to select one or more points, or to select a predefined 
point group. Or, click one or more points with the Color Points tool.

2. Click the Color Swatch to choose a color for the selected points.

3. Adjust the Color Strength, if desired, by entering a numerical value in the Color 
Strength field. The default setting is 1.

Tool Options

 Color Points tool options.
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• Select Group: Allows you to choose a point selection by name, as saved with 
the Select Point tool. For more information on how to create a point group, see 
“Select Points” on page 39.

• Color Strength: Increase or decrease the color strength by setting a numerical 
value in this field. The default setting of 1 applies the color at full strength.

• Color Swatch: Click the color swatch to assign a color to the selected point(s). 
You can also use the eyedropper to select a color from your scene, or from any 
other point on your screen.

• Clear: Click this button to clear the color assignments from the selected point(s).
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Chapter 5: Bone Tools
The following tools are available when working with Bone or Switch layers.

In general, tools that are used for bone setup can only be used when the time is set 
to frame 0 - others can be used at any time.

Moho has a smart tool palette, which shows and hides tools 
based on their need. The position of the tool shown in 

the screenshots may differ, depending on the selected layer in the 
Layers Window, and the current time in the timeline.

Click the tool icon in the properties bar to display a submenu. 
Choose Reset Tool to reset the current tool to its default 

settings. Choose Reset All Tools to reset all tools to their default 
settings.

 Bone Tools (Debut)

 Bone Tools (Pro)

Select Bone
Using this tool, you can click a bone to select it. You can also draw a 
marquee or a lasso around multiple bones to select more than one bone 

with the Select Bone tool.

You might want to select a bone in order to delete it (press the Delete or Backspace 
keys - all of its children will be deleted too). You also might want to select a bone in 
order to add new child bones to it. Click anywhere besides a bone to de-select all 
bones.

Tool Options
The following options appear in the Options toolbar when the Select Bone tool is 
active:
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 Select Bone Options (Part 1)

• Bone Constraints: Opens the Bone Constraints dialog, described in “Bone 
Constraints” on page 84.

• Select Bone: Use the Select Bone dropdown list to select a bone by name.

• Bone Name field: Displays the name of the selected bone. You can edit the 
bone name in this field.

 Select Bone Options (Part 2)

• Lock Bone: When checked, prevents accidental changes to the current bone.

• Lasso Mode: When checked, allows you to select multiple bones by drawing 
a lasso around them. When unchecked, you can select multiple bones by 
drawing a rectangular selection around them.

• Color: Click the Color selector to choose a representative color for the bones: 
Plain, Cadet Blue, Coral, Green, Orange, Pink, Purple, Red, Tan, Turquoise, or 
Yellow. These colors can be representative of any category you choose and 
are provided for project organization. The keyframes for colored bones will 
show up in the timeline in specially colored channels that match the colors you 
assign.

 Color options

• Show Label (Pro Only): Check the Show Label option to display the name of the 
bone in the project window. The names displayed are those which are either 
automatically or manually assigned in the Select Bone list. User-assigned labels 
help you remember what a particular smart bone controls (eye blinks, mouth 
shapes, etc.) To change the name of the bone, enter a new name for the 
selected bone in the text field immediately to the right of the list.

• Shy Bone (Pro Only): Shy bones help reduce workspace clutter. To mark a bone 
as shy, select the bone(s) and check the Shy Bone option. All bones marked 
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as shy can then be displayed or hidden with the Bone > Hide/Show Shy Bones 
command, discussed in “Hide/Show Shy Bones (Pro Only)” on page 463.

• End Flip (Pro Only): Click to flip the selected bone end to end.

• Side Flip (Pro Only): Click to flip the selected bone side to side.

Flipping bones can be essential to certain rigs in Moho. In the 
past, you could only flip a bone once. This would alter 

the position for the whole animation. Moho Pro brings a welcomed 
change to this workflow. Now when you flip a bone mid-animation, a 
keyframe will be created, allowing the effect to change at any time. 
This works with any bone setup you can think of: parents, targets, 
point binding and layer binding. You can even rig your Smart Dials to 
flip bones, adding more flexibility to any workflow.

 End Flip and Side Flip

Bone Constraints
With the Select Bone tool selected, click the Bone Constraints button in the options 
bar to open the Bone Constraint options dialog shown below.

For detailed instructions and examples of the options in this 
dialog, refer to the Angle Constraints section in “Tutorial 

3.2: Bone Constraints” on page 111 in your Moho Tutorial Manual.
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 Bone Constraints Options

• Angle constraints: Check this option if you want to limit the movement of the 
bone within certain angles.

• Min/max degrees: Enter the maximum and minimum angle range that you 
want the bone to rotate. For example, if you only want the bone to rotate 10 
degrees in either direction, enter -10 in the Min field, and 10 in the Max field.

• Independent angle (Pro only): Normally, if you move or rotate a parent bone, 
the child bone moves or rotates with it. If you check the Independent Angle 
option on a child bone, the child will keep the original angle. This is extremely 
helpful when rigging a character, as it can be used to keep the feet parallel 
to the ground as the legs move and rotate during a walk cycle. For more 
information about using independent angles, see “Tutorial 3.6: Enhanced Bone 
Features (Pro Only)” on page 140 in your Moho Tutorial Manual.
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 In the default position, the last bone is parallel to the ground.

 If you rotate its parent bone, the child also rotates.

 If you set Independent Angle on the child bone, it will rotate independently of its 
parent.

• Squash and stretch scaling (Pro only): When this option is checked, the objects 
that are controlled by the bone will maintain their volume when they are 
scaled. The height of the object will decrease as the length of the bone is 
increased, and the height of the object will increase as the length of the object 
is decreased. Enter the desired scaling factor in the field provided. For more 
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information, see “Tutorial 3.6: Enhanced Bone Features (Pro Only)” on page 140 
in your Moho Tutorial Manual.

 Squash and stretch scaling helps maintain the volume of an object as the bone is 
scaled.

• Maximum IK stretching (Pro only): Enter the maximum amount that you want to 
allow a bone to stretch with Squash and Stretch scaling.

• Arc IK Solver (Pro only): Check this option to use an alternative inverse solver 
for chains that have more than two bones. When turned off as on the green 
bone in the following figure, there are many possible ways for an IK target to 
reach the goal, and sometimes the movements cause the bones to fold upon 
themselves like an accordion. However, you will have more control over the 
bone this way. On the other hand, when the Arc IK Solver is turned on (as it is on 
the purple bone below), Moho will attempt to move the bones so that they line 
up as segments on a smooth arc. However, when the Arc IK solver is turned on it 
may be more difficult to move the bones into an S-curve.

 Arc IK off (left) and on (right)

• Ignored by inverse kinematics: When checked, inverse kinematics will ignore 
the bone. This is useful for attaching accessory bones on arms and legs. For 
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more information about ignoring inverse kinematics, see “Ignoring Inverse 
Kinematics (Pro only)” on page 88.

• Target (Pro only): Allows you to assign another bone as a target. The most 
common use for this is to set up Inverse Kinematics for a character so that you 
can more easily animate walk cycles. For more information about using target 
bones, see “Tutorial 3.6: Enhanced Bone Features (Pro Only)” on page 140 in 
your Moho Tutorial Manual.

Bone parents and targeting can be animated. For more 
information, see “Tutorial 3.7: Animated Bone Targets 

(Pro Only)” on page 150 in your Moho Tutorial Manual.

• Angle/Position/Scale control bone: Allows one bone to control the motion of 
another. Click to select the bone that you want to be affected, and then use 
the drop-down menu to select the bone that you want to use as the controller. 
Enter the desired control angle (positive and negative values are accepted) 
in the Angle field, the X and Y coordinates in the Position fields, or the desired 
scale factor in the Scale field.

• Bone dynamics: Tells Moho to move the selected bone automatically, based 
on values entered in the Torque Force, Spring Force, and Damping Force values 
entered. See “Tutorial 3.3: Bone Dynamics” on page 120 in your Moho Tutorial 
Manual.

• Close: Closes the Bone Dynamics palette.

Ignoring Inverse Kinematics (Pro only)
When designing a character, a simple arrangement is to have two leg bones, as well 
as a foot that has an IK target. 

Assume now that you want to attach other bones to the leg. For example, if you are 
rigging a furry character and you want to animate the fur on its upper and lower 
leg, you parent other bones to each of the leg bones as shown below; or you add 
other bones to animate muscles in a character.

Pin Bones are automatically marked to ignore inverse 
kinematics.
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 Two leg bones with additional child bones for animated fur.

When you animate the leg, you’ll notice that it doesn’t follow the IK target any 
longer. When Moho tracks IK chains, it stops when it encounters bones that have 
multiple children. If you select all of the fur bones that are parented to the legs, 
you can uncheck the Ignored by inverse kinematics option in the Bone Constraints 
popup. 

 Ignore by Inverse Kinematics option in the Bone Constraints popup.

After doing that, you will notice that the child bones will be ignored by Inverse 
Kinematics and the leg will animate and follow the target as expected. You can 
then go back and animate the fur bones by hand.
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 Extra leg bones (for fur) are ignored by IK and the leg follows the target as expected.

Add Bone
Use the Add Bone tool to add new bones to a skeleton. When you add a 
new bone, Moho automatically assigns a name to it. By default, the first bone 

you add is named B1, the second B2, and so on.

If another bone is selected before you click and drag, it will be the parent of the 
new bone you create. Otherwise, the new bone will be parentless, a root bone.

Note that bones don’t have to be touching to have a parent-child relationship. In 
the example shown in “Tutorial 3.4: Character Setup” on page 125 in your Moho 
Tutorial Manual, the upper arm bones are children of the spine, even though they 
are separated from it by a small distance. This will often be the case - arms should 
rotate about the shoulders, not the neck, even though they move when the spine 
moves.

You can add bones in one of two ways:

• Standard bones: Click with the Add Bone tool to set the base of the bone (the 
point that it rotates around), and drag to set the end point.

Hold the Shift key to constrain the new bone to point in a 
direction that is a multiple of 45 degrees.

• Pin Bones: Simply click the Add bone tool where you want to add a pin bone. 
When adding Pin Bones, do not parent them to each other. You should either 
parent them to a regular bone, or make them root bones.

More about Pin Bones
Pin Bones work with vector and image layers that are placed beneath a bone layer. 
When you use the Add Bone tool, you simply click in the spot where you want to 
add the Pin Bone. You will not need to drag your mouse to create the end point. Pin 
Bones are represented by a circle with crosshair.
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Zero length bones can be created with or without parents. If 
you don’t want your zero-length bone to have a 

parent, make sure that you deselect all bones first.

 A face with several Pin Bones to animate the features.

Pin Bones work like regular bones, except that they don’t have a length. You can 
use the Bone Strength tool to adjust the area of influence that the zero-length bone 
has. You can translate and rotate Pin Bones and animate those transformations. 
Simply drag a zero-length bone to translate it to a new position, or press the Alt key 
while dragging to rotate it. 

 Pin Bones can be translated and rotated, and keyframed for animation.
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Bone Snapping
When you add a bone, the next bone that you draw will automatically be a child of 
the previous bone. The new bone will automatically snap to the tip of the previous 
bone. 

To connect a completely separate bone to the tip of another bone, use the 
Transform Bone tool to drag the disconnected bone toward the bone you want to 
connect it to:

• Dragging the bone to the tip of a bone will connect the two bones together at 
the tip of the destination bone.

• Dragging the bone to the central axis of a bone will connect the two bones 
together at the base of the destination bone.

• Hold down the Ctrl/Cmd key to disable snapping. The child bone will not 
automatically snap to the tip of the previous bone when working in this mode.

Tool Options

 Add Bone Options

• Select Bone: Click this menu button to select a bone by name.

• Text Field: Allows you to assign a name to the currently selected bone, or to edit 
the name of the bone as automatically assigned by Moho.

Transform Bone
The Transform Bone tool allows you to translate, rotate, or scale a selected 
bone.

When the Transform Bone tool is selected, two dots appear at the ends of each 
bone. In addition, the cursor will change to display the type of transformation that 
will be applied:

 Transform Bone tool indications
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• To rotate a bone: Click near the bone, but outside of the handles. A rotate 
cursor will provide indication when the mouse is placed correctly. Then drag the 
mouse to rotate the bone.

• To translate a bone: Click and drag the dot at the base of the bone. Translated 
bones will snap to existing bones as described in “Bone Snapping” on page 
92.

• To scale a bone: Click and drag the dot at the end of the bone.

The following key combinations work while the Transform Bones tool is selected:

• Holding the Shift key will cause the bone to only translate horizontally or 
vertically relative to its parent (if you click near the base)

• Holding the Shift key while rotating will constrain the rotation to 45 degree 
increments.

• You can nudge the selected bone by small increments by holding down the Ctrl 
key (Windows) or Cmd key (Mac) and pressing the arrow keys. Hold down Shift 
in addition to Ctrl/Cmd to nudge the bone by a greater increment.

• If any objects in other layers have been bound to the bone, they will not move 
if the current frame is 0. At frame 0, you are modifying the bone layout - at later 
frames you are animating with this tool, and bound objects will move with the 
bone.

Tool Options

 Transform Bone Options (part 1)

• Select Bone: Click this menu button to select a bone by name.

• Position X: Allows you to numerically enter a value for the X coordinate.

• Position Y: Allows you to numerically enter a value for the Y coordinate.

• Length: Allows you to view or enter a numerical value for the length of the bone.

 Transform Bone Options (part 2)

• Reset: If pressed at Frame 0, resets a layer back to its default length. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

• Scale: Allows you to view or enter a numerical value for the scale of the bone.

• Reset: If pressed at Frame 0, resets a layer back to its default scale. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

• Angle: Allows you to view or enter a numerical value for the angle of the bone.
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• Reset: If pressed at Frame 0, resets a layer back to its default angle. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

• Show Path: When checked, the document window will display the path(s) that 
the animated bone(s) follow.

• End Flip (Pro only): Click to flip the end to end positions of the selected bones.

• Side Flip (Pro only): Click to flip the side to side positions of the selected bones.

Manipulate Bones
Animatable: Yes

The Manipulate Bones tool has two purposes. First, when the current frame is 
set to 0, it is used to test whether a skeleton is set up and working properly. 

Although it moves bones and points around, the changes it makes are only 
temporary. When you switch to another tool, the skeleton is reverted back to its 
original shape.

When working inside a Smart Bone action, the Manipulate 
Bones tool can introduce extra unwanted bone motion 

in the Smart Bone action. For this reason, the Manipulate Bones tool 
will be disabled.

The second use of this tool is at frames greater than 0. If the current frame is greater 
than 0, then this tool will move the skeleton in the same way, but the move will 
introduce a keyframe for animation.

To manipulate a skeleton, just click and drag the various bones that make it up. If 
points or other layers have been bound to the bones, they will move as well. The 
way the skeleton and the bound points move with this tool is exactly the same 
whether at frame 0 or a later frame. If some part of the skeleton doesn’t move 
correctly, you can find out with this tool and fix it before you start animating.

Note: If you only want to rotate a single bone, it’s better to use the Rotate Bone tool. 
The Manipulate Bones tool will move a whole chain of bones, which is definitely not 
what you want if you plan to rotate a single bone.

Sketch Bones
The Sketch Bones tool draws a chain of bones in freehand mode. It allows 
you create and animate bone chains very quickly, and is suitable for objects 

like long necks, tails, ropes, or other similar items that bend freely.



Moho 13.5
Users Manual 

95

Chapter 5: Bone Tools

 Animating a bone chain with the Sketch Bones tool.

You initially draw the bones on frame 0. The length of the bones can be set using the 
New Bone Length option in the toolbar.

Press the Shift key while drawing to constrain the bone chain horizontally or vertically.

 A chain of bones drawn with the Sketch Bones tool.

If you want to create another chain of bones that are a child of one of the bones in 
the previous chain, select the desired parent bone before adding the new chain.
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 Another chain with its parent set to an intermediate bone in the first chain.

When you use the Sketch Bones tool on a frame other than 0, you can edit the bone 
chains that you drew on Frame 0. You’ll notice that the display of bones is different. 
When you click on any bone in an existing bone chain and draw a new curve, you 
reshape the bone chain from that point on. A reference line appears to represent 
the total length of the chain while you draw the new shape. Once you reach the 
end of this reference line the Sketch Bones tool will not add additional bones, it will 
reshape the existing bones to the new shape that you created. 
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 Use the Sketch Bone tool on any frame other than 0 to reshape a bone chain.

Tool Options
The following options appear for the Sketch Bones tool:

 Sketch Bone Options

• New Bone Length: Enter a numerical value for the length of the new bones.

• Scale Bones: When turned on, the chain of bones will scale itself to fit the new 
curve that you draw while using the Sketch Bones tool on a frame other than 0. 
The number of bones in the chain will remain the same, regardless of whether 
the curve is shorter or longer than originally created.

You can assign Squash and Stretch behavior to selected bones 
and then use the Scale Bones option to lengthen or 

shorten the curve. As the curve shortens, the selected bones will 
“squash” and become fatter. As the curve lengthens, the selected 
bones will “stretch” and become thinner.
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Reparent Bone
Sometimes when building a skeleton, you may accidentally add bones to 
the wrong parent. Later, when you discover the error, deleting bones and 

adding new ones is just too much work. Instead, use the Change Parent tool to 
change a bone’s parent. First, select the bone whose parent you want to change 
(using the Select Bone tool). Then, using this tool, click on the new parent bone. (The 
new parent will become highlighted in blue.) If you want to turn the selected bone 
into a root bone (one that has no parent), just click on the background.

Tool Options

 Reparent Bone Tool

• Select Bone: Click this menu button to select a bone by name.

Bone Strength
When using bones to control the points in a vector layer or to warp an image 
layer, by default every bone has some degree of influence over every point 

in the vector layer (or image). The Bone Strength tool lets you adjust how much 
influence each bone has. When this tool is activated, a semi-transparent region 
appears around each bone - this region indicates the strength of the bone. If you 
drag side to side on a bone with the Bone Strength tool, you cause the region of 
influence to shrink or grow. Points that are closer to the center of this region move 
more when the bone itself is moved.

Although by default, all bones have some influence over some points, you can 
change this behavior. In the Layer Settings dialog, under the Bones tab, there are 
two options, Flexible binding and Region binding. Flexible binding means that every 
bone will influence every point. Region binding, on the other hand, means that a 
point will only move under the influence of the bone(s) in whose region of influence 
it lies. If that point only lies in one bone’s region, it will only move with that bone - if 
the point is overlapped by the regions of two bones, it will move with both of those 
bones.

Flexible binding is the default setting for new bone layers because it works 
reasonably well almost automatically. The downside is that it leads to rubbery 
movement of the attached vector artwork. Region binding will give you cleaner 
movement, but takes a little more work to set up. “Tutorial 3.4: Character Setup” on 
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page 125 in your Moho Tutorial Manual shows you how to use the Bone Strength 
tool together with both types of binding to quickly set up a character’s skeleton.

Tool Options

 Bone Strength Options

• Select Bone: Click this menu button to select a bone by name.

• Bone Strength: Allows you to view or enter a numerical value for bone strength.

Offset Bone
The Offset Bone tool lets you add an extra amount of bone movement 
starting at frame 1 of your animation. The reason you might want to do this is 

to simplify the setup of a complex character. Often, parts of a character such as 
arms and legs overlap, making it difficult to set up bones and attach the proper 
parts of the character’s body to them. The Offset Bone tool lets you draw the parts 
of a character in disconnected positions, set up bones, and then move them all 
back into position.

It’s difficult to describe the usefulness of this tool without a hands-on example, so 
look in “Tutorial 3.4: Character Setup” on page 125 in your Moho Tutorial Manual.

Tool Options

 Offset Bone Options

• Select Bone: Click this menu button to select a bone by name.

• Animation Offset X: Allows you to numerically enter a value for the amount of 
offset on the X axis.

• Animation Offset Y: Allows you to numerically enter a value for the amount of 
offset on the Y axis.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

Bind Layer
Other layers can be contained within a bone layer. For example, you could 
create a hand layer and place that within an arm layer. To bind the hand to 

the arm, use this tool. Just click on the bone in the parent layer that you want to 



Moho 13.5
Users Manual 

100

Chapter 5: Bone Tools

connect to, and the entire layer will move with that bone. In the arm/hand example, 
you would click on the bone nearest the wrist to bind the hand to the end of the 
arm.

Use this tool to bind an entire layer to a single bone. If you would rather bind certain 
points in a vector layer to certain bones, then you should use the Bind Points tool 
instead.

For more information on how to use the Bind Layer tool, see the 
Layer Binding section of “Tutorial 3.1: Bone Binding” on 

page 104 in your Moho Tutorial Manual.

Bind Points
The Bind Points tool operates exactly like the Select Points tool described in 
“Select Points” on page 39. Use it to select a group of points to bind to a 

bone. In order to use this tool, you must be on Frame 0, and a bone must first be 
selected. When a bone is selected, the points that are currently bound to it are 
automatically selected as well. Use this tool to add or remove points from that 
selected group. When the correct group of points is selected that you want to bind 
to the bone, press the spacebar - this tells Moho to perform the binding. This 
technique is demonstrated in “Tutorial 3.1: Bone Binding” on page 104 in your Moho 
Tutorial Manual.

We don’t usually recommend using the Bind Points tool. 
Instead, the best way to attach points to bones is to use 

automatic bone binding, together with the Bone Strength tool.

When you use the Bind Points tool on a vector layer, the bones 
are colored automatically. When points are bound to a 

bone, they will have the same color as the bone. For example, the 
points in the head in the image below is bound to a bone, so the 
bound points are colored the same as the head bone. The other 
points, which are not yet bound to bones, are still colored with the 
default point color.
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 Points that are linked to bones display with the bone color.

Bone Physics (Pro Only)
When objects that have bones are added to a Group layer that has physics 
applied to it (as mentioned in “Tutorial 5.9: Basic Physics (Pro Only)” on page 

214 in your Moho Tutorial Manual), the bones will respond to the physics properties 
that you have set for the object. Physics are applied to each bone based upon the 
bone’s area of influence, as set by the Bone Strength tool.
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 A boned character placed into a physics group

The Bone Physics tool is a setup tool and will only be available at Frame 0, and once 
a boned object is placed inside a Group layer that has physics enabled. The options 
mentioned in the following section become available in the Options bar. You can 
assign different physics properties to the bones by clicking each bone with the Bone 
Physics tool.

For additional information on configuring groups and objects 
for physics, see “Tutorial 5.9: Basic Physics (Pro Only)” 

on page 214 in your Moho Tutorial Manual.

After you set up the objects in your scene, and the bones in your 
character, you can press the play button to see how the character 
responds to the physics as it comes into contact with the other 
stationary and physics-enabled objects in the scene.

 The boned character responding to other objects in the scene
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Tool Options

 Bone Physics tool options.

• Select Bone: Click this menu button to select a bone by name.

• Bone Physics Region: With physics, bones are represented internally with a 
kind of pill-shaped region around them, the physics region. You can enter a 
number numerically, but generally you would just use this tool to click and drag 
on individual bones to control the size of the physics region, trying to get it to 
match the underlaying character as closely as possible. When you play back 
the animation, the bone physics regions are what is used in collisions, not the 
character artwork. (This is because the bending of the character is not directly 
physics related. The physics pushes the bones around according to the physics 
regions, and the bones then move the character just like they would if you were 
hand-animating.)

• Motor Speed: . The motor speed is the number of degrees per second the 
object will rotate (it can be negative to rotate backwards). Depending if the 
object bumps into obstacles or there are other influences, it may not actually 
rotate at that speed, but in a zero gravity setup with no collisions, that will be the 
speed of rotation.

• Motor Torque: Motor torque controls the strength of the motor. With low torque, 
when a motorized object bumps into other objects it may come to a stop, 
depending on the size and density of the obstacles. With a high torque, it will 
tend to push obstacles out of its way. Even with no obstacles, if a motorized 
object is unbalanced (off center of its origin), a low torque setting may mean 
that it can even lift itself up.

• Return to Neutral: Check this option to return the bone to neutral position.

• Lock Tip: When physics are in affect, if a bone has its tip locked it acts as though 
the endpoint of the bone has been nailed to a stationary point.

Smart Bones (Pro Only)
The Smart Bones feature in Moho Pro allows you to have more control over shapes 
when you bend them with bones. You can use Smart Bones to control the following 
types of scene elements.

• In vector layers that are a child of a bone layer: Point motion, Curvature, Line 
Width, Fill Color, and Stroke Color.

• In any layer type that is a child of a bone layer: Layer translation, Layer scale, 
Layer Rotation (X, Y, and Z), Layer Shear, Layer Opacity, Layer Blur

In the same layer as the Smart Bone itself:

• Bone translation

• Bone scale
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• Bone rotation

Smart Bones can be used to control the following additional elements:

• Stroke exposure: Use Smart Bones to expose more of a stroke along a path as 
you rotate the bone.

• 3D Thicknesses: Increase or decrease the thickness of vector shapes that have 
been converted to 3D shapes with Extrude or Inflate.

• Shape and Fill effects: Change the colors and positions in a gradient fill.

• Switch layers

• Layer order

• Layer visibility

• Follow path

• Flip layer horizontally/vertically

• Shape effect positioning

How Smart Bones Work
To illustrate how Smart Bones work, create a vector layer and add a rectangle to it.

You will eventually add two bones to this rectangle, so you’ll also want to make sure 
that there are some points in the center of the rectangle where the two bones will 
meet (as a joint).

In the Layers Window, create a bone layer and drag the rectangle vector layer into 
it. With the Bone layer selected, use the Add Bone tool to create two bones to the 
bone layer.

 Create a rectangle with points at the center; add a bone group, and create two 
bones.

Use the Bone Strength tool to adjust the bone weights so that the rectangle bends in 
the center as shown below.
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 Adjust bone strengths to get a nice bend in the center.

You’ll notice that if you bend the bone too far that the area around the bend 
doesn’t look good because the rectangle gets squeezed in the middle.

In previous versions of Anime Studio, the way around this distortion was to add 
points in the center of the rectangle that would reshape the center appropriately. 
However, this method resulted in a lot of corrections that had to be made whenever 
that bone was animated.

Smart Bones use a different approach, by linking a bone rotation to an action, and a 
resulting correction.

The steps that follow describe how to create smart bone 
actions manually. You can use the Bone > Make Smart 

Bone Dial command to set up the smart bone dials more quickly. 
See “Make Smart Bone Dial (Pro Only)” on page 464.

Creating a Smart Bone Action
In order to use this feature, you need to assign a name to each bone that needs 
correction. In the following figure the bones are named B1 (for the bone on the left) 
and B2 (for the bone on the right). You can name the bones whatever you want to 
name them.

Every bone automatically gets named when you create it. By 
default, the bone is assigned a name such as B1 (for 

the first bone), B2 (for the second bone) and so on.

You’ll notice when you rotate bone B2 it causes the rectangle to distort when it is 
bent. You can correct this distortion by creating an action that is associated with 
that bone.
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 Each bone is assigned a name.

Choose Window > Actions to bring up the Actions window. If you have a bone 
selected when you create a new action, Moho will automatically assign the same 
name as the bone to the new action.

 Create a new action, named the same as the bone you want to correct.

At that point you are editing the action. Choose the Rotate Bone tool in the Tools 
panel, and rotate the bone as far as you expect it to move (or, to the limit that is set 
on the bone in that direction).
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 Rotate the bone to the limit at which you expect it to rotate (upward in this case).

Now switch to the vector layer and use any of the available editing tools to adjust 
the shape of the rectangle so that it looks good. The joint correction feature can 
track point movement and curvature changes. This shape will be the target shape 
for when bone B2 is rotated to that angle.

When working inside a Smart Bone action, the Manipulate 
Bones tool can introduce extra unwanted bone motion 

in the Smart Bone action. For this reason, the Manipulate Bones tool 
will be disabled.
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 Select the vector layer for the rectangle, and create the target shape for that 
rotation angle

In the Actions window, switch back to the main timeline by clicking Mainline. Now 
when you rotate bone B2 toward that angle, it will automatically pick up the action 
that you just created.

Now the distortion around the joint works much better. You can now go to 
frames other than zero to add keyframes that animate the bones. The actions will 
automatically be added when the bone is rotated, and the action will be removed 
when the bone is straightened.

Creating a Second Smart Bone Action
You’ve just created an action for the bone when it moves in one direction. However, 
you also need to create an adjustment for the other direction
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 A second action must be created for when B2 is rotated downward.

To create another action that corrects the second direction, go back to the Actions 
window and create another new action. This bone will be assigned the name of the 
bone, followed by a space, and the number 2 (B2 2). The B2 prefix associates the 
action with Bone B2, and the number 2 is a number designation to differentiate it 
from the first action.

When you create a second action for the same bone (such as 
when you want to add a bone that controls in both 

clockwise and counterclockwise rotation), Moho will automatically 
append the number 2 after the second action for the same bone.

A bone can only have two Smart Actions assigned to it 
(clockwise and counter-clockwise rotation). If you 

attempt to create a third action for the same bone, the name 
suggested by the software will be Action followed by the first 
available number greater than 0.



Moho 13.5
Users Manual 

110

Chapter 5: Bone Tools

 The new action also incorporates the name of the bone you want to correct.

As you did in the first case, select the vector layer for the rectangle, and adjust the 
shape for when B2 is bent downward. An example is shown in the following figure.

 Bend the bone in the other direction to see if adjustments are needed.
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Editing a Bone Action
You can also go back to a previous bone action and make corrections to it. For 
example, when you created the first bone action, it simply improved the shape of 
the bend. Suppose you want to go back and create something like a muscle bulge 
for when an arm is bent upward. Bone actions make this process easy to do:

• To begin, go back to frame 0 and add a point to the rectangle, located in the 
area where you want the muscle bulge to happen.

• Select the first correction action (B2).

• Move the new point like a bulging muscle.

 Add a new point and position it to make a bulging muscle.

• Go back to the main timeline and play the animation. The keyframes that 
you originally added will now also include the new muscle bulge when 
the rectangle is bent in the appropriate dimension. When the arm bends 
downward, the muscle bulge will not be included because it was not added to 
the B2 2 action that bends the arm downward.

Fixing Bad Transitions
You might discover after creating your bone actions that the object doesn’t look 
quite right when it’s bent in intermediate positions. For example, objects might bend 
unpredictably if their point count is too high, or unoptimized. The following solution 
can help improve the appearance of intermediate frames.
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You can also use Blob Brush to fix a transition between two 
bones (such as an elbow or knee bend). This type of 

bone binding can be applied to vector and image layers. For more 
information about this feature, see “Create Smooth Joint for Bone 
Pair (Pro Only)” on page 460.

The processes discussed in “Creating a Smart Bone Action” on page 105 and 
“Creating a Second Smart Bone Action” on page 108 are still used to create your 
bone action in this case. But in this example you see a rectangle that has many 
more points along its length (to simulate an object that is not optimized). Most of the 
points in the rectangle aren’t really necessary for it to maintain its shape when it’s 
bent.

 A rectangle with many points along its length

Bones are added to the rectangle, and the second bone (Bone B2) is posed as 
described earlier in “Creating a Smart Bone Action” on page 105. The end result 
looks similar to the previous example when Bone B2 is rotated to its extreme position.

 Bone B2 bend end result

However, you might notice problems in intermediate positions, such as shown 
in the following figure. If you only have an action that defines the start and end 
shapes, you don’t have any way to fix interpolation problems that might occur in 
intermediate frames in your actual animation.
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 An intermediate frame shows some shaping problems.

If your bone action works fine in the intermediate frames, using just a single frame 
action, leave it as is.

If the in-between frames are objectionable, you can do the following to correct it:

• Go back to the B2 action.

• Instead of creating the angle at frame 1, you can move it somewhere later in 
time, like frame 120. Move the keyframe for the bone angle out to 120.

Moho doesn’t care how many frames you need to complete 
the bone action. But because of the nature of the 

program it interpolates in steps. If an action is too short (3 frames), 
you only have three steps in between to make the animation 
smooth. Spreading it out smoother gives you room to correct for a 
more smooth transition.

Select all of the point positions that you changed for the original 
bone action and move them out to 120 as well. Now the action 
takes 120 frames to complete the bend.

• Move to an intermediate frame in that bone action (not in the main timeline) 
until you locate an area that looks objectionable. Now you can adjust the in 
between positions of the points. Make sure when you edit the points that they 
are the only keyframes that are selected.
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 Frame 60 of the bone action before adjustment.

 Frame 60 of the bone action after adjustment

After you make your adjustments, scrub through to make sure that there are no 
other areas that need adjustment. If you find others, just move the points in that 
frame of the bone action (not in the main timeline) to make additional corrections 
as needed.

After your edits are complete go back to the main timeline. Test out bending the 
bone on frame 0.

Other Uses for Bone Actions
Here are some eyes in which bones have been set up to make the eyes do a variety 
of movements such as blink, dilation, sideways, and up-down. Tags have been put 
on the bones to show what the bones are used for, but this is not necessary. The 
bones aren’t really being used as bones, but they are being used as control levers.
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 Bones used as control levers.

The bones were initially created with the bone strength set to zero. Each of the 
bones was assigned a name (the name isn’t really important but helps you keep 
track of the actions that the bones are intended to control). When you go to the 
actions window, you can create actions that match each one of the control levers.

For example, if you are working on the Blink action you rotate the bone to the other 
extreme, and then adjust the points in the Lids layer to close the eyelids. When you 
go back to the timeline and move the bone, it closes the eyelid.

 A bone used as a control lever to make an eye blink.

Smart Bones and Binding
The original type of binding used in Moho 1.0 was a direct binding method. With 
direct binding, each point can be bound directly to one particular bone. When that 
bone moves, the point tracks that bone exactly, without influence from any other 
bones.
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Flexible binding was introduced in later releases of Anime Studio, and is now the 
default behavior in Moho. The benefit of this type of point binding is that it’s relatively 
easy to make points bend smoothly around joints in a bone structure. With this 
method, every bone has some kind of influence on every point. Points that are closer 
to a given bone are more influenced by that bone; but bones that are far away 
from certain points can also move those points a small amount. Bone strength also 
plays a part in how much each bone controls each point.

Here’s where the type of binding matters: When bones move points, that movement 
is going to be different depending on the type of binding. When you set up a bone 
rig with smart bones, the smart bone actions get set up as movement relative to the 
bone rotation.

If you set up smart bones, but then later change the type of binding on the points, 
the smart bone actions will no longer be meaningful. Because the basic point 
motion changes when you change binding, you’ll get unexpected results when you 
apply an action that was designed for a different point motion on top of that.

If you need to change the type of point binding for vector layers when working with 
smart bones, you will generally need to delete and recreate the smart bone actions, 
or at least review them carefully and tweak them to make sure they still look good 
with the new point binding. As a general rule of thumb, we recommend that you 
get the rig to work as well as you can first. Adjust bone position, strength and point 
binding first, and commit to them before you set up any smart bone actions.
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Chapter 6: Layer Tools
The following tools are available to be used with any type of layer. Their purpose is to 
modify an entire layer, not just an individual object in that layer.

 Layer Tools (Debut)

 Layer Tools (Pro)

Moho has a smart tool palette, which shows and hides tools 
based on their need. The position of the tool shown in 

the screenshots may differ, depending on the selected layer in the 
Layers Window, and the current time in the timeline.

Click the tool icon in the properties bar to display a submenu. 
Choose Reset Tool to reset the current tool to its default 

settings. Choose Reset All Tools to reset all tools to their default 
settings.

Reset tool options.

Transform Layer
Animatable: Yes

Use this tool to translate, rotate, or scale the entire layer. It doesn’t matter 
what objects are selected - everything in the layer will move when you use 

this tool.

When the contents of the layer are selected, a pair of rectangles will surround the 
items in the layer.
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 Transform Layer rectangle

• To translate a layer: Click anywhere inside the inner rectangle to move the layer 
to a new location.

 � Hold the Shift key while translating to constrain the movement to straight 
horizontal or vertical movement.

 � Hold the Alt key while translating to move the layer on the Z (depth) axis.

When transforming multiple layers with the Transform Layer tool, 
make sure that you do not transform one or more layers 

when their parent is also selected. Otherwise, double transforms will 
result in the child layer(s). 

In Moho Pro, when you move an object forward or backward 
in Z, it appears to move toward the center of the 

camera. What you are seeing is a perspective effect. If you want to 
move an object backward but keep the visual size the same, press 
the SHIFT and ALT keys together while you transform the layer. You 
will see the object move backward or forward, but it will also be 
transformed along the X and Y axes as well. This will make the layer 
appear as though it is moving forward or backward from its center.

In Moho Pro, when you release the mouse after transforming 
the layer with the Shift ALT keys, it will appear as though 

the layer pops back to its original size. If you rotate the camera you’ll 
see that the object has become larger. This helps you maintain the 
same composition from the view of the camera, allowing you to 
compose your scene in 2D but then add depth to it in Moho. As you 
move the object forward or backward the change in scale reflects 
the amount that the object is moved. After you release the mouse, 
the object changes scale to retain the original composition of the 
scene.
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• To rotate a layer: Click in the area between the inner and outer rectangles, and 
drag up, down, left, or right to rotate the layer around its origin point.

 � Hold the Shift key while rotating to snap the rotation to 45 degree angles.

• To scale a layer: Click one of the corner handles to scale the layer uniformly. 
Scaling is proportional by default. To perform non-proportional scaling with a 
corner handle, press the Shift key while you scale the object. 

• Drag a handle on the top, bottom, right, or left edge of the rectangle to scale 
the object horizontally or vertically.  

 � Press the Alt key while scaling to maintain the volume of the object while 
you scale ... in other words, if you increase the height of an object, the 
width will decrease; or if you increase the width of an object, the height will 
decrease.

When you are working with a 3D camera, the original plane of 
the object might not be the best place to move the 

object. You can use the Pan and Tilt camera tools to position the 
camera along the plane in which you want to move the object, and 
then use the Transform Layer tool to move the object along the 
plane of the camera’s current view.

If the Show Path box in the tool options area is checked, then the motion path for 
the current layer will be displayed in the working area when this tool is active. This 
makes it easier to visualize and plan out the motion of a layer.

Direct Path Editing: To edit the motion path directly, hold down the Ctrl key 
(Windows) or Cmd key (Mac) , then click and drag anywhere on the motion path to 
adjust the curve that the layer will follow through space.

Nudging: When this tool is active, you can nudge a layer by small increments by 
holding down the Ctrl key (Windows) or Cmd key (Mac) and pressing the arrow keys. 
Hold down Shift in addition to Ctrl/Cmd to nudge the layer by a greater increment.

Tool Options (for Translating)

 Transform Layer Options for Translating

• Position X: Allows you to numerically enter a value for the X coordinate.

• Position Y: Allows you to numerically enter a value for the Y coordinate.

• Position Z: Allows you to numerically enter a value for the Z coordinate.’

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.
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Tool Options (for Scaling)

 Transform Layer Options for Scaling

• Scale X: Allows you to enter a numeric value for scaling along the X axis.

• Scale Y: Allows you to enter a numeric value for scaling along the Y axis.

• Scale Z: Allows you to enter a numeric value for scaling along the Z axis.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

Tool Options (for Rotating)

 Transform Layer Options for Rotating

• Angle: Allows you to enter a numerical value for rotation along the Z axis.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

Tool Options (Other)

 Other Transform Layer Options

• Show Path: Check this option to display the motion path on the layer. Uncheck 
the option to turn the motion path display off.

• Flip Layer Horizontally: Click this button to flip horizontally.

• Flip Layer Vertically: Click this button to flip vertically.

• Alignment: After you select two or more layers, click the Alignment button to 
choose how you want to align them. Options are Left, Right, Center Horizontally, 
Top, Bottom, or Center Vertically. 
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 Alignment button and options

Separating Timeline Channels (Pro only)
Moho allows you to separate timeline channels so that you can work with them 
independently. For example, the following types of channels can be separated:

• Layer translation

• Layer scale

• Layer shear

• Camera tracking

• Camera pan/tilt

• Selected bone translation

• Selected point position

For bone and point channels, you can only work with selected 
bones or points because it is more than likely that you 

do not want to split all bones or points in a given layer. Working with 
selected channels gives you more control over the items in the 
channels that you want to split.

When layer transformations appear in the timeline, you can separate them into the 
X, Y and Z layer transformation channels in the timeline. To illustrate how this works, 
assume that you want to make a ball bounce up and down and move across the 
screen. You begin by creating the up/down motion (along the Y axis) with the ball 
moving down at frame 4, and up again at frame 8. Next, you add a cycle in the 
timeline at frame 8 to create the bounce. 
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 Simple bounce keyframes with cycle

Now you want to make the bounce move across the screen. So you advance to 
a later frame and move the ball sideways (along the X axis). But in doing this, you 
break the cycle. The ball moves up and down in its cycle until it reaches the frame 
where you transformed it to the right of the screen, and suddenly jumps to that spot.

You can separate the transform channels in the timeline to have more control over 
how this bounce works. To separate the channels, you first delete the keyframes that 
moved the ball to the right side of the screen, leaving only the bounce cycle that 
you created at the beginning.

Now right-click the Transformation channel icon at the left side of the timeline, and 
choose Separate Dimensions. After doing that you will see three individual channels 
in the timeline, and all of the keyframes that you created appear for each individual 
channel. 

The Red channel is the X translation (left to right); the Green 
channel is the Y translation (up and down); and the 

Blue channel is the Z translation (forward to backward).

You can right-click on a separated channel icon and choose 
Rejoin Dimensions to merge the separated channels 

back together again.
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 Separated channels for the bounce cycle

Since the bounce happens in the Y (up and down) dimension, you can delete the X 
and Z channels in the timeline. Select the X (red) and Z (blue) channels, and delete 
them. When you play back the animation you should still see your ball bounce.

 X and Z channels are removed from the bounce cycle

Now you can advance to your later frame, and translate the ball to the right side of 
the screen. You’ll notice now that Moho displays a path that will cause the ball to 
bounce up and down from left to right.
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 Move the ball toward the right to create the bouncing ball.

Set Origin
Animatable: Yes

With the Set Origin tool selected, click anywhere in the layer to set the origin 
to that point. The origin of a layer is indicated by the crosshair displayed 

when editing that layer. The origin is the point that the layer rotates around when 
using the Rotate Layer tool, and the point that the layer resizes around when using 
the Transform Layer tool. The location of the origin can also define how a layer will 
move when it is attached to a group of bones.

Although you can change the origin at any time, the position of a layer’s origin is not 
animated. We recommend setting the layer’s origin just once, and then leaving it 
alone for the rest of the animation - otherwise unpredictable movement can occur. 
In most cases, you will never need to change the origin of a layer at all.

Tool Options

 Set Origin Options

• Origin X: Allows you to view or enter a numerical value for the X origin
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• Origin Y: Allows you to view or enter a numerical value for the Y origin

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

• Flip Layer Horizontally: Click this button to flip horizontally.

• Flip Layer Vertically: Click this button to flip vertically.

Follow Path
This tool allows you to assign any layer to follow a path in your scene. You will 
need two layers, one with the path, and the other with the object that will 

follow the path.

Previously, there was no indication that a layer was set to follow 
a path. This could make it very confusing when opening 

a file you weren’t familiar with (or hadn’t used in a while). Certain 
layers might move in unexpected ways. Now, layers that follow a 
path get a little extra squiggly line (indicating path following) on top 
of their icon in the Layers Window.

If a layer follows a path, an extra squiggly line will appear on 
top of their icon in the Layers Window.

 Two layers, one with a path, and another with a character or object

To use the tool, select the layer that contains object that you want to follow the 
path. Then select the Follow Path tool from the Layer section of the toolbox. The 
path appears in the scene after you select the Follow Path tool. Click the path in the 
scene to reposition the object to the beginning of the curve.

You can click and drag left or right with the Follow Path tool to position the object 
along the curve at any point. You can then move to a later frame in your animation 
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and set the object to a new position. This allows you to animate the object travelling 
along the path.

 The fish before and after it is placed on the path with the Follow Path tool

You can set the object to rotate so that it follows the path. Double-click the object’s 
layer in the Layers Window, which opens to the General tab. Check the Rotate to 
follow path option in the Options section of the Layer Settings dialog and click OK. 
This causes the object to automatically orient itself to follow the path to which it is 
assigned.
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 Check the Rotate to Follow Path option in the Layer Settings dialog to orient the 
object to the path

You can also combine path following with the Stroke Exposure 
tool, and expose the stroke of the curve while the 

object moves along the path.

If you hold down the Alt key while clicking on a curve, the 
object will now bend along the curve. This allows for 

text bending, characters that warp along a path (like a snake), and 
so on. You can animate this effect. For example if you go to another 
point in the timeline, you can Alt-click somewhere else on the curve.
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 Press the Alt key while using the Follow Path tool to bend the object along the path

Tool Options

 Follow Path Options

• Percentage: Allows you to enter a numerical value for the position of the object 
on the path. A value of 0 places the object at the beginning of the path, while 
a value of 100 places the object at the end.

Rotate Layer XY (Pro Only)
Click and drag up and down to rotate the layer around the X (horizontal) 
axis. This is a true 3D rotation, so that one half of the layer rotates into the 

screen and the other half out of the screen.

Click and drag side-to-side to rotate the layer around the Y (vertical) axis. This is a 
true 3D rotation, so that one half of the layer rotates into the screen and the other 
half out of the screen. You can verify this by using the Orbit Workspace tool to 
change your view of the scene.
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Tool Options

 Rotate Layer XY Options

• X Rotation: Allows you to enter a numerical value for rotation along the X axis.

• Y Rotation: Allows you to enter a numerical value for rotation along the Y axis.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

Shear Layer (Pro Only)
Animatable: Yes

Use this tool to shear the current layer horizontally or vertically. Click and drag 
to shear, or slant the current layer to the left, right, up, or down.

Tool Options

 Shear Layer Options

• Shear X: Allows you to view or enter a numerical value for shear along the X axis.

• Shear Y: Allows you to view or enter a numerical value for shear along the Y axis.

• Shear Z: Allows you to view or enter a numerical value for shear along the Z axis.

• Reset: If pressed at Frame 0, resets a layer back to its default value. If pressed at 
any other frame, resets the layer to the value or values set at frame 0.

Layer Selector
The Layer Selector helps you quickly find and edit the vector, image, and 3D 
content in your layers. It is very helpful, especially when you have dozens or 

hundreds of layers in your project and can’t remember which layer a specific shape 
appears on.

This tool can be also be used by Alt Right-clicking on the object 
that you want to select.

You can Alt Right click any layer type that has visible contents. If you click a shape 
that appears in a Bone group, for example, it will select the vector layer that 
appears within that Bone group.
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There are no options for this tool. Simply click on the object you want to select, and 
its layer is automatically selected for editing. If there are multiple objects in the layer, 
the object that you click on is the selected object.

Insert Text
Moho allows you to enter text in your projects. While doing so, you have the 
option to automatically create a word balloon that encloses the text.

Moho supports both TrueType and OpenType fonts in Windows.

The following example explains how you can add text and a word balloon inside a 
project:

1. Choose one of the following to open the Insert Text dialog:

 � In the Layers Window, create a new Text layer.

 � Click the Insert Text Tool, located in the Layer Tools section.

 � Choose Draw > Insert Text

 � Use the keyboard shortcut COMMAND/Ctrl T. The Insert Text dialog 
appears.
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 Insert Text Options

2. The Select Font list displays all of the fonts on your system. Select the font that 
you want to use from the list.
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 Select Font list

3. Enter the text in the Text field. The project window will update as you type.

Word balloons will automatically resize to accommodate the 
text. If you want to break the text into multiple lines, you 

will need to press the Enter key where you want a line break to 
occur.

 Enter your text in the text field.

4. Use the remaining settings to set additional text properties as follows:
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 Select fill, stroke, and other font options.

 � Style 1 or Style 2 (Pro Only): Select a saved style to assign to the text.

 � Fill: Check this option if you want your text to be filled with a solid 
color. Uncheck the option if you want your text to only use an outline 
stroke (described next). For filled text, click the color swatch or use the 
eyedropper to select the fill color.

 � Stroke: Check this option if you want your text to have an outline. Click the 
Color swatch or use the eyedropper to select the outline color.

 � Width: Enter the desired pixel width for the outline stroke in the Width field.

 � Justification: Click the justification type that you want to apply to the text. 
Choices are Left, Center (the default), or Right.

 � Create One Shape: With this option checked, your text object will be 
added to the currently selected layer. This text will be added as a vector 
object and will not be editable.

If you leave the Create Text Layer option unchecked, your text 
object can be manipulated just like anything else. This 

includes using any of the drawing tools to distort its shape, or to add 
new points in the middle of a character. This also means that in order 
to move or rotate a text object, you need to select all the points in 
the object. This is easy to do using the Select Points tool - just click on 
the filled in area of the text to select all of it.
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If your text is added as a vector object, you can use the 
Freehand tool and Delete Edge tool to create uniquely 

colored text. First, create your text as normal, making sure that there 
is a stroke on the text. Then use the Freehand tool (with its Auto Weld 
option on) to slice the text or letter up into shapes that you can color 
differently. Finally, use the Delete Edge tool to remove the lines that 
hang out from the edges of the text. See “Freehand” on page 49 
and “Delete Edge” on page 53 for more information on how to 
use those tools.

 Create colorful text using the Freehand and Delete Edge tools with the Insert Text tool.

 � Create Text Layer: With this option checked. a new text layer will be 
created, and you can easily edit the text afterward. To do so, open the 
Layer Settings dialog and click the Text tab to make your changes.

 � Scale: Use the Scale slider to increase or decrease the text size, or enter a 
scale value in the Scale field.

 � Leading: Use the Leading slider to adjust the spacing that appears 
between multiple lines of text. Move toward the left to decrease space, 
and toward the right to increase space. Negative values are also valid.

 � Kerning: Use the Kerning slider to adjust the amount of space between 
letters. Move toward the left to decrease space, and toward the right to 
increase space. Negative values are also valid.

5. If you want to use a word balloon to enclose your text, select one of the word 
balloons from the Select word balloon type list. Otherwise, choose <none> if you 
do not want to use a word balloon.

6. Additional word balloon options (custom for each word balloon type) appear 
beneath the selection. These options allow you to change the appearance 
of the word balloon. For example, you might find options that affect the 
appearance and placement of the balloon tail, or whether the outer edges 
of the balloon are smooth or cloud-like. Each of these balloon morphs are set 
to zero, initially. You can move the dials in any combination to change the 
appearance of the balloon. The preview window updates as you make your 
changes. The text will appear in your document, pre-filled with the current fill 
color and style, and it can be resized and positioned just like any other object.
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 Choose a word balloon type, if desired, and use the balloon morphs to customize its 
appearance.

7. Use the following settings to determine the color and size of the word balloon:

 Choose a word balloon type, if desired, and use the balloon morphs to customize its 
appearance.

 � Custom Fill: Check this option if you want to select a fill color for the word 
balloon. Click the color swatch or use the eyedropper to choose the 
desired fill color.

 � Custom Stroke: Check this option if you want to select a stroke (outline) 
color for the balloon. Click the color swatch or use the eyedropper to 
choose the desired stroke color.

 � Stroke Width: Enter the width of the stroke used for the word balloon in 
pixels.
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 � Size Relative to Text: Use this slider to increase or decrease the amount of 
white space that appears between the text and the outer edges of the 
balloon. Move the slider toward the left to decrease the amount of space, 
and toward the right to increase the amount of space.

 � Flip Vertical: Check this option to flip the object vertically. For example, if 
the tail is on the bottom of the balloon by default, it will place the tail on 
the top.

 � Flip Horizontal: Check this option to flip the object horizontally. For 
example, if the tail is on the left side of the balloon by default, it will flip the 
balloon so that the tail is on the right side.

 � Constrain Proportions: Check this option if you want to keep an equal 
amount of white space around the width and height of the balloon. When 
unchecked, the height of the balloon will be closer to the text, and the 
width of the balloon will have more white space.

8. Press OK to add the text to your project.

 Text added as a text layer.

Creating Word Balloons (Pro Only)
You can use Moho Pro to create word balloons for your own use. Briefly, the 
following conditions should be met when creating word balloons:

• The Moho files must contain a rectangular point group named Text Region. If this 
point group is missing, the balloon will be considered invalid.

• If you want to add morph targets to your word balloon, you will need to use the 
Window > Actions command to open the Actions window. Use the New Action 
button in the Actions toolbar to design single-frame animations that you can 
use for your morph targets. For further information on this process, see “Creating 
Morphs (Pro Only)” on page 370.
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• Default word balloons for Moho appear in the Resources > Support > Word 
Balloons installation folder. It is not recommended to put your custom word 
balloons in this same folder. Instead, create a content folder as recommended 
in “Creating a Content Folder” on page 16, and place your custom word 
balloons in its Word Balloons subfolder.

Eyedropper
To use the Eyedropper, click on a shape to copy its parameters.

Hold the ALT key to push the current color.

• Press the COMMAND/CTRL key down while you click to pick up the properties 
of the underlying object. This is not limited to vector layers. For example, if 
you have a Bone Layer active in the Layers Window but click over a gradient 
shape on the stage, the properties of the gradient shape will be copied to the 
clipboard in a Web color format. You will then be able to paste that property 
into the Color Picker to assign that color to a fill, stroke, or project background 
color.
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Chapter 7: Camera and 
Workspace Tools

Camera Tools
The following tools let you move a virtual camera around in a scene. Although layers 
in Moho are primarily 2D, Moho’s camera can be moved around in true 3D space. 
The camera tools affect all layers in the document, not just the currently active layer.

 Camera Tools (Debut)

Camera Tools (Pro)

Click the tool icon in the properties bar to display a submenu. 
Choose Reset Tool to reset the current tool to its default 

settings. Choose Reset All Tools to reset all tools to their default 
settings.

Reset tool options.

Track Camera
Animatable: Yes

This tool moves the camera up and down, and side-to-side. By giving the 
project’s layers different depth values, you can create parallax (depth) 

effects. Holding the Shift key while using the Track Camera tool will constrain the 
camera to only move vertically or horizontally. Holding the Alt key will move the 
camera forward and back.

If the Show Path box in the tool options area is checked, then the motion path for 
the camera will be displayed in the working area when this tool is active. This makes 
it easier to visualize and plan out the motion of the camera. (The camera’s motion 
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path is only visible when the Orbit Workspace tool has been used to view the scene 
from outside the camera.)

Zoom Camera
Animatable: Yes

This tool zooms the camera in and out on the scene, just like the zoom control 
on a real camera. Technically, the Zoom Camera tool is changing the field of 

view angle (or focal length) of the virtual camera. The default camera Z position 
and field of view is equivalent to a 35 mm camera to reduce the wide angle 
distortion.

Roll Camera
Animatable: Yes

This tool rolls the camera side to side. Try tilting your head side to side, and 
you’ll understand this tool immediately.

Pan/Tilt Camera (Pro Only)
Animatable: Yes

This tool changes the viewing angle of the camera. Drag the tool up and 
down to change the tilt angle of the camera, and drag side to side to 

change the pan angle. Hold the Shift key while using this tool to constrain the 
camera to only one direction of rotation. Press the Alt key while dragging with the 
Pan/Tilt camera tool to orbit arround a central point, such as when you want to fly 
around a 3D object.

This tool is most useful when you’ve set up a scene in 3D (different layers at different 
depths), and have placed the camera so that it is sitting somewhere among the 
layers, not viewing them from a distance.

In order to be consistent with multi-touch features, the Pan/Tilt 
Camera tool has had its mouse direction reversed.

Workspace Tools
Change your view of the workspace

The last group of tools in the toolbar is always available, regardless of the current 
layer type or the current selected object. These are the Workspace tools, and are 
used to control your view of the project, but don’t actually modify the project itself.

 Workspace Tools (Debut)
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 Workspace Tools (Pro)

Pan Workspace
When the Pan Workspace tool is selected, you can click and drag in the 
working area to move the project side to side and up and down. Note that 

this isn’t the same as moving the objects in your project - only your view of them is 
changing, not where they appear in the final image. 

A shortcut for the Pan Workspace tool is to click and drag in the working area using 
the right mouse button - it’s a quick way to pan, regardless of what tool is selected in 
the toolbar.

Several tools allow you to pan the workspace by pressing the spacebar and 
dragging the workspace. The cursor turns into a hand when panning is active.

Zoom Workspace
The Zoom Workspace tool is similar to the Pan Workspace tool: it moves your 
view of the project, without modifying the objects themselves. With this tool, 

dragging the mouse left or right zooms your view of the project in and out.

A shortcut for the zoom tool is to click and drag left or right in the working area using 
the right mouse button while holding down the shift key - it’s a quick way to zoom, 
regardless of what tool is selected in the toolbar.

Rotate Workspace (Pro Only)
The Rotate Workspace tool is used to temporarily rotate the workspace. Think 
of drawing on paper - sometimes you might rotate the physical paper to 

draw from a different angle. The Rotate Workspace tool works in a similar way - 
sometimes (especially with the Freehand drawing tool) it may be helpful to orient the 
workspace in a different direction. A shortcut for the Rotate Workspace tool is to 
click and drag in the working area using the right mouse button or the touchwheel 
on a Wacom tablet, while holding down the control key - it’s a quick way to rotate, 
regardless of what tool is selected in the toolbar.

To get back to the normal view of the scene, you can select Reset from the View 
menu, click the Reset View button in the tool options area of the Moho window, or 
press the Home key to reset the view.

Orbit Workspace (Pro Only)
The Orbit Workspace tool allows you to view your scene from outside the 
camera. It’s like holding the scene in your handing and turning it around to 

look at it from different angles. This tool is mainly useful when you’re working on a 
scene with 3D elements (layers with different depths, complex camera moves, etc.). 
Hold the Alt key while using this tool to move your view forward and back.
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After using this tool to change your view of the scene, a blue wedge will be visible in 
the scene, representing the location of the camera. To get back to the normal view 
of the scene, you can select Reset from the View menu, click the Reset View button 
in the tool options area of the Moho window, or press the Home key to reset the 
view.
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Chapter 8: Special Tools
Moho includes a number of special tools that are available in specific 
circumstances. These tools appear in the Special section of the tool palette when 
the conditions are met. The sections that follow describe how these special tools are 
uses.

Moho has a smart tool palette, which shows and hides tools 
based on their need. The position of the tool shown in 

the screenshots may differ, depending on the selected layer in the 
Layers Window, and the current time in the timeline.

Click the tool icon in the properties bar to display a submenu. 
Choose Reset Tool to reset the current tool to its default 

settings. Choose Reset All Tools to reset all tools to their default 
settings.

Reset tool options.

Poser (Pro Only)
Animatable: Yes

Poser 7 or later must be installed on your system in order for this feature to 
work. In addition, the scene that you import into Moho must contain objects 

that are installed in libraries that are recognized by your Poser application. Refer to 
your Poser documentation on how to use, add, and maintain content in your Poser 
library folders.

After you create your scene in Poser, save it to a folder on your hard disk. The file will 
be saved with a .PZ3 or .PZZ extension, depending on whether you use compressed 
files or not. In Moho, choose the File > Import > Poser Scene command, and select 
the scene that you saved from Poser.

Poser scenes that use dynamic hair are very resource intensive. 
If your Poser scene uses dynamic hair or other resource-

intensive features, be careful not to use extreme settings.
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 A Poser figure, imported into a Moho scene

After the Poser scene has been imported, the Poser tool is enabled in the Special 
section of the tool box. You can click one of the body parts to rotate it with the 
Poser tool, or you can use the Poser Parameters dialog (Window > Poser Parameters) 
to rotate or scale the selected body part through the use of sliders. When you rotate 
the integrated Poser content, the display of the character switches to Box mode to 
reduce demand of your computer resources.

 Rotate or scale Poser actors with dials in the Poser Parameters dialog
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Poser animations are baked into the Poser project that you 
import. If you make animation changes in Moho, the 

changes that you make will be transferred to the Poser project file. 
When you quit and relaunch Moho, the keyframes in your Poser 
object layer will be gone because they have been written into the 
Poser project file.

To select the character’s root actor (usually the BODY), hold 
down the ALT key while clicking the figure with the 

Poser tool.

The parameters for each body part can be animated. For example, you can pose 
the figure on one frame in your timeline, and then move to a frame that appears 
later in the timeline and reposition the body part. Moho will then animate the in-
between frames by interpolating the motion between the keyframes that you set.
The Poser integration features also import any animation associated with the Poser 
scene. 

The Poser tool allows you to select a Poser figure or actor (such as a body part) 
within the scene, and then modify the parameters of the selected item. You will 
be able to edit many of the same parameters as you can in Poser. For example, 
you can select a body part and then adjust the Bend, Twist, Front-Back, or Side-
Side parameter to rotate the body part to a different position. You can also use 
the Window > Poser Parameters command to open the Parameters window for the 
selected body part. When you move a body part, keyframes appear in the timeline.

If the Poser project used a BVH motion capture file to generate 
the animation on the character, you will see keyframes 

on every frame. You can select and delete some or all these 
keyframes and edit the animation within Moho if desired. A new 
keyframe will be added at any point in the timeline when you make 
a change in the Poser Parameters palette.

After importing the Poser scene, you may notice a difference in 
the time length of your animation after you import into 

Moho. Poser’s default frame rate it 30 frames per second, whereas 
Moho’s default frame rate is 24 frames per second. To make the time 
match up to that created in the Poser program, choose File > Project 
Settings, and set the frame rate of your Moho project to 30 frames 
per second.

Switch Layer
Animatable: Yes

This is a specialized tool for use with Switch layers only. This tool has no effect 
if you click and drag in the workspace. What it does is supply a popup menu 

in the tool options area that lists all the sub-layers of a switch group. You can change 
the active layer by selecting it from the menu.
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Tool Options

 Switch Layer Options

• Active Child: Use this menu to select the active layer for the switch function

Particle Layer (Pro Only)
Animatable: Yes

This is a specialized tool for use with Particle layers only. This tool has no effect 
if you click and drag in the workspace. What it does is supply a checkbox in 

the tool options area that lets you control whether the particle layer is turned on or 
not (emitting particles or not).

Options that appear in the Particle Options dialog are discussed in detail in “Particle 
Layers (Pro Only)” on page 195.

 Particle Layer Options
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 Particle Options

Crop
The Crop tool allows you to crop an image layer to a specified area. After 
you add the image, select the Crop tool and draw a rectangle around the 

area that you want to keep. As you draw the rectangle, Moho highlights the area 
that you want to keep. When you release the mouse, the image layer will be 
cropped to the rectangle that you drew.

Tool Options

 Crop tool
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• Reset Crop: Click the Reset Crop button to restore the image to its original 
apperance.

• Center Image: Click the Center Image button to center the cropped image 
around the point that the entire image was originally centered.

 Using the Crop tool

Image Masking
Many Moho users do not use Photoshop or other similar programs, making it 
difficult to create images with transparent backgrounds. The Image Masking 

tool assists with this task. This tool helps you clear out and remove background areas 
from images that you import into Moho.

Tool Options

 Image Masking tool

• Clear Mask: Click the Clear Mask button to remove all areas from the mask and 
restore the image to its unmasked state.
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 Import an image into your Moho scene

After you import an image, select the Image Masking tool from the Layers section 
of the tool box. Click on an area that you want to remove from the background. 
Click and drag left or right to control the sensitivity of the tool. Drag toward the left 
to decrease the sensitivity, and toward the right to increase it. Release the mouse 
button when you have masked out the desired area.

 Click with the Image Masking tool to mask out areas of the image that you want to 
hide

Video Tracking
To use the video tracking feature, you need to have a movie file in your 
project. Either import a movie into an existing project or open a movie file 
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from scratch. The following sections describe the process of how the video tracking 
feature works.

Adding Tracking Points
Assume that you have imported a video, and you want to eventually add an 
object that will follow the position and rotation of a person’s thumb and wrist. The 
first step of the process is to add tracking points that identify the two points you 
want to follow. The Primary tracking point controls the position of the object’s origin. 
The Secondary tracking point controls the angle or scale of the object. To add the 
tracking points, select the Video Tracking tool from the Layer panel.

Click on the first point you want to track. You can click, and then drag to position 
the point exactly where you want to place it. It is optional, but recommended, that 
you name the tracked point in the Tracker Name field of the status bar. For example, 
since we are tracking a thumb here, we name the tracking point Thumb.

 The first tracking point is added to the thumb

Now we add the second tracking point for the wrist, and name it (appropriately) 
Wrist.
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 The second tracking point is added to the wrist

After you place your tracking points, make sure the Video Tracking Tool is still 
selected. Also make sure that there are enough frames in your project to play the 
movie segment.

Play the video back and watch the tracking points follow the points you selected. 
Playback runs a little slower during video tracking.

As you play the video back, you’ll notice keyframes being added to the timeline. 
While the video is playing, watch for any problem spots in the way that the tracking 
points follow the items you want to track. When you see a problem, don’t worry ... 
there are ways to fix them!

 After the tracking points are added, keyframes are generated in the timeline
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Fine-tuning Marker Positions
You might notice some places where the tracking points seem to drift away from 
the marker, or stop following it entirely. If this happens, stop the video playback. Go 
back to the beginning of the movie. Zoom in more closely to the video and use the 
Video Tracking tool to reposition the markers that need to be adjusted.

Choose View > Reset to reset the zoom level of the video back to the default. Play 
the video again and watch for any other problems. Keep making adjustments until 
you are happy with the results. The following movie shows our markers after they 
have been adjusted.

Click this link to view a brief video in your browser that shows 
what the markers look like after they are adjusted.

Re-syncing Tracking Points
You may also find instances where the tracking points go out of sync with the 
tracked object. The most likely cause for this is when the tracked area touches 
or passes over another area in the video that is very close in color. For example, 
when the tip of the thumb goes in front of the paper on the wall, there are similar 
colors in the paper that cause the tracking point to go out of sync with the thumb. 
Fortunately, there is a way to fix that. The next movie shows one of those problem 
areas.

Click this link to view a brief video in your browser that shows 
how the tracking point loses focus after reaching the 

paper on the wall.

To fix this type of problem, you scrub through the timeline until you find the point 
where it loses track. In the next figure you see the spot where the thumb appears to 
blend in with the paper. This is the area that causes the tracking point to lose sync 
with the thumb.
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 Find the point where the point loses focus

After you find the problem frame, advance ahead a couple of frames until you 
reach a point where there is more contrast. Then drag the tracking point to position 
it where it should be. When you press Play, the tracking point will continue tracking 
from there.

 Advance the video to a clear spot and adjust the tracking point
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Sometimes color similarities occur for a period that is longer than a couple of frames. 
For example, in our video there is a segment where the thumb passes across the 
face. This is a much larger area where there is very little color contrast between the 
tracked object and the area it passes over.

The solution here is slightly different. You can use interpolation to calculate the path 
between two good points. First, move back to find the last good point before the 
thumb crosses the face. Delete the keyframes from that point until the thumb passes 
across the face and reaches the other side.

You can use the Animation > Clear Animation > From Layer 
After Current Frame or Animation > Clear Animation > 

From Document After Current Frame commands to delete keyframes 
from the current frame to the end of the project.

Here we move to the point just before the thumb passes over the face ..

... and we delete the keyframes that occur until the thumb reaches the other side of 
the face
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Jump ahead in the video to a point after the thumb passes over the face and 
reposition the tracking point. When you play the video back, Moho will interpolate 
the motion between the keyframes that are missing.

 On the other side of the face, we reposition the tracking point to a good spot

Adjusting Tracking Point Sensitivity
When you add tracking points, you can change the sizes of the inner and outer 
rings to adjust the falloff. Click and drag on the edge of the rings to change the size. 
The inner ring defines the region that you are trying to track. For example, if you are 
trying to track an eye, adjust the inner ring so that it surrounds the eye.

The outer ring represents how fast the object can move. From one frame to the next, 
the outer ring represents the maximum distance that you want the object to move. If 
you have a fast-moving object you may need to increase the size of the outer circle 
for tracking. Expanding the search area too much can lead to further errors, so you 
want to keep it as narrow as possible. The default settings are generally sufficient for 
most cases.
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 Two rings control the sensitivity of the tracking point

Assigning the Tracked Layer
After you set the two points on the object you want to track, you can then assign 
the layer that will track those points. In our example, we returned to Frame 0 and 
added an exclamation point to a new layer. Now we want the exclamation point to 
follow the hand in the video.

To assign the layer that will track the points, choose Animation > Track Layer to 
Video. The Motion Tracking dialog lists the videos in your scene (in this case, there is 
only one).

 Select the movie to track, then choose the primary and secondary tracking points
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First we’ll assign the Primary Tracking Point, which is associated with the origin point 
of the tracked layer. We want the origin of the exclamation point to track the Wrist 
point. So, we select Wrist here and choose OK. When we play the result, the origin of 
the exclamation point (represented by the crosshairs) tracks the wrist.

 The crosshairs of the exclamation point, representing the origin, now follow the 
primary tracking point

The secondary tracking point is optional. You can use it to control either the angle or 
scale of the tracked layer. In our case, we want the thumb to control the direction of 
the exclamation point, so we select the thumb as the primary tracking point and teh 
wrist as the secondary point. Then we check the option to control Angle.

 The secondary tracking point can control the angle or scale of the tracked layer. We 
want the thumb to control the angle of the exclamation point

The following movie shows the results of our selections. Now when you play the 
movie, the origin of the exclamation point follows the wrist, and the angle of the 
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exclamation point is follows the angle line from the wrist (primary tracking point) to 
the thumb (secondary tracking point).

Click this link to view a brief video in your browser that shows 
how the exclamation point follows the wrist and points 

in the same direction as the thumb.

Offsetting the Origin
You can use the Transform Points tool in the Draw panel to move the tracked object 
away from the origin. The origin still tracks to the two tracking points, but the object 
that you are tracking can be offset.

 You can offset the object from its origin with the Transform Points tool

Once you have applied video tracking points to another layer, the two layers are 
totally independent. The tracking feature creates standard keyframes. You can edit, 
add or remove keyframes to the tracked object. You can also hide or delete the 
video layer that was used to initially create the tracking points and keyframes. The 
layer that was tracked to the video will still continue to follow the motion. This allows 
you to use a video file as a reference whether or not you want to see the video in 
your final project.



Moho 13.5
Users Manual 

158

Chapter 8: Special Tools

Moho Windows
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Chapter 9: Moho’s Main 
Window

Overview
The Moho interface has various windows that are used for controlling different 
aspects of a Moho project. In this chapter we’ll briefly describe some general 
components of the Moho project window.

The more complex parts of the Moho interface, such as the Layers Window, have 
their own chapters that follow this one. Although this chapter will describe how the 
main window works, it won’t go into detail about creating a drawing or animation.

 Moho Pro interface

Working Area
Most of the Moho project window is taken up by the working area. This is the region 
where you will create and view your drawings and animations. In every project, 
even an empty one, two items will be displayed in this area. The first is a cross 
marking the center of the currently active layer. The second is a blue rectangle that 
indicates the visible region of the project. Only objects that are within this rectangle 
will appear in your final animation.



Moho 13.5
Users Manual 

160

Chapter 9: Moho’s Main Window

 Working Area

Although every project has a fixed image size (for example 640x480 pixels), the 
working area is basically an endless flat space on which you can draw and animate. 
The blue visibility rectangle mentioned above indicates the actual image area 
for the project. While working, you may want to zoom in or out to see more or less 
detail in your project. A quick way to do this is by using your right mouse button. By 
dragging the right mouse button in the working area, you can move around from 
side to side. If you hold down the shift key while right-clicking and then drag left or 
right, you can zoom in and out. If you want to restore a reasonable overall view in 
the working area, press the Escape or Home keys, or choose Reset from the View 
menu (see “Chapter 24: View Menu” on page 487).

The background of the working area is usually just a blank color, but if you drag 
an image file into the working area, it will appear in the visibility rectangle. This is a 
helpful feature meant to allow you to trace the image with the drawing tools.

The real work that happens in the working area is not covered here, but is described 
in the sections “Moho Tools” on page 31, and“Moho Windows” on page 158.

Toolbar
The toolbar to the left of the main Moho window is where you select which tool you 
want to work with. The available tools will change depending on whether you’re 
currently animating, which objects are selected, and what type of layer is currently 
active. The purpose and use of each tool is described in the following chapters:

• Draw Tools: See “Chapter 3: The Draw Tools” on page 32

• Fill Tools: See “Chapter 4: Fill Tools” on page 62

• Bone Tools: See “Chapter 5: Bone Tools” on page 82

• Layer Tools: See “Chapter 6: Layer Tools” on page 117

• Camera Tools: See “Chapter 7: Camera and Workspace Tools” on page 138
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• Workspace Tools: See “Chapter 7: Camera and Workspace Tools” on page 
138

 Moho Tools (Pro tools shown)

Status Bar
The status bar along the top of the Moho window displays a short description of 
the currently active tool in the toolbar. If you don’t know what a tool does, the best 
thing is to read this manual. However, if you just need a quick reminder, the status 
bar can be helpful.

 Status Bar (Pro version shown)

Playback Buttons
Near the bottom-left of the main Moho window are a set of playback buttons that 
allow you to play/stop/rewind/etc. your animation.
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 Playback controls

Display Quality (Pro Only)
Near the bottom-right of the main Moho window is a popup box that lets you 
customize the level of display quality in the editing area. The Display Quality popup 
lets you control the following options.

 Display Quality options
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Note that this only applies to the editing view - when rendering your final project, 
everything will be drawn in full quality, regardless of the following settings.

• Paths: Display points and curves for vector layers.

• Fills: Display the fill colors of vector shapes.

• Strokes: Display the outlines of vector shapes.

• Shape Effects: Displays shape effects

• Images: Display images in image layers.

• Smooth images: Display images with higher quality alpha blending.

• Masking: Display masking effects.

• Transparency: Display shape transparency.

• Brushes: Display brush effects applied to shape outlines.

• Labels: Displays bone labels on the workspace so you can easily identify what 
the bones control.

• Fade unselected layers: Fades the content of unselected layers so that you can 
more easily see and work on the content in layers that are currently selected.

• Antialiasing: Draw shapes with smooth edges.

• GPU Acceleration: Check this option to enable GPU acceleration; uncheck to 
disable it. GPU Acceleration improves the display of image and vector layers. 
An OpenGL-compatible graphics card is required.

 GPU Acceleration off (top) and on (bottom)
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A little way to the left of the Display Quality popup is another popup box labeled 
Current Layer. This popup contains similar options to those found in Display Quality. 
The options in Current Layer apply only to the current layer, while Display Quality’s 
options apply to the entire project. So, for example, if you wanted to display fill 
shapes for all layers except one, you would leave Fills turned on in the Display 
Quality popup, but turn it off in the Current Layer popup for the layer in question.

Docking and Undocking Windows
You can dock and undock the windows that appear at the sides and bottom of the 
Moho interface to maximize the area that the document window uses. The windows 
that you can dock and undock appear in the upper portion of the Windows menu 
as shown in the following figure:

 Window commands

Windows that are normally docked (the Tools, Layers, Timeline and Style windows) 
will become undocked if you choose the Window menu command associated with 
that window. Choose the command again to redock the windows in their default 
space.

Windows that are normally hidden (Switch Selection, Actions, Library, Audio 
Recording, and Poser Parameters (the last in Pro Only)) will open undocked when 
choosing the command. Choose the respective command again to close the 
window.
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Chapter 10: Layers Window
A Moho document is composed of layers, each of which can be independently 
edited and animated. Layers can be thought of as transparent sheets of plastic. 
You can draw separately on each of these sheets, and the final picture is the 
composition of all the sheets stacked on top of one another.

Layers can be added, removed, copied, and re-ordered. The Layers Window is 
where all these operations take place in Moho, and is the topic of this section.

Overview
The Layers Window has four main sections of interest shown  in the following figure:

1. Layer toolbar: Displays buttons that allow you to create and manage the types 
of layers in your project. These are described in “Layer Toolbar” on page 166.

2. Layer Search: (Pro only) Allows you to search for specific types of content in 
your layers. See “Searching the Layer List (Pro Only)” on page 167 for more 
information.

3. Layer headers: Identifies the type of information contained in that column in the 
Layers list. The Layers list has a Quick Settings context menu that allows you to 
display or hide the Quick Settings dialog for that layer.

Layer preferences in the Layers/Objects tab are described in 
“Layers/Objects Tab” on page 438.

4. Layer List: Displays information about the type of content in each layer, along 
with other information according to your preferences. For more information on 
using the layer list, see “The Layer List” on page 173.

 The Layers Window
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Layer Toolbar
At the top of the Layer panel is a toolbar that provides several layer operations. From 
left to right, the buttons are New Layer, Duplicate Layer, Reference Layer (Pro only), 
Delete Layer, Layer Settings, and Layer Comps (Pro only). 

The buttons in the toolbar are described below:

 Layer Toolbar

• New Layer: Adds a new, empty layer to the project. A popup menu allows 
you to choose the type of layer you want to add. The new layer is 

placed directly above the current active layer.

• Duplicate Layer: Makes a copy of the current active layer and adds it to 
the project. This new copy is placed directly above the current active 

layer. If you duplicate a group layer, all of the sub-layers inside it will be 
duplicated also.

You can copy a layer and paste it into another opened 
document. Select the layer that you want to copy, and 

choose the Edit > Copy Layer command. Switch to the destination 
document, and choose Edit > Paste Layer to paste it directly above 
the currently selected layer. You can also copy multiple layers as 
outlined in “Editing Multiple Layers” on page 205.

If you have multiple layers selected when the Duplicate Layer 
button is pressed, all of the selected layers will be 

duplicated. 

If the Inline layer naming option is enabled in the Layers/
Objects tab of the Preferences dialog, you can 

immediately edit the name when a single layer is duplicated. If 
multiple layers are selected before duplicating, none of the 
duplicated layers will enter edit mode.
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• Reference Layer (Pro only): Creates a reference layer immediately above 
the current layer, which takes on the properties of the selected layer. 

See “Using Layer Referencing (Pro Only)” on page 178 for more information.

• Delete Layer: Deletes the current active layer. This operation cannot be 
undone, so you will be asked to verify if this is really what you want to 

do.

• Layer Settings: This command brings up a dialog with various controls to 
modify the layer’s appearance and behavior. The next section, Layer 

Settings, goes into detail about these options. The Layer Settings dialog can also 
be invoked by double-clicking the current active layer in the layer list.

• Layer Comps (Pro Only): Click to display a menu of Layer Comp 
commands. These commands are discussed in “Using Layer Comps 

(Pro Only)” on page 176.

Searching the Layer List (Pro Only)
Many projects contain many different layers, and it can sometimes become difficult 
to locate specific types of content in your scene. Moho’s layer search makes it 
easier to locate content by according to search terms and other settings that you 
specify.

When a search filter is being applied to the list, you can right-
click a layer and choose Reveal Layer in Unfiltered List. 

The layers list will remove the search filter, and display all entries in 
the Layers panel, and the layer that you right-clicked will be 
selected.

 Layer Search

The layer search is located immediately beneath the Layers toolbar. It supports OR 
or NOT syntax as follows:

• Use the | symbol for the OR operator. For example, you can type cat | dog and 
get results that contain either cat or dog.

• Preface a search term with the - or ~ symbol for the NOT operator. For example, 
if you type cat - dog, or cat ~ dog, you will get results that contain cat but do 
not contain dog.
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In Moho Pro, the Search consists of the following areas:

• Search context menu: The search context menu appears at the left side of the 
search area. It allows you to perform searches based on the following criteria:

If you select a criteria without entering search text or select a 
menu option that displays all layers, normal display 

mode is displayed.

 � No filter: Choose this option to hide the search field. All content in the 
layers list will appear.

 � Name contains: This is the default option. Searches by layer name, 
according to the search term that you enter in the text field.

 � Group name contains: .Returns any group whose name contains the 
entered text. It will be shown along with all of its children.

 � Comp name contains: Searches for layer comps named according to your 
entry in the earch field.

 � Kind contains: Searches through the layer list by kind. For example, entering 
Image in the search field will display all image layers in the layer list.

 � Label color is: Searches the layer list by layer color. Available colors are 
Plain, Blue, Cadet Blue, Coral, Green, Orange, Pink, Purple, Red, Tan, 
Turquoise, and Yellow. Choose Any Color (default) to remove color 
specifications.

 � Visibility is: Allows you to search for all visible or invisible layers. Choose Is or 
is not visible to remove visibility option from the search.

 � Tags contain: (Pro Only) Allows you to search for information included in 
tags, based on the text you enter in the search field.

 � Comments contain: (Pro Only) Allows you to search through layer 
comments, based on the text you enter in the search field.

• Search text field: Where the search type selected above is based on a text 
string, simply enter the search term in the field. Results will be filtered in the layer 
list as you enter the string.

When you enter text in the search field, it will display any layers that contain that 
text, along with its parent hierarchy. When you delete the text no filter will be 
applied.

Layer List Columns
The top of the layer list contains identifiers that describe the type of information 
within that column, depending on the type of information that you want to show or 
hide.
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 Layer list headers

Comments (Pro Only)
Choose Comments to display a column that contains a small word balloon indicator. 
Click the indicator in the desired layer to display or edit the comments for that layer. 
Then click the Set Comments button to apply the changes.

The Set Comments dialog will initially pre-fill in with the 
comments from the last selected layer. This is similar to 

how they would be in the Layer Settings dialog under the General 
tab when multiple layers are selected. You may need to use modifier 
keys to preserve the selection when clicking the indicators if you 
want to edit multiple layers. Changes are undoable.

 Comments column

Kind
The Kind column is resizeable. Displays information about the type of layer; for 
example, Image, Bone, Vector, Frame by Frame, and so on. Additionally, Kind 
information can also include additional information, such as whether a layer is a 
Reference layer, or if it is Masked.
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Reference Layers will be designated with a little badge.

Certain types of layers act as groups, and can contain other layers within them. (You 
can think of them like folders on your hard drive.) These layers have a triangle on 
their left side. Clicking this triangle opens and closes these group layers, allowing you 
to access or hide the sub-layers they contain.

 Kind column

Label
The Label column allows you to choose a color for the selected layer. Click the 
square icon to assign a label color. Available choices are Plain, Blue, Cadet 
Blue, Coral, Green, Orange, Pink, Purple, Red, Tan, Turquoise, or Yellow.  If the 
Label column is not visible, you can also double-click a layer to assign a color, as 
described in “Using Layer Colors” on page 177.  

If multiple layers are selected when you choose the label color 
control, all selected layers will be assigned that label 

color.

Name
The Name field is required, so the option to hide this identifier is greyed out. This 
column is resizeable. You can assign a name for the layer when you initially create it; 
or by single-clicking the Name field in the Layers Window, or by a fast double-click to 
open the Layer Settings dialog.

If you change the name of an item when the layers list is sorted 
by name, the renamed item will be resorted to the 

appropriate location for the new name.

You can double-click the Name or Kind column resizer to 
automatically expand the column to the maximum 

width required to fully display the columns.
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Quick Settings (Pro only)
The Quick Settings column displays an arrow that opens the Quick Settings dialog 
for the selected layer. For more information on the Quick Settings dialog, see “Using 
Layer Quick Settings” on page 179.

If you do not have the Quick Settings column displayed in the 
layers list, you can also right-click a layer and choose 

Quick Settings for Layer from the context menu to open the Quick 
Settings dialog.

Tags (Pro only)
The Tag column displays a small tag icon. Click the icon to assign tags to the 
selected layer. After entering the tags, click Set to apply the changes.

Timeline Visibility (Pro only)
The Timeline Visibility column displays a checkbox for each layer, which allows you to 
show or hide that layer on the timeline. Check the box to display the selected layer 
in the timeline. If you have assigned a color label, the timeline will display that layer 
in the selected color.

Visibility
The Visibility control determines whether a layer is visible or invisible in the 
workspace. This control appears in the Layers Window by default, but you can 

hide it if desired.

Right-click the Visibility column to choose a label color from a context menu. This 
provides a combined visibility and label column, should you choose not to display 
the Label column separately. When you sort the columns in your layer list by visibility, 
items will be subsorted by their label color.

If visibility is set to On, any objects drawn in the layer will appear in the main Moho 
window, as well as in any rendering of the project. If you turn visibility off, the layer 
will turn invisible and will not appear in the main Moho window. This can be a 
convenient way to remove clutter in the main window when you don’t need to see 
all the layers at once. Also, only visible layers will appear when you render a view of 
the project or export an animation - you can generate test movies much quicker if 
you turn some layers invisible that don’t involve what you’re currently working on.

The visibility box of the currently active layer behaves 
differently. The currently active layer is always visible 

(how could you edit it if it wasn’t?), and clicking its visibility box (while 
holding the Alt/Option key) will turn all the other layers at the same 
level visible or invisible.
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If you click in the Layers Window to toggle the visibility of a 
layer, you can set underlying layers to the same 

visibility. To do so, keep the mouse button pressed down while you 
drag over the underlying layers. Release the mouse button after you 
drag over all layers you want to set.

Reordering Column Headers
After you display the columns you want to include in the Layers Window, you can 
rearrange the order in which they appear in the Layers list. Drag the column header 
left or right to reposition it to the column in which you want it to appear.

 Drag a column header left or right to change the order of displayed columns.

Sorting Columns
A sort button appears in the upper right corner of the Layers Window. Click this icon 
to enable or disable sorting in the Layers Window. 

When sorting is enabled, you can click the column header that you want to sort. 
Click again to reverse the sort order.

 Enable sorting with the Sort button in the upper right corner, then click a column 
header to sort items in the layer list.
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You will not be able to rearrange layer order when sorting is 
enabled. If you need to change the layer order, click 

the Sort button to turn off sorting, and rearrange your layers as 
desired. You can re-enable the Sort feature after you have 
reordered your layers.

Resizing Columns
The Name and Kind fields in the Layers Window are resizeable. If you find that your 
layer names are getting cut off due to lack of space, simply drag the right side of 
the column header to resize the column. 

 Drag the right side of the Name or Kind column header left or right to resize the 
columns.

The Layer List
Most of the Layers Window is taken up with the layer list. This is a vertical scrolling list 
of all the layers in the document. The layers are stacked in order from bottom to top. 
That is, when the project is displayed, the lowest layer in the list is drawn first, followed 
by the second from the bottom, and so on up to the top. When two layers contain 
objects that overlap, this ordering determines which object is in front and which is 
behind.

A layer’s entry provides you with several pieces of information: In the following figure, 
it shows layer visibility (1), timeline visibility (2), layer color/label (3) and layer name 
(4).:
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 A single layer in Moho

You can edit more than one layer at a time in Moho, as 
described in “Editing Multiple Layers” on page 205.

Right-click in a column header to open the Layer List display options. Check or 
uncheck the categories that you want to show or hide in the layer list:

 Layer list display options

Reordering Layers
Layers can be re-ordered simply by dragging one layer above or below another 
layer. Just click and drag the layer you want to move - you will see a red insertion 
bar indicate where the layer will be placed when you drop it. When the insertion bar 
appears at the location you choose, just drop the layer and you’re done. You can 
also use this method to drag sub-layers into or out of group layers.

When you drag multiple layers in Mac, a number appears at 
the right side of the Layer name to indicate the number 

of layers that are selected for dragging. Windows displays a drag 
cursor only. 

Layer Context Menu
When you right-click a layer, a context menu provides commands that are 
applicable to that layer type. The following commands are typical of all layer types:
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 Right-click a layer to display a context menu of commands that are specific to that 
layer type.

• Quick Settings: Choose this option to display the Quick Settings dialog for that 
layer. See “Using Layer Quick Settings” on page 179.

• Add Tags: (Pro only) Opens a text field that allows you to add tags to the 
selected layers. Tags should be separated by commas.

• Remove Tags: (Pro only) You can use the Layer Settings dialog to enter tags for 
multiple selected layers, which results in several layers having the same tags. 
Choose the Remove Tags option to display a popup menu that allows you to 
enter the tags that you want to remove from the selected layer. 

Other context menu commands are displayed, depending on the type of content in 
that layer:

• The context menu for vector layers provides quick access to masking options, 
including whether or not to mask the layer and how to apply the mask if 
selected.

• Audio Files, image layers, and Poser layers (Pro only) provide options to reveal 
the source media in the Finder or Explorer and open the source media file. The 
source file will open in the default application assigned to that media type.

• The context menu for a group layer provides the option to convert to a Bone 
group or a Switch group.

• The context menu for Bone Groups provides an option that converts the bone 
grouo to a switch group.

• If the layer is included in a layer comp, the name or names of the layer comps 
will appear in the context menu.

 � If multiple layers are selected and they are all included in a layer comp, 
the comp name will have a plus sign that precedes the layer comp name.

 � If the selection of layers includes some that are included in a layer comp 
and some that are not, a minus sign will precede the layer comp name.

 � A checkmark appears in front of a layer comp name if the currently 
selected layer is included in that layer comp. If you select a comp name 
that has a checkmark beside it, any of the currently selected layer(s) that 
are included in that layer comp will be removed from it.
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 � If you select a layer comp in the list that does not have a checkmark 
beside it, any of the currently selected layer(s) that are not assigned to 
that layer comp will be added to it.

Changing Layer Settings
The last thing you can control in the layer list is the property set of any layer. By 
double-clicking a layer in the list, a dialog will appear with various options controlling 
the appearance and behavior of the layer. This dialog is described in “Chapter 12: 
Layer Settings” on page 205.

Copying and Pasting Layers Between Documents
The Edit > Copy Layer and Edit > Paste Layer commands allow you to copy and 
paste a selected layer between documents. For more information on these 
commands, see “Copy Layer (Pro Only)” on page 428 and “Paste Layer (Pro Only)” 
on page 428.

Using Layer Comps (Pro Only)
Layer comps are useful if you want to export only selected items in your scene so 
that you can composite them externally in third party software. For example, you 
can create a layer comp that relates to background elements, another that relates 
to characters, and another that relates to foreground elements or titles.

Turn groups on and off until you get elements that logically belong together. Then 
create a new layer comp from that group. At render time, you can then choose to 
render specific layer comps as a movie file.

The Layer Comp tool appears in the toolbar in the Layers Window. Click the Layer 
Comps tool to display a menu that includes the following commands:

 Layer Toolbar

• New Layer Comp: In the Layers Window, hide the layers and objects that you do 
not want included in the layer comp, and make sure that all items that you do 
want to include are visible. Then choose New Layer Comp. Enter a name for the 
layer comp in the dialog that appears.
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 Creating a new layer comp

• Update Layer Comp: Choose this option if you need to make changes to an 
existing layer comp. Make sure that all items that you want to include are visible 
on the stage. Choose Update Layer Comp and select the layer comp that you 
want to change.

• Rename Layer Comp: Choose this option and then select the Layer Comp that 
you want to rename. A dialog will prompt you to enter a new name for the 
selected Layer Comp.

• Expose Layer Comp: Allows you to “solo” the items in a selected layer comp. All 
other items will be set to invisible. Select the layer that you want to expose from 
the list of layer comps.

• Show Layer Comp: Allows you to show a single layer comp by name. Select the 
layer comp that you want to show from the list of layer comps.

• Hide Layer Comp: Allows you to hide a single layer comp by name. Select the 
layer comp that you want to hide from the list of layer comps.

• Show All Layers: Shows all previously hidden layer comps.

• Hide All Layers: Hides all layer comps.

• Delete Layer Comp: Allows you to delete a layer comp from the list. Deleting a 
layer comp does not delete the content contained within it, it only removes the 
references to the deleted layer comp.

Using Layer Colors
If you have many different layers in your Layers Window, you can assign colors to 
them to help find specific content more easily. To do so, double-click the layer in 
the Layers Window to open the Layer Settings dialog. In the General tab, choose a 
color for the layer from the Layer Color drop-down selector. The layer will then be 
displayed in the Layers Window in the color that you choose.

Alternatively, if the Label column is displayed in the Layers Window you can click the 
button to assign a color. 
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 Choosing a layer color

Using Layer Referencing (Pro Only)
Layer referencing allows you to create one or more references or instances of 
a layer. Referenced layers take on the properties of the original layer. This even 
extends past the initial creation of the layer. As an example, let’s say you have a 
rigged character. When you create a reference of the character and then move 
the original character’s arm, the reference layer character will also move his arm! 
If changes are made to the reference layer, it will act independently from the 
original, allowing for the creation of unique assets. You can even reference layers 
across multiple documents, opening up new workflow possibilities for team based 
productions.

When you make changes to the original layer, the changes are applied to all 
instances as described in the following sections.

You can easily create reference layers from the Layers Window. Simply click the 
Reference Layer icon to add a reference layer above the currently selected layer. 
Referenced layers have a special icon that displays a curved arrow over the layer 
type symbol, and the Kind column will label the layer as referenced. 
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 Reference Layer icon

For more information and hands-on examples that describe 
how to create and use reference layers, see “Layer 

Referencing (Pro Only)” on page 274 in your Moho Tutorial Manual.

Using Layer Quick Settings
The Quick Settings dialog displays frequently used layer settings in a convenient 
format. You can open the Quick Settings dialog. If you have the Quick Settings 
column displayed in the Layers Window, you can click the icon in the Quick Settings 
column to open the Quick Settings dialog for the selected layer(s).

 Quick Settings dialog

From the Quick Settings dialog you can apply a number of different settings to the 
selected layer, including:

• Name: The name for the selected layer.
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• Visible: Shows or hides the selected layer.

• Hidden in editing view: Turn on this checkbox to hide the layer while editing. 
The layer will still appear in rendered output, but will be invisible in Moho’s edit 
view. This can be useful to reduce clutter and improve performance. Things you 
might consider hiding in the editing view are background details, texture and 
detail layers, or special effects like particle layers. Note that if a hidden layer is 
the currently active layer, it will temporarily un-hide itself so that you can edit 
whatever it contains.

• Don’t render this layer: If this box is turned on, then the layer will not appear 
in any rendered/exported movies. This option is usually used for some kind of 
helper layer. For example, you might draw a layer with some guide lines to help 
you draw and animate a scene, but you don’t want those guides to appear in 
the final output. Note layers have this option turned on by default.

• Layer Color: Layer colors are used to help you categorize the content in your 
project using colors of your choosing. Use the Layer Color selector to choose 
a color for the current layer. Plain will display the layer in the normal Moho 
interface color. Several other color choices are available for categorizing your 
layers.

• Details: Enables or disables display of several different types of properties in 
your scene. Many of the settings below are also available in the Display Quality 
options dialog, discussed in “Display Quality (Pro Only)” on page 162.

 � Paths: Display points and curves for vector layers.

 � Fills: Display the fill colors of vector shapes.

 � Strokes: Display the outlines of vector shapes.

 � Shape Effects: Displays shape effects.

 � Images: Display images in image layers.

 � Smooth Images: Display images with higher quality alpha blending.

 � Masking: Display masking effects.

 � Transparency: Display shape transparency.

 � Brushes: Display brush effects applied to shape outlines.

 � Labels: Displays bone labels on the workspace so you can easily identify 
what the bones control.

 � Antialiasing: Draw shapes with smooth edges.

 � Apply changes to all selected layers: After you check the settings you 
want to apply to the selected layers, click the Apply button.
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Chapter 11: Layer Types
Drawings in Moho are vector-based. Vector drawings are different from pixel-based 
images (like a photograph) in that they use lines and curves to represent a picture, 
rather than a grid of colored pixels. This difference makes a lot of things easy in 
Moho that would be difficult or impossible to do with a pixel-based image.

First of all, since a Moho drawing is represented as a bunch of curves, you can 
reshape the curves at any time, without ever losing precision. Also, Moho projects 
are relatively small, even for complex animations - this means Moho doesn’t require 
much memory even when working on a long movie. Vectors also have benefits 
when it comes to animation. By moving just a few points, you can totally change the 
shape of an object over time.

You’re not restricted to vector artwork, though - Moho also has Image Layers. Using 
this type of layer, you can work with regular images within a Moho project. So, Moho 
is not strictly vector-based, but you will probably still use mostly vector layers, as 
image layers are not as flexible when it comes to animation.

Of course, most standard image and movie formats are not vector-based, so when 
you’re done working on a Moho project, it must be rendered to create a traditional 
pixel-based image. During the rendering process, Moho can apply various effects to 
the objects, such as shading and blurring.

Moho is designed in such a way that projects are split into layers. You can have 
many, many layers in a Moho project, each representing a different element 
in a scene or animation, such as background scenery, a character, or a title. 
Some layers can even contain other layers, so a more complex object, such as a 
character, might contain separate layers for each arm and leg.

Layer Types
Moho currently supports the following types of layers:

• Vector Layers are used to hold vector-based artwork. These are the main type 
of layer you will use to create drawings. See “Vector Layers” on page 183 for 
more information.

In Moho Pro, you can use the Scripts > Draw > Simplify Curve 
menu command to reduce the number of points in a 

complex Vector layer.

• Image Layers can be used to bring in images from other applications. Image 
files created in 3D programs or photo editing applications can be used in Moho 
with Image Layers. See “Image Layers” on page 184 for more information.

• Group Layers (Pro only) are used to group together multiple layers. If you 
created 20 layers with trees for example, you could put them all in a Group 
Layer and call it a forest. Group layers are a useful tool for organizing a complex 
project. See “Group Layers (Pro Only)” on page 186 for more information.

Right-click a Group Layer in the Layers Window to quickly 
convert the Group layer into a Bone or Switch layer.
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• Group with Selection Layers (Pro only): After selecting two or more groups, 
choose the Group with Selection layer type to create a group that contains the 
selected layer(s). See “Group with Selection Layers (Pro Only)” on page 187 for 
further information.

• Bone Layers contain skeletons that are used to control the artwork in your 
vector and image layers. You manipulate skeletons as if they were “puppets” by 
bending arms and legs to make a character move. See “Bone Layers” on page 
188 for more information.

Right-click a Bone layer in the Layers Window to quickly convert 
it into a Switch layer.

• Switch Layers are just like Bone layers, except they will only display one of their 
sub-layers at a time. Switch layers are an excellent way to perform lip-sync 
animation. Which sub-layer gets displayed is controlled by a switch data file. 
You can create this data file by hand, or better yet, use a lip-syncing program 
like Papagayo. See “Switch Layers” on page 190 for more information.

• Frame by Frame Layers (Pro only): Provide a quicker and easier way to create 
frame by frame animation. For further explanation of the settings, see “Frame 
by Frame Layers (Pro Only)” on page 194. For a hands-on tutorial, see “Tutorial 
5.10: Using Frame by Frame Layers for Animation (Pro Only)” on page 221 in 
your Moho Tutorial Manual.

• Particle Layers (Pro only) are used as a way to simulate water, sparks, smoke, 
crowds, or any number of effects that can be made up of many small objects. 
A Particle layer behaves somewhat like a Group layer, but instead of displaying 
each of its sub-layers, it can display many, many copies of each sub-layer 
arranged in sort of a “spray” formation. The sub-layers appear to be moving 
outward from the origin of the Particle layer. For more information, see “Particle 
Layers (Pro Only)” on page 195

• Note Layers (Pro only) are like sticky notes in Moho. You might use a note layer 
when you want to leave a note for yourself or another animator. For example, 
you might create a note layer at a particular frame that needs some work, or 
to describe why a character is set up in a particular way. See “Note Layers (Pro 
Only)” on page 198 for more information.

• Audio Layers (Pro only) allow you to add a sound file to your project. When 
adding an audio layer you will be prompted to select an audio file.

• Patch Layers (Pro only) allow you to arrange layers so that part of a layer can 
appear behind a layer, and another part of the same layer can appear in front 
of a layer. They are used in conjunction with the Character Wizard, but can also 
be used in other ways.

• 3D Layers (Pro only) can be used to import 3D objects that were created in 
a 3D modeling program. Use the File > Import > 3D command to create a 3D 
Layer. 3D models can be a good source of background scenery. Or, use a 3D 
model for a character’s head, and decorate it with eyes, mouth, etc. created 
with Moho’s vector layers. See “3D Layers (Pro Only)” on page 200 for more 
information.
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Enhanced Layer Alignment Features 
(Pro Only)
The Layer Alignment features in Moho assist in alignment when using 2D to 3D 
conversions. New layers align to face with the current camera view. This allows you 
to create more complex 3D objects in your Moho scenes.

To demonstrate, try this:

1. Create a new Moho scene.

2. Use the Draw Shape tool to draw a box in the scene.

3. Use the 2D to 3D conversion features to extrude the 2D box into a 3D box. To 
convert a 2D vector layer to 3D, double click on the layer in the Layers Window 
and click on the 3D Options tab. Then select ‘Extrude’ from the 3D Conversion 
drop down menu.

4. Use the Orbit Workspace tool to rotate the camera so that you are looking at 
the 2D box from a different angle.

5. Create a new layer, and add another extruded box on that layer. The new box 
faces the current angle of the camera.

6. Rotate the camera so that you can see how the two boxes relate to each 
other.

 New layer alignment features

Vector Layers
Vector layers are the most common layer in Moho projects. Artwork that you create 
in Moho is always contained in a vector layer. Tools are available for drawing and 
editing curves, setting up fills and outlines, and connecting your drawings to bones.
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 Vector Layers

The tools available for working with vector layers essentially make up a 2D drawing 
program. You can draw lines and curves, re-shape existing curves, and manipulate 
objects in various ways. There are a couple ways that Moho differs from other 
drawing programs. First, everything you draw in Moho is a set of points and curves. 
In many programs, when you draw a circle, you get a circle object, or you may 
type some text to create a text object. In Moho, once you’ve created the circle or 
the text, there’s no difference between them whatsoever - they’re both collections 
of curves. One happens to be in the shape of a circle, and the other in the shape 
of some text. There are advantages in treating all objects the same: first, you never 
have to worry about what type of object you’re working with - the answer is always 
the same: a set of points and curves. The other advantage is that any operation 
you can perform on hand-drawn curves can be performed on text, or a circle, or 
whatever.

The other feature of Moho’s drawing mode that is different from many other drawing 
programs is the concept of welding. In Moho, two points can be welded together 
into a single point. In fact, any number of points can be welded together. When 
points are welded together, moving one of them moves them all, along with any 
curves that pass through that point. This is particularly useful when you start to 
animate objects. For example, if you want to move a character’s nose, then welding 
it to the face might not be a bad idea. That way, however you distort the nose or 
the face, they’ll always stay connected.

Image Layers
Image layers are a way of importing artwork into Moho that was created in other 
programs. Any program that can produce image files can be used together with 
Moho this way. For example, a painting program, photo editor, or 3D modeling 
program can produce images that can be used in a Moho image layer. You can’t 
edit the pixels of one of these images in Moho, but you can move, resize and rotate 
image layers, and attach them to skeletons for more complex animation.
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When an image layer is first selected, the default tool is set to 
the Transform Layer tool.

 Image Layers

The best image format to use with Moho is PNG. PNG files have high quality, good 
compression, and support full alpha channels for transparency effects. Although 
PNG is the preferred format for use with Moho, you can also use JPEG, BMP, Targa, or 
GIF images.

Image layers can also be used to bring external movies into Moho. Instead of 
selecting a still image, select a movie file when creating a new image layer. Moho 
can import QuickTime (Windows and Mac OS) or AVI (Windows only) movies as 
image layers. When importing a movie file, Moho will use the movie’s alpha channel 
(if present) to composite the movie with other elements in the scene.

Due to differences in media support between Macintosh and 
64-bit Windows OS, you will need to use the 32-bit 

version of Moho Pro to import and export MOV files that have alpha 
channels.

Image Sequence Layers
Create an image sequence layer, or choose File > Import > Image Sequence to 
Import a numbered sequence of images. Each image is imported as its own layer, 
and the entire group is enclosed in a switch group. The image files should be named 
using a numerical sequence. For example, “file0001.jpg”, “file0002.jpg”, “file0003.
jpg”, etc.

Image Sequence layers allow you to import sequentially-numbered images into 
Moho Pro. After choosing an Image Sequence layer, you will be prompted to   
locate your sequentially numbered images on your hard drive. Click the first image, 
then shift-click to select the last image in the sequence. Then click Open to create 
the Image Sequence layer.
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 Image Sequence Layers

In the timeline, the first image in the sequence will be designated by a green 
triangle pointing forward in the timeline, and the last image in the sequence will 
be designated by a red triangle pointing backward in the timeline. You can scrub 
through the timeline to see the individual frames in the sequence, just as you can 
with a movie.

 Image Sequence Layers

Group Layers (Pro Only)
Group layers are used to group together multiple sub-layers so that they can be 
manipulated as one. They’re also very useful for organizing complex projects. You 
can think of a group layer as a folder that can contain files (layers) and other 
folders (more group layers). When you move a group layer, turn it invisible, or apply 
an effect (such as a layer shadow), these are all applied to every layer contained 
within the group.
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 Group Layers

Group with Selection Layers (Pro Only)
You can use the Group with Selection layer type to combine two or more selected 
layers into a group.

The group layer will be created as the parent of the last layer that you selected, 
unless its parent is also selected. In that case, the new group will become the 
grandparent of the last selected layer.

 Group with Selection Layers
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Bone Layers
Bone layers are similar to Group layers - they can both group together multiple sub-
layers that can then be manipulated as a single object. However, bone layers have 
an additional feature: In a bone layer, you can set up a skeleton that can be used 
to manipulate your artwork. A skeleton is exactly what it sounds like - an internal 
structure that can move the outer, visible portion of your artwork.

 Bone Layers

Setting up bones is sort of a pre-animation phase. You don’t draw shapes in Bone 
layers, you set up controls that will help you animate later on. The purpose of setting 
up bones is exactly what you might think: creating a rigid skeleton inside your 
drawing. Later on, during animation, when you want to move an object, bones 
make the job easy. By moving a single bone in the arm of a character, for example, 
the whole arm will move with it. Around the elbow, the drawing of the arm will bend 
and stay smooth (as long as the bones were set up well with the Bone editing tools).

Bones by themselves don’t really do much of anything: you can move them around, 
but they’re invisible in the final Moho output. To really make use of bones, they need 
to be attached to objects in other layers. This process is covered in “Bones” on page 
104 in your Moho Tutorial Manual, and also “Chapter 5: Bone Tools” on page 82.

When you create a skeleton out of a group of bones, the bones have a hierarchical 
relationship. Each bone has a single parent (or maybe no parent at all, in which 
case it’s called a root bone), and each bone may have multiple children. The 
relationship between parent and children is that when a parent bone is moved, all 
of its children move with it. When a child bone is moved however, it’s parent remains 
unchanged.

Below is a picture of a skeleton created in Moho. Red arrows have been added that 
point from each bone to its parent (the spine has no parent and is referred to as the 
root of the skeleton). Note that the currently selected bone is highlighted in red, and 
its parent (if it has one) is highlighted in blue, as shown below.
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 A skeleton hierarchy

When you use bones with a vector layer, you need to consider how the bones and 
curve control points will interact. When a bone moves, it moves the points around 
it as well. Each bone has a region of influence (which you can adjust). Points move 
mostly with the bone whose region of influence they fall within, although other bones 
can still have an effect on them. Below is a picture of some points and bones. Notice 
the region of influence around each bone. The second picture shows the same 
object after the bones have been moved. Notice how the points follow the bones 
according to regions of influence (and how the curves pass smoothly through the 
points, wherever they move to).

 A bone and vector setup
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 Moving bones moves the curve control points

Switch Layers
Switch layers are used to group together multiple layers, much like Group layers. 
However, switch layers have an interesting twist: only one of their sub-layers can be 
displayed at a time.

 Switch Layers

One reason you might want to do this is for lip-sync animation. In this case, each of 
the sub-layers would correspond to a mouth shape for a particular sound.

Many of the characters in the Library provide switch layers for the visemes that Moho 
supports. For example, if you load Jace from the Version 6 character library and 
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expand the Mouth layer, you’ll see support for the following visemes and mouth 
positions: Rest, Etc, FV, L, MBP, O, E, AI, U, and WQ.

Moho includes powerful automatic lip-syncing which is a big time saver .

• Moho Debut uses the volume of the audio track to determine which mouth 
shape to use. When the audio is quiet, the mouth is more closed. When the 
audio is louder, the mouth is more open.

• Moho Pro uses a production sync library that analyzes the audio track to 
determine the phonemes (the basic components of speech) that are being 
used. Results are improved when you enter the spoken words into Moho. After 
the production sync analysis is done, Moho Pro applies the matching mouth 
shape.

The mouth shapes supported by the Moho lip syncing features follow standards 
developed by Preston Blair, an animator from the early days of Disney.

To set up a mouth that can lip sync, you will need to create a 
switch layer that contains at least ten sub-layers with 

different mouth shapes. Shapes should be created for the 
appearance of the mouth when at rest, and when speaking each of 
the 9 before-mentioned phonemes. The Preston Blair mouth shapes 
are discussed in more detail at http://minyos.its.rmit.edu.au/aim/a_
notes/mouth_shapes_01.html.

For examples of how lip syncing is used, see “Tutorial 5.1: 
Automatic Lip-Sync” on page 180 in your Moho 

Tutorial Manual and “Tutorial 5.2: Phoneme Lip-Sync” on page 182 
in your Moho Tutorial Manual.

If you prefer more control over lip-syncing than what the automatic built-in lip-
syncing offers, you can take full manual control over the process using a separate, 
and free, tool called Papagayo (see http://www.lostmarble.com/papagayo/). In 
Papagayo, you type in the words that are being spoken. Papagayo then uses a 
phoneme dictionary to break down the words into spoken phoneme components. 
These are lined up on a timeline, along with the audio waveform.

Initially, the lineup on the timeline in Papagayo is rough and the phonemes are 
spaced evenly. You then shift words and phonemes along the timeline so that they 
line up better with the actual sounds you hear. The final result is saved out as a 
“switch data file” that can be imported into Moho.

You can also create a switch data file by hand. To do this, the data file should look 
like this:
MohoSwitch1
1 A
2 A
10 B
22 A
37 C
40 C

• The first line is a header that just tells Moho that the file is a switch data file.

• The following lines contain two items each:
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• The first item is a keyframe.

 � The second item is the name of one of the switch group’s sub-layers. (In this 
example, the switch layer should have three sub-layers, named “A”, “B”, 
and “C”.)

If you make changes to the switch data file outside of Moho, and you want to 
incorporate those changes, you will need to re-load the data file. To do this, double-
click the Switch layer in the Layers Window, and in the dialog that opens up, go to 
the Switch tab, press Source Data and re-select the data file.

You don’t have to use a data file to work with Switch layers - you can also control 
them manually from within Moho. To control which sub-layer is displayed at any 
frame in your animation, just right-click on the Switch layer in the Layers Window. A 
pop-up menu will appear that lets you choose which sub-layer to display.

Moho includes several sample mouth sets for doing lip-sync with Papagayo - take a 
look at those files to see how a switch layer should be set up. Also, check out the lip-
sync tutorials included in this manual.

Switch layers have a feature that allows for smooth switching. To use this feature, all 
the sub-layers need to be Vector layers, and they need to have the same number 
of control points. Then, when switching, Moho can smoothly transition between 
sub-layers. To enable this feature, turn on Interpolate sub-layers in the Switch layer’s 
properties dialog. An example of using this feature is included in one of the mouth 
sets mentioned above.

Switch layers can be set up with skeletons, just like bone layers. More accurately, 
a switch layer is a bone layer, just a specialized one. If you add bones to a switch 
layer, you can use them (for example) to change the shape of a mouth as it speaks, 
bending it into a smile or a frown.

Don’t feel restricted to lip-sync animation with switch layers. They have a lot of 
potential uses (controlling eyes, syncing to music & sound effects, switching between 
different hand gestures, etc.).

Using Switch Layers
Improvements to switch layers now include behaviors that will make them work 
better for frame-by-frame animation. These improvements include the following 
changes and enhancements:

• You no longer need to select a switch layer’s active child in the Layers Window. 
You can now simply Alt COMMAND/Ctrl Right-click on it in the workspace.

• You can Alt-click the child of a switch layer in the Layers Window to activate it.

• You can activate the previous switch layer child using the Alt+D shortcut.

• To activate the next switch layer child, use the Alt+C shortcut.

• When moving switch layer keys in the timeline:

 � Drag the left side of the switch layer key to move it forward or backward in 
time.

 � Drag the right side of the switch layer key to move it forward or backward 
in time.
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 � For shorter keys, you can use shortcut keys as follows: hold the Cmd/Ctrl 
key down to move the right side, or the Shift key to move the left side.

 � Hold the Alt key down to revert to the old behavior of simply moving 
keyframes around.

 � Drag the center of the switch layer key to move the entire switch layer as 
a whole. You can also drag it before or after a neighboring switch layer to  
swap positions.

• When a layer is added to an empty switch group, it becomes the active child at 
frame 0.

• When a new layer is created inside a switch group, Moho will assign a unique 
name (which is necessary for proper switch group functionality).

• When a layer inside a switch group is renamed, the switch animation channel is 
updated to use the new name to preserve existing switch animation.

• When a new layer is created inside a switch group at a frame other than zero, 
that new layer is not marked invisible prior to that time. (The switch layer takes 
care of its visibility, so setting it separately is redundant and makes it difficult to 
re-time the frame-by-frame effect.)

• When a new shape is drawn in a vector layer inside a switch group at a frame 
other than zero, that shape will not be set invisible prior to that time. (Same 
reasoning as for new layers.)

If the children of a switch layer have layer colors assigned to 
them (as described in “Using Layer Colors” on page 

177), the corresponding keys in the timeline will have the same 
color when those children are active. This makes it easier to see at a 
quick glance what switch layer is active at what time.

Switch layer keyframes are displayed in the timeline. You can 
mouse over one of the keyframes to see which layer is 

active at that point.

Using the Switch Selection Window
Choose Window > Switch Selection to open the Switch Selection window. When you 
have a switch layer selected in the Layers Window, the Switch Selection window 
will allow you to choose a switch layer by moving the slider left and right.  Use the 
Center Preview checkbox to toggle between centered preview or a group-relative 
display. This choice will be stored with the document.

• To add a switch layer to the timeline: Advance to the frame where you want 
the switch layer to change, and then move the slider to the switch layer you 
want to add to that frame. As you move the slider, a preview of the associated 
switch layer will appear in the preview window. A keyframe will automatically 
be added to the timeline after you choose the switch layer with the slider.
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• To remove a switch layer from the timeline: Advance to the frame that contains 
the switch layer you want to remove. Then click the Clear button in the Switch 
Selection dialog.

 Switch Selection Window

Frame by Frame Layers (Pro Only)
The Frame by Frame layer type automatically creates a layer that has the Frame 
by Frame option turned on in the Layers Window. A new vector layer will be placed 
inside the Frame by Frame animation layer so that you can begin drawing in it. 

All of the drawing tools are available when a frame by frame layer is selected. Unlike 
doing frame by frame animation with switch layers, you will not need to go into the 
individual layers inside the frame by frame layer. If a frame by frame layer is selected 
when you insert text, the text will be created on the active vector layer. You also will 
not need to expand a Frame by Frame animation layer to select the individual layers 
while you draw.

See “Tutorial 5.10: Using Frame by Frame Layers for Animation 
(Pro Only)” on page 221 in your Moho Tutorial Manual 

for more information on how to use Frame-by-Frame layers.
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 Frame by Frame Layers

Particle Layers (Pro Only)
Particle layers are a way to simulate such effects as flowing water, fire, bubbles, or 
other effects that you can imagine are made up of many small objects. A particle 
layer is like a group layer in that it can contain sub-layers. However, instead of just 
displaying its sub-layers as they are, a particle layer will automatically animate its 
sub-layers so that they appear to be flowing outward from the particle layer’s origin.

 Particle Layers

The direction that a particle layer sprays its particles is illustrated below.
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 Particle spray direction

During an animation, a particle layer can be turned on or off. When it is turned off, 
no more particles will be created, but those that already exist will continue to the 
end of their lifetime. To turn a particle layer on or off, right-click its entry in the Layers 
Window. A popup menu will appear to let you turn the particle layer on or off.

The complete list of settings for a particle layer is as follows. These settings are 
accessible in the Layer Properties dialog, under the Particles tab:
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 Particles Layer Settings

• Particle Count: The total number of particles visible at any one time

• Preview particles: The number of particles displayed in the working view (a 
smaller number than Particle count keeps the working view from slowing down 
too much)

• Lifetime (frames): The number of frames before a particle is recycled and sent 
back to the source. If set to zero, the particles will keep going for the duration of 
the animation.

• Source width: The width of the spray source

• Source height: The height of the spray source

• Source depth: The depth of the spray source. If set to a number greater than 
zero, then some particles will appear closer to the camera than others.

• Velocity: The speed that particles start at (a value of 2 will cause a particle to 
cross the entire screen vertically in one second)

• Velocity spread: The amount of random variation in the particles’ velocity

• Damping: This acts kind of like air resistance, or backwards acceleration
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• On at start: Whether the particle layer should be on at the start of the animation

• Full speed start: If the layer is on, this checkbox indicates if it should be running 
at full speed, or just starting

• Orient particles: If checked, then the particles will rotate to face the direction 
they’re moving in

• Free-floating: If unchecked, then the particles will be tied to the particle layer if 
it is moved

• Evenly spaced: if checked, then the particles will be released in even time 
increments

• Randomize playback: Normally, particles will start their animation from the 
beginning when they are first created. If this box is checked, then particles will 
start playback at a random time. This is useful when simulating things like crowds 
of people when you use effects (see “Effects” on page 233 in your Moho 
Tutorial Manual).

• Use Base Layer as Source: Check this option if you want to use the bottommost 
layer as a shape that generates your particles. For more information on this 
feature, see “Tutorial 6.9: Using 3D Models (Pro Only)” on page 269 in your 
Moho Tutorial Manual.

• Direction: An angle indicating direction to spray particles in (see above figure)

• Spread: How wide the spray should be (see above figure) (a value of 360 will 
cause particles to spray in all directions)

• Acceleration: The direction of acceleration (straight down simulates gravity)

• Rate: The rate of acceleration

• Copy all Particle settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all particle 
settings to all other applicable selected layers.

Note Layers (Pro Only)
Moho’s Note layers work kind of like sticky notes. You can add a note layer to remind 
yourself of something you need to work on, or to explain to other animators some 
important aspect of your project file. If you add a note layer at a frame other than 
zero, the note will only appear starting at that frame. That way, you can add notes 
that refer to specific parts of your animation (ex. “Use more exaggeration here!”).
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 Note Layers

By default, Note layers do not appear in final rendered output, so your audience 
doesn’t need to see your comments to yourself. However, if for some reason you do 
want a note to appear in the final product, you can do that by unchecking Don’t 
render this layer in the Layer Settings dialog.

You can assign a color to the Note layer in the General tab. 
After you create the Note layer, open the Layer 

Settings dialog and switch to the General tab. Choose a color from 
the Layer Color drop-down menu, as described in “General Tab” on 
page 207. If the color is set to Plain, the note will appear against the 
default background color.

Audio Layers
Audio layers allow you to add an audio file to your project. You will be prompted to 
select a file after choosing this layer type. A graphic representation of the audio file 
appears in the timeline after the file is selected.
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 Audio Layers

3D Layers (Pro Only)
3D layers are a way for you to import true 3D models into Moho. When a 3D layer is 
rotated in space (or the camera moves around it), you actually see that backside of 
the model. Moho supports importing OBJ files into 3D layers - OBJ is a common 3D file 
format that most 3D programs can read and write.

When importing OBJ files, Moho will also load any associated material file, importing 
the objects’ colors and texture maps.

3D layers can also be used with skeletons. Using a bone layer, you can warp a 3D 
model by moving bones around. Keep in mind that while 3D layers are truly three-
dimensional, bone layers are only 2D. So, any manipulation you do with bones is 
going to be limited to some degree.

Because Moho is not a true 3D program, not all 3D features are supported. In 
particular, lighting. Any 3D model you import will be flat shaded. However, because 
Moho does support texture maps, you can simulate lighting if a texture map has 
lighting effects baked into it.

There are lots of quality 3D programs we recommend for use with Moho Pro. The 
following are products that will work well with Moho Pro:

• Poser

• Amapi

For further information on importing 3D objects within Moho Pro please see the Moho 
Tutorials section at http://youtube.com/mohoanimation.

When preparing a 3D model for use with Moho, it’s usually a 
good idea to triangulate the model before exporting it 

as an OBJ file. This will eliminate any problems with concave or 
complex faces.
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Patch Layers (Pro Only)
Patch layers are used in the Character Wizard to create objects that appear both 
in front of and behind objects on another layer. You can also create patch layers 
manually.

 Patch Layers

Patch layers are intended for use when you are constructing a character such as 
a humanoid figure. For example, let’s say you are drawing different body parts on 
different layers in a bone group. The head is on one layer, the torso on another, 
upper left and right arms on their own layers, and so on. Each layer has its own 
outline and fill.

However, when one joint meets another joint, there are outlines that overlap with 
other body parts. This is where patch layers come in, because you can blend the 
two layers together and “hide” the line where they connect.

Look at the following example, which shows a number of body parts that are placed 
inside a Bone layer named Skeleton.
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 Determine the areas that you want to blend with underlying layers.

Let’s say you want to blend the area between the torso and the right upper arm 
(Upper Arm R), which appears directly above the torso in the Layers Window. To do 
this, you would follow these steps:

1. Select the Upper Arm R layer, so that the new Patch layer will appear above it.

2. Create a new Patch layer in the Layers Window.

3. A dialog asks you to select a target, and you can select the target layer from 
the Target drop-Down menu. Choose the Torso layer and click OK.

4. You’ll see a new circle in the project window. The circle is the patch. The patch 
will be named according to the target layer that you selected in the Patch 
Layer dialog. In the case of our example, the patch layer is named Torso-Patch.

5. Use the Transform Layer tool to position and scale the patch so that the lines are 
covered. It should be positioned at the point where the shoulder will rotate.
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 The new Patch Layer in place.

6. Use the Manipulate Bones tool to test the positioning of your patch.

If you need to change the target at any time, you can double-
click the Patch layer and choose a new target from the 

Patch tab in the Layer Settings dialog.

 Double-click the Patch layer to change the target if necessary.

Text Layers
The Text Layer option adds a text layer to your document, and works the same as 
the Text tool, the Draw > Insert Text command or by using the keyboard shortcut Ctrl/
Command+T. For a description of the Insert Text dialog, see “Insert Text” on page 
130.
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 Text Layers
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Chapter 12: Layer Settings
The Layer Settings dialog can be invoked either by double-clicking a layer in the 
layer list, or by selecting a layer, then clicking the Layer Settings button in the layer 
toolbar. The various controls are grouped into tabs that we’ll describe in order.

Click the Apply button to apply changes in settings. The Layer Settings window will 
remain open so that you can make additional changes.

Editing Multiple Layers
When you select a layer in the Layers Window, you can view the settings for that 
layer in the Layer Settings dialog. You can use the Shift or Command/Ctrl keys to 
make multiple selections in the Layers Window. The layers that you select don’t have 
to be the same type of layer. For example, you can select an image layer and a 
vector layer as shown in the following figure:

 Use the Shift or Command/Ctrl keys to select multiple layers in the Layers Window.

When multiple layers are selected, the last layer that you select becomes the 
primary layer. The primary layer is displayed in a slightly darker shade in the Layers 
Window. Secondary layers are displayed with a slightly lighter colored highlight.

A message appears at the bottom of the Layer Settings dialog to indicate that 
multiple layers are selected. In addition, a checkbox appears at the bottom, 
labeled Copy all <Tab name> settings to other selected layers. Check this option in 
the applicable tab and click the Apply or OK button to copy all settings from that 
tab to all the other selected layers, as applicable. Reference the General, Image, 
Audio, and Text tab sections in this chapter for minor exceptions that are not copied 
to the other tabs when this option is selected.

 The Layer Settings window displays a message when multiple layers are selected.
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The following rules apply when you are making changes to multiple selected layers:

• If different layer types are selected, the Layer Settings window will only display 
the tabs that apply to the primary layer. For example, if your primary layer is a 
vector layer but you have image layers as secondary layers, the Image tab will 
not be displayed. However, you will be able to edit settings that are common to 
image and vector layers in the Vectors tab.

• When you change a setting that is common to all selected layer types, those 
common changes will be applied to all of the selected layers when you click 
the Apply or OK button in the Layer Settings dialog. In other words, you can 
change the Blur or Opacity setting in the Vectors tab, and then apply that 
change to all of the layers in the selection, whether they are vector or image 
layers.

• If you make settings that are specific to the primary layer type, they will not be 
applied to sublayers of a different type. For example, if your primary layer is an 
Image layer and you make changes in the Images tab, those changes will not 
be applied to the vector layers in your selection.

• Where settings are grouped, any change to one of those grouped settings will 
cause all settings within that group to change on all of the selected layers. For 
example, the Outline section of the General tab groups three settings together: 
Outline On, Width, and Color. If you change the outline color, Moho will also 
update the outline state (on or off) and outline width to all of the layers when 
you click Apply or OK. Settings are grouped as follows:

 � Outline (“General Tab” on page 207): Outline On, Width, and Color.

 � Colorizing (“General Tab” on page 207): Colorize Layer, and Color.

 � Layer Shadow (“Shadows Tab” on page 217): Shadow On, Offset, Blur, 
Shadow color, Shadow threshold, Expansion, and Shadow direction.

 � Layer Shading (“Shadows Tab” on page 217): Shading On, Offset, Blur, 
Shading threshold, Shading color, Contraction, Inverted, and Shading 
direction.

 � 3D Shadow (“Shadows Tab” on page 217): Perspective shadow on, Blur, 
Shadow threshold, Scale, Shear, and Color.

 � Motion Blur (“Motion Blur Tab” on page 222): Motion blur on, Frame count, 
Frame skip, Start opacity, End opacity, and Blur radius.

 � Depth Sorting (“Depth Sort Tab” on page 239): Sort layers by depth, Sort 
by true distance, Enable animated layer order.

 � Toon Settings (“Image Tab” on page 241): Toon effect, Edge level, Gray 
level, Black level, Saturation, Lightness, Quantization.

If you make any settings in the Image tab that apply to videos, 
they will only be modified in secondary image layers 

that have video files as their sources.

 � All Settings in the 3D Options tab (“3D Options (Pro Only)” on page 250): 
In Moho Pro, any changes that you make in the 3D Options tab will be 
applied only to other layers if they are the same type as the primary layer. 
For example, if the primary layer is a 2D vector layer, the changes that 
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you make in the 3D options tab will only be applied to 2D vector layers. If 
the primary layer is a true 3D layer (such as an imported Poser scene), the 
changes will only be applied to other true 3D layers.

 � Physics Settings, Pro only (“Physics Tab (Pro Only)” on page 253): Enable 
physics, Gravity direction, Gravity magnitude, Use baked physics.

General Tab
This tab is available for all layer types, and controls general layer properties.

 General Layer Settings
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• Name: This field allows you to change the name of the layer. You can type in 
any name for the layer you want here, and the name will appear in the layer list 
after you click the OK button. Good names make working with large projects 
much easier. Examples of layer names might be Background, Body, or Head.

• Hide in editing view: Turn on this checkbox to hide the layer while editing. The 
layer will still appear in rendered output, but will be invisible in Moho’s edit view. 
This can be useful to reduce clutter and improve performance. Things you 
might consider hiding in the editing view are background details, texture and 
detail layers, or special effects like particle layers. Note that if a hidden layer is 
the currently active layer, it will temporarily un-hide itself so that you can edit 
whatever it contains.

• Don’t render this layer: If this box is turned on, then the layer will not appear 
in any rendered/exported movies. This option is usually used for some kind of 
helper layer. For example, you might draw a layer with some guide lines to help 
you draw and animate a scene, but you don’t want those guides to appear in 
the final output. Note layers have this option turned on by default.

• Allow animated layer effects: When checked allows you to animate layer 
effects by varying settings through the timeline. When unchecked, layer effects 
do not animate.

• Layer Color: Layer colors are used to help you categorize the content in your 
project using colors of your choosing. Use the Layer Color selector to choose 
a color for the current layer. Plain will display the layer in the normal Moho 
interface color. Several other color choices are available for categorizing your 
layers.

Compositing Effects
This group of controls allow you to change certain layer properties over time. When 
you modify any of these at a frame greater than 0, you will add a keyframe to the 
corresponding layer effects channel. For example, if you go to frame 1 and uncheck 
Visible, then go to frame 20 and re-check Visible, that layer will not appear in the 
final animation until frame 20.
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 Compositing Effects

• Visible: Controls whether a layer is visible in the final output. It is important to 
note that this checkbox is totally independent of the visibility box displayed 
in the layer list: these are two separate notions of visibility, and don’t affect 
each other at all. The visibility control in the layer list is meant for your editing 
convenience: you can turn one layer off while you work on another. The visibility 
checkbox in this dialog is meant to allow certain effects during an animation. 
For example, if you had a layer with a drawing of a glowing lightbulb, you could 
uncheck the visibility of this layer at frame 1, then turn it on at frame 10, off at 
frame 20, on at frame 30, etc. to create the effect of a blinking light.

• Blur radius: Lets you apply a blur (in pixels) to an entire layer to simulate such 
effects as camera focus. The blur can be animated over time to make a layer 
look like its coming in and out of focus. Decimal values are allowed to provide 
smoother transitions during animation.

• Opacity: Allows you to modify the transparency of an entire layer. An opacity 
value of 100 will not affect the layer at all, while a value of 0 will make it totally 
transparent. By changing the value from 0 at frame 1 to 100 at frame 10, the 
layer will seem to gradually appear out of nowhere, which in some cases 
is more desirable than the type of on/off visibility provided by the Visible 
checkbox.

• Auto shading radius: Allows you to simulate 2D ambient occlusion effects. 
Double-click the desired layer, or highlight a layer in the layers panel. Turn the 
Auto Shading option on and set the radius to a value other than zero. A good 
starting point is somewhere between 8 and 16 pixels.
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 Without Auto Shading

 With Auto Shading

• Threshold: Works in conjunction with blur, and can be used to produce 
smoother transitions in corners. The more an object is blurred, the more the 
threshold will have an effect. The blur is computed first, and then the threshold is 
added on top of it to smooth out the overall shape.
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The threshold is applied to the RGB values at whatever you add 
in the threshold field. A value of 128 is a midpoint value. 

If you end up with unusual colors after applying the threshold, you 
can use Colorizing to overlay a color on the layer. For more 
information about colorizing, see “Colorizing” on page 212.

• Noise: Adds noise to the fills in the selected layer. Enter the amount of noise 
desired in the Noise field. Accepted values are 0 to 255. Visible in preview and 
final rendering.

• Pixelation: Adds pixelation to the objects in the scene. Enter a value, in pixels, for 
the size of the pixel blocks. Accepted values are from 0 to 255. Visible in preview 
and final rendering.

• Flip horizontally and Flip vertically: Clicking these boxes flips the entire layer in 
the direction specified. (If the layer is a group layer, then the sub-layers inside 
it get flipped as well.) This can be convenient in the case where you want to 
duplicate a layer and have the second copy face the first one as a mirror 
image.

Outline
The General Tab of the Layer Settings dialog displays the following options for 
outlines:

 Outline Options
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• Outline on: Check this option to create an outline around the objects on the 
layer.

• Width: Set the desired width of the outline, in pixels.

• Color: Click to set the color of the outline.

You can add an outline to a layer by enabling the option in this section and 
specifying the width and color of the outline.

You can set separate colors and widths for each layer to add nice effects to your 
drawings. If you set just one color and width on a bone group, but not on each layer 
of a bone group, the layer outline will only be applied to the outline of the character 
(and not each individual part).

After you specify your outline parameters, you will need to preview your drawing 
with the File > Preview command, or use the shortcut Cmd R (Mac) or Ctrl R 
(Windows).

 With 10 pixel blue outline around the bone group

Colorizing
The Colorizing section allows you to overlay a color on the selected layer. The 
options are as follows:
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 Colorizing Options

• Colorize layer: Check this option to apply a color overlay to the selected layer.

• Color: Click to set the overlay color and properties.

You can use the Colorizing feature to eliminate unwanted or objectionable colors 
that occur after you apply thresholding to objects on a layer (see “Compositing 
Effects” on page 208 for information about the Threshold settings). The figure shown 
below shows several objects on a layer which have a blur setting applied (top). 
Thresholding is added to soften the shapes between the objects. After rendering, 
you may see unusual colors (middle) because the threshold is applied to the R, G, 
and B values in the original object color. To fix this, choose the Colorize layer option 
and select your overlay color. Render again to see the final result (bottom).
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 Original objects (top); threshold applied (middle); with color overlay (bottom)

Options
The Options section of the General Properties tab provides the following options:

 General Options

• Rotate to follow path: When this checkbox is turned on, the layer will 
automatically rotate to follow its direction of movement. (Specifically, the up 
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direction will turn to follow the direction of layer translation.) This can be useful 
for creating things like flowing arrows that need to point in their direction of 
movement.

• Scale compensation: When this box is checked (as it is by default), and you 
scale an entire layer larger or smaller, the lines in the final rendered output will 
automatically get thicker or thinner so that they retain their relative weight in the 
overall image. Also, layer effects like blurs and shadows will become larger or 
smaller to match the scale of the layer.

• Use HSV modifier image: This checkbox lets you use an image file to distort the 
colors of the layer. Sometimes you may want to do this to break up the solid 
colors in your project and make it look less computerized. The exact behavior 
of this feature is difficult to explain. The best way to try it out is to use one of the 
HSV modifier images included with Moho. These images should be pretty close 
to 50% gray. Other images may produce bizarre, unexpected results. Feel free 
to experiment - you can always turn off this checkbox if you don’t like the results.

• Immune to camera movements: Sometimes you may want to make some layers 
ignore camera movements. For example, certain backgrounds or title or logo 
layers you may want to stay in one place on the screen even while you move 
the camera around.

• Embedded Script File: Allows you to attach a lua script to a layer. When you 
play it back in the timeline or render a document, the script is executed to go 
with that layer.

• Immune to depth of field: The depth of field function (in the Project Settings 
dialog) lets you simulate the blurring of objects with different distances from the 
camera. This option allows you to turn off this effect for any particular layer.

• Rotate to face camera: In previous versions of Anime Studio, a layer would pivot 
only on the Y axis and face the center of the camera. In Anime Studio 9.5.2 or 
later, you can choose different pivot axes, and the layer can face the camera 
center or the image plane. This can be useful when using Moho’s 3D camera 
- especially for scenery-type objects. Trees, for example, that always face the 
camera can save you a lot of work. Choose a rotation option from the popup 
menu:

 � No: Turns off the Rotate to Face Camera feature.

 � Pivot X Axis: Rotates the layer on its X (horizontal) axis as best it can to 
make the layer’s Z axis point at the camera.

 � Pivot Y Axis: Rotates the layer on its Y (vertical) axis as best it can to make 
the layer’s Z axis point at the camera.

 � Free Pivot: Rotates the layer on both its X (horizontal) and Y (vertical) axis as 
best it can to make the layer’s Z axis point at the camera.

 � Face Image Plane X Axis: Rotates the layer on its X (horizontal) axis as best 
it can to keep the layer parallel to the camera plane.

 � Face Image Plane Y Axis: Rotates the layer on its Y (vertical) axis as best it 
can to keep the layer parallel to the camera plane.



Moho 13.5
Users Manual 

216

Chapter 12: Layer Settings

 � Face Image Plane Free Rotate: Rotates the layer on both its X (horizontal) 
and Y (vertical) axis as best it can to keep the layer parallel to the camera 
plane.

In the diagrams that appear below, the X and Z Axes are 
shown in red and blue. The Y axis points straight up, so 

being that we are looking at the scene from the top, the Y axis points 
at you. The black pyramid represents the camera view, with the 
point of the pyramid representing the eye. An image plane appears 
in front of the camera. This image plane is like film, and represents 
where the rendered image gets focused.

There are also three layers in the diagrams: Layer A is not set to face 
the camera. Layer B pivots on the Y axis so that it faces the center of 
the camera. Layer C is set to Face Image Plane Y Axis.

In the first image, the camera is in its default position and rotation. 
Layer A, which has the Rotate to Face Camera feature off, will not 
move when the camera is moved. Layer B, which is set to rotate on 
the Y axis, turns to face the camera. Layer C, which is set to rotate 
with the image plane, is rotated the same as the image plane.

A Moho scene, viewed from the top.

When the camera is moved to the left of the scene, and rotated to 
face the center, the image plane also rotates to the same angle. 
Notice now that Layer A remains in the same position because 
Rotate to Face Camera is off. Layer B, which is set to rotate with the 
Y axis of the camera, rotates to face the new position of the camera 
eye. And Layer C, which is set to rotate with the Y axis of the image 
plane, rotates in parallel with the image plane.
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A Moho scene viewed from the top, with the camera moved to the left side

• Layer blending mode: Normally, layers are composited on top of each other 
simply according to the transparency of each layer. The layer blending mode 
popup lets you select a different blending mode for each layer. This can be very 
useful for simulating shading and lighting effects.

• Tags: (Pro only) You can now set your own tags for one or more layers. Enter a 
list of keywords, separated by a comma. This allows keywords to contain more 
than one word that is separated by a space. 

• Comments: (Pro only) Enter comments for the selected layer(s).

• Copy all General settings to other selected layers (except Name): When 
multiple layers are selected, check this option and click the Apply button to 
copy all settings (except the name) to all other applicable selected layers.

Shadows Tab
The controls in this tab allow you to apply automatic shadows and shading to an 
entire layer.
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 Shadows Layer Settings

The Shadows tab includes the following option that applies to layer shadow, 3D 
shadow, and layer setting options:

• Copy all Shadow settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all shadow tab 
settings to all other applicable selected layers.

Layer Shadow
This section lets you apply a drop-shadow effect to a layer. The options are:
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Layer Shadow options.

• Shadow On: Checking the Shadow on checkbox will make all objects in the 
layer cast shadows on the layers underneath.

• Offset: Controls how far the shadow appears from the actual objects. A larger 
offset makes objects appear higher up above the layers below them.

• Blur: Determines how hard or soft the edges of the shadow appear.

• Shadow Threshold: Works in conjunction with blur, and can be used to produce 
smoother transitions in corners. The more an object is blurred, the more the 
threshold will have an effect. The blur is computed first, and then the threshold is 
added on top of it to smooth out the overall shape.

• Expansion: Allows you to expand the reach of the shadow. This can be useful for 
halo-type effects. Try an Offset of 0, Blur of 8, and Expansion of 8.

• Clip shadow to group: Clips the layer shadows to the contents of the enclosing 
group.

• Shadow Color: Clicking on the “Shadow color” swatch lets you change the 
color of the shadow that is being cast. You can also modify the transparency of 
the shadow with this control.

• Shadow Direction: Controls the direction the shadow is cast. Just drag the knob 
in circles to change the direction of the shadow.

Layer Shading
This section is similar to the “Layer Shadow” section above. However, instead of 
producing a shadow effect behind the layer, these controls let you apply a shading 
effect on top of the layer.
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Layer Shading options.

• Shading On: Checking the “Shading on” checkbox will make all objects in the 
layer appear shaded, giving them a rounded edges effect.

• Offset: Controls how far inside the layer the shading appears. A larger offset 
makes objects appear to have more “rounded” edges.

• Blur: Determines how hard or soft the edges of the shading appear.

• Shading Threshold: Works in conjunction with blur, and can be used to produce 
smoother transitions in corners. The more an object is blurred, the more the 
threshold will have an effect. The blur is computed first, and then the threshold is 
added on top of it to smooth out the overall shape.

• Contraction: Allows you to pull the shading further into the center of the layer.

• Inverted: Inverts the shading effect so that the object looks like it has a rim 
highlight.

• Shading Color: Clicking on the “Shading color” swatch lets you change the 
color of the shading that is applied. You can also modify the transparency of 
the shading with this control.

• Shading Direction: Controls the direction the shading appears. Just drag the 
knob in circles to change the direction of the shading.

3D Shadow (Perspective Shadows)
Moho allows you to easily create perspective shadows for the objects in your scene. 
Select a layer from the Layers Window and open the Layer Settings dialog. Click the 
Shadows tab, and adjust the settings in the 3D shadow area. You can animate this 
feature by applying different settings at different points in the timeline. You will not 
see the shadow until after you render the current frame, or all or part of a movie.
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The position of the shadow is determined by the Set Origin tool in the Layer section 
of the toolbox. When you set a perspective shadow, pay attention to the location 
of the origin of the object. The shadow is cast from the origin point. The origin 
represents the ground point, so you can position it to make the object look as 
though it is resting on the ground, or as if the object is floating in the air.

 Position the origin point at “ground” level.

The settings for perspective shadows are as follows:

3D Shadow options.

• Perspective Shadow On: Check this button to turn Perspective Shadows on. 
Uncheck it to turn Perspective Shadows off.

• Blur: Sets the amount of blur on the perspective shadow. Higher values create a 
softer shadow.
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• Scale: Controls the “depth” of the shadow. Higher values make the shadow 
seem more elongated, while lower values make the shadow shorter

• Shear: Allows you to control the slant of the shadow (the direction that the light 
source is coming from).

• Color: Allows you to select a color for the shadow. Default color is black.

Motion Blur Tab
The controls in this tab control the motion blur effect for this layer. Motion blur can be 
turned on and off during the course of an animation.

Moho’s motion blur feature simulates how an object moves while the shutter of a 
camera is open. Double-click the layer or layers that you want, and enable the 
Motion Blur On option in the Motion Blur tab. 

• Motion Blur On: Checking “Motion blur on” turns on the effect. When this option 
is not checked, motion blur will not be applied.

Legacy Motion Blur
Legacy motion blur is available in both Moho Debut and Moho Pro. To use Legacy 
motion blur in Moho Pro, uncheck the Sub-frame motion blur setting.

The following settings apply to Legacy motion blur:

 Legacy Motion Blur Layer Settings (Pro shown)
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• Frame Count: Used with Sub-frame motion blur. Controls the amount of blur that 
is applied in a single frame. Lower values will create less smearing, and higher 
values will create more blur. The following image shows (from left to right) sub-
frame counts of 2, 10, 20 (default) and 40.

• Frame Skip: Used with Sub-frame motion blur. Controls the separation between 
blur frames. A larger number will cause the blur effect to trail farther out behind 
the current position.

• Start Opacity and End Opacity: Used with Sub-frame motion blur. Control how 
the blur fades away behind the layer. Generally, a motion blur effect will fade 
a bit as it trails behind the layer. For some special effects, however, you may 
not want the motion blur to fade at all. In those cases, set both values to 100 to 
keep the motion blur completely opaque.

• Blur Radius: Used with Sub-frame motion blur. Controls the radius (in pixels) of the 
motion blur effect.

• Copy all Motion Blur settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all motion blur 
settings to all other applicable selected layers.

Enhanced Motion Blur (Pro Only)
In addition to legacy motion blur, Moho Pro offers an enhanced motion blur that 
more accurately simulates motion blur found in real world cameras. To enable this 
feature, check the Sub-frame motion blur option in the Motion Blur tab (Pro only).

 Enhanced Motion Blur Layer Settings (Pro only)
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The settings relating to sub-frame motion blur are as follows:

• Sub-frame motion blur: Check this option to use the new sub-frame motion blur. 
Leave it unchecked to use legacy motion blur, described previously.

• Frame Count: Used with Sub-frame motion blur. Controls the amount of blur that 
is applied in a single frame. Lower values will create less smearing, and higher 
values will create more blur. The following image shows (from left to right) sub-
frame counts of 2, 10, 20 (default) and 40.

 Sub-frame settings of 2, 10, 20, and 40

• Frame percentage: Used with Sub-frame motion blur. In real-world cameras, the 
shutter does not stay open for the entire duration of the frame. The value you 
enter in this field represents the percentage of the frame that should remain 
open for the blur effect. A value of 50 is similar to a real camera, and is more 
subtle than a value of 100 (which blurs the movement through the entire frame).

• Extended frames: Used with Sub-frame motion blur. This setting goes beyond 
real-world motion blur. It not only takes the blur between one frame and the 
next, but you can also use multiple frames for an exaggerated blur. Enter the 
number of extra frames that you want to include to create an exaggerated 
motion blur. A value of 0 will be most like real-world animation.

Masking Tab
This tab is used to control layer masking. Layer masking controls the visible region 
of a layer - objects in a layer that are not within the visible region of the mask will 
not appear in the final output. This tab is available when a group or bone layer is 
selected.
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 Masking Layer Settings

If the layer is a group or bone layer, then the following options are available:

No masking in this group: Means that no masking will occur in this group.

• Reveal all: Means that masking is on, and by default all sub-layers will be fully 
visible.

• Hide all: Means that masking is on, and by default all sub-layers will be invisible 
(this is the most common option when using layer masking).

All other layers inside a group will have the following options for layer masking:
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• Mask this layer: Clip this layer against the current mask.

• Don’t mask this layer: Skip all masking operations for this layer.

• + Add to mask: Add this layer to the mask. Any higher layers will be visible 
wherever this layer is visible.

• + Add to mask, but keep invisible: Add this layer to the mask, but don’t show it 
in the final output.

• - Subtract from mask: Use this layer to cut a hole in the current mask.

• + Clear the mask, then add this layer to it: This makes the mask identical to the 
transparency value of the current layer.

• + Clear the mask, then add this layer invisibly to it:

• Exclude Strokes: Check this option to exclude outlines from the mask.

• Expand mask by a pixel: Adds an additional pixel around a layer mask.

• Copy all Masking settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all masking 
settings to all other applicable selected layers.

The masking controls are simple but powerful options that can 
be used for all kinds of creative tricks. The best way to 

explain these is with a hands on example. See “Tutorial 2.6: Brushes” 
on page 73 in your Moho Tutorial Manual.

Masking Tips and Tricks
When setting up masking in a group, the best approach is to first set up the mask, 
then set up the objects to be masked. The bottom-most layers should define the 
mask by either adding to it or subtracting from it. Then the layers above that should 
be masked against the defined mask.

For masking to be fringe-free, try to follow these guidelines:

• Masking should only increase in a one-way direction. The alpha channel must 
increase monotonically.

• Use additive masks only (use Hide All, instead of Reveal All)

• Don’t use any of the following modes for child layers in the group:

 � Subtract from mask

 � Clear this mask then add this layer invisibility to it

 � Don’t Mask This Layer (unless all other layers in the group above this one 
also use Don’t Mask This Layer)

 � Exclude Strokes (unless all layers in the group above are set to Masked)

The following examples demonstrate some do’s and don’ts in masking techniques.
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Simple Masking (Produces No Fringing)
This example starts with a group that contains five layers. each with a different 
shape. This group renders with no fringe because it follows the rule of only adding to 
a mask.

 A group with five layers, each with a different shape.

To mask an example such as this, use the following settings:

• Group mask: In the Group Mask section, choose Hide All. In the Layer Masking 
section, choose Mask this layer.

• Layer 1: Set to +Add to mask.

• Layer 2: Set to Mask this layer.

• Layer 3: Set to Mask this layer

• Layer 4: Set to + Add to mask

• Layer 5: Set to Mask this layer

After you apply the above settings, the end result will look as shown in the following 
figure, when rendered.
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 Result of simple masking.

Mask Reset (Produces Fringing)
This example consists of a group with five layers, each with an oval shape. This group 
doesn’t follow the rules. It renders with fringe because Layer 4 is set to “Clear and 
Add to the Mask.”
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 A group with five layers, each with a different shape.

This example uses the following settings:

• Group mask: In the Group Mask section, choose Hide All. In the Layer Masking 
section, choose Mask this layer.

• Layer 1: Set to +Add to mask.

• Layer 2: Set to Mask this layer

• Layer 3: Set to Mask this layer

• Layer 4: Set to + Clear the mask, then add this layer to it.

• Layer 5: Set to Mask this layer

After you apply the above settings, the end result will look as shown in the following 
figure, when rendered.
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 Result of mask reset.

Complex Masking (Produces Fringing)
This example starts with a group that contains three layers. each with an oval 
shape. This masking example also renders with fringe, because it breaks the rules by 
combining additive and subtractive masking in the same group.
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 A group with three layers, each with a different shape.

This example uses the following settings:

• Group mask: In the Group Mask section, choose Hide All. In the Layer Masking 
section, choose Mask this layer.

• Layer 1: Set to +Add to mask.

• Layer 2: Set to -Subtract from mask (this layer will be invisible)

• Layer 3: Set to Mask this layer

After you apply the above settings, the end result will look as shown in the following 
figure, when rendered.
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 Result of complex masking.

Vectors Tab
This tab is only available for vector layers, and controls the appearance of lines and 
fills in the layer. The controls here enable the vector “noise effect”. By adding “noise” 
to a layer, you can make it look more hand-drawn, or at least get rid of some of that 
pesky computer precision. Of course, that’s up to artistic interpretation: if you like 
computer precision, the noise effect may not be the feature for you.
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 Vectors Layer Settings

• Noisy Outlines and Noisy Fills: The first two checkboxes turn on noise for outlines 
and/or fills. If you turn on both of these, all the shapes in the layer will become 
distorted. However, if you check only one, the effect will look like someone was 
coloring but didn’t stay in the lines. The circle displayed on the right side shows a 
preview of what your noise effect settings will do to the final drawing. (The best 
way to understand this feature is to just start clicking the checkboxes and watch 
the circle.)

• Animated noise: Controls whether the noise factor will vary over time in your 
animation. This can lead to either a very distracting look, or a very sketchy, free-
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form one, depending on your tastes. Again, experiment with this and watch the 
circle.

• Extra Sketchy: (Associated with noise settings). Creates gaps in the outlines. If 
you have a curve being drawing you might actually have little gaps in it.

• Offset: Determines how far in pixels (on average) your drawing will be distorted 
from its original shape.

• Scale: Determines the “jaggedness” of the distortion. Larger scale numbers will 
result in smoother, lumpier distortion, while smaller numbers will give you a more 
scribbled look.

• Interval (Frames): When vector noise is set to be animated, you can set an 
interval so that the noise changes every nth frame, with n being the number 
that you enter in this field. Increase the number to reduce the amount of noise.

• Line Count: Tells Moho to draw a number of lines, distorting each in a different 
way.

• Animated Shape Order (Pro only): Check this option if you want to enable 
animated shape order on the selected layer, using the Draw > Raise Shape, 
Lower Shape, Raise to Front, or Lower to Back commands (or their equivalent 
shortcuts: Up arrow, Down arrow, Shift Up arrow or Shift Down arrow). This will 
allow you to select shapes on the current layer and animate the order in which 
they are stacked in relation to the camera. In the following example, animated 
shape ordering is used in combination with smart bones to position the ears 
above or below a character’s head as the head turns. When the smart bone 
is positioned toward the left, the character is looking to the left, the right ear is 
above the head and the left ear is below the head. When the smart bone is in 
its center position, the character looks to the center, and both ears are above 
the head. Finally, when the smart bone is positioned to the right, the character 
looks to the right, the left ear is above the head and the right ear is below the 
head.
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 Animated shape ordering allows you to position the ears of a character as its head 
turns.

See “Tutorial 5.11: Animated Shape Ordering (Pro Only)” on page 
229 in your Moho Tutorial Manual for a hands on tutorial on how to 
use animated shape ordering.

• Gap Filling: Sometimes two shapes are drawn that line up exactly side-by-side 
with no overlap whatsoever. In some situations, a small crack can appear 
between them. Turn this option on to enable Moho to fill in these cracks.

• Legacy Curves (Pro only): Switches a layer back to the curve drawing method 
used in Anime Studio 7 and earlier. Documents created in Anime Studio 7 and 
earlier should open in the application with this option turned on so that the 
existing artwork does not suddenly change.
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• Antialiasing (Pro only): Applies antialiasing to the currently selected vector 
layer(s).

• Smart Warp Layer: Allows you to assign a 2D triangulated mesh as a Smart Warp 
layer that deforms the currently selected layer. For more information, see “Smart 
Warp Layers (Pro only)” on page 236.

• Copy all Vector settings to othe.r selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all vector 
settings to all other applicable selected layers.

Smart Warp Layers (Pro only)
Smart Warp layers allow you to deform another vector or image layer using a 2D 
triangulated mesh. The following example shows a very quick way to create a smart 
warp layer from a 2D grid. You can also use the Add Point tool to draw selections 
around areas that you want to warp.:

1. Create a new vector layer in the Layers Window.

2. Select the Draw Shape tool. Use the Grid option to create a two-dimensional 
grid that can be used as a start point for a triangulated mesh. 

3. Enter the number of horizontal and vertical divisions for the grid in the Horizontal 
and Vertical fields for the shape grid. By default, the grid will have four horizontal 
and four vertical divisions.

4. Draw the grid in the workspace. Make a grid that is large  to completely enclose 
the layer that you want to warp.

  Use the Draw Shape tool to create a grid that is large enough to cover the area you 
want to warp.
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5. Use the Draw > Triangulate 2D Mesh command to triangulate the Grid layer. The 
grid will turn transparent and all points in the grid will be triangulated.

 Triangulate the grid layer with the Draw > Triangulate 2D Mesh command.

6. Double-click the layer that you want to morph to open the Layer Settings 
dialog. Expand the Smart Warp Layer selector to choose the layer that contains 
the 2D triangulated mesh.

 � If the layer that you want to morph is an image layer, you will find the Smart 
Warp Layer selector in the Image tab of the Layer Settings dialog.

 � If the layer that you want to warp is a vector layer, you will find the Smart 
Warp Layer selector in the Vectors tab of the Layer Settings dialog.

When you use a vector layer to warp an image, the vector 
layer will automatically be marked “Don’t render this 

layer.”

When a vector layer is triangulated, the alpha of the triangles is 
reduced, and the original edges will be preserved for 

visual reference.
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 Assign a 2D triangulated mesh as a Smart Warp layer.

After you choose the Smart Warp layer in the Layer Settings dialog, choose the grid 
layer in the Layers Window. When you use the Transform Points tool to animate the 
points in the grid, you will notice the image or vector warp beneath the grid.
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 Animate the points in the grid to warp the image or vector layer.

Depth Sort Tab
This tab is only available for group and bone layers. Depth Sort has two controls that 
can be used with Moho’s 3D features.
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 Depth Sort Layer Settings

• Sort Layers by Depth: Allows sub-layers to move in front of and behind each 
other during an animation. Normally, layers are drawn in the order they appear 
in the Layers Window. However, with this option turned on, layers are displayed 
according to how far they are from the camera. Typically, layers are sorted by 
their depth from the camera, but if you’re trying to create a 3D object using 
multiple Moho layers (like a cube or pyramid), you may want to turn it on.

• Sort by True Distance: Tells Moho to sort layers by the distance from the camera 
to the layers’ origins, rather than by depth. Usually this option will be left 
unchecked.
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• Enable animated layer order: During the course of an animation, you may 
want to move objects in front of or behind each other. One example is when 
simulating head turns. The children of a group layer have the ability to move 
back and forth in layer order over the course of an animation, but you need to 
turn this option on to allow it. If it’s off, then moving one layer in front of another 
affects them for the entire timeline.

• Copy all Group settings to other selected layers (except Name): When multiple 
layers are selected, check this option and click the Apply button to copy all 
group settings to all other applicable selected layers.

Image Tab
This tab is only available for image layers. There are five options in this tab.
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 Image Layer Settings

• Set Source Image: Lets you select the image to be used in the image layer. Use 
this if you want to change the image, or if it got lost for some reason.

• Reveal Source Image: Click the button to open Explorer (Windows) or Finder 
(Mac) to the folder that the current source image is contained within.

• AVI movie has alpha: Turn this on if the image layer is using an AVI movie, and 
that movie includes an alpha channel.
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• Loop movie indefinitely: When checked, the movie plays in a loop for as long as 
required in the animation. When unchecked, the movie plays once and stops 
when it reaches its end.

• Play backwards: When checked, plays a movie layer backwards (in reverse 
frame order).

• Persist First Frame: When checked, displays the first frame of a movie continually 
until the playhead reaches the frame at which the movie begins to play. When 
unchecked, the movie will not appear in the project until the playhead reaches 
the first frame in the movie.

• Persist Last Frame: When checked, displays the last frame of a movie continually 
after the playhead reaches the last frame of the movie in the timeline. When 
unchecked, the movie will no longer appear in the project after the playhead 
moves beyond the last frame in the movie.

• Premultiplied Alpha: If an imported movie has an alpha channel and the edges 
look bad after importing, it may be because the movie has premultiplied alpha. 
Check this option to improve appearance.

• Movie FPS: Sets the speed of the movie in Frames per Second

• Warp using bones: If this box is checked and the image layer is placed inside a 
bone layer, the bones can be used to warp the image as if it were printed on a 
rubber sheet.

• Nearest neighbor sampling: When this option is not checked, Moho will try to 
smooth out the areas in between pixels when you enlarge the image. If you 
want the images to look blocky when they are resized, turn this option on. Moho 
will not smooth the image and it will start to look blocky when it is enlarged.

• Higher quality rendering: Renders the image at twice the size, and then scales it 
down. This is useful to reduce antialiasing in the image.

• Unwrapped: Mirrors an image both horizontally and vertically to create a 
seamless tile.

 Unwrapped image (original image in center)
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• Smart Warp Layer: (Pro only) Use the Draw > Triangulate 2D Mesh command to 
create a triangulated 2D mesh layer that will be used to morph the image. Then 
double-click the image that you want to morph. Expand the Smart Warp Layer 
selector in the Image tab to choose the layer that contains the triangulated 
mesh. You can use 2D triangulated meshes to warp either vector or image 
layers. For additional information, see “Smart Warp Layers (Pro only)” on page 
236.

Toon Settings
The Toon Effect filter is used with images and movies. Load an image or movie into 
a new layer. Open the Layer Settings dialog to the Image tab and check the Toon 
Effect option. The image or movie will be processed through the Toon Effect filter.

 Toon effects on a photograph

When used with videos, the processing can take quite a while. When working 
with videos, open up the movie file and apply the toon effect filter. Immediately 
afterward, import the animation as a new movie file. Use the new movie file, with the 
toon effect applied, in your final project.

Some types of images work better than others. Faces should be pretty large in the 
image. If the face is small then a lot of detail will be lost or blurred together.
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The Toon Effect filter has several parameters in the Image tab:

 Toon settings in the Layer Settings Image tab

• Toon effect: Check this option to enable toon effect settings.

 � Edge level: Controls the width of the edges in the toon effect. Increase 
the setting to make the edges wider, and decrease to make the edges 
thinner.

 � Gray level: Darkens the middle areas of the toon effect.

 � Black level: Darkens the dark areas of the toon effect.

 � Saturation: Increases or decreases the amount of color. Negative values 
make the toon more black and white.

 � Lightness: Increase the setting to make the image appear more faded.



Moho 13.5
Users Manual 

246

Chapter 12: Layer Settings

 � Quantization: Sets the number of colors in the image. When set at 0, the 
quantization works the same as found in Anime Studio 7 and earlier. When 
set to a value greater than 1, the value you enter is the number of colors in 
the image.

• Copy all Image settings to other selected layers (except Source Image): When 
multiple layers are selected, check this option and click the Apply button to 
copy all image settings (except the source image) to all other applicable 
selected layers.

Audio Tab
This tab is only available for audio layers. The options are:
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 Audio Layer Settings

• Set Source Audio: Click the Set Source Audio button to select an audio source 
file on your system.

• Reveal Source Audio: Click this button to locate the audio source file in its folder 
location.

• Audio level: Displays a numeric value for the audio volume, with 1 being equal 
to the default volume of the audio file.

• Spatial Positioning: Enabled by default. When enabled, Moho will use and play 
back.
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• For more accurate lip syncing, enter the spoken text below: If your audio file 
consists of dialog, you can enter the text in the field provided. 

Switch Tab
This tab is only available for switch layers.

 Switch Layer Settings

• Select Audio Sync Source: Lets you select a data file used to control the switch 
layer. A data file is not required (you can control a Switch layer manually by 
right-clicking its entry in the Layers Window), but if you do want to use a data file 
you have two choices:

If you want a quicker lip-sync solution, you can use an audio file 
as a data file. In this case, your switch file should 

contain several version of a mouth shape, ranging from closed to 
wide open. The volume of the audio file will control which mouth 
shape is used at which frame. If you do use an audio file to control 
the Switch layer, you can either use automatic volume gain 
(recommended) or set the gain manually. The gain controls how 
wide the mouth gets. When using manual gain, start with a value of 
1 - if the mouth seems too wide, try smaller values (0.75 or 0.5). If the 
mouth isn’t wide enough, try higher gain values (1.5 or 2).

See “Tutorial 5.1: Automatic Lip-Sync” on page 180 in your 
Moho Tutorial Manual and “Tutorial 5.2: Phoneme Lip-

Sync” on page 182 in your Moho Tutorial Manual for examples of 
using audio lip-syncing functions.

• Interpolate sub-layers: If this box is checked Moho will do smooth transitions 
between the sub-layers as long as they’re all vector layers and contain the 
same number of points.
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• Frame-by-frame drawing (Pro only): Check this option to enable Frame-by-
frame drawing features on the selected switch layer. This option is used in 
conjuction with frame-by-frame animation layers. For a thorough example of 
using frame by frame animation in Moho, see “Tutorial 5.10: Using Frame by 
Frame Layers for Animation (Pro Only)” on page 221 in your Moho Tutorial 
Manual.

• Copy all Switch settings to other selected layers: If other Switch layers are 
selected, the settings you choose in the Switch tab will be applied to the other 
selected Switch layers.

Particles Tab (Pro Only)
This tab is only available for particle layers. The description for how these controls 
affect a particle layer can be found in “Particle Layers (Pro Only)” on page 195.
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 Particles Layer Settings

3D Options (Pro Only)
This tab is only available for 3D layers.
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 3D Options Layer Settings

• Edges: Allows you to control which elements get edges (or outlines) and to 
what degree. You can choose to enable or disable outlines around silhouettes, 
materials, or creases. The Crease Threshold setting controls the level of crease 
outline that will appear. The Edge Extension setting makes the outline thicker.

• Shading: Controls the type of shading that appears on the 3D object, along with 
the shading color and density. Choices of shading include None, Smooth, Toon, 
Hatched, or Extruded Side Color.
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 3D Shading Options

• Polygon orientation: Allows you to adjust whether the polygons in your model 
are oriented clockwise or counter-clockwise. After importing a model, if it looks 
turned inside-out or otherwise distorted, try switching the polygon orientation.

• Warp using bones: If this box is checked and the 3D layer is placed inside a 
bone layer, the bones can be used to warp the 3D model. Be aware that 
although the model is three-dimensional, bone layers are only two-dimensional, 
so you will be limited in the ways you can control the 3D object using bones.

• Reset Z buffer: Moho uses a z buffer rendering algorithm and the result is that 
all 3D objects in the scene interact in a visually consistent way. Objects that 
are closer appear in front of those further away, regardless of the layer order. 
However, if you turn this checkbox on for layer X (a 3D layer), then when 
layer X gets rendered it first resets the z buffer. This is a way to force a 3D 
layer to appear in front of other 3D layers that it might actually be behind. In 
other words, sometimes you may want multiple 3D layers to interact in the Z 
dimension (hide behind each other, or even interpenetrate so that some parts 
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of one object are in front of another and some parts behind). This is the normal 
behavior. Turning on the Reset Z Buffer option forces 3D objects to act like 
regular 2D layers and just be in front of or behind each other according to the 
layer order in the Layers Window.

• Copy all 3D settings to other selected layers: When multiple layers are selected, 
check this option and click the Apply button to copy all 3D settings to all other 
applicable selected layers.

Note Tab (Pro Only)
This tab is only available for note layers, and lets you change the text label in the 
note.

• Copy all Note settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all Note settings 
to all other applicable selected layers.

 Notes Layer Settings

Physics Tab (Pro Only)
The settings in the Physics tab are as follows:

 � Enable physics: Check this option to turn the physics simulator on.

 � Gravity direction: Use the directional slider to point to the direction from 
which gravity is originated. By default, the direction is straight down (270 
degrees). 0/360 degrees is at the 3:00 position of the dial.

 � Gravity magnitude: Controls the strength of the gravity. Lower values make 
the gravity less forceful (objects are lighter) and higher values make the 
gravity more forceful (objects are heavier).

 � Use baked physics (advanced): Turn this option on to stop the physics 
simulation from running. It will play back results from the last time you 
played back the animation.

 � Copy all Physics settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all physics 
settings to all other applicable selected layers.
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Normally, physics simulations are re-run every time you play 
back an animation so that they can respond to other 

objects in the scene. The advantages to using baked physics are (1) 
it is faster to re-use simulations rather than to re-run the physics; (2) If 
the physics simulation doesn’t give you the results you want, you 
need to tweak results. You can’t manually animate objects if they 
are under the influence of physics, but you can use the 
precomputed physics while you modify keyframes as you see fit. (3) 
If you get a result that you like, you can turn this option on to make 
sure it doesn’t change.

Physics will only work with objects that are filled.

For more information on how to use physics in your Moho projects, see “Tutorial 5.9: 
Basic Physics (Pro Only)” on page 214 in your Moho Tutorial Manual.

 Physics Settings

Bones Tab
The settings in the Bones tab are as follows:

• Binding Mode: Check one of the following to select the binding mode that you 
want to use for bones.

 � Flexible Binding: This option is selected by default. This uses Flexi-Binding, 
which allows greater control over how bones affect different layers in a 
bone group. See “Tutorial 3.5: Flexi-Binding” on page 136 in your Moho 
Tutorial Manual.

 � Region Binding: Uses the binding style that was used by Anime Studio prior 
to version 9.5. See “Tutorial 3.4: Character Setup” on page 125 in your 
Moho Tutorial Manual.
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• Allow Nested Layer Control: Allows you to control the children of their children, 
making it easier to work with bones on images and vector art.

• Copy all Bones settings to other selected layers: When multiple layers are 
selected, check this option and click the Apply button to copy all bone settings 
to all other applicable selected layers.

Moho provides an option that allows you to control the children 
of a bone’s children, making it easier to work with 

bones on images and vector art. In other words, if you have a group 
inside a bone layer, and vector layers inside that group, the bone 
layer can warp the artwork in those vector layers if Allow nested 
layer control is turned on in the Bones tab of the Layer Properties 
palette and if the group layer is not bound. This allows more powerful 
bone rigging while also allowing you to organize your layers in a 
hierarchy. This allows you to have parent bones and “Grandpa” 
bones ... bones that affect more than one layer of bones beneath 
them.

 Bones Settings
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Chapter 13: Style Window
The Style window is where you set up colors, line widths, fill effects, and other 
properties to control the appearance of your vector artwork. The Style window has 
two views, Basic and Advanced.

The Advanced checkbox in the lower-left corner of the dialog will toggle the 
Styles palette between Basic and Advanced views. Check the option to display in 
Advanced view, and uncheck it to display in Basic view.

The options in the Style window are displayed and listed on the following page.

When you edit the fill color, stroke color, or brush settings, the changes will be 
displayed live on the canvas so that you can see the effects of your changes.

Style Window Options:

Red numbers in the image at the right indicate 
controls that are available in basic view. 
Blue numbers indicate controls that are only 
available in Advanced view.
1. Shape selection drop-down menu
2. Style management drop-down menu (Pro 

only)
3. Window mode indication
4. Name field
5. Fill enable checkbox
6. Fill color selector
7. Fill color override checkbox (Pro only)
8. Fill effect drop-down menus
9. Fill effect settings buttons
10. Stroke enable checkbox
11. Stroke color selector
12. Stroke brush selector
13. Stroke color override checkbox (Pro only)
14. Stroke width override checkbox (Pro only)
15. Stroke line width field
16. Stroke effect drop-down menu
17. Round end caps checkbox
18. Stroke effect settings button
19. Applied styles drop-down menus (Pro only)
20. 3D conversion thickness field
21. Color swatch drop-down menu
22. Color swatch
23. Copy button
24. Paste button
25. Reset button
26. Advanced window checkbox
27. Checker selection (Pro only)

 

Shapes
The Shapes controls appear only when the Style window is set to Advanced view. It 
consists of the controls mentioned below.
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Shape Selection Drop-Down Menu (1)
This menu appears in Advanced view only. You can use this menu to select any 
existing and named shape on the current vector layer. Select <None> to deselect all 
shapes.

 Shape Selection Drop-Down Menu

• Shapes: The fill and/or stroke that make vector construction visible when 
rendering/exporting. For example, if you use the Draw Shape (E) tool with 
the Auto-fill and Auto-stroke options unchecked, you will create a vector 
construction without any shape and it will not be visible when rendered/
exported. You can always use the Create Shape (U) tool to make a shape using 
this vector construction. Enabling either or both of these Auto options before 
using the Draw Shape tool will create a visible shape with the properties chosen.

Choose Edit >Preferences... and in the Option tab, you can 
select Auto-name new shapes so that all of your shapes 

have names when created. Refer to “General Tab” on page 435 
for more information.

Style Management Drop-Down Menu (2, Pro Only)
A style contains all of the properties which define how a shape should look. Use the 
Styles menu to create, delete, and edit your styles.

 Style Management Drop-Down Menu
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These are the options of this menu:

• New: This option allows you to create a new saved style.

• Delete: This option allows you to delete a selected style.

• Delete Unused: This option allows you to delete all styles that are not currently 
applied to any shapes.

• <None>: This option deselects all saved styles.

• List of style names: If you have created any saved styles there will be a list of 
their names. Selecting one of these will open that style for editing.

Style names are now referenced internally by a unique ID 
rather than by name. This allows you to have more than 

one style of the same name, and also prevents naming collisions 
when you import styles of the same name from another document.

Window Mode Indication (3)
This control is visible in Advanced view only. It indicates the current mode of the Style 
Window. There are three modes:

 Window Mode Indication

• DEFAULTS (For new shapes): In this mode the style you define will be applied to 
any new shapes you create. This default will retain the style of the last shape 
you had selected. This is the default mode when there are no shapes or styles 
selected.

• SHAPE: In this mode the style you define will edit the style of the currently 
selected shape. Selecting a shape in the workspace or in the shape selection 
drop-down menu will enter shape mode.

• STYLE: In this mode the style you define will either create a new style or edit an 
existing one, depending on the option you select from the style management 
drop-down menu.

Name Field (4)
This control is visible in Advanced View only. The name field allows you to name or 
rename any selected shape or style and displays any existing name. In Moho Pro, it is 
only active in SHAPE or STYLE mode.
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 Name Field

Fills
Two controls appear in the Fill section when in Basic view. Three additional controls 
appear in Advanced view. These controls are as follows:

Fill Enable Checkbox (5)
This checkbox determines whether a selected shape has a fill.

A fill is the color inside of a closed shape. This option is only available when you have 
an existing shape selected.

 Fill Enable Checkbox

Fill Color Selector (6)
This displays the fill color for the default style, the selected shape, or the selected 
style, depending on the style window mode. Clicking on it allows you to edit the 
color with the color picker, or by using the Eyedropper tool to pick a color.

 Fill Color Selector

The color picker allows you to select the color and transparency of the fill or stroke of 
your style. The large field to the left is where you can chose the color saturation and 
brightness. The vertical colored bar to the right of this is where you chose the color 
hue. The next, checkered bar is where you set the color alpha value (opacity). At 
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the top right are two color chips. The top one is the current color and the lower one 
is the previous color ( click to restore). Below these are manual inputs for the red, 
green, blue, and alpha values. And last is a hexadecimal field where you can copy 
or paste hex values to set the color.

 Color Picker

Fill Color Override Checkbox (7, Pro Only)
This option appears in Advanved view only. If checked, the color displayed in the fill 
color selector will override any other fill color in the style.

 Fill Color Override Checkbox

This works slightly different, depending on which mode the window is in:

• DEFAULTS and SHAPE: In these modes the override is only available if a saved 
style has been applied (see 19). Enabling this will override the applied style fill 
color with the current color in the fill color selector.

• STYLE: In this mode the override determines what properties are included in the 
saved style. There is an override for fill, stroke (see 12), and line width (see 14). 
You can create styles with any combination of these properties.

• When a style is applied any overrides checked in that saved style will override 
those properties in the shape or default.
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Fill Effect Drop-down Menu (8)
These drop-down menus in advanced view allow you to select two different fill 
effects. There are many effects to chose from:

 Fill Effect Drop-Down Menu

• <plain> indicates that no effect is applied in this drop-down.

This is followed by a list of fill effects. Some fill and line effects can be animated, with 
keyframes being added to the timeline when you change colors, blur radius, angles, 
offsets, blurs, and more.

 Expanded Menu (Moho Pro shown)

Selecting an effect will bring up an effect settings dialog, each of which are 
described in the sections that follow. Each effect has a variety of specific 
parameters for the user to adjust, as well as an effect preview that updates as 
changes are made to these settings.

You will only be able to view the results of some effects on your 
shapes by rendering a single frame (Cmd/Ctrl R) or 

exporting the animation (Cmd/Ctrl E).
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Many of the fill and stroke effects can be shown in the 
workspace, while others can only be seen once 

rendered. This can slow down performance, so it is disabled by 
default. To enable effects in the Moho Pro workspace, open the 
Display Quality settings drop-down at the bottom of the workspace 
and enable the Shape effects checkbox.

Shaded Fill Effects
When you choose Shaded Fill effects, a dialog displays the following options:

 Shaded Effect Options

• Light Angle: Provides a dial that allows you to change the direction that the light 
is coming from. You can also enter a numerical value. Zero degrees is located 
at the bottom of the dial.

• Offset: Allows you to assign a value for how far the shadow is offset from the 
filled area

• Blur: Controls the softness of the shadow.

• Shadow Color: Allows you to choose the shadow color from a color palette.

• Shadow Only: Check this option to only display the shadow, without the fill.

• Threshold: Works in conjunction with blur, and can be used to produce 
smoother transitions in corners. The more an object is blurred, the more the 
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threshold will have an effect. The blur is computed first, and then the threshold is 
added on top of it to smooth out the overall shape.

Soft Edge Fill Effects
When you choose Soft Edge Fill effects, a dialog displays the following options:

 Soft Edge Effect Options

• Blur Radius: Allows you to increase or decrease the softness, or blur, around the 
edge of the fill.

• Threshold: Works in conjunction with blur, and can be used to produce 
smoother transitions in corners. The more an object is blurred, the more the 
threshold will have an effect. The blur is computed first, and then the threshold is 
added on top of it to smooth out the overall shape.

Halo Fill Effects
When you choose Halo Fill effects, a dialog displays the following options:
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 Halo Effect Options

• Inset Radius: Adjusts the radius of the inner area

• Blur Radius: Adjusts the softness around the halo

• Halo Color: Click the Color chip to select a color for the halo.

• Halo Only: Check this option to only add the halo effect without the fill.

Gradient Fill Effects
Gradient fill effects can be animated and can also respond to bone warping. You 
can animate the location and color of all of the color markers in the gradient. All 
changes in color will show up in the timeline when added.

This is the dialog used to control the gradient effect. The following options appear:
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 Gradient Effect Options

• Type: Allows you to choose one of four types of gradient effects: Linear, Radial, 
Reflected, or Angle. The preview shows an example of each type.

• Allow transparency: Check this option if you want the gradient to appear 
partially or completely transparent in some areas.

• Color: Allows you to select a color and transparency for the selected gradient 
marker (below).

• Gradient bar: This bar shows the current gradient.

• Gradient markers: Below the gradient bar are initially three markers that 
define the start, middle, and end colors of the gradient. The middle color is the 
underlying color of the object. Double-click any of the markers to display or 
choose a color from the Color selector. These markers can be moved anywhere 
along the gradient bar.

• You can also add additional color markers to the gradient by clicking anywhere 
just below the gradient bar. You can copy an existing marker by holding the Alt 
key when you select a marker. You can then drag this copied marker to a new 
location on the gradient bar, or even click the color selector to change its color.

Image Texture Fill Effects
When you choose Image Texture Fill effects, a dialog displays the following options:
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 Image Texture Effect Options (Moho Pro shown)

• Select Texture: Click this button to choose an image file to be used as a texture 
fill.

• Tile: Choose this option if you want the image to repeat more than once to fill 
the selected area

• Don’t Repeat: Choose this option if you do not want to repeat image used for 
the fill. The image will be rescaled proportionally as needed to fit the width or 
height of the area that will be filled.

• Through Transparency (Pro only): Check this option to mask areas of an 
underlying shape with transparent areas in a texture fill.

When you apply a texture fill effect, you can select images that are partially 
transparent. After you select the image, the preview in the Texture dialog will 
apply the partially transparent image over the shape so that you can see the 
underlying color through the texture.

When the Through Transparency option is checked, you will see a change 
after you render a preview. The transparent areas in the texture will now be 
transparent through the entire shape. This causes the transparencies in the 
image to function similar to a mask.
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A shape filled with a partially transparent image.

Drop Shadow
The Drop Shadow feature allows you to quickly and easily create a drop shadow for 
your objects. The feature allows you to set the angle from which the light shines, how 
much the shadow is offset from the object, and the blur radius (or softness) of the 
shadow. In addition, you can set the color of the shadow through a color swatch.

When you choose a Drop Shadow, a dialog displays the following options:
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 Drop Shadow Effect Options

• Light Angle: Provides a dial that allows you to change the direction that the light 
is coming from. You can also enter a numerical value. Zero degrees is located 
at the bottom of the dial.

• Offset: Allows you to assign a value for how far the shadow is offset from the 
filled area

• Blur: Controls the softness of the shadow.

• Shadow Color: Allows you to choose the shadow color from a color palette.

• Threshold: Works in conjunction with blur, and can be used to produce 
smoother transitions in corners. The more an object is blurred, the more the 
threshold will have an effect. The blur is computed first, and then the threshold is 
added on top of it to smooth out the overall shape.

A preview of the settings appears in the preview window as you adjust them. 
When you are satisfied with the appearance of your shadow, click OK to apply the 
settings. You will need to preview the frame (Cmd/Ctrl R) or export the animation 
(Cmd/Ctrl E) to see the results.

Crayon (Pro Only)
The Crayon feature allows you to simulate the effect of something that is drawn 
with a crayon. The feature allows you to adjust the width and density of the crayon 
stroke. You can also use the crayon as an eraser.

When you choose the Crayon effect, a dialog displays the following options:
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 Crayon Effect Options

• Line Width: Allows you to increase or decrease the width of the crayon stroke.

• Density: Decrease the setting to give the crayon a more grainy appearance. 
Increase the setting to make the crayon more “solid.”

• Erase to Background: Check this option to erase underlying strokes with the 
crayon.

• Minimize frame-to-frame randomness: Check this option to keep the crayon 
effect from jittering during the animation.

A preview of the settings appears in the preview window as you adjust them. When 
you are satisfied with the effect preview, click OK to apply the settings.

Legacy Effects (Pro Only)
Legacy Effects (Moho Pro only). These are older effects that significantly slow down 
render speeds, do not respond to bone influence, and may have other limitations 
and drawbacks. You must decide for yourself whether these effects are worth the 
extra time to render an animation that makes use of them.

Splotchy (Pro Only)
This effect fills the selected area with a splotchy pattern. You can control the 
contrast, scale, and chromatics of the pattern fill.
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 Splotchy Options

• Magnitude: Allows you to adjust the contrast of the splotchy pattern.

• Scale: Adjusts the scale of the splotchy pattern.

• Monochrome: When this option is checked the splotchy pattern will only use 
shades of the fill color.
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Spots (Pro Only)

 Spots Options

• Spot length: This option determines the length of the spots.

• Spot width: This option determines the width of the spots.

• Length spacing: This option determines the space between the ends of the 
spots.

• Width spacing: This option determines the space between the sides of the spots.

• Angle: Provides a dial that allows you to change the direction of the spots. You 
can also enter a numerical value. Zero degrees is located at the right of the 
dial.

• Spot color: Allows you to choose the spot color from a color palette.

Fill Effect Settings Button (9)
Each of these buttons in advanced view become active when you have an effect 
selected in the effect drop-down menu next to it. These buttons allow you to access 
and edit the effect settings dialog of the selected effect.
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 Fill Effects Settings Button

Stroke
The Stroke area consists of six options in basic view, and two additional controls in 
Advanced view. They are described in the following sections.

Stroke Enable Checkbox (10)
This checkbox determines whether a selected shape has a stroke.

A stroke is the outline of a shape. Shapes can exist without a stroke or only 
composed of a stroke. This option is only available when you have an existing shape 
selected.

 Stroke Enable Checkbox

Stroke Color Selector (11)
This displays the stroke color for the default style, the selected shape, or the selected 
style, depending on the style window mode. Clicking on it brings up the color picker.

 Stroke Color Selector
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Stroke Brush Selector (12)
This displays the current brush used for the stroke of the default style, selected shape, 
or selected style.

If a brush style references a brush that is not found in the Style 
window, the Stroke Brush Selector will display Missing 

Brush instead of No Brush.

 Stroke Brush Selector

Clicking this box opens the Brush Settings dialog:

 Brush Settings Dialog (Moho Pro shown)
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• Brush selection menu: This displays all of the available brushes. You can click on 
one to select it for use or select None for no brush.

• Selected Brush: Displays a tooltip for the name of the currently selected brush, 
even if the image is not found.

• Align brush with curve: This option changes the orientation of the brush to the 
vector curve it is applied to.

• Brush jitter angle: This option determines how much the orientation angle varies, 
with zero being no variance.

 Brush jitter angle off (top) and on (bottom)

• Brush angle drift (Pro only): This setting works well with multibrushes that have 
some sort of obvious alignment. With brush angle drift on (see bottom stroke in 
the figure below), the alignment angles will vary depending on the drift angle 
value that you enter. Smaller values will produce less angle drift than larger 
values.
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 Brush angle drift off (top) and on (bottom)

• Brush spacing: This allows you to set the spacing between each instance of the 
brush. Improvements to brush spacing have been made so that brush spacing 
remains consistent whether the brush curve follows curve points that are either 
pointed or curved.

• Minimize frame-to-frame randomness: Check this option to keep the brush from 
jittering during the animation.

• Merge alpha (Pro only): With merged alpha turned on (see top stroke in 
following figure), an alpha value will be applied uniformly on strokes that were 
made with multibrushes. With merged alpha turned off (see bottom stroke in 
following figure), multibrush strokes are allowed to build up and the strokes 
appear more like natural media (as shown in the two strokes on the left in the 
following figure).
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 Merge alpha on (top) and off (bottom)

• Tint brush using stroke color: For brushes that are colored (not all black) this 
option allows the brush to take on the selected stroke color instead of the color 
displayed in the brush selection menu.

• Random Order: When checked, randomizes the order of the Multi-Brush shapes 
while the stroke is painted.

• Brush preview: This displays a preview of the chosen brush settings.

• Save Brush: Allows you to save a brush with the current settings. Click this button 
to enter a name for your new brush. The settings for the brush will be encoded 
onto the end of the name. You are also allowed to choose where the brushes 
are saved. Click Custom Content Folder to save the new brush in one of your 
user content folders. Click Choose Folder to save the new brush to another 
folder on your hard drive. 

New brushes will be saved with a .mohobrush extension. These 
brushes will be loaded first. Older brushes with the same 

name will not be loaded.
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The name that you assign to the brush must be a legal filename 
for your system. Underscore characters that appear in 

the base filename will be converted to dashes to preserve encoding 
requirements in Moho.

If you save a new brush into the Brushes folder in your User 
Content folder, they will not show up in the Brushes 

picker until you reload the brushes. You will be given the option to 
reload the brushes when you save the new brush to the User Content 
folder.

Using Multi-Brushes (Pro Only)
Moho Pro includes a feature called Multi-Brushes. If you go into the Brush Settings 
dialog you will notice several new brushes. Multi-brushes are indicated in the Brush 
Settings dialog with three dots in the upper left corner of the brush preview.

 Multi-Brushes are indicated with three dots in the upper left corner of the brush 
preview.

When you select a Multi-brush, the preview window at the bottom of the Brush 
palette displays a preview of the selected brush. You will notice that there are 
multiple images mixed into a single brush stroke.

 Multi-Brushes allow you to add multiple shapes in a single brush stroke.

Some Multi-Brushes mix different textures into a single stroke. The differences in 
texture may appear to be more subtle in the preview window, but the variations will 
be more obvious after you render a preview.
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 Subtle Multi-Brush differences will be more clear after rendering (as seen in the 
bottom)

Creating Multi-Brushes (Pro Only)
It is very easy to create your own Multi-Brushes. First, locate your User Content folder. 
If you did not create a User Content folder when you first ran Moho (as described 
in “Creating a Content Folder” on page 16) you can specify a custom content 
location in the General tab of the Preferences dialog.

Your Custom Content folder includes a brushes category folder within it. Beneath this 
brushes folder, create a new folder that has the same name as the Multi-Brush that 
you want to create.

The following naming convention can be used to save settings that apply to the 
brush. The foldername can contain six numbers, separated by underscores as 
follows:
Brushname_#_###_###_#_#_#

The numbers represent the following brush settings:

• First number: Align brush with curve off (0) or on (1).

• Second number: Represents the Brush Jitter angle.

• Third number: Represents the Brush Spacing setting.

• Fourth number: Minimize Frame to Frame Randomness off (0) or on (1).

• Fifth number: Tint Brush Using Stroke Color off (0) or on (1).
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• Sixth number: Random Order off (0) or on (1).

After you create the folder, place PNG files, with transparent backgrounds, for 
each shape that you want the Multi-Brush to paint. The following figure shows three 
different flower shapes added to the Flowers 1 Multi-Brush folder.

 Create a Multi-Brush folder in your custom content folder, within the brushes category 
folder, and place PNG files into the new folder.

The next time you start Moho, you will find the new Multi-Brush added to the Brush 
palette. It will appear last in the list. You can further adjust the brush settings as 
indicated previously in “Stroke Brush Selector (12)” on page 273.

 Stroke Line Width Field
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Stroke Override Checkbox (13, Pro Only)
If checked in advanced view, the color displayed in the stroke color selector will 
override any other stroke color in the style.

 Stroke Override Checkbox

This works slightly different, depending on which mode the window is in:

DEFAULTS and SHAPE: In these modes the override is only available if a saved style 
has been applied (see 19). Enabling this will override the applied style stroke color 
with the current color in the stroke color selector.

STYLE: In this mode the override determines what properties are included in the 
saved style. There is an override for fill, stroke, and line width (see 14). You can create 
styles with any combination of these properties.

When a style is applied any overrides checked in that saved style will override those 
properties in the shape or default.

Stroke Width Override Checkbox (14, Pro Only)
If checked in advanced view, the width displayed in the line width field will override 
any other line width in the style.

 Stroke Width Override Checkbox

This works slightly different, depending on which mode the window is in:

• DEFAULTS and SHAPE: In these modes the override is only available if a saved 
style has been applied (see 19). Enabling this will override the applied style line 
width with the current width in the line width field.

• STYLE: In this mode the override determines what properties are included in the 
saved style. There is an override for fill, stroke, and line width. You can create 
styles with any combination of these properties.

• When a style is applied any overrides checked in that style will override those 
properties in the shape or default.
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Stroke Line Width Field (15)
This field allows you to set the stroke line width of the default style, selected shape, or 
selected style. The minimum line width is .25. After clicking in this field you can either 
type in or use the mouse wheel to adjust the value.

 Stroke Line Width Field

Stroke Effect Drop-down Menu (16)
This drop-down menus allow you to select a stroke effect. There are many effects to 
chose from. The stroke effects are the same as the fill effects described earlier.

 Stroke Effect Drop-Down Menu

There are two more stroke Legacy Effects in Moho Pro:
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Sketchy

 Sketchy Effect Options

• Radius: Adjust the radius of the effect.

Angled Pen

 Angled Pen Effect Options

• Radius: Adjust the radius of the effect.
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• Angle: Provides a dial that allows you to change the direction of the angled 
pen. You can also enter a numerical value. Zero degrees is located at the right 
of the dial.

Round End Caps Checkbox (17)
You’ll notice the addition of a Round Caps option in the Stroke section of the 
Advanced Style window. Check this option if you want to use strokes that have 
rounded ends. Uncheck the option to use flat ends on your strokes (similar to those 
used in Anime Studio 7 and earlier).

 Rounded End Caps Checkbox

Older files will open with plain end caps to retain their original appearance. New 
artwork will default to round end caps unless the Round Caps option is unchecked.

 Rounded end caps compared to ends that are not rounded.

Stroke Effect Settings Button (18)
This button becomes active when you have an effect selected in the effect drop-
down menu next to it. This button allows you to access and edit the effect settings 
dialog of the selected effect.



Moho 13.5
Users Manual 

284

Chapter 13: Style Window

 Stroke Effect Settings Button

Applied Styles
Two options appear in the Applied Styles area for Moho Pro only.

Applied Styles Drop-Down Menus (19, Pro Only)
These drop-down menus, which appear in advanced view, allow you to apply two 
different saved styles.

Applied Styles Drop-Down Menus

A saved style is a set of information used by a shape (color, line width, line brush, 
effects, etc.), but it doesn’t actually appear on its own in your animation. Instead, 
after creating a style, you can apply that saved style to one or more shapes. For 
example, you might create a “Skin” style, and apply it to all the body parts of a 
character. Later, if you want to change the color of the character, just modify the 
Skin style, and any shapes that use that style will change instantly. Use the Style 
management drop-down menu to create new styles and to select a style for editing.

You can select any saved style you have created to apply to the default style or the 
selected shape. Select <None> to clear the applied style.



Moho 13.5
Users Manual 

285

Chapter 13: Style Window

 Expanded Menu

You can define global shading, line width, etc. to maintain a consistent look 
throughout your project.

3D Conversion Thickness Field (20)
This option (20) is only available for the default style or selected shapes on vector 
layers that are using either the Extrude or Inflate options of the vector layer Layer 
Settings > 3D Options tab > 3D Conversion drop-down. This field displays the 3D 
thickness of the default style or selected shape. After clicking this field, you can type 
in or use the mouse wheel to adjust this value.

These swatches appear in the Color Swatch (10) below.

 3D Conversion Thickness Field

Swatches
Color Swatch Drop-down Menu (21)
This menu allows you to select from a variety of color swatches or select a Custom 
Image as a swatch.
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 Swatches menu

 Expanded menu

These swatches appear in the Color Swatch (22) below.

Color Swatch (22)
The swatch you select from the color swatch drop-down menu shows up here as 
a simple color picker. You can use this as a shortcut for selecting colors for your 
objects. Just click a color in this palette to assign it as the selected shape’s fill color. 
Right-click a color swatch to assign it as the selected shape’s outline color.

Use the following shortcuts for selecting colors from the Color Swatch palette:

• Click a color swatch to assign a fill color.
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• Ctrl-click or right-click a color swatch to assign a stroke color.

• Alt-click a color swatch to assign a point color (see “Color Points” on page 80 
for more information about the Color Points tool).

 Color Swatch

Copy, Paste, and Reset Buttons
There are three buttons that we’ve classified as “other” controls:

 Copy, Paste, and Reset buttons

• Press Copy (23) to copy the properties of the selected shape or style.

• Press Paste (24) to apply a previously copied set of properties to another shape 
or style.

• Press Reset(25) to switch back to editing the default fill and line properties - if a 
shape or style is currently selected, it will be de-selected.

Advanced Window Checkbox (26)
As mentioned at the beginning of this chapter, this checkbox switches the style 
window between Basic and Advanced views. The basic view minimizes the style 
window to some of the options most used while animating.
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 Advanced Window Checkbox

Checker Selection (27, Pro Only)
When the Checker Selection option is unchecked, a bounding box will be shown 
around the selected shape rather than displaying the object with a checkerboard 
pattern. This allows you to see the colors and outlines of the selected shape more 
clearly.

 Checker Selection Checkbox
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Chapter 14: The Library 
Window

If the Library Window is not open, select Window > Library or use the keyboard 
shortcut Command/Ctrl Shift L.

The Moho Library window provides access to all of the content that ships with 
Moho such as characters, props, images, audio, etc. The Library tab consists of the 
following main areas:

 The Moho Library window
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1. Library Tabs: Allows you to display items in the content library, or items in your 
current project. For more information see “Library Tabs” on page 290.

2. Library Folder List: Displays a list of the top-level library folders. For more 
information see “Using the Location Menu (Pro only)” on page 291.

3. Library Search: Allows you to perform library searches based on different criteria. 
For more information see “Searching the Library” on page 293.

4. Item List: Displays subfolders and content thumbnails of the content in your 
library. For more information see “Using the Library List” on page 296.

5. Thumbnail Slider: For more information see “Using the Library List” on page 296.

6. Details panel: For more information see “Details Panel” on page 302.

7. Library icons: For more information see “Library Icons” on page 301.

8. Actions selector: Click the Actions button to choose a command that is 
applicable to the content that is selected. Commands available here are also 
available if you right-click a content item to choose a command from the 
context menu..

Library Tabs
The library consists of two main tabs: 

 The Moho Library window

• Library Assets: This tab displays several different types of content.

 � Factory content that is furnished with Moho. Factory content is treated 
as read-only. You can’t edit it directly but you can add it to your opened 
projects as noted later in this chapter.

You can disable display of factory content in the library, if 
desired. Open the Preferences dialog to the General 

tab, and uncheck the Include factory content in the Library option. 
This option is checked by default.

 � Content that you have saved in your User Content folder.

 � Files that exist in external folders that you specify. You add these folders 
from the Location list, as described in “Adding Custom Locations (Pro 
only)” on page 292.
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• Open Document Assets: This tab displays assets that appear in documents 
that you currently have opened in Moho. The assets will appear in this tab 
automatically as you add images, video, audio, and other external assets to 
your open documents.

The Open Documents tab makes it easy to share media assets 
between projects. With two or more projects open in 

Moho, select the project that you want to add content to. Next, go 
to the Open Document Assets tab and click to highlight the media 
item that you want to add to the current project. Right-click the item 
in the library list and choose Add to the Current Document.

 The Open Documents Assets tab lists media files that are used in all open documents.

Using the Location Menu (Pro only)
The Location menu displays the names of the folders that make up your library 
assets:

• Click the Location list (1) to display a context menu.

• The context menu (2) allows you to add or remove custom  folders, or to go 
back to specific folders that appear in the list.

• Use the Go Back and Go Forward buttons (3) to navigate through your library 
history, which keeps track of the folders that you have viewed. Click and hold 
on these buttons to display a list of folders that you can go to.
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 The Location List

Adding Custom Locations (Pro only)
You can add your own custom folders on disk to the Library. When you add custom 
folders they will be added to the Location list in the Library Assets tab, and treated 
as a Library folder. Library data folders will be created as needed in all levels of the 
folders that you add. Additional thumbnail and metadata files may also be written. 

When you add a folder you will be asked to set a unique identifier, or root location, 
for the path. This identifier will be used to facilitate relative path support. 

If another user creates a unique identifier that has the same name as yours, the 
folders beneath it will be treated as relative paths. While the physical/absolute paths 
may be different on each machine, the relative paths will be resolved based on the 
unique path that is the same on both machines. As long as both people place the 
files in the same location relative to the root location, your libraries will be able to 
find the same content.

You can rename non-factory items in custom folder by clicking the name of the 
item. 

To add your own folders to the library, follow these steps:

1. Click the Location list to expand the menu, and choose Add Custom Location.

 Adding a custom location

2. Use the Browse for Folder dialog to locate the folder that you want to add to 
the library.

3. Click OK. You will be prompted to enter a unique name that identifies this 
location. The name will be associated with the folder and will be used for 
relative path resolution. 

4. Click OK to assign the name to your library folder. The new Library folder 
appears in the tree.
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Removing Custom Locations
To remove custom library folders:

1. Select the folder that you want to remove in the Library tree.

2. Click the Location list to expand the menu, and choose Remove Selected 
Custom Location.

3. Moho will ask you to confirm that you want to remove the custom library folder. 
Click Remove to complete removal, or Cancel to leave the custom folder in the 
library.

Searching the Library
In order to perform Library searches, Moho must index your content first. Indexing is 
performed the first time you open the library, when Moho begins indexing content. 
Generally, indexing is performed fast, but indexing can take more time if you have 
a particularly large amount of content. Indexing is also performed when you add 
new content to the library, or when you click the Refresh icon to manually refresh a 
folder.

 Click the Refresh button to manually refresh the contents of a folder.

The Search section of the library allows you to perform searches on the assets in your 
library. The search is based on the text that you enter in the search field. Simply enter 
text and press the Search button to search for content that contains that string.

After the content is indexed, you will be able to perform searches to find specific 
content. If any item contains the search term value in the search type that you 
select, results will be returned in the search. Up to 500 items will be returned at a 
time. If additional results are available, the Search button will say Continue, and 
a Click to find more matches message will appear. Each time you click Continue, 
another 500 results will be returned until no additional results are available.

All search terms must match for an item to be returned, unless you use OR or NOT 
options:

• OR: Use the | operator to perform an OR search. In other words if you enter 
phone|money, the search will return items that contain phone OR money.
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 Use the | character as an OR operator for your search.

• NOT: If a search term is preceded by a - (minus sign) or a ~ (tilde), the search will 
only return items that do not contain that search term. NOT operators only apply 
to a single item.

 � beach~chair will be evaluated as a string that must be matched in its 
entirety.

 � beach,~chair will return items that contain the word beach, but do not 
contain the word chair.

 � beach|bum,~chair will return items that contain either beach or bum, but 
do not contain chair.

When using the OR or NOT operator, spaces will automatically 
be trimmed out before and after the operator 

character. In other words, you can enter either cat|dog or cat | dog 
and the extra spaces before and after the | in the latter example 
will be trimmed off before the search is performed.

The Location popup will display an item to show Search Results. These results will 
remain in the item list until you navigate to a regular library location. You can use the 
Location popup window or the Back button to discard the search results and return 
to the main library window.
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 Use the Location popup or the Back navigation button to return to the main library 
window and clear the search results.

Metadata Searches (Pro Only)
In Moho Pro, the type of search that you perform is selected in the popup menu that 
appears to the left of the search entry field. The Moho library allows you to search 
for various types of metadata, including: Name, Framerate, Tags, Comments, Type, 
Title, Creator, Contributor, Rights, Rights Holder, Created, Has Version, Audience, 
Instructional Method, Subject, and Requires.

 Various types of metadata can be searched in Moho Pro.

You can add metadata to any non-factory content that you 
add to your library in the Details section of the Library 

palette, See “Details Panel” on page 302 for more information.

• If the search option is set to Tags, you can enter multiple tags in a comma-
separated list. For example, you can enter woman,astronaut,space, and the 
search will return tag matches that contain woman, and matches that contain 
astronaut, and matches that contain space.
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The Tags search option is the only one that supports a comma-
separated list.

If the metadata itself contains commas, the metadata will be 
treated as separate search items separated by those 

commas. Each term must match in order for the search to identify a 
match.

Maintaining Your Library
Using the Library List
The library list displays the content in your library in a hierarchical manner. Content 
is organized in folders and subfolders. Each item in the library is displayed in the tree 
with the name of the content, a thumbnail image, the kind of content, and the date 
that the content was last modified.

• To display contents in a folder, double-click the folder that you want to view.

• Right-click an item that is displayed in the library to display a contextual menu 
that pertains to that type of content. These menus are further described in 
“Factory Content Options” on page 298 and “Non-Factory Content Options” 
on page 299.

• To delete a non-factory item from the library and move it to the Trash (Mac) or 
Recycle Bin (Windows), select the item you want to delete and click the Trash 
icon in the lower left corner of the Library window.
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 Use the Location popup or the Back navigation button to return to the main library 
window and clear the search results.

• Click a column header in the tree (1) to sort content by name, kind, or date 
modified. A small up or down arrow appears at the right side of each column 
header to indicate whether the column is sorted in forward or reverse order.

• Use the arrows (2) that appear at the left of a folder to display or hide the 
contents in that folder.

• Double-click a folder to go to that folder in the tree list. The currently selected 
folder will be highlighted (3).

• The thumbnail slider (4) is always visible. You can increase or decrease the size 
of the thumbnails as needed to preview items before you add them to your 
project.
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Factory Content Options
Factory content is read-only in the Moho library. When you right-click factory 
content items, you get a context menu that includes the following options, 
depending on the type of content that you select. Similar contextual menus appear 
for items in the search list.

 Right-click a content item in the list to display a context menu. (Pro shown)

The following actions apply to factory content items:

• Add To The Current Document: When you select this option, the Insert Option 
dialog opens so that you can select items from a Moho project. If there are no 
opened documents this command will be unavailable. This option also appears 
when you right-click image, video, and audio files.

You can also drag and drop one or more items from the Library 
into your opened document.

• Open Project as Template: Opens the selected Moho project file in a new 
untitled document window. 

• Add to Exporter (Pro Only): Opens the Moho Exporter window and adds the 
selected Moho project to the export list.

Actions also appear in the Actions selector at the bottom of the library palette. 
Highlight the item that you want to view or use, and click the Actions selector to 
display available actions for that content item.

 Expand the Actions selector at the bottom of the library to choose an action for 
selected content.

In addition to the context menus described previously, you can double-click content 
to add it to your project. For example: 
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• Moho projects: Double-click to open the Insert Object dialog, which allows you 
to check objects in the project file and add them to your project.

• Moho Styles: Double-click to add the style(s) to the Styles popup in the Style 
palette.

• Image and Movie Files: Double-click the library item to add the image to your 
project at the current position in the timeline.

• Audio files: Click on the library item to preview the sound. Double-click to add it 
to your project at the current position in the timeline.

Non-Factory Content Options
Moho provides several other options when you browse non-factory content in the 
Library. These items allow you to open and locate projects, and import or export 
content from and to the library.

In addition to the options that are available for factory content (as indicated 
above), you may see the following additional options when you right-click a 
non-factory content item, depending on the type of content you choose. These 
additional options are available for Moho project files that are located in your user 
or custom content folders:

 Several additional options appear for non-factory content.

• Open Project: Opens the project in a new document window.

• Show in Explorer/Finder: Opens Windows Explorer or Mac Finder to the physical 
location that stores the selected library item.

• Set Thumbnail Image: Allows you to choose a thumbnail image for the selected 
library item. The thumbnail image that you select will be copied into a folder 
named _LibraryData, which will be placed in the same folder that contains the 
library item. If multiple items are selected, the action will only be applied to the 
last item selected.

• Duplicate: Creates a duplicate copy of the item that you right-click. The 
duplicate will be named the same as the item that you duplicated, but will 
initially be appended with the word Copy.
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• Import Selected Layers: Select one or more layers in your current scene. Then 
right-click one of the folders in your user or content folder in the Library. Choose 
Import Selected Layers to import the selected layers into the library.

When you add layers, documents, styles, or other content to 
the library, Moho will notice that the contents of the 

library have changed, and will automatically refresh the folder after 
a slight delay.

• Import Current Document: Imports a complete Moho document into your user 
or custom content Library folder. Select a non-factory folder and choose Import 
Current Document. You will not be prompted to select layers in the project file 
with this option. All media will be gathered with the project during import. You 
can import complete documents into the library.

• Import Styles: If your current document contains styles, you can easily add 
them to the library. First, select the document that contains the styles you want 
to import. If you want to import styles from one or more specific layers in that 
document, select only the layers that contain the styles.  Next, go to the Library 
window and select the user or custom content library folder that you want 
to save the styles to. Right-click the folder and choose Import Styles from the 
context menu. A dialog prompts you to enter a name for the styles document. 
By default, all styles from the current project will be imported. To only import 
styles from selected layers, uncheck the Export all styles from the current project 
option.

 You can import all styles from the current document, or styles from selected layers in 
that document.

• Import Selected Actions: If your project contains actions, you can save selected 
actions from that project into the Library. Open the Actions window and choose 
the actions that you want to import. Switch to the Library and select the user 
or custom content folder that you want to save the actions into. Right-click the 
folder and choose Import Selected Actions. The actions will be saved into the 
selected folder, and will use a .mohoaction extension.
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 Adding selected actions to the library.

• Add New Folder: Select this option to add a new folder to your user or custom 
content library. The new folder will be created as a subfolder to your initial folder 
selection. A dialog prompts you to enter a name for the new folder. After you 
enter the name, click OK to create the new folder.

Library Icons
Four icons appear in the lower left hand corner of the Library window. These icons 
allow you to add or remove content from your Content Folder Library, or from 
custom library folders that you added.

From left to right, these icons are:

• Import selected layers from the current document: After you select layers 
from the current document, switch to the Library and select the user 

or custom content folder that you want to save the layers into. Then click the 
Import Selected Layers icon. 

In Moho Pro, after you add the layers you can add metadata 
that will help you retrieve them in your library searches, 

as described in “Details Panel” on page 302.

When you save layers to the Library, media assets that already 
exist in the library will not be gathered together and 

saved to the library again. It will also exclude gathering of child 
folders that reside in shared resource folders. 

• Add the selected library item to the current document: Click to highlight 
the library item or items that you want to add to your current 

document. Then click the Add the Selected Library Item button to add the items 
to your current document. The items will be added immediately above the layer 
that was selected in the Layers Window.
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• Add new folder: Allows you to add a new folder to your user or custom 
content Library. Select the folder beneath which you want to create a 

subfolder. Then click the Add new folder icon. 

• Move to Recycle Bin/Trash: After you select one or more items or folders in 
your user or custom content location, click the Trashcan icon to move 

the selected items to the Windows Recycle Bin or Mac Trash.

Converting Legacy Documents to the New Format
When you select a legacy Anime Studio document from the Library, you will be 
given an option to convert it to the new file format. This includes files with the .anme, 
.ming, and .scattershow extensions. 

There is no option to convert old .moho documents to the new 
.moho format, or to convert .anime or .animeproj 

documents to .moho or .mohoproj. 

Details Panel
The Details Panel displays a larger thumbnail of the selected item, along with details 
such as file name, size, kind, creation date, modified date, and file size. Use the 
scrollbar to display additional information (if available). 

Adding Metadata (Pro Only)
You can add metadata information to any non-factory item in your library. When 
you select an item in the library, you will notice that the bottom portion of the library 
displays details about the content item. If you use the scrollbar at the right side of the 
detail panel, you will notice a series of text entry fields where you can add or edit the 
metadata for the items in your user or custom content folders. These text fields will 
not be enabled for factory content items.

These fields allow you to add metadata for tags (Pro only), comments (Pro only), 
type, title, creator, contributor, rights, rights holder, created, has version, audience, 
instructional method, subject, and requires. You can enter any text that you wish in 
these fields. The Tags field in Moho Pro is the only field that will allow items that are 
separated by commas to be treated as individual entries. You can later use the 
dropdown menu in the Search area of the library to search through the library for 
content that matches the specific types of metadata that you search for.

When you add metadata to a content item, Moho will save an XMP file and 
thumbnail image with the library item. The XMP file and thumbnail will automatically 
be renamed whenever you rename the associated project file. In addition, XMP 
and thumbnail files will also be duplicated when their associated project file is 
duplicated.
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 Use text entry fields in the Details panel to add metadata for your custom content.
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Chapter 15: The Character 
Wizard

The Character Wizard allows you to quickly and easily create characters that you 
can animate in Moho. It consists of several different tabs that allow you to specify 
body proportions, facial features, movement, clothing and other styling features.

Using the Character Wizard
You can open the Character Wizard by clicking the Character Wizard button that is 
located in the upper right corner of the Moho interface. It appears just to the left of 
the Library button.

The Character Wizard consists of a number of different tabs that help you design 
your own character. There are also a few controls that appear from one tab to the 
next.

 Click the Character Wizard button to open the Character Wizard

 The Character Wizard window



Moho 13.5
Users Manual 

305

Chapter 15: The Character Wizard

Presets
The Presets drop-Down allows you to choose from a number of different character 
types: Boy Spiky, Creature, and Mannequin. Each of these different humanoid 
character types has a different appearance to start with, varying in proportion, 
body shape, head shape, and so on. Some presets are more “human” while other 
are more fantasy-like. You can use the other tabs to customize the appearance of 
the Preset even further.

Use the + button beside the Preset drop-Down to create your own preset, or the - 
button to delete a preset that you have previously saved yourself. Built-in presets 
cannot be deleted.

The preset will be saved at its current state. If you go back and 
later change the character’s appearance (such as 

changing features or colors), the saved preset does not 
automatically update to reflect those changes. You can resave the 
character under its original name to overwrite the old one, or save a 
new preset under a different name.

 Presets available in the Character Wizard

Changing the Character Views
On the right side of the Character Wizard, you will see a preview of the current 
character. Beneath the preview is a slider, that allows you to view your character 
in one of eight angles. Move the slider to the right or left to change the perspective 
view of the character. The first bar displays the character in its front view. As you 
move the slider toward the right, the view changes to reflect 1/8 of a circle (as if the 
character has turned 45 degrees).
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 Changing character views
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 Different character views

Exporting Views
After you complete your character in wizard, either with a preset or by customizing 
in the other tabs (described in the sections that follow) you can click OK to exit the 
character wizard and view the character in your Moho project.

Before clicking the OK button, you should check the status of the Export All Views 
option beneath the view slider. With this option checked, five views of the character 
will be exported to your Moho project (Front, Front 3/4, Back, Back 3/4, and Side). 
With the option unchecked, only the currently selected view will appear in your 
project.

If any of the parts used in the character have pre-animated 
movement (such as eyes that blink), the movement will 

also be added to your character. The animation will show on the 
Movement tab in the Character Wizard, and will be added as 
Actions in your Moho Pro project.

Randomizing Characters
The lower-right corner of the Character Wizard contains a Randomize button. When 
you click this button, the Character Wizard combines settings from the different tabs 
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to create a totally unique character. This is a quick and easy way to generate a 
customized character or preset as a starting point that you can later modify yourself.

 Some random characters

Body Tab
The Body tab allows you to adjust the proportions of the various parts of the 
character’s body. Move the sliders left or right to adjust the proportions as described 
in the following sections. The preview window will update the character in real time 
while you make your adjustments.

 Character wizard Body tab
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Proportions
• Height: Move the slider toward the left to make the character shorter, or toward 

the right to make the character taller.

• Torso height: Move the slider toward the left to decrease the height of the area 
between the shoulders and hip, or toward the right to increase the height of this 
area.

• Leg length: Move the slider toward the left to shorten the legs, or toward the 
right to lengthen them. The feet will remain stationary on the ground.

• Head height: Move the slider toward the left to make the head smaller, or 
toward the right to make the head larger. The height of the character will 
remain the same.

• Belly width: Move the slider toward the left to decrease the width of the waist, 
or toward the right to increase it.

 Proportion options

Legs
• Hip width: Move the slider toward the left to decrease the width of the hip, 

bringing the legs closer together. Move the slider toward the right to increase 
the width of the hip, creating more space between the legs.

• Leg width: Move the slider toward the left to make the legs and hip thinner, and 
toward the right to make the legs and hip wider.

• Leg muscles: Move the slider toward the left to make the legs appear less 
muscular (and more bony). Move the slider toward the right to add more 
muscle to the legs.

• Foot length: Move the slider toward the left to decrease the size of the feet, or 
toward the right to increase the size of the feet.
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• Feet: Use the Feet drop-Down menu to select the appearance of the feet. 
Choose Generic to create a simple representation of a bare foot with no toes. 
Other choices include Anime Boy Sneakers, Bare (with toes), Bowling Shoes, 
Female Sandals, Male Sandals, Reference, and Simple.

 Leg options

Arms
• Arm length: Move the slider toward the left to shorten the arms from the 

shoulder, and toward the right to lengthen them.

• Shoulder width: Move the slider toward the left to decrease the width of the 
shoulder (bringing the arms closer toward the body), or toward the right to 
increase the width of the shoulder (moving the arms away from the body).

• Arm width: Move the slider toward the left to decrease the size of the arms 
(making them thinner), or toward the right to increase the size of the arms 
(making them fatter).

• Arm muscles: Move the slider toward the left to make the arms less muscular 
and bony, or toward the right to make them more muscular.

• Hand length: Move the slider toward the left to decrease the size of the hands, 
and toward the right to increase the size of the hands.

• Hands: Use the Hands drop-Down menu to select a style of hands for the 
character. Choose Generic to create generic hands that have no fingers. Other 
choices include Anime Boy Mittens, Female Red Nails, Long Fingers, Simple, 
Square, and Toon.
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 Arm options

Face Tab
The Face Tab of the Character Wizard allows you to select and adjust the facial 
features, including the head, eyes, mouth, and nose. Included at the bottom of the 
various categories are the following sliders:

• Horizontal adjustment: Move the slider left or right to position the facial features, 
if necessary after you adjust the head proportions. For example, you can move 
the eyes, nose, and mouth closer to the face if they appear to be detached 
from the face. The adjustment slider will be disabled in the Front and Back views 
where it does not apply.

• Vertical adjustment: Move the slider left or right to adjust the height of the facial 
features, if necessary after you adjust the head proportions. For example, in 
some cases, the profile of the lips will not match up with the line of the mouth 
and this control can match it more closely.
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 Character wizard Face tab (Moho Pro shown)

Head
• Head selector: Click the Head drop-Down list to choose from a number of 

preset character heads. Styles range from human to fantasy and more. Some 
characters have hair or hats, while others are bald.

• Neck width: When you are working with a head where the size of the neck can 
be adjusted, this dial allows you to increase or decrease the width of the neck. 
The option will be disabled when the character does not have a resizeable 
neck.

• Head top: (enabled for Generic head only) Move the slider toward the left to 
decrease the width of the crown, or toward the right to increase the width.

• Head middle: (enabled for Generic head only) Move the slider toward the left 
to decrease the width of the middle head, or toward the right to increase the 
width.

• Head bottom: (enabled for Generic head only) Move the slider toward the left 
to decrease the width of the lower head, or toward the right to increase the 
width.
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 Head options

Eyes
• Eye selector: Use the Eyes drop-Down list to select one of several different eye 

shapes.

• Size: Move the slider toward the left to decrease the size of the eyes, or toward 
the right to increase the size of the eyes. The size will increase or decrease from 
the center point of each eye.

• Height: Move the slider toward the left to lower the eyes, or toward the right to 
raise the eyes.

• Spacing: Move the slider toward the left to bring the eyes closer, or toward the 
right to move the eyes farther apart.

 Eyes options

Mouth
• Mouth selector: Use the Mouth drop-Down list to select one of several different 

mouth shapes.
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• Size: Move the slider toward the left to decrease the size of the mouth, or 
toward the right to increase the size of the mouth.

• Height: Move the slider toward the left to lower the mouth, or toward the right to 
raise the mouth.

 Mouth options

Nose
• Nose selector: Use the Nose drop-Down list to select one of several different 

nose shapes.

• Size: Move the slider toward the left to decrease the size of the nose, or toward 
the right to increase the size of the nose.

• Height: Move the slider toward the left to lower the nose, or toward the right to 
raise the nose.

 Nose options

Head Prop
Head props are only enabled when the Creature is selected as a character preset.

• Prop: Use the Prop drop-Down list to select one of several different head props, 
such as hats, beards, curls, and other facial and head features.

• Size: Move the slider toward the left to decrease the size of the head prop, or 
toward the right to increase its size.
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• Height: Move the slider toward the left to lower the head prop, or toward the 
right to raise it.

 Head Prop options

Movement Tab
The Movement tab in the Character Wizard allows you to generate a walk cycle 
for your character, very quickly and easily, through the use of sliders. As you design 
the walk cycle, it will be applied to all of the character views (front, back, sides, and 
quarter-views).

In Moho Pro, the character is not automatically animated by default. When you add 
a character to the scene, the actions will also appear in the Actions palette so that 
you can manually add actions in the timeline where you want them to occur. For 
example, you can apply a walk at frame 1, and then add a jump action at frame 
100 and a wave action at frame 120.

When you export a single view of your character, it will appear 
as a bone group inside your Moho scene. When 

multiple views of the character are exported to your Moho Pro 
scene, the character will appear as a Switch Layer. Beneath that 
switch layer, you will see a bone group for each of the character 
views (front, back, and so on).

You will not initially see the actions appear in the Moho Pro 
timeline because the bone groups and layers are 

contained within a switch layer. The actions that you use in your 
animation will be applied to the currently selected view (active 
switch layer) of the character. To view the actions in the timeline, 
select one of the bone groups beneath the main switch layer.

The Walk cycle is a computer generated action. The others (Jump, Kick, and Wave) 
are custom actions that were created in Moho Pro. These actions can be applied to 
any character.
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 Character wizard Movement tab (Moho Pro shown)

The following options appear:

• Actions (Pro Only): Use the Actions drop-Down list to select the type of action 
that you want to use or preview.

 Actions options

• Insert Walk Action (Debut Only): When you check this option, your character will 
be exported with movements. If you later decide that you aren’t happy with the 
movement, you will need to delete the keyframes associated with it. With the 
option unchecked, keyframes for movement will not be exported.

• Steps per second: Move the slider toward the left to make your character walk 
more slowly, and toward the right to make it walk faster.

• Step distance: Move the slider toward the left to make your character take 
shorter steps, and toward the right to make your character take longer steps.
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• Step height: Move the slider toward the left to keep the steps closer to the 
ground (less knee bend); and toward the right to raise the feet more from the 
ground (more knee bend).

• Arm swing: Move the slider toward the left to decrease the arm swing (making it 
stiffer), and toward the right to increase the arm swing (making it looser).

• Torso bend: Move the slider toward the left to add less bend to the torso 
(making the posture straighter). Move the slider toward the right to add more 
bend (adding more bounce to the walk).

 Other settings options

Clothing Tab
The Clothing Tab allows you to change the style and colors of the pants and shirt 
that the character wears. There are two sections available in this tab.
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 Character wizard Clothing tab

Pants
• Type selector: Choose whether you want your character to wear short or long 

pants.

• Color: Click the color chip to open the color palette, where you can select a 
new color for the pants.

 Other settings options

Shirt
• Type selector: Choose whether you want your character to wear a short-

sleeved shirt or a long-sleeved shirt.
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• Color: Click the color ship to open the color palette, where you can select a 
new color for the shirt.

 Other settings options

Style Tab
The Style tab allows you to change the skin color, hair color, and stroke color and 
width for your character.

 Character wizard Style tab

The settings you select here are as follows:
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 Other settings options

• Skin color: Click the color chip to open the color palette, where you can select 
a new color for the skin.

When you create body parts for the character wizard in Moho 
Pro, special colors MUST be used for the skin and hair. 

Use Yellow (R 255, G 255, B 0) for any body part that you want to 
identify as skin color, and Cyan (R 0, G 255, B 255) for any part that 
you want to identify as hair. Any parts that use these colors will inherit 
the skin or hair colors that you identify in the Character wizard.

• Hair color: Click the color chip to open the color palette, and select a new 
color for the hair.

• Stroke color: Click the color ship to open the color palette, and select a new 
color for the character outlines.

• Stroke width: Sets the stroke width size to use as the default.

If you have a mouse with a scroll wheel, you can increase or 
decrease this value while watching the character 

update in the preview window

• Set as default: Click this button after you change the value in the Stroke Width 
field.

• Randomize line width: With this setting on, the line width will vary slightly across 
the character. With the setting off, the line width will be uniform.

• Scale compensation: When checked, the stroke width will be proportionally 
adjusted as the character is resized. If you make the character smaller, the 
strokes will get narrower. If you make the character larger, the strokes will get 
wider. When unchecked, the stroke width will remain the same when you 
increase or decrease its size, and changes to stroke width will need to be made 
manually.
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Designing a Character and Walk 
Cycle
The Walk cycle is a computer generated action. The others (Jump, Kick, and Wave) 
are custom actions that were created in Moho Pro. These actions can be applied to 
any character.

To create a walk for your character, follow these steps:

1. Click the Character Wizard button in the upper-right corner of the Moho 
interface to open the Character Wizard.

2. Design your character using the Body, Face, Clothing, and Style tabs as outlined 
in the previous sections. Use the view slider beneath the preview window to 
view your character from all directions as you design it.

Pay attention to the adjustments you make in height and 
placement of the facial features. Use the Horizontal 

and Vertical adjustment sliders to position the eyes, nose, and mouth 
in the side and quarter-view, and then verify that the changes are 
acceptable for each of those views. In other words, if you use the 
slider to adjust the position of the nose and mouth in the side view, 
also look at how the changes affect the placement of the facial 
features in the Front 3/4 and Back 3/4 views.

3. After you design your character, click the Movement tab.

 Character wizard Movement tab
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4. (Moho Pro only) From the Actions drop-down menu, choose Walk (it should be 
selected by default).

5. Adjust the Steps per second, Step distance, Step height, Arm swing, and Torso 
bend sliders until you are happy with the walk.

6. The preview window shows a preview of the walk cycle as it is applied to your 
character. You can view the walk from several angles by moving the slider right 
below the preview window. Examine your character from all directions and 
make tweaks as necessary before you export it to your Moho project. You will 
export your character in the next tutorial.

7. Click the + button at the top of the Character Wizard window. Name your 
character My First Character and click OK to save the preset. Now you will be 
able to reuse that character preset in any of your projects.

 Saving a preset character

8. Click OK to exit the Character Wizard. You will notice that the character 
appears in your scene when you do so. The next two tutorials will explain 
different ways that you can export and use the character in your projects.

Making Your Character Walk
In the previous project you designed a character and a walk, and saved the preset. 
When you exited the Character Wizard, you noticed that the character that you 
worked on appeared in the project window. However, because you saved the 
character, you can easily reuse it at any time in any project you start. We will begin 
this tutorial with a new project, and you’ll reuse the character preset that you 
designed in the previous exercise. In this tutorial, you will export only one view of the 
character: the Side view.

1. Start a new empty project in Moho.

2. Optionally, you can shorten the length of the animation from its default of 240 
frames. To do so, enter 100 in the end frame field in the timeline.
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 Decrease the length of the animation to 100 frames.

3. Click the Character Wizard to open the Character Wizard.

4. From the Presets menu at the top of the screen, select the My First Character 
preset that you created in the previous exercise. Your custom character 
appears in the preview area.

 Choosing a preset character

5. Move the View slider so that you see your character in the side view.

6. Uncheck the Export All Views option beneath the preview window. This will 
export only the current view, which is now set to the Side view.

7. Click OK to exit the Character Wizard. Your character now appears in the 
scene. Press the Play button and you will see the character walking in the 
center of the scene. Press the Stop button after you view the animation.

8. Click the Rewind button to move the timeline back to Frame 0. Then use 
the Transform Layer tool to move your character off the screen to 

the left.
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 At frame 0, move the character to the left of the screen.

9. Advance the timeline to frame 96, and move the character off to the other 
side.

 At frame 96, move the character to the right of the screen.

10. Press the Play button to view your character as it walks across the screen.

Rotating Your Character 360 Degrees
In this exercise you’ll make your character spin around in a full 360 degree circle.

It’s fairly easy to do, if you follow these steps:

1. Start a new empty project in Moho.

2. Click the Character Wizard to open the Character Wizard.

3. From the Presets menu at the top of the screen, select the My First Character 
preset that you created in the previous exercise. Your custom character 
appears in the preview area.
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4. Select the Front view before you export the character. This is the view that will 
be visible when you initially import the character into your scene.

5. Make sure that the Export All Views option beneath the preview window is 
checked. This step will be necessary, because you will be working with all of the 
exported views in this project.

6. Click OK to exit the Character Wizard. The character appears in your project.

7. The top layer of the character is a Switch layer, and the various character views 
appear as bone groups beneath it. With the character’s switch layer selected 
(the topmost layer), use the Transform Layer tool to resize your character as 
needed.

As a general rule, you will want to select the Switch Layer (the 
top layer) when you translate, scale, or rotate your 

character. This applies the changes to all views of your character. If 
you want your character to face a different direction at a specific 
point in the timeline, you simply move to a later frame, and make 
the appropriate switch layer active. This will be demonstrated in the 
next few steps. For more information about switch layers, see “Switch 
Layer” on page 144.

8. If you are not already at Frame 0 in the timeline, use the Rewind button to return 
there. Your character should be facing toward the front.

9. Now, advance the timeline to Frame 6. Expand the character’s switch layer so 
that you see the various views, as shown in the following figure. The view that 
has the filled-in bone is the layer that is currently in view.

When you export multiple views of the character, you will see 
the character appear as a Switch Layer. Each of the 

different views of the character then appear as individual bone 
groups beneath that layer, as shown in the following figure. The view 
that is currently visible is the layer that you had selected at the time 
you exported the character (in this case, the Front view).
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 The different views of the character appear as bone groups within the switch layer. 
The layer that shows a highlighted bone is the switch layer that is currently visible for 

the character.

10. At Frame 6, right-click in the Switch layer (shown as Man in the above figure), 
and select the Front 3/4 view. Your character should rotate to that view and a 
keyframe will appear at Frame 6.

 At Frame 6, right-click the Switch layer (shown here as Man) and select the Front 3/4 
view.

11. Now move to Frame 12 (the next keyframe), and right-click to select the Side 
view in the Layers Window. Your character will rotate to face the side.

12. At Frame 18, switch to the Back 3/4 view.

13. At Frame 24, switch to the Back view. At this point, your character has turned 
one-half of the circle.

14. Now select the Transform Layer tool. You won’t actually use this tool, but you will 
use the Flip Horizontal button later in this tutorial.
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15. Advance to Frame 30. In the Layers Window, right-click the switch layer, and 
choose the Back 3/4 view.

16. Next, to make your character continue to spin in the same direction (rather than 
return in the same direction from which it came), you’ll need to click the Flip 
Layer Horizontally button in the Transform Layer tool option bar, as shown below.

 At Frame 30, select the Back 3/4 view and then flip it horizontally.

17. Complete the remaining three frames as follows:

 � Frame 36: Right-click the switch layer to choose the Side view.

 � Frame 42: Right-click the switch layer to choose the Front ¾ view.

 � Frame 48: Right-click the switch layer to choose the Front view.

18. Save the project if you like, and then play back the animation. You should see 
your character spin around in a circle.

Designing Your Own Actions (Pro Only)
Advanced Moho users may be interested in creating their own actions for the 
Character Wizard. The actions that you create will appear in the Actions selection 
menu that appears at the top of the Character Wizard Movement tab.

The steps to create your own custom actions are briefly as follows:

1. Use Windows Explorer (Windows) or Finder (Mac) to locate your Moho 
installation folder.

2. Navigate from your installation folder to the Resources > Support > Common 
> Character Wizard > Actions folder. You will see three ANME files within that 
folder: Jump, Kick, and Wave. These are the three files that are associated with 
the actions that appear in the Actions selection menu.
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If you are prompted to convert the document to the new 
document format, choose OK to continue.

3. Open one of these projects, and save it into the Character Wizard folder that 
resides in your custom Moho Content folder (see “Creating a Content Folder” 
on page 16). Name the file according to the action that you want to create 
(twist, dance, Jumping Jack, etc). This step is important ... if you save the file 
under its original name and location you will overwrite the original action that is 
furnished with Moho.

4. The project will consist of five different bone layers that animate a mannequin 
figure: Back, Back 3/4, Side, Front 3/4, and Front. If you play the animation you 
will notice that all of the views are animated in unison.

 Five bone layers display a mannequin in different views.

5. Choose the Animation > Clear Animation > From Document command to 
remove all of the keyframes in the timeline. They will be removed from all bone 
groups in the document.

6. Use the Manipulate Bone tool to modify the movement of each view so that you 
again create five different views of the character that move in unison. Make 
sure you make your changes on frames 1 or higher (do not make changes on 
Frame 0).

7. Make sure that you adjust the length of your animation so that the movement 
is seamless when it is played in a loop. Add or remove frames as necessary to 
create a smooth-flowing animation where you cannot tell where the loop starts 
or ends.
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 Edit each view for your figure so that the character moves in the same manner for 
each view.

8. After all five views of your character have been animated, save the modified 
file. You should now see your new action appear in the Actions menu in the 
Character Wizard Movement tab.

 Your new action will appear in the Actions menu in the Character Wizard movement 
tab.

Creating Content for the Character 
Wizard (Pro Only)
Your Moho application installation folder includes the Character Wizard subfolder 
as mentioned previously in “Designing Your Own Actions (Pro Only)” on page 327. 
In addition to the Actions folder previously discussed, the Resources > Support > 
Common > Character Wizard folder contains other subfolders that store the ANME 
files for the Character Wizard content that you select in the Body and Face tabs.
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 Character Wizard content folders.

The additional subfolders are as follows. Examine the files for some ideas on how you 
can create your own content:

• Eyes: Contains the Eyes content that you select from the Eyes section of the 
Face tab.

• Feet: Contains the Feet content that you select from the Legs section of the 
Body tab.

• Hands: Contains the Hands content that you select from the Arms section of the 
Body tab.

Eyes, Feet, and Hands come in pairs ... you have a right eye 
and a left eye, a right foot and a left foot, and a right 

hand and a left hand. When you create content for paired body 
parts, precede the topmost layer (switch layer, bone group, or 
image) with a name that starts with Right or Left, where Right 
corresponds to the right part, and Left corresponds to the left part. 
For example, if you create a set of animated eyes for the front view, 
place the character’s right eye in a switch layer named Right Front, 
and the character’s left eye in a switch layer named Left Front. 
Names are case-sensitive and should be initial-capped. Open one 
of the files in the Eyes, Feet, or Hands folders and examine the layers 
within them to view the naming conventions used.

• Head Props: Contains the Prop content that you select from the Head Prop 
section of the Face tab.

• Heads: Contains the Head content that you select from the Head section of the 
Face tab.

• Mouths: Contains the Mouth content that you select from the Mouth section of 
the Face tab.

• Noses: Contains the Nose content that you select from the Nose section of the 
Face tab.
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Heads, Head Props, Mouths, and Noses don’t come in pairs, so 
you won’t need to add the Right or Left prefix as you do 

with paired body parts. When you create switch layers for a “single” 
body part, name the switch layer according to the view that you are 
creating. For example, if you create a head for the Front 3/4 view, 
place the head in a switch layer named Front 3/4. Names are case-
sensitive and should be initial-capped.

Here are some additional notes and tips about creating content for use in the 
Character Wizard. Again, we recommend that you study the various ANME files in 
the Character Wizard subfolders to learn more about how these features work.

Pay attention to the point of origin for the layer that you are working on. The point 
of origin is important for the main folder (the topmost layer for the part - whether it 
be a switch group, a bone layer, or an image). For example, if there are multiple 
eyes contained in a switch layer to make an animated eye, you only need to set the 
point of origin on the switch layer, instead of on each individual eye layer within that 
switch layer. If you only have one layer for a body part, set the point of origin on that 
one layer.

• The points of origin for eyes, mouth, and nose should generally be set at the 
center. On the other hand, if you are creating something like a broken nose, the 
point of origin might look better being a little bit off center. For moving parts (like 
hands, feet, and head) you should set the point of origin at the point of rotation.

• Parts can be resized, but only to a limited degree. In order to work well within 
the “normal range”, parts should be designed to the size of the blue output 
rectangle. This rule can be broken ... for example, if you intentionally want small, 
beady eyes you can make them much smaller.

• Examine the heads that are included within the Heads folder. Some heads have 
hair that fall in front of facial features (for an example, see the Spike head, and 
turn visibility on and off for the various layers to examine how they work).

• Hair color is controlled within the Style tab of the Character Wizard. When 
designing your character, assign the color R 0, G 255, B 255 to the objects that 
you are using for hair (or eyebrows, moustaches, and beards). The Character 
Wizard will replace this “special” color with the hair color that you choose in the 
Style tab.

• Skin color is also controlled within the Style tab of the Character Wizard. When 
designing your character, assign the color R 255, G 255, B 0 to any parts that you 
want to replace with the Skin color selected in the Style tab.

• Stroke color is also controlled within the Style tab of the Character Wizard. Any 
strokes in your Character Wizard content file that are pure black (R 0, G 0, B 0) 
will be replaced with the Stroke color that is specified in the Style tab.
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Chapter 16: The Timeline 
Window

The Timeline window is used when animating in Moho to control the current time, 
and to control objects’ keyframes.

 The Moho timeline (Moho Pro shown)

The Timeline window only displays information about the currently active layer in the 
project. When you switch to a new layer, the timeline panel will update its display to 
show the new layer’s keyframes.

Changes are not displayed in the timeline until you actually create a keyframe 
change in a channel. For example, you won’t see a change in the Bone channel 
until you actually move a bone.

 Animation channels are not displayed in the timeline until you add them to your 
project

If you then rotate the layer, you’ll see the Rotation channel added to the timeline, 
along with its keyframe.

 A rotation channel added to the timeline
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Consolidating Timeline Channels
There is a Preferences option that allows you to consolidate timeline channels. This 
option is off by default in Moho Pro, and on by default in Moho Debut.

 Uncheck the Consolidate Timeline Channels option before you delete keyframes

This option combines all changes on a single layer into one line in the timeline. The 
following image shows an example of a layer that has several channel changes 
(top), and what the layer looks like if the Consolidate Timeline Channels option is 
active (bottom).
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 A timeline that is not consolidated (top), and a consolidated timeline (bottom)

The consolidated timeline view displays a keyframe when there 
is a change in any of the consolidated layers. If you 

delete a keyframe, you may not be sure which type of keyframe you 
are deleting , or whether or not there are multiple keyframes being 
deleted at that point. Be sure to uncheck the Consolidate Timeline 
Channels option in the Preferences dialog before you remove any 
keyframes from your timeline.

Condensing and Expanding the 
Timeline
A condense/expand timeline options widget appears in the upper left of the 
Timeline window. Click the button to access the dialog.

 Click the Timeline Options widget to condense or expand the Timeline Options.

Timeline options appear at the top of the timeline. These options can be hidden or 
shown with a controller that appears next to the ruler. If the options are hidden when 
you click the widget, a dialog displays the applicable options, along with options to 
show specific items in the timeline.
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 Timeline display options.

• Show timeline options toolbar: Check Show timeline options toolbar to unhide 
the Timeline Options banner in the timeline.

• View: Allows you to choose between Channels view, Sequencer View, and 
Motion Graph view. Motion Graph view is available in Pro only.

• Auto-freeze keys: Enables or disables the Auto-Freeze Keyframes feature, 
described in “Auto-Freeze Keyframes” on page 472.

• Zoom In: Zooms in so that you can view less frames in the timeline.

• Zoom Out: Zooms out so that you can view more frames in the timeline.

The following additional options are available in Moho Pro:

• Interpolation: Allows you to choose a default interpolation method. For more 
information, see “Choosing an Interpolation Method” on page 338.

• Interval: Allows you to choose an animation interval. See “Choosing an 
Animation Interval (Pro Only)” on page 344.

• Onion Skins: Enables or disables onion skinning. See “Onion Skins (Pro Only)” on 
page 345.

• Relative Keyframing: Relative frames are enabled by default. When this option 
is checked, you will be able to scrub through the timeline, and the onionskin 
markers will move with the current frame, keeping the same relative distance 
to each other. When unchecked, the onion skin frames will remain stationary as 
you scrub through the timeline.

• Add Marker: Adds a timeline marker at the current frame.
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Controlling Time
The top of the Timeline window has controls for setting the current time. Whenever 
you modify an object in Moho, the modification is recorded at the current time. The 
process of modifying an object, changing the time, and modifying it again is how an 
animation is created in Moho.

Time in Moho is expressed in terms of “frames”, where there are x number of frames 
in a second. By default, a new Moho project has 24 frames per second, although this 
value can be adjusted in the Project Settings dialog.

The first set of controls for adjusting time is a set of VCR-like playback buttons. (These 
are actually at the bottom of the main window, not in the Timeline window itself.) 
From left to right these buttons are: rewind, step back, stop, play, step forward, and 
jump to end.

 Playback controls

Rewind sets the current frame to 0, while jump to end sets the current frame to the 
last one in the animation (the length of the animation is defined by the shaded area 
in the time ruler). The step forward and back buttons advance and back up by one 
frame. The play button plays back the animation in the main editing area, repeating 
playback in a loop. Finally, the stop button stops playback.

At the top-left of the Timeline window is a text control that indicates the current 
frame number. You can change the current frame by typing in a new value here 
and pressing enter.

Directly below the frame field is a sort of ruler that measures time. This time ruler has 
small tick marks, one per frame, and has labeled frame numbers at intervals along 
its length. The time ruler also displays the current frame with a red triangular marker 
above the current frame’s tick mark. The time ruler is used both as an indicator of the 
current time, as well as a control to adjust it. By clicking (or clicking and dragging) 
anywhere on the time ruler, you can change the current frame.

A certain range of frames in the time ruler are shaded with a darker color. This 
shaded region indicates the length of your animation. When you play back your 
animation in Moho or export it as a movie file, this shaded region is the part that 
will play back. You can change the start and end frames of your animation in the 
Project Settings dialog, or you can Alt-click in the time ruler to set a new start and/or 
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end time. Alt-Click with the left mouse button to set the start of your animation, and 
Alt-click with the right mouse button to set the end.

Navigating the Timeline with the 
Mouse
To navigate through the timeline with your mouse, you can use the following:

• Use the mouse scrollwheel to move the sequencer vertically (up and down 
through the layers).

• Press the Alt key while you use the scrollwheel to move the playhead right and 
left through time.

• Right-click and drag to pan left or right through the timeline.

• Use the mouse wheel in Graph mode to zoom in and out of the timeline.

Using Timeline Markers (Pro Only)
Moho provides an option to add timeline markers that help you identify where 
specific events take place in your project. The Marker dialog allows you to enter a 
string of text that identifies the marker. They can be added for an entire document, 
or per layer.

• To add a timeline marker, go to the frame at which you want the marker to 
start. Click the Add Marker button in the timeline.

 Add Marker button (circled)

• When the Edit Marker dialog opens, enter a name for the marker. Check the 
Document-wide marker option if you want the marker to apply to the entire 
document, or leave the option unchecked to add the marker to the currently 
selected layer.
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 Edit Marker dialog

• After you create the marker, a marker appears in the timeline. If the text for 
the marker is longer than can be displayed on the timeline, you can hover 
the marker to display all the text. Double-click the marker indicator to edit the 
settings for that marker.

 Edit Marker dialog

Timeline marker regions are based on the keyframe’s hold 
values.

You can manipulate markers just like any other keyframe type.

Choosing an Interpolation Method
You can choose a keyframe interpolation method in one of two ways:

• To change the interpolation method for existing keyframes: Select one or more 
keyframes. Then right-click a selected keyframe to open the Keyframe menu. 
Select one of the available interpolation methods from the menu.
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 Choosing an interpolation method for existing keyframes (Moho Pro shown)

• To change the interpolation method used for keyframes that you will add to the 
timeline (Pro only): Immediately to the right of the Motion Graph tab you will 
see a popup menu that allows you to choose a default interpolation method. 
The method that you choose here will be applied to any new keyframes that 
you create. Moho will provide a real-time preview of the changes as they are 
applied.

 Choosing a default Interpolation Method

The interpolation methods are as follows:

• Default Interpolation (Pro only): Uses the interpolation method that is set by the 
Interpolation popup.

• Smooth: Takes into account neighboring keyframes, creating a smooth transition 
from one keyframe to the next.



Moho 13.5
Users Manual 

340

Chapter 16: The Timeline Window

 Smooth interpolation

• Linear: Moves an object in a straight line, with no acceleration or deceleration 
from one keyframe to the next.

 Linear interpolation

• Ease In/Out: Creates a smooth transition at the beginning and the end.

 Ease In/Out interpolation

• Ease In: Creates a smooth transition at the beginning.



Moho 13.5
Users Manual 

341

Chapter 16: The Timeline Window

 Ease In interpolation

• Ease Out: Creates a smooth transition at the end.

 Ease Out interpolation

• Bezier (Pro only): Allows you to use Bezier handles to shape an animation curve. 
Bezier handles in the timeline graph mode are colored Red, Green,and Blue to 
match colors for X, Y, and Z keyframes.

 Bezier interpolation

• Step: Holds an object, unmoving, at the previous keyframe’s position until the 
next keyframe is reached. Then it suddenly jumps (or steps) to the new position.
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 Step interpolation

• Noisy: Can be used to simulate a handheld camera, but it can be used to 
interpolate any value. It adds jitter to the interpolation process so that the 
object appears wobbly from one keyframe to the next.

 Noisy interpolation

• Cycle: Cycles back to a specific frame number (absolute cycling), or back by a 
specified number of frames (relative cycling).

 Cycle interpolation

• Bounce (Pro only): Creates a bounce between the start and end points. Settings 
include the number of bounces, and the height scale. A setting of 4 for a 
bounce count and a scale of .75 would result in an object that bounces four 
times, and each bounce would reach 75 percent of its previous height.
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 Bounce interpolation

• Elastic (Pro only): Similar to bounce, above, except that the effect overshoots 
the ending value and then curves back again until it settles down on the ending 
value. You have control over the scale of the bounces, and can also allow the 
elastic effect to happen in reverse.

 Elastic interpolation

• Stagger (Pro only): Creates a stairstepping effect between keyframes, and gives 
the illusion of an object that is staggering against weight.

 Stagger interpolation

• Copy Previous Key (Pro only): Uses the setting of the previous key as the new 
default interpolation method for the current channel.
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Choosing an Animation Interval (Pro 
Only)
By default, interpolation is calculated for each frame (an animation interval of 
1). There might be cases when you want your animation to be calculated less 
frequently. The greater the animation interval, the less smooth your animation will be.

The Animation Interval popup menu will allow you to select an animation interval 
between 1 and 6 frames. You can find this popup menu in the Timeline, between the 
Interpolation and Onionskins popup menus.

The interpolation level is normally 1, which means that a change is interpolated for 
each frame. When you choose an animation interval other than one, a change will 
not occur until after that number of frames is reached. For example, an interpolation 
level of 3 would cause the selected layer to change at every third frame. This can 
create motion that looks more staggered, without having to add a lot of keyframes 
to accomplish the same effect.

• To change the animation interval for existing keyframes: Select one or more 
keyframes. Then right-click a selected keyframe to open the Keyframe menu. 
Expand the Interval command to select an animation interval between 1 and 6.

 Choosing an Animation Interval for selected keyframe(s)

• To change the default animation interval: Use the Animation Interval popup that 
appears in the Timeline window. Click the Animation Interval button to select a 
default animation interval between 1 and 6. This default animation interval will 
be applied to any new keyframes that you add, until you change the default 
setting.



Moho 13.5
Users Manual 

345

Chapter 16: The Timeline Window

 Choosing a default Animation Interval

Onion Skins (Pro Only)
Next, just below the time ruler, is the onionskin controller. Expand the Onionskins 
menu to enable this feature and set additional options.

 Onion Skin Options

The Onionskin options are as follows:

• Enable onion skins: Onion skins are disabled by default. Click the Onion Skins 
button to turn on the display of onion skins. This allows you to set onion skin 
markers in the timeline. You can also toggle onion skins on/off with the View > 
Enable/Disable Onion Skins command. You will be unable to add onion skin 
markers unless this option is turned on. You’ll notice has marks that line up with 
the frames in the time ruler. By clicking one of these tick marks, you can turn on 
an “onionskin” frame. Moho can display up to 8 onionskin frames.

 � To add an onionskin marker, click in the tickmarks, beneath the frame 
number at which you want to add an onionskin.

 � To remove an onionskin marker, click the marker that you want to remove.
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 Onion skin markers placed in the timeline.

If you uncheck this option after you set onionskin markers, it will 
remove the existing markers completely and the 

onionskin bar will be inactive. To remove existing markers but keep 
the bar active, use the Clear All button, described below.

• Outlines only: Outlines are turned off by default. With this option unchecked, 
onion skin frames will be displayed at various levels of opacity. Frames that 
are farther away from the current frame will be more transparent, and frames 
that are closer will be less transparent. With this option checked. the onion skin 
frames will be displayed only in outline form. Onionskins before the current frame 
will be colored red in varying transparencies. Onionskins after the current frame 
will be displayed green in varying transparencies.

 With Outlines Only unchecked, onionskins are shown as partially transparent versions 
of the layer.
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 With outlines only checked, onionskins are shown as red and green outlines of varying 
transparency.

• Relative frames: Relative frames are enabled by default. When this option is 
checked, you will be able to scrub through the timeline, and the onionskin 
markers will move with the current frame, keeping the same relative distance 
to each other. When unchecked, the onion skin frames will remain stationary as 
you scrub through the timeline.

• Selected layer only: This option is enabled by default. When checked, this 
option will only display the onionskins for the currently active layer. When 
unchecked, onionskins will be displayed for all layers in the scene.

• Draw Behind: This option is enabled by default. 

• Clear All: Click this button to remove all existing onion skin markers. The onion 
skin bar will remain active so that you can add new onionskin markers.

Playing a Partial Segment
Sometimes, you may want to play back just a short segment of the timeline, instead 
of your entire animation. For example, you may be working on one small move, and 
you want to play it back over and over while you make small changes to see when 
you’ve got it just right.

To set a limited segment of the timeline for playback, hold down the Ctrl key 
(Windows) or Cmd key (Mac) while you click in the time ruler. Click with the left 
mouse button to set the beginning of the segment, and click with the right mouse 
button to set the endpoint. To remove the limited playback segment, Ctrl-click on 
the segment endpoints to remove them from the timeline.

Animation Channels
Most of the timeline panel is taken up with animation channels, drawn as horizontal 
bars below the time ruler. Each animation channel displays a certain type of motion 
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or effect that can take place in a Moho animation. These animation channels 
only appear in the timeline if you have keyframes associated with that particular 
animation channel.

Different types of layers have different animation channels available. For example, 
vector layers are the only ones with a point animation channel, and bone layers 
are the only ones with bone animation channels. At the left end of each animation 
channel is a small icon that indicates what type of channel it is.

Shown below are the icons for the various types of animation channels. Note that 
the red-colored channel icons represent animation for the currently selected object. 
(If you’re ever unsure about which channel an channel icon refers to, just hold your 
mouse over it momentarily for a tooltip reminder.)

To help reduce visual clutter, not all animation channels have 
to be displayed at once in the timeline. For example, 

you won’t often have to refer to the Layer Shading channel in the 
timeline. Hidden channels are still doing their work behind the 
scenes, they just aren’t displayed in the timeline. See “Hiding and 
Showing Timeline Channels (Pro Only)” on page 351 for more 
information. 

Marker Channels (Pro Only)
Document Markers

Layer Markers

Vector Channels
Point Motion Selected Point Motion

Point Curvature Selected Point Curvature

Fill Color Selected Fill Color

Shape Effect Transforms Selected Shape Effect 
Transform

Shape Effect Selected Shape Effects

Shape Thickness Selected Shape Thickness

Line Color Selected Line Color

Line Width Selected Line Width

Curve Exposure Selected Curve Exposure

Point Color Selected Point Color

Point Color Strength Selected Point Color 
Strength

Shape Order



Moho 13.5
Users Manual 

349

Chapter 16: The Timeline Window

Layer Transform Channels
Layer Translation

Layer Scale

Layer Z Rotation

Layer Y Rotation

Layer X Rotation

Layer Horizontal Flip

Layer Vertical Flip

Layer Shear

Path Following

Physics Channels
Enable Physics

Physics Nudge

Physics Motor Speed

Physics Force Field

Selected Physics

Layer Effect Channels
Layer Visibility

Layer Blur

Layer Opacity

Auto Shading

Threshold

Layer Noise

Layer Pixelation

Layer Shadow

Layer Shading

Layer Motion Blur

Perspective Shadow

Outline



Moho 13.5
Users Manual 

350

Chapter 16: The Timeline Window

Layer Color

Camera Channels
Camera Tracking

Camera Zoom

Camera Roll

Camera Pan/Tilt

Bone Channels
Bone Angle * Selected Bone Angle

Bone Translation * Selected Bone Translation

Bone Scale * Selected Bone Scale

Bone End Flip Selected Bone End Flip

Bone Side Flip Selected Bone Side Flip

Bone Lock Selected Bone Lock

Bone Target Selected Bone Target

Bone Parent Selected Bone Parent

Bone Dynamics Selected Bone Dynamics

Bone Motor Speed Selected Bone Motor Speed

* Angle, Translation, and Scale channels are also displayed in the timeline for 
colored bones (appropriately colored Coral, Cadet Blue, Turquoise, Pink, Tan, Purple, 
Blue, .Green, Yellow, Orange, and Red.

Group Channels
Layer Ordering

Switch-Only Channels
Switch Layer

Particle-Only Channels
Particles On/Off
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Physics Channels (Pro Only)
Enable Physics

Physics Nudge

Physics Motor Speed

Physics Force Field

Other Channels
Audio Jump

Audio Level

Media Jump

Mute

No Mute

Off

On

Poser Selected Poser

Tracking Point Selected Tracking Point

Hiding and Showing Timeline Channels 
(Pro Only)
The View > Timeline Channels command opens the Timeline Channels dialog, which 
allows you to configure the channels that appear in the timeline.
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 Timeline channels dialog

The top of the Timeline Channels dialog shows three buttons:

• All: Click the All button to set all channels to display in the timeline. The channels 
will appear in the timeline whether or not they are used in the project.

• None: Click the None button to set all channels off in the timeline. Channels that 
are set to off will not appear in the timeline, even if they are used in the project.

• All Auto: Click the All Auto button to set all channels to Auto. This mode will 
cause a timeline channel to appear in the timeline only if it is used in the 
project, and is the default selection when you first open the Timeline Channels 
dialog.

• You can also select individual channels to on, off, or auto by clicking the 
appropriate icon next to the channel that you want to set. 

• After you set your timeline channel display options, click OK to exit the dialog. 
You can also click Apply to assign those that are already configured and 
remain in the dialog to make additional changes. Click Cancel to exit the 
dialog without saving changes.

Working with Keyframes
Keyframes are displayed along the length of an animation channel. A keyframe 
represents a point in time at which you, the animator, made a modification to an 
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object. For example, if you set the current time to frame 24, then scale the layer, a 
keyframe will appear in the layer scale channel at frame 24.

Keyframes appear as small markers on the channels. At points in time that lie in 
between keyframes, Moho automatically calculates how to move an object from 
one keyframe position to the next.

Keyframes are not just static elements displayed in the animation channels. They can 
be moved, deleted, and copied. Moho remembers what key frames are selected 
when you change layers, delete keys, move keys, and so on.

Editing Keyframe Settings
The Window > Keyframe command opens the Keyframe window so that you can 
manage settings for the keyframes in your project.

1. Select the keyframes that you want to modify.

2. Choose Window > Keyframe or use the shortcut Ctrl/Command+Alt E to open 
the Keyframe dialog.

 Keyframe dialog

3. Modify the following settings as applicable. Settings are applied live as you 
modify them:

 � Keyframe: Displays the frame number at which your keyframe selection 
begins. The plus sign indicates that the selection extends beyond the 
designated frame number.

 � Interpolation: Use the Interpolation menu to select the desired interpolation 
method for the keyframe selection. These methods are described in 
“Choosing an Interpolation Method” on page 338.

 � Stagger: Check this option to apply a “stairstep” effect to the selected 
interpolation method.

 � Hold Duration: Enter the number of frames desired for the hold duration 
(the number of frames you want to hold the objects in their current 
position) and press Enter to apply the setting. For additional information, 
see “Hold Durations” on page 357.
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 � Interval: By default, interpolation is calculated at every frame. Increasing 
the setting creates an animation that is less smooth.

 � Label: Use the Label dropdown to choose a color that later helps you 
identify keyframes that share common settings.

 Keyframes with a color label applied.

Adding Keyframes
Keyframes are added automatically when you make a change (such as position, 
rotation, scale, etc) on any object in your project.

Use the Animation > Add Keyframe command to add a new keyframe to any 
animation that already has keyframes.

You can also add a keyframe to the current frame at any time by double-clicking 
the timeline in any animation channel. This also works in graph mode in Pro only.

Copying and Pasting Keyframes
Another way of creating keyframes is to copy an object’s position from another 
point in time. Keyframes can also be copied from one layer to another, or from one 
document to another.

To copy keyframes:

1. Select the keyframes you want to copy.

2. Press CMD/Ctrl C to copy the keyframes to the clipboard.

3. Select the layer or document to which you want to paste the keyframes.

4. Set the current frame to when you want the copied keyframe to appear (using 
the time ruler or the step forward/back buttons).

5. Press CMD/Ctrl V to place a copy of the keyframes at the current time. When 
you paste keyframes, they become the new selection so that you can move, 
scale, or finetune them.

You can also right-click on selected keyframes in the timeline, 
and choose Cut, Copy, or Paste from the context 

menu.
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You can also use the Edit > Paste Relative command to paste 
keyframes and continue animation relative to the 

current position in the timeline. See “Paste Relative” on page 428 
for more information.

Selecting Keyframes
To modify a keyframe, first it must be selected. This is accomplished simply by clicking 
a keyframe in the timeline panel. A selected keyframe shows up in a highlighted 
color.

Multiple keyframes may be selected by holding the shift key while clicking on 
keyframes. Alternatively, you can click and drag a rectangular selection box around 
the group of keyframes you want selected.

In Moho Pro, you can also right-click a keyframe and then use the Select Keys to 
Right command in the context menu to select all keyframes that appear in time 
after the currently selected keyframe. This helps when you need to add space in the 
middle of a long animation, because you won’t have to scroll through to the end of 
the animation while selecting keyframes manually.

 Keyframe context menu (Moho Pro shown)

Deleting Keyframes
To delete selected keyframe(s), press the Delete key. Deleting a keyframe removes 
motion from an object.
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Moving Keyframes
Keyframes can also be moved by dragging them forward and back in time. If you 
want some motion to take less time, drag its keyframe to the left. To take more time, 
drag it to the right. You can also move selected keyframes beyond other keyframes.

Coloring Keyframes
You can use color to label the keyframes in your timeline in ways that are meaningful 
to you. For example, you can assign one color to keyframes that pertain to a 
particular character in your scene, and another color for another character. This 
helps you visually keep track of the movements associated with a particular object 
or group of objects.

To add color to keyframes, select the keyframes that you want to assign color to. 
Then right-click to display the Keyframe context menu, and choose Label > followed 
by your color choice (Blue, Cadet Blue, Coral, Green, Orange, Pink, Purple, Red, Tan, 
Turquoise, or Yellow).

 Assigning a color label to keyframes

Editing Multiple Keyframes
If you have a number of keyframes that you want to edit. you can now select 
multiple keyframes and edit them at the same time. For example, if you want to 
move an object to a different part of the screen but want to keep the animation 
of that object the same, you can select all the keyframes and translate them all at 
the same time. Select all the keyframes for that object and use the mouse to move 
the object to the new location. Then release the mouse button to complete the 
movement.

This works for both layer movement and point movement. For example, let’s say that 
you have a circle that squashes and stretches, but you want to turn it into a petal 
shape. You can select all of the keyframes and then reshape the object on the first 
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keyframe as needed. Then the reshaping will be applied to all of the keyframes that 
follow.

Hold Durations
There are times when you need to hold an object in the same position for a while, 
before the animation starts. In cases like this, you can add a hold duration that 
keeps the object in place for a set number of frames. Place a keyframe in the first 
frame where you want the object to stay still, and then add a hold duration for the 
number of additional frames where you want the object to pause.

To directly modify the hold duration for a selected keyframe, hold down the ALT/
OPTION key while dragging the keyframe in the timeline. A red pill shape will appear 
in the frames where the keyframe is held in its set position.

You can also right-click the keyframe in the timeline to display the keyframe context 
menu, and then enter a hold duration (in frames) in the Hold Duration dialog.

 Hold durations shown in the timeline.

Pill shapes are used to represent switch keys, layer ordering 
keys, and keyframes that have hold durations.

Keyframe Transitions
As mentioned before, Moho automatically calculates what happens in between 
keyframes. However, you do have some control over this. By default, Moho will 
compute a smooth transition from one keyframe to the next - most of the time, 
this is probably what you want. However, you can change the transition type by 
right-clicking a keyframe and choosing a new method from the popup menu that 
appears. The transition methods are: smooth (the default), ease in/out (also a 
smooth motion, but the object starts off moving kind of slowly and slows down again 
as it approaches the next keyframe), linear (motion is straight from one keyframe 
to the next, leading to a somewhat mechanical look to the motion), step (there is 
no transition at all - the object just jumps from one keyframe to the next), noisy (the 
object moves in a slightly wobbly motion), and cycle (the value from this keyframe 
to the next will be taken from some earlier section of the timeline).
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Sequencer
The sequencer provides another view of the timeline. It displays each layer as a 
block of time. Keyframe changes are not displayed in the sequencer, but you can 
create keyframe changes in this view.

 The Sequencer

The Sequencer allows you to easily move a layer forward or backward in time. Move 
the clip toward the left to have it start sooner, or toward the right to have it start 
later. The green arrow in the time ruler, located at the top of the Sequencer timeline, 
indicates the frame at which the currently selected clip will start.

You can also reposition your clips in the Channels timeline view. 
Select the channel you want to move, then right-click 

in the Time Ruler to drag the green arrow to the right or left. You’ll 
notice the keyframes and arrow relocate with the mouse.

For example, you can reposition a layer from frame 1 to frame 38, causing the 
animation in that layer to start at a later time. To move a layer and its sublayers, click 
the topmost layer and move all of them at the same time. To move a sublayer, click 
the desired sublayer to move it on its own.

 Select a layer to move it and its sublayers
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 You can also move a sublayer by itself

You can also use the sequencer to show or hide a layer at any time during the 
movie. Advance to the frame where you want the layer to become invisible. 
Open the Layer Settings dialog for the layer that you want to hide, uncheck the 
Visible checkbox, and close the Layer Settings dialog. The contents in the layer will 
disappear in the project window, and the track in the sequencer will appear as 
though it ends at the point where it was hidden.

 Check or uncheck the Visible setting in the Layer Settings dialog to show or hide a 
layer

To make the layer reappear later in the timeline, repeat the process. Select the 
layer you want to unhide, open the Layer Settings dialog, and check the Visible 
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checkbox. After you close the Layer Settings dialog the layer will reappear in the 
sequencer.

 The sequencer shows a break where the layer is hidden

If you import an audio file, it has a fixed duration in the sequencer. You can see 
where the sound effect will happen. Say you want a pop to happen when your 
character disappears from the scene. You can place the pop in the right place.

It works the same way if you import a video layer. For example, if you want an 
explosion to happen just before the pop, you can import a video layer and place it 
just before the sound effect.

 You can precisely place audio and video files in Sequencer view

Motion Graph (Pro Only)
In the Motion Graph in the Timeline window, you can enable Moho’s graph mode. In 
graph mode, the animation channels of the current layer are displayed graphically, 
rather than just as points along a line. In the example below you can see what graph 
mode looks like:
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 The Timeline window in graph mode

The main body of the timeline is now a graph, showing the value of the animation 
channels as curves:

• The horizontal dimension represents time in frames (just as in the regular timeline 
mode). To move forward or backward in time, you can scrub the playhead left 
or right.

• Depending on the values in your animation channels, the curves on the graph 
may be too large to view, or too small to work with easily. You can change the 
vertical scale of the graph in the following ways:

• Scroll the mousewheel to increase or decrease the vertical scale.

 � Set the vertical scale numerically in the Scale text field in the Graph Mode 
popup.

 � Press the Page Up/Page Down keys to zoom in and out vertically. If you 
hold the Shift key while pressing Page Up/Page Down, you can move the 
graph up and down.

 � Press the End key, to automatically scale the graph to accommodate the 
currently active channel.

 Use the scrollwheel on your mouse to increase the vertical range of the animation 
curves.

If all animation channels were displayed at once, the graph would become too 
cluttered to be useful, so it’s up to you which channels to display at any given 
time. To turn the display of a channel on and off, click its icon on the left side of 
the timeline. Channels that are turned on become highlighted in the color of their 
respective curves in the graph - in the following example, three channels are turned 
on. Double-click again to display further information for a channel: Move (red), 
Scale (blue), and Rotate (green).
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 Channels can be shown or hidden in the timeline.

In graph mode, you can still add keyframes (use the popup menu through the right 
mouse button), delete keyframes, and move keyframes back and forth. In addition, 
you can move keyframes vertically - that is, change the value of keyframes.

Something that will become apparent in graph mode is that some channels have 
more than one value for every keyframe. For example, the Layer Translation channel 
has separate values for X, Y, and Z translation. These values will appear as separate 
colors in the graph: Red for X, Green for Y, and Blue for Z.

 Different colors are used for X (Red), Y (Green) and Z (Blue) layer translations.

Another thing you may notice when using animation cycling: A channel that cycles 
will have a repeating curve, without more keyframes after the one that cycles.

For a hands-on example of using the timeline in graph mode, see “Tutorial 5.4: 
Animation Curves (Pro Only)” on page 188 in your Moho Tutorial Manual.

Displaying Multiple Layers in the 
Timeline
If you select multiple layers in the Layers Window, they will all appear in the timeline.

• The layer name will appear in the timeline. Click the layer name to select that 
layer in the timeline. The name of the selected layer will highlight and appear in 
italicized text.

• In Moho Pro, the Layers Window contains Timeline Visibility controls that allow 
you to select which layers you want to display in the timeline. You can enable 
or disable this column using the Quick Settings dialog, discussed in “Using Layer 
Quick Settings” on page 179.
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• If the layer has a color assigned to it in the Layers Window, the layer color will be 
reflected in the timeline.

• You can select keyframes from multiple layers, and delete, copy or paste them 
at the same time.

 Timeline Visibility of two layers is set in the Layers Window. The current layer is 
highlighted in the timeline.

Muting Animation Channels (Pro only)
If you are working on a scene or character that has a lot of layer movement or 
camera movement, you can “mute” other animation channels so that you can 
concentrate on the character. This will temporarily disable any keyframes in the 
muted channel. After you finish your changes, you can click the Mute button again 
to toggle the channel back on.

To mute a channel, click the small dot that appears to the right of the channel icon 
that you want to mute. You can also right-click the channel icon and choose Mute 
Channel from the context menu.
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 Muting animation channels.
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Audio Recording
Moho allows you to record audio tracks within the application. Select Window > 
Audio Recording to open the Audio Recording palette. You will see the following 
controls and settings:

• Record Button: Press the Record button to start a recording. After you have 
recorded the content you want to record (speech, sound effects, etc.), press 
the same button to stop the recording.

You can start a recording at any selected frame in the timeline. 
Simply select the frame at which you want the 

recording to begin, and start your recording at that frame.

• Play Button: After the recording is complete, press the Play button to hear the 
recording.

• Sync with Timeline Playback: If this box is checked, the timeline will play back 
while you record the audio (and when you play back the audio). This lets you 
record in sync with the visuals if you choose to do so.

• Microphone Drop-Down List: Selects the microphone that you want to use for 
audio recording.

• Pitch Shifting: Use the Pitch Shifting slider to raise or lower the pitch of the 
recording. Move the slider toward the left to lower the pitch, or toward the right 
to raise the pitch. The Reset button returns the recording to its original pitch.

• Add to Project: Once you are satisfied with the recording, click this button 
to save the recording as a WAV file. The WAV file also appears in the Layers 
Window as a new audio layer, and in the timeline of your current project.
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 Audio Recording Window

Actions Window (Pro Only)
In Moho, “actions” are short clips of animation that can be inserted into the timeline 
and re-used over and over again. You might use actions to create little bits of 
animation that you don’t want to have to re-create each and every time you use 
them - for example, eye blinks, head turns, walk cycles, etc. The Actions window 
(as you may have guessed) is where you create and use actions. “Tutorial 5.5.1: 
Animated Layer Ordering” on page 196 in your Moho Tutorial Manual shows you 
step-by-step how to use actions in Moho.

When you start up Moho, the Actions window is hidden. To bring it up, select 
“Actions” from the Window menu. The Actions window looks like this:
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 The Actions window

Across the top of the window are several buttons and controls:

• New Action: Creates a new action, as described in “Creating New Actions (Pro 
Only)” on page 369

• Insert Reference: Adds an action to the timeline (see “Using Actions (Pro Only)” 
on page 373)

• Insert Copy:Adds a copy of an action to the timeline (see “Using Actions (Pro 
Only)” on page 373)

• Delete Action: Deletes the action from the actions list.

• Import Action: Allows you to import an action file that was previously exported 
from another project. Click the Import Action button and locate the action file 
you want to import (.asaction or .mohoaction extension). Alternatively, you can 
right-click inside the action list and choose Import to select your file.

• Export Action: Actions can be exported for use in other projects. Either select the 
action you want to export and click the Export Action button, or right-click the 
action and choose Export from the context menu. The file will be saved with the 
.mohoaction extension. 

• Sort: If you have many actions in your list you might find it convenient to check 
the Sort option. If this option is unchecked the Actions window will display the 
actions in the order in which they were created in the layer You can manually 
reorder the items in the list when the checkbox is not checked.

• Filter: When you enter a string in the Filter field, only action names that contain 
that string will appears in the list along with mainline and the current action.
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The Actions List
Below the buttons is the actions list, which contains a list of all actions available for 
the current layer. You can display the Actions list in one of four views:

• All: Displays all actions in your project.

• Regular: Displays actions of a general nature, and which are not configured as 
morphs or smart bones.

• Morphs: Displays a list of actions that apply to morphs only. See “Creating 
Morphs (Pro Only)” on page 370 for further steps.

• Smart Bones: Displays a list of actions that apply only to Smart Bones. See “Smart 
Bones (Pro Only)” on page 103 for more information.

New layers have no actions, just “Mainline”, which represents the main animation 
timeline.

The Actions List Context Menu
If you right-click an action in the Actions list, a context menu presents several 
options, many of which serve the same functions as the buttons at the top of the 
Actions window:

 The Actions window

• Make Active: Sets the action that you right-clicked as the currently active 
action.

• Insert Reference: Adds an action to the timeline (see “Using Actions (Pro Only)” 
on page 373)

• Insert Copy:Adds a copy of an action to the timeline (see “Using Actions (Pro 
Only)” on page 373)

• Rename: Opens the Action Name dialog, where you can enter a new name 
and shortcut key for the action.

• Convert to Relative: When characters have the same bone structure but do not 
have the same proportions, export the action to a file, and then import it into 
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another character that has different proportions. After importing the action to 
the new character, right-click and choose Convert to Relative. This will cause 
the bones to adapt to the proportions of the new character.

• Export: Actions can be exported for use in other projects. Right-click the action 
and choose Export from the context menu. The file will be saved with the 
.mohoaction extension. 

• Remove External Connection: When you import an action from an external 
file, it will be connected to that file. If you modify the action, the change will 
be reflected in every project that uses that action. If you remove the external 
connection, the action will no longer be dependant.

• Import: Allows you to import an action file that was previously exported from 
another project. Click the Import Action button and locate the action file you 
want to import (.asaction or .mohoaction extension). Alternatively, you can 
right-click inside the action list and choose Import to select your file.

• Delete Action: Deletes the action from the actions list.

Creating New Actions (Pro Only)
To create a new action, just click the New Action button. Moho will prompt you to 
name the action. The new action is created in the current layer and, if the layer is a 
group-type layer, in all of its child layers.

Creating a New Action
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 Default state (left) and Happy morph (right).

After you create your new morph, click the Mainline (top) line in the Actions window. 
The character should return to its default state. 

Double-click to select the Happy action again in the Actions window, and notice 
a single-frame action in the Channels tab of the timeline. Notice that all of the 
keyframes are on Frame 1. This is very important when blending poses. A general 
action can have as many keyframes as you like … but if you want to blend poses, 
the action can only contain a keyframe at Frame 1.

 Select the Happy morph in the Actions window, and notice the keyframes in the 
timeline

Creating Morphs (Pro Only)
Moho allows you to blend several different morph targets together to create a 
combination of actions or effects. For further information on this feature, see “Blend 
Morphs” on page 494.

For example, after we finish our Happy morph, we continue by creating additional 
actions (such as Angry and Sleepy) that we can blend together. Note that the 
action can change keyframes for anything. For example, in addition to moving 
some points, the Angry action also changes the color of the face. Now you should 
have a number of actions, all with single-frame animations that have keyframes on 
frame 1.

You can use the Window > Blend Morphs command to blend the various morphs 
together. For example, you can combine the Happy and Angry morphs to create a 
new expression on the face, as shown below.
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 You can morph any type of value. The Angry morph will change the color of the face 
in addition to changing the facial features.

Editing Actions (Pro Only)
To edit an action, double-click it - this will switch an action into editing mode. (When 
you create a new action, it also starts off in editing mode.) You can tell which action 
is in editing mode by the red arrow to its left, as seen below.
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The Happy action in editing mode.

When you’re editing an action, you’ll also notice a change in the Timeline window. 
The background of the timeline changes color to remind you that you’re editing an 
action, and not the main timeline.

As you edit an action, the timeline works like normal, but instead of working on your 
main animation, you’re working on a little reusable clip. Actions by themselves do 
not appear in your final animation - they only appear if you use them in the main 
timeline. 

To switch back to the main timeline, double-click on the “Mainline” action in the 
actions window. (Mainline is not really an action - it’s just a way to refer to the main 
animation timeline.)

Double-click the Mainline action to return to the regular timeline.
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Using Actions (Pro Only)
When you simply create actions, they won’t appear in the final animation - they 
need to be used in the main timeline. To use an action, you just need to insert it into 
the main timeline, which is a simple process.

Make sure the “Mainline” action is active (double-click it so that it has a red arrow 
next to it).

1. Set the current time to the frame at which you wish to use the action.

2. Click once on the action you wish to use to highlight it.

You can select multiple items in the actions list, allowing you to 
move or delete more than one at the same time. Undo 

can reverse accidents.

The actions window also allows you to filter the action list to 
display only the actions whose names contain the text 

you enter. The Mainline and current action will also be displayed 
along with them.

3. Click either the “Insert Reference” or “Insert Copy” buttons in the Actions 
window. 

 Inserting an action.

 � If you insert an action by reference, Moho will insert a special keyframe 
in the Mainline that refers back to the action you used. Later, if you make 
changes to the action, these changes will automatically be reflected in 
the mainline. 

 � If you insert an action by copy, Moho will simply copy all of the keyframes 
in the action to the mainline, and they will act just like other normal 
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keyframes. If you later modify the action, any changes you make will not 
appear in the mainline.

If you create actions for objects in your scene you can assign shortcuts to those 
actions. You can assign the shortcut when you create an action, or you can right-
click on an existing action and assign a shortcut.

The shortcuts make it easy to reuse the actions in an animation. You can press the 
shortcut keys while an animation is playing back to insert the action into the timeline.

 Setting an Action Shortcut.

Deleting Actions (Pro Only)
To delete an action, click once to make sure it is highlighted, then click the Delete 
Action button. When you delete an action, if that action was inserted by reference 
into the mainline at any point, those inserted references will also disappear. If you 
inserted the action as a copy, those copies will remain unchanged.
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Moho Menus
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 File Menu (Pro-only features marked)
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New
Creates a new, empty Moho project using the default project settings (NTSC D1, 720 
x 534 pixels). Use the Project Settings command (“Project Settings...” on page 385) 
to change your project settings if desired.

Moho names the first new document Untitled.moho. After that, each new document 
is named Untitled x.moho, where x is a number that is one higher than the number of 
untitled documents that are currently opened.

Multiple Document Support
When you create a new document, it will open in a new tab and keep the other 
documents open in their own tabs. You can drag the tabs left or right to change the 
order in which they appear. Moho allows you to have up to 64 documents open at 
the same time. You will receive an alert when that number is exceeded.

Use the View > Show Document Tabs command or the keyboard shortcut 
Command/Ctrl Shift J to show and hide the document tabs in the interface. If the 
tabs are hidden, you can select documents in the following ways:

• A chevron control appears in the far right corner of the document tab bar 
when you have opened more documents than can be displayed there. Click 
this chevron to display a menu of all opened documents. When you choose a 
document from the menu, Moho will move it to the first tab in the document tab 
bar.

 Click the chevron at the far right corner of the document tab to display a menu of 
additional opened documents.

• A document tab will display a pencil icon to the right of the document name 
when that document contains any unsaved changes.
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 Unsaved Changes icon.

• Open documents also appear in a list at the bottom of the View menu. Select 
one of the documents in the list to bring it to the foreground.

• To switch to the next document press Ctrl Tab (Windows) or Alt Tab (Mac).

• To switch to the previous document press Ctrl Shift Tab (Windows) or Alt Shift Tab 
(Mac).

Autosave files are generated for all open documents. If the application doesn’t shut 
down properly for some reason, a dialog will give you the opportunity to reopen 
them the next time you launch Moho. Viewport settings and tool selections will also 
be restored.

Document Tab Context Menu
When you right-click one of the document tabs, a context menu displays four menu 
options:

• Save: Saves the document that you right-clicked.

• Revert: Reverts the document to the version that was last saved to disk.

• Close: Closes the document on which you right-clicked.

• Export Animation: Opens the Export Animation dialog, where you can 
specify settings for creating an animation. For further information, see “Export 
Animation...” on page 407.

• Close All Documents: Closes all currently opened documents.

• Close Other Documents: Leaves the current document open but closes all other 
opened documents.
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 Document Tab Context Menu.

New Workspace (Pro Only)
Choose File > New Workspace to select a starting point for your next new project. 
You can select a workspace template from the Workspace dropdown menu. 
Several workspaces are provided with Moho Pro. Each workspace contains different 
folders and files that are useful for that type of workspace. 
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 New Workspace dialog.

New from Template (Pro Only)
Allows you to create a new project based on a template. Expand the submenu to 
see an available list of templates.

Templates are standard MOHO files that are saved to the 
Templates folder within your Moho installation folder. 

For example, if you want to create a template for use in Moho Pro, 
you can save your MOHO file to Lost Marble > Moho 13.5 > 
Templates folder.

Open...
Prompts you to open a Moho project file that was previously saved to disk. The Open 
dialog allows you to select multiple documents. You can also drag one or more 
documents from Windows Explorer or Finder to open them in Moho. Each document 
will open in its own tab.
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Moho will display an alert if you try to open more than 64 
documents.

See “Multiple Document Support” on page 377 for more information.

If you open an Anime file that references an image file that has 
been renamed, you only need to locate it one time, 

even if it used multiple times in the Anime file.

The Moho file format is a JSON-based file format, which is saved with a .moho 
extension. This format will make it easier to maintain backward and forward-
compatible features as newer versions of Moho are released.

The JSON format organizes data in specific, yet flexible, hierarchies. This file format is 
a text-based format that is widely used on the web to communicate data between 
web pages and web services. In Moho, the JSON-based file format will also remove 
the need to export files that are version-specific.

Moho will still read .anme files going back to Anime Studio 6. 

In Moho Pro, the .moho format can be saved with Metadata in 
the document. This behavior will also be deprecated in 

favor of a “ScriptData” object that is only used in user scripts. We 
recommend that you prefix any script data with a distinguishing 
name in order to avoid data collisions with other user scripts. In 
addition, we recommend that this data is no longer intermingled 
with data that Moho saves as metadata.

The .moho format is a compressed JSON-based file format, which is the default file 
format used by Moho. Essentially, it is a ZIP archive with a .moho extension. We have 
used a standard compression file format so that you can expand the archive with 
standard archive tools. When you decompress the file you will find a file named 
project.mohoproj. The archive file may also include a preview.jpg file, which is a 
preview image of the document. You can choose the desired thumbnail size in 
the Documents tab of the Preferences dialog. Select the desired thumbnail size (or 
choose No Thumbnails) from the Document preview thumbnail size dropdown list.

Detailed information about the new file format appears in 
“Appendix F: Moho Document File Format” on page 

551.

Open Recent
Displays a list of recent files that you can reopen. Files that have been moved or 
deleted since saving them will automatically be removed from the list.

To clear the list of recent files, choose File > Open Recent, and click the Clear Menu 
command at the bottom of the list.
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On Macintosh systems you can also open recent documents 
by right-clicking the application icon in the dock, and 

selecting one of the recent documents from the popup menu.

Close
Closes the current project. You can also close a document by clicking the X that 
appears in the left side of the document tab when you hover over the tab.

 Click the X in the tab to close the current document.

Close All
Closes all opened documents. You will be prompted to save unsaved changes 
befrore the document closes.

You can also right-click on a document tab and select Close 
All from a context menu.

Save
Saves the current project to disk.

Your Moho project is automatically saved every 30 seconds 
while you work, to a temporary location on your hard 

drive. If the application crashes, you will be asked if you want to 
reopen the previous project the next time you start Moho.

Moho documents are now saved with a preview thumbnail. By 
default the it generates a thumbnail that is 128 x 128 

pixels. You can set thumbnail preferences in the Preferences dialog. 
See “General Tab” on page 435 for more information about 
thumbnail options.

Save As...
Prompts you for a name and location, then saves the project to disk.
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Save All
Saves all open documents that have unsaved changes.

Revert
Revert the current document to its last saved state. This command is disabled if the 
active document has not yet been saved, or if there are no unsaved changes.

Gather Media
When you import something into a Moho project, such as an image, movie, or 
audio file, the original locations of the imported objects are only referenced within 
the Moho project. In other words, they are not actually part of the project file itself, 
rather the project file links to the files on your disk(s).

If your project contains many external files, we recommend that you place them in 
a common folder. When you do that, you have a self-contained folder that you can 
copy, archive, or move the project and the project will still work.

If you haven’t kept your files in a single folder, the File > Gather Media command 
allows you to create a single location for all related project files. This is very useful 
if you need to send your project to someone else for collaboration or for technical 
support.

After choosing the command, you are prompted to select or create a folder in 
which to store the project-related files. You then enter a name for the gathered 
project and click Save to save it to the selected folder. When you look in the folder, 
you will see the Moho project file, along with Audio, Images, and/or Movies folders 
that store the collected media associated with it. A thumbnail image of the project 
will also be saved.

A bill of materials.txt file is also included, and lists all files required by the project. This 
bill of material also lists switch layer data as well as items such as fonts, and brushes 
that may not be included when gathering. The Bill of Materials document also lists 
other Moho documents with layers referenced by the gathered document. Media 
used by reference layers is gathered, but not the Moho document containing the 
referenced layer.

Poser scenes will not get gathered, due to the complex 
structure of the Poser library folder hierarchy.
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 A Gathered Media folder

Export as Version 9 File (Pro Only)
The File > Export as Version 9 File command will export a project file that is 
compatible with Anime Studio 9.

The algorithims that underly blurs (layer blur, shadows, shading, 
depth of field, etc.) and variable width lines changed 

in Anime Studio 10. Exporting them to Version 9 may produce slightly 
different results.

Any of the following features that are used in an Anime Studio 10 project will not be 
exported when you choose this command:

• Bone targets

• Independent bone angles

• Squash and Stretch bones

• Hidden bones

• Shy bones

• Stagger interpolation

• Bounce and Elastic interpolation

• Texture fill effects with transparency option

• Threshold effects

• Use of new brushes.

Export as Version 10 File (Pro Only)
The File > Export as Version 10 File command will export a project file that is 
compatible with Anime Studio 10.
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Export as Version 11 File (Pro Only)
The File > Export as Version 10 File command will export a project file that can be 
opened in Anime Studio 11. This command does not make the project compatible 
with Anime Studio 11.

Remove Comments & Tags
The FIle > Remove Comments and Tags command will remove all comments and 
tags from the currently selected document. They will be removed from the Project 
Settings dialog, as well as all layers in the document.

Project Settings...
Brings up the project settings dialog. As seen below, the project settings dialog 
lets you control the pixel width and height of the project, as well as the number of 
frames per second. You’re free to change these values at any time, although it’s 
easiest if you set up the values you want before you start creating your animation 
(particularly the frame rate). Also in this dialog, you can set the start and end frames 
of your animation, defining how long the overall animation will be.

 The Project Settings dialog

Dimensions
• Dimensions menu: Allows you to set Custom dimensions, or choose from a wide 

variety of presets. Presets include the following:

 � Custom: Allows you to enter or edit your own settings.
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 � NTSC D1: 720 x 534 pixels, 24 frames per second

 � NTSC D1 Widescreen (Pro Only): 872 x 486 pixels, 24 frames per second

 � PAL D1/DV: 788 x 576 pixels, 24 frames per second

 � PAL D1/DV Widescreen (Pro Only): 1050 x 576 pixels, 24 frames per second

 � 480p Widescreen: 852 x 480, 24 frames per second

 � 720p (HDV/HDTV) (Pro Only): 1280 x 720 pixels, 24 frames per second

 � 1080p (HDTV) (Pro Only): 1920 x 1080 pixels, 24 frames per second

 � VGA: 640 x 480 pixels, 24 frames per second

 � Web: 320 x 240 pixels, 24 frames per second

 � Web Widescreen: 426 x 240 pixels, 24 frames per second

 � YouTube: 640x480 pixels, 24 frames per second

 � YouTube 720p (Pro Only): 1280 x 720 pixels, 24 frames per second

 � YouTube 1080p (Pro Only): 1920 x 1080 pixels, 24 frames per second

 � iPhone: 480 x 320 pixels, 24 frames per second

 � Constrain Proportions: This option allows you to maintain the aspect ratio 
of your animation project. When the option is checked, you can enter a 
new width or height, and the other dimension will automatically change 
to maintain the same width-to-height aspect ratio. If you choose one of 
the preset configurations from the Dimensions drop-down list, it will ignore 
the Constrain Proportions option and resize your project to the dimensions 
specified in the selected preset.

• When you select a preset, the following settings appear below.

 � Width: The width, in pixels

 � Height: The height, in pixels

 � Frame Rate: The number of frames per second in the animation.

 � Start Frame: The starting frame of the animation.

 � End Frame: The ending frame of the animation.

Background Color
• Background Color: Sets a background color for the project - just click on the 

color swatch to select a color from the Color Picker. You can also click and 
drag from the Eyedropper to select a color from the style window or from 
anywhere on your screen.

Depth of Field (Pro Only)
• Depth of Field: Depth of field simulates a camera, where a certain range of 

objects are in focus, while closer or more distant objects become blurry

 � Enabled: Check this option to enable or disable the Depth of Field feature 
in your project.
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 � Focus Distance: The focus distance value is the distance from the camera 
to the plane of perfect focus.

 � Focus Range: Objects that are within the “focus range” distance of this 
plane will also appear in focus. For this feature to work correctly, you need 
to set up multiple layers with different depth values so that some can be 
in focus, and others out of focus. If you move the layers (or the camera) 
in your animation, the focus will automatically change based on distance 
from the camera.

 � Max Blur Radius: Sets a maximum value for the blurriness of your scene.

Moho makes it easy to define sharp and blurry areas when Depth of 
Field is used. “Tutorial 6.6: Using Pre-made Particle Effects (Pro Only)” 
on page 256 in your Moho Tutorial Manual shows how to use these 
features.

Render Style (Pro Only)
The Render Style section allows you to select the type of rendering that will be 
performed when you choose the File > Preview command, or use the Cmd +R (Mac) 
or Ctrl R (Windows) shortcuts.

The following settings are included in this section:

• Fill Style: Select the fill style that you want to use each time you render. Choices 
are Normal, None (same as turning the Fill option off in the Style window); 
Background; Back Transparent; Crayon; Hatched, and Pen. The preview window 
updates as you make your selections.
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 Global Fill styles

• Stroke Style: Select the stroke style that you want to use each time you render. 
Choices are Normal; None; Basic Black; Sketchy; Crayon; and Pen. The preview 
window updates as you make your selections. In addition, there is a Chalk 
style that is designed for use with a white stroke color on a dark background as 
shown below.

The Crayon style is also available as an effect in the Advanced 
view of the Style window.
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 Global Stroke styles.

 Chalk Stroke style.

• Layer Style: Select the layer style that you want to use each time you render. 
Choices are Normal, Heavy Outline, and Cutout. The preview window updates 
as you make your selections.
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 Global Layer styles.

• Minimize frame-to-frame randomness: If this option is not checked, styles like 
crayon will have lines that appear different on each frame, which can cause 
some distraction unless frame rates are lower and the effect is intentional. When 
you turn this option on, Moho will try to use the same crayon strokes from frame 
to frame to reduce the amount of flickering.

Other Settings
• Sort Layers by Depth: The “Sort layers by depth” checkbox allows top-level 

layers in Moho to move in front of and behind each other during an animation. 
Normally, layers are drawn in the order they appear in the Layers Window. 
However, with this option turned on, layers are displayed according to how far 
they are from the camera. See “Tutorial 5.5: Sorting Layers by Depth (Pro Only)” 
on page 192 in your Moho Tutorial Manual for an example of using this feature.

• Sort by True Distance: Typically, layers are sorted by their depth from the 
camera, but if you’re trying to create a 3D object using multiple Moho layers 
(like a cube or pyramid), you may want to turn on “Sort by true distance”. This 
tells Moho to sort layers by the distance from the camera to the layers’ origins, 
rather than by depth. Usually this option will be left unchecked.

• Antialiasing (Pro Only): Antialiases the project. Can be used on its own, or 
combined with pixellation.

• Noise Grain (Pro Only): With the “Noise grain” field, you can set up some noise 
grain for the project. Noise grain is a subtle film grain-type effect that adds 
slight variations to the pixels in your project and leads to a more natural look 
to the final image. It can also increase the visual quality in some kinds of movie 
compression when you generate an animation. If you want to try out noise 
grain, a value of 16 is a good start for a subtle noise effect.
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• Pixelation (Pro Only): Allows you to create pixellated renders. The amount of 
pixelation is determined by the value you enter in the Pixelation field. The higher 
the value (for example: 2, 4, 8, or 16) the more blocky the render appears.

• Stereo Rendering (Pro Only): Use the Stereo Rendering drop-Down to select the 
type of stereo rendering you want to perform:

 � None: Turns off stereo rendering capabilities.

3D Rendering settings should be set to None if you do not want 
to render out in a 3D format).

 � Red/Blue Anaglyph (Pro Only): When you render or preview your project 
with this setting enabled, you will see 3D objects rendered as a red/blue 
stereo pair. You will need special red/blue stereo 3D glasses to see the 
object in three dimensional space.

 � Side By Side (YouTube friendly) (Pro Only): Produces two separate images 
rendered side by side in the same image, one for the left eye and one for 
the right eye.

 � Cross-eyed (Pro Only): Looks similar to Side by Side, except that the left 
eye image is on the right side, and the right eye image is on the left side. 
This is the type of stereo rendering that YouTube expects.

Choose View > Stereo to see a live preview of the Red/Blue 
stereo effects. This makes it easier to preview and 

reposition your 3D objects

 3D Stereo view

• Eye Separation (Pro Only): This setting controls how far apart the right and left 
eyes are when rendering two images for a stereo rendering. If the value is too 
close, the 3D effect is lost. If the value is too far apart, the 3D effect will cause 
eye strain or won’t look as effective.
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• Extra SWF Frame: Check this option to add an extra frame at the end of the 
video

• Save as Defaults: When you create a new project in Moho, your animation 
defaults to 320x240 pixels at 24 frames per second. If you create most of your 
projects at different settings, you can change these defaults. Just type in new 
values in this dialog, and click “Save As Defaults” to make the new settings the 
default settings for all new projects.

• Restore Defaults: Resets the project to the default values.

• XMP Tags: (Pro only) Allows you to enter metadata tags that apply to the entire 
document.

• XMP Comments: (Pro only) Allows you to enter comments that apply to the 
entire document.

(Pro Only) Project tags and comments that are entered in the 
XMP Tags and XMP Comments fields will be stored 

within the moho project file. XMP information also includes height, 
width, framerate, frame start and frame end information from the 
project.

Import
Moho can import several kinds of other media files into an animation project. The 
commands in this sub-menu let you import these files.

• General Import: This menu option will allow you to import any type of file that is 
supported by Moho.

• Moho Object: This command will ask you to choose a Moho project file. Once 
you’ve chosen a file, a list of layers in the project will show up in the dialog. If the 
imported Moho project file used Lua scripts, you can import the script as a copy, 
import by reference, or ask user.
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 The Insert Object dialog

Checkboxes appear to the left of each of the items in the scene you want to 
import. Check one or more of the layers to add it to your own project (a preview 
of the selected layer appears on the right side of the dialog. The Uncheck All 
or Check All buttons can be used to deselect or select all of the items in the 
project. Press OK to copy the selected layers into your open project, including 
any animation in the layer. This is an easy way to share objects between project 
files and reuse bits of animation here and there.

Several files are included with Moho that contain scenery, characters, props, 
etc. You are welcome to include these in your own projects by using this menu 
command.

• Moho Styles (Pro Only): Choose this command to select a .mohostyle document 
or a .moho project containing styles you would like to import into the current 
project. If the item you select contains styles not already in the current project 
they will be added to the project.

• Image Imports an image file as a new Image layer. The most common type 
of file to import into Moho is images. It doesn’t matter how the images are 
created, so feel free to use pictures from digital cameras, backgrounds from 
scanned drawings or painted on the computer, textures, computer-generated 
3D scenery, etc. The image formats supported by Moho are: JPEG, BMP, Targa, 
GIF, and PNG. Generally, we recommend PNG, since the PNG format provides 
for variable levels of transparency, allowing you to create non-rectangular 
images that can blend in smoothly with other elements in the scene.

• Movie: Imports a movie file as a new Image layer. Moho supports importing 
QuickTime (Windows and Mac OS) and AVI (Windows only) movie files. A movie 
that you import into Moho will play back along with the Moho animation, 
allowing you to combine 2D and 3D elements, or to composite a Moho 
animation on top of a pre-recorded video sequence. On Windows, if you have 
problems importing QuickTime movies, then you probably need to download 
and install QuickTime (http://www.apple.com/quicktime/). Moho will also import 
native Anime Studio files (files ending with .anme or .anime).
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• Vector File (Pro Only): (Moho Pro only) Asks you to select an Adobe Illustrator 
(.ai) file (http://www.adobe.com), SVG file, or EPS file. Moho will import the 
bezier curve shapes in this file into a new Moho vector layer. These objects can 
then be further edited and animated in Moho. Moho can import vector artwork 
created in other vector illustration programs. These files can be in Adobe 
Illustrator, EPS, or SVG format. If your files are in Illustrator format, make sure that 
you save them as Illustrator 8 (or earlier) format.

You can open multiple Illustrator files at once. Simply drag and 
drop multiple Illustrator files into the Moho window.

• Tracing Image (Pro Only): (Moho Pro only) Loads an image file to be used for 
tracing purposes. The image formats supported by Moho are listed in “Appendix 
A: Product Comparison” on page 524. The Tracing Image command is the 
same thing as “Select Tracing Image” in the View menu.

• Audio File: Loads a sound file to be used as a soundtrack for the current 
animation. The audio formats supported by Moho are listed in “Appendix A: 
Product Comparison” on page 524. Moho uses libsndfile to handle sound 
files (see http://www.mega-nerd.com/libsndfile/), so any format that libsndfile 
supports is fair game. Generally, it’s best to stick with uncompressed WAV or AIFF 
files.

• OBJ 3D Model (Pro Only): Imports a 3D model as a new Moho 3D layer. Moho 
can import 3D files that are in OBJ format. More information about 3D layers 
can be found in “3D Layers (Pro Only)” on page 200. Finally, Moho can import 
3D files created by 3D modeling programs. At this time Moho can only import 
OBJ files, but it’s a quite common format, and most 3D programs can export to 
OBJ. OBJ files can include texture maps, and if your model uses one, Moho will 
import and use it as well. If you’re new to 3D, and you’re looking for a program 
to create 3D models for use with Moho, we recommend Poser.

• Poser Scene (Pro Only): If you already own Poser, you can import Poser scenes 
directly as discussed in “Poser (Pro Only)” on page 142.
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 An imported Poser scene

They are also editable in the Style window. You can turn the stroke on or off, and 
adjust the width of the stroke.

Many OBJ files and Poser objects have multiple materials. The 
multiple materials will show up as Shapes in the Style 

window. Select a material from the Shapes drop-Down (discussed in 
“Shapes” on page 256) and change material settings if desired. If 
you select None from the Shapes drop-Down it controls the default 
material and stroke.
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 Materials appear as Shapes in the Style window

When you are using a 3D layer, you can open the Layers Window 
and go to the 3D Options tab to control some additional properties. 
See “3D Options (Pro Only)” on page 250 for more information.

The lower section of the File > Import menu displays several different categories 
that allow you to open content that is furnished with Moho. You will also find 
these items in the Library (see “Chapter 14: The Library Window” on page 289). 
In the Import menu this content is arranged in the following categories: 3D, 
Audio, Characters, Effects, Images, Props, Scenes, and Video.
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Real-Time Media Connection (Pro 
Only)
The “live linking” feature allows you to import images, movies and sound files and 
then edit them in their native editors without worry. Any edits you make later in third 
party editors will automatically be recognized and updated within Moho.

When media that is referenced by projects is changed in the 
background, Moho will sync those changes your 

project. If a large number of changes are updated at once, Moho 
may not notice the changes until the main window is brought to the 
foreground, or brought to the front after appearing behind a non-
floating window.

Real-time media connections, combined with Photoshop layer support on import, 
provide an exceptional way to design characters and other content for your Moho 
scenes. For more information on Photoshop support, see “About Photoshop Layer 
Support (Pro Only)” on page 403.

Poser Integration (Pro Only)
Choose File > Import > Poser Scene. Locate the PZ3 file that you want to import. After 
a brief wait, the Poser file will be imported into your scene. For further information, 
see information on the Poser tool, discussed in “Poser (Pro Only)” on page 142.

Import Notes and Tips
Referenced Files
Please note that Moho references the directory location of images, OBJ’s, sound 
files and movies files that have been imported for use. When exporting into movie 
format, Moho continues to reference this directory location. Moving referenced 
items from one location to another will prevent the item from being displayed or 
heard. We recommend that all items used in your animations or artwork accompany 
it’s native file format (ANME) and final exported format.

Startup Folder
Adding your own .moho file to the “Startup Folder” (located in the root directory of 
your Moho installation) will always make Moho open this .moho document first when 
it’s initially launched. Please make sure to rename your .moho file to “StartupFile.
moho”.

Moho Files
Moho will also import native Moho files (files ending with .moho).
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Library Content
Please read Section 6 of the EULA (End User License Agreement) for rules on using 
the content that has been supplied with your version of Moho. Please note that 
when importing existing content/movies from the Moho Content Library using the File 
> Import option, some animations/movies exceed the default “End Frame”. This will 
prevent you from seeing the full movie. To adjust the default “End Frame” settings, 
please select File > Project Settings and change the field beside “End Frame”. You 
can also double click the movie/content file you would like to view from within the 
Content Library. To access the Library, select Help > Open Content Library.

The Library content files (characters, props, etc.) are installed in 
a shared documents location on both Windows and 

Macintosh. This allows multiple users on the same computer to share 
library resources, and to install additional content that they might 
download (from Content Paradise, for example). On Windows 
systems in particular, it can be difficult to add new files to the 
Program Files directory when running newer versions of the Windows 
operating system, which is why the shared documents location is 
used.

Importing 3D OBJ’s (Pro Only)
Please note that loading 3D OBJ files may take some time. Loading times depend on 
the complexity of the OBJ file.

Photoshop Tips
Importing Photoshop Files (Pro Only)
When you use the File > Import > Image command to import a Photoshop file into 
Moho, a dialog will ask how you want to handle the layer import within Moho.

 Photoshop images can be imported with individual layers, or as a composite image.
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If Moho detects unsupported layers, you will be prompted to 
cancel the import, or to import the PSD file as a 

composite image.

The choices are:

• Individually: Choose this option if you want to retain the Photoshop layers 
when you import your Photoshop file. Each Photoshop layer will appear in the 
Layers Window and will be named exactly as they are named in the original 
Photoshop file. You will be able to show and hide the layers individually within 
Moho in the same way that you can in Photoshop, and you will be able to use 
the Moho tools to modify or animate the layers.

 Photoshop layers shown in Photoshop.
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 Photoshop layers shown in Moho Pro.

Further, you can group layers in Photoshop that can be interpreted as layers in 
Moho. For example, you can create a Photoshop group that contains various 
mouth positions. If you make only one of those mouths visible in the group before 
you import the Photoshop file into Moho, the other layers in the group will be 
configured as switch layers for the visible mouth when it appears inside Moho.
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 Mouth group in Photoshop (with one mouth layer visible).
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 Mouth group in Moho Pro (with the same mouth layer visible).

There will also be a live connection between Moho and Photoshop, such that 
if you make changes to the Photoshop file and resave it, the changes will also 
appear in your Moho project.

If you add new layers to a PSD file that has been imported into 
Moho, the new layers will automatically be imported 

into your project.

If layers are reordered in the original PSD file, Moho will maintain 
its own layer order, but the PSD layers will still be 

properly referenced.

The opacity of a Photoshop layer will be baked in Moho when 
imported. In other words, if the opacity of a layer was 

set to 50% in Photoshop, Moho will see that as the 100% value. You 
will not be able to increase to 100% in Moho.

• Composite: Choose this option if you want the Photoshop file to be combined 
into a single image layer in Moho.

• Select Layers: Click the Select Layers button to choose specific layers in the 
Photoshop file for import into Moho. The Insert Object dialog appears and allows 
you to check or uncheck all of the layers in the Photoshop document, or to 
select or deselect layers one at a time.



Moho 13.5
Users Manual 

403

Chapter 18: File Menu

About Photoshop Layer Support (Pro Only)
When importing a PSD file, you have the option to load layers individually or load the 
composite as a single layer.

The live linking feature between Photoshop and Moho may 
work unexpectedly in certain situations. The live link 

works as expected when layers are edited and left visible in 
Photoshop. However, the live link may work unexpectedly after 
importing into Moho if you later move, delete, or hide layers in 
Photoshop and then return to Moho.

Photoshop has many features, and not all of them are supported within Moho. In 
general, standard 8-bit RGB files with regular pixel layers are the best way to go for 
compatibility.

Moho has been tested with several Photoshop examples, and the following 
Photoshop features are known to work within Moho:

• Blending modes are supported

• Layer opacity is supported. 

• Layers that are set to invisible will be kept invisible upon import into Moho.

• Groups are supported. Groups where only one child of the group is visible come 
in as switch layers.

• Smart objects and smart filters do work internally to the PSD. They store a flat 
representation of themselves.

The following Photoshop features are not supported in Moho:

• Layer effects are not imported.

• Any layer that has a mask in Photoshop gets skipped.

• 3D layers, text layers, and other kinds of non-basic or non-pixel layers cannot be 
imported.

• Layers that have visibility turned off in Photoshop will have their names grayed 
out in the Moho Layers Window.

Using Moho with Unity (Pro Only)
Moho Pro provides a Unity Import script that improves performance of Moho projects 
in Unity 5.3 or later. When you use the FBX export in Moho in conjunction with a Unity 
Import script (also provided with Moho Pro), you will see improvements in how Unity 
displays layering and lighting of your Moho FBX files.

FBX files that were exported from Anime Studio 11 or Anime 
Studio 11.1 will have to be imported into Anime Studio 

11.2 or later and then re-exported as FBX again in order to work 
properly with the steps noted below.

To use Moho projects inside Unity, proceed as follows:



Moho 13.5
Users Manual 

404

Chapter 18: File Menu

1. After your Moho project is complete, choose File > Export > Export FBX. Choose 
a folder and a file name for your FBX file and click Save.

2. Create a new project in Unity.

3. From Moho Pro, choose File > Open Custom Content Folder to open the Custom 
Content Folder on your hard drive. Select the Extra Files > Unity Importer folder, 
and locate the AnimeStudioFBXImporter.cs script. Copy this script into the Assets 
> Editor folder in your Unity project. (If this folder does not exist in your project 
you will need to create it).

4. Locate the FBX file that you saved with Moho Pro, and import it into the Unity 
Assets window.

5. Preview the content in the Unity preview window to verify that it appears the 
same as it did in Moho.

Exporting from Photoshop
Moho is equipped with a Photoshop export script that will give you the ability to take 
your PSD files and export them into .moho format. The .moho format is the native 
Moho format. This process helps users from having to re-draw or export individual 
layers as images into Moho.

The PSD to ANME script is named Export Layers To Moho.jsx. To access this script, 
please make sure you’ve configured a content location as described in “Creating a 
Content Folder” on page 16. The script will be copied into that folder.

To use the script within Adobe Photoshop, copy the Export Layers To Moho.jsx file 
to your .../Photoshop/Presets/Scripts folder. You should then be able to open up a 
Photoshop document, run this script from File > Scripts > Export Layers to Moho, and 
it will generate a new Moho file complete with an image layer for each original 
Photoshop layer. Basically, the script converts PSD formatted files to .moho files. It 
exports every layer that was created originally in Adobe Photoshop and makes it 
completely readable when imported into Moho. All versions of Adobe Photoshop 
since version 7 should support this script.

The script exports the following 2 things: Firstly, it converts the PSD file into a .moho 
file. Secondly, all the individual layers of the PSD file are converted into individual 
PNG files and are placed in a folder of the same name as the .moho file. The folder 
with the PNG’s and the newly converted .moho file will be located side by side. It is 
important to note that whenever you open the .moho file, it will reference the PNG 
folder. So please keep them side by side. If the PNG folder and the newly converted 
.moho are not located in the same folder, the layers within your newly opened 
.moho will not work properly in Moho.

Show in Explorer (Windows only)
The File > Show in Explorer command will reveal the source project file for the current 
document in Windows Explorer when this command is selected. 
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Show in Finder (Mac only)
The File > Show in Finder (Mac) command will reveal the source project file for the 
current document in the Mac Finder when this command is selected. 

Refresh Media
The File > Refresh Media command (or the keyboard shortcut Command/Ctrl M) 
causes Moho to check the modification dates of all of the media that is referenced 
in the project, and will reload the media that has changed.

Preview
Generates a preview image of what your project will look like. If you’re in the process 
of animating your project, the image will be of the current frame in your animation. 
A preview image does not contain all the fill styles, and is of lower quality, but is 
quicker to generate than a fully rendered image.

When the Preview window opens up to display your work, you can save the preview 
as a still image, using the popup menu in the Preview window. By default, the file will 
be named with the name of your project, followed by the frame number.

The following options are available in the Preview window:

 Preview window.

• Render Cache: Click to place a preview render in your render cache. By default 
you can store up to 100 preview images in your render cache, which has to 
be located in a User Content folder. If you did not set up a User Content folder 
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during installation, see See “Creating a Content Folder” on page 16 for more 
information.

The Options tab in the General Preferences dialog allows you 
to specify the number of images stored in your Render 

Cache. See “General Tab” on page 435 for more information.

• Save As: Expand the menu to choose the file format (JPG, BMP, Targa, or 
PNG). You can also copy the image to a clipboard and paste it into another 
application.

• Zoom: Move the scrollbar left or right to zoom in and out of the image. You can 
also use the mouse scrollwheel to zoom in or out.

• Percentage field: Allows you to enter a zoom percentage value.

• Restore Defaults: Resets the preview window to the default zoom level.

Preview No Antialiasing (Pro Only)
Use the File > Preview No Antialiasing command to generate a quick preview of 
your work. Jagged edges will be visible on slanted or curved surfaces.

 Antialiasing (top); No antialiasing (bottom).
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Preview Animation (Pro Only)
The File > Preview Animation command performs a screen capture of the items on 
the canvas during playback and saves it as a movie file. You can also generate 
a preview animation by holding down the Option key (Mac) or Alt key (Windows) 
while clicking the Play button.

Export Animation...
This command brings up a dialog that lets you export an animated sequence and 
save it to disk. The Moho project file is where your work is saved, but to view the 
animation as a movie, to put it on the web, or to work with it in other programs, you 
have to export the animation.
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 The Export Animation dialog.

The options in this dialog are:

• Project:

 � Start Frame: Enter the start frame for your exported movie here.

 � End Frame: Enter the end frame for your exported movie here.



Moho 13.5
Users Manual 

409

Chapter 18: File Menu

 � Entire Animation: Press this button to reset the start and end frames to 
include all frames in the movie

• Output:

 � Format: The options in the Export Animation dialog are described in 
“Output Formats and Presets” on page 411:

 � Preset: The options in the Preset list are described in “Output Formats and 
Presets” on page 411:

 � Quality: Move the slider left to decrease quality (creates a smaller file). 
Move the slider right to increase quality (creates a larger file).

• Render Options:

 � Enable multi-threaded rendering (Pro Only): With this option unchecked, 
only one thread will be used to rendering. With the option checked, up to 
four threads will be used.

 � Render at half dimensions: Check this box to render a smaller version of 
your movie. The output resolution is as indicated in the dialog. This makes 
rendering faster if you just want a quick preview, and is useful for making 
smaller movies for the web.

 � Render at half frame rate: Check this box to skip every other frame in the 
animation. This makes rendering faster, and results in smaller movie files.

 � Apply shape effects  (Pro Only): If this box is unchecked, Moho will skip 
shape effects like shading, texture fills, and gradients.

 � Apply layer effects: If this box is unchecked, Moho will skip layer effects like 
layer shadows and layer transparency.

 � Reduced particles  (Pro Only)): Some particle effects require hundreds of 
particles to achieve their effect. Check this box to render fewer particles. 
The effect may not look as good, but will render much faster if all you need 
is a preview.

 � Render layer comp (Pro Only): Check the option and select the desired 
layer comp to render.

 � Antialiased edges  (Pro Only): Normally, Moho renders your shapes with 
smoothed edges. Uncheck this box to turn this feature off.

 � Extra-smooth images: Renders image layers with a higher quality level. 
Exporting takes longer with this option on.

 � Do not premultiply alpha channel (Pro Only): Useful if you plan to 
composite your Moho animation with other elements in a video editing 
program.

 � Use NTSC-safe colors (Pro Only): Automatically limits colors to be NTSC safe. 
This is only an approximation - you should still do some testing to make sure 
your animation looks good on a TV monitor.

 � Variable line widths (SWF)  (Pro Only): Exports variable line widths to SWF. 
See “What to Avoid” on page 417 for more information about variable 
width lines and Flash.
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 � Animated GIF Options (Pro Only): Enabled when Animated GIF is selected 
for output format. For additional information, see “Exporting Animated GIF 
Files (Pro Only)” on page 413.

 � Render layer comp: (Pro only) When you export layer comps, the name of 
the layer comp will be added to the name of the output file. Check the 
option and select the layer comp you want to render.

 � Overwrite existing files: (Pro only) Check this option to overwrite existing 
files if desired. If you choose not to overwrite existing files, a number will 
be appended to name of the new file to prevent overwriting the existing 
version.

• Destination: (Pro only) Options in the Destination section determine where your 
renders will be saved:

 Destination options.

 � Export to: Allows you to choose the localion where the project will be 
exported. You can export to the same folder as the project file, or specify 
another location.

 � Name:  Assigns a name for the exported project. 

• Other Settings: (Pro only)

 � Choose a configuration to apply: Allows you to choose, edit, or create 
render configurations. Click the Edit Configurations button to create a new 
render configuration. If there are no custom configurations, the only choice 
will be Application Defaults. 

 � Save As Defaults: Click the button to save the present settings as the new 
export defaults.

When exporting a movie, Moho will include an alpha channel if the codec you’re 
using supports it. This makes it possible to composite Moho movies with other media 
in a video editing program.

If you’re using QuickTime, set the color depth to “Millions of 
Colors+”. The “+” is QuickTime’s indication of an alpha 

channel. The codecs that support this include Animation, None, 
PNG, TGA, and TIFF.

Moho can only export to a maximum size of 900 pixels x 900 
pixels and 3000 frames. (Moho Pro does not have this 

limitation.)
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Output Formats and Presets
The Export Animation dialog has several options for adjusting the output quality 
of your animation. These default to the highest quality rendering, but you may 
sometimes want to lower the quality to increase rendering speed or to output 
animations with smaller file sizes for streaming over the internet.

Supported formats for Windows and Mac, as noted, include the following:

• Image Sequence: Supported image formats are JPEG, BMP, Targa, PNG, or PSD.

• M4V: When choosing M4V format, the following presets are available:

 � Apple M4V (H.264-AAC): Saves the movie in M4V format using H.264 video 
and AAC audio codecs.

 � Apple M4V (JPEG-AAC) (Macintosh Only): 

• MP4: When choosing MP4 format, the following presets are available:

 � Apple M4V (H.264-AAC): Saves the movie in mp4 format using an H.264 
video and AAC audio codec. Windows 7 or higher.

 � Apple M4V (JPEG-AAC) (Macintosh Only): 

• AVI: The following AVI options appear on Windows XP or higher systems only:

 � AVI (MJPEG): 

 � AVI Movie (DV): (Windows XP and higher only). Saves the movie as a 720 x 
480 file in avi format.

 � AVI Movie (Uncompressed): (Windows XP and higher only). Saves the 
movie in avi format using an uncompressed video codec. Expect these 
movies to be large compared to a compressed format like DV.

• AVI (Video for Windows): The following legacy AVI format appear in Windows XP 
or higher systems only: 

 � AVI Movie: Saves the movie in avi format. In the next dialog, the user will 
be prompted for the video codec of the export.

• Flash (SWF): One preset appears for Flash movie export:

 � Flash (SWF): Exports your animation to a Flash SWF file, using the dimensions 
of your project.

• QuickTime: (Mac and 32-bit version of Moho Pro for Windows only. Not available 
in Moho Debut or 64-bit Windows). Saves the movie in QuickTime (mov) format.

On Windows, QuickTime output format only appears in the 32-
bit version of Moho Pro. The 32-bit version of Moho Pro is 

not installed by default; you will need to check the option to install 
during setup. You will also need to have QuickTime player installed.

 � QuickTime (H.264-AAC): 

 � QuickTime (H.264-PCM): 

 � QuickTime (JPEG-AAC): 

 � QuickTime (ProRes 422-AAC): 
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 � QuickTime (ProRes 4444-AAC): 

 � QuickTime (ProRes 4444-ALAC): 

 � QuickTime (ProRes PNG-AAC): 

• Legacy QuickTime: (Mac and 32-bit version of Moho for Windows only, not 
available in Moho 64-bit Windows). Saves the movie in QuickTime (mov) format. 
In the next dialog, you will be prompted for the video codec and quality of the 
export.

On Windows, this output format only appears in Moho Debut, 
and the 32-bit version of Moho Pro. QuickTime software 

must be installed.

The Mac App Store prevents the export of media formats using 
the QuickTime media library. Because of this, the 

QuickTime (PNG-AAC), iPhone Movie, and QuickTime Movie movie 
formats are not supported. The other QuickTime formats are 
supported using the newer AV Foundation media library.

 � QuickTime Movie (Animation): 

 � QuickTime Movie (H.264): 

 � QuickTime Movie (JPEG): 

 � QuickTime Movie (MPEG-4): 

 � QuickTime Movie (PNG): 

• Flash: One preset appears for Flash movie export. See “Exporting Flash” on page 
414.

 � Flash (SWF): Exports your animation to a Flash SWF file, using the dimensions 
of your project. Quality choices allow you to choose a range of movie 
qualities between Maximum and Minimum, with the default selection 
being High quality. The higher the quality, the larger the file size will be, and 
the longer it will take for others to download.

When choosing a compression format or codec for export, 
keep in mind that viewers must also have the same 

codec available to view the file. We recommend that you select a 
basic compression format/codec that is installed with Mac OS X.

• Animated GIF: (Moho Pro only)

 � Animated GIF: See “Exporting Animated GIF Files (Pro Only)” on page 413

• SVG: (Moho Pro only)

 � SVG: See “Exporting Sequential SVG Files (Pro only)” on page 417.

After you select your format and quality, choose OK to render the animation.
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Exporting Animated GIF Files (Pro Only)
Moho allows you to easily create animated GIF files that can be shared on 
FaceBook, or included in web pages and emails. Animated GIF files do not contain 
sound, and they cannot contain any more than 256 colors. However, they can be 
read in a wide variety of applications, including being directly embedded into web 
pages.

To create an animated GIF file, follow these steps:

1. Choose File > Export Animation. The Export Animation dialog appears.

2. Choose Animated GIF from the Format dropdown in the Output section. This 
automatically selects the Animated GIF preset.

3. Click the Animated GIF Options button in the Render Options section. You will 
be presented with the following options:

 � Number of colors: Choose 2, 4, 8, 16, 32, 64, 128, or 256. Default is 16 colors.

Moho looks at the first frame in your animation to choose the 
colors that will be included in the animated GIF. If your 

first frame is a solid color, there is a workaround that you can use to 
select colors from a frame that is more representative of the entire 
animation. See “Notes and Tips” on page 413.

 � Dithering: Reduces bending by creating graduated color transitions.

If possible, turn off dithering in the Animated GIF options - for 
animations with a lot of solid colors this can reduce the 

resulting file size.

 � Transparency: Renders your animation against a transparent background.

If using transparency, set the background color to something 
close to your expected background (often white, gray, 

or black). (This is because animated GIF transparency is an on/off 
situation, so some of the background color can still blend into your 
artwork.)

 � Frame Difference: Keep this option checked to create an optimized 
animation that stores only the changes that are made from frame to 
frame. Unchecking the option creates a larger file because each frame is 
stored in its entirety in the animation.

4. Choose OK to apply your settings. Moho prompts you to select a folder and 
enter a name for your animation. After your animation is exported, you will find 
the GIF file in its saved location.

Notes and Tips

• Be careful with pixel dimensions and duration - the smaller and shorter, the 
better. You will probably want to reduce the project dimensions, because the 
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default settings will create animated GIF files that are very large (1280 x 720 
pixels).

• Flat colors will compress better, and will dither less - avoid gradients and image 
textures if possible.

• Try reducing frames per second to get smaller files.

• Avoid things that cause the entire screen to update, like moving the camera.

• If the first frame in your animation is not a good representation of the colors that 
are included in the entire animation, advance to a frame that does include 
all or most of the colors. Render a preview of that frame (File > Preview, or the 
Ctrl/Cmd+R shortcut) and click the Sample GIF Colors button at the bottom of 
the Preview window. The sampled colors will be remembered in the document. 
When you choose the File > Export Animation command, Moho will remember 
the sampled colors and will use them to compile the animated GIF. 

 Click the Sample GIF Colors at the bottom of the preview window to sample colors 
from a representative frame.

• You can choose specific colors to be included in your animated GIF. To do so, 
create a separate vector layer that you can set as invisible or hidden during 
rendering. This custom color layer can contain simple shapes that are filled with 
the colors you want to include. For example, you can include various shades 
of gray which will cause Moho to convert your animated GIF to grayscale. Use 
the Sample GIF colors in the Preview window to sample the custom colors as 
described previously.

Exporting Flash
Moho can also export Flash files in SWF format. Flash is a common vector animation 
format on the Web. When exporting Flash, Moho will also include the soundtrack 
(if any), if the soundtrack is in MP3 format. If you plan on exporting Flash files, it is 
important to read “How to Create Efficient Flash Files” on page 416.
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If you plan to export your animations to Flash (SWF) format, you 
will need to use MP3 audio files instead of WAV audio 

files. In addition, if you plan to render to SWF format, you can only 
use a single audio file in the project.

Flash Tips
Advice for working with Moho and Flash

Among the other export formats that Moho offers, you also have the option to 
output Flash SWF files. SWF is a format created by Adobe as a way to deliver 
animated vector artwork and interactive applications. Flash animations are very 
common on the web, and most users already have the Flash player installed on 
their computers. Because Moho is also vector-based, there are enough similarities to 
make it possible for Moho to export SWF files.

However, Moho and Flash are not completely compatible. Therefore, not all the 
features of Moho can be exported successfully to Flash. In addition, because Flash 
is a web format, small file size is important - there are certain issues to keep in mind 
when working with Moho if Flash is your intended output format.

When exporting SWF files, you may want to use Macromedia’s Flash authoring tool 
to combine multiple SWF files, add extra elements, sound, etc. Be aware that Moho’s 
SWF files are compatible with Flash MX and later - Flash 5 and earlier are not able to 
load Moho-created SWF files.

What Can be Exported
Most common objects in Moho can be exported to Flash. These include:

• Vector layers

• Fills/Outlines/Colors

• Transparency

• Gradients

• Variable-width lines (try to use these sparingly - see below)

• Bone warping of vector layers

• Image layers (PNG and JPEG only, and only if they are not warped by a bone 
layer)

• Particle layers (careful - a complex particle effect can easily overwhelm Flash)

• A soundtrack can be exported if it’s in MP3 format, and at either 44100 Hz, 
22050 Hz, or 11025 Hz sample rate. If you want your SWF file to contain audio, 
make sure that your project contains only one audio track, and that the audio 
track is in MP3 format. In order for Moho to play MP3 format audio files, you must 
have QuickTime installed
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What Can’t be Exported
On the other hand, some things in Moho are just not compatible with Flash, and 
cannot be exported to a SWF file. The following list covers the most important of 
these objects and effects.

• Brushes

• Fill and line effects (except gradients)

• Layer effects (shadows, shading, layer blur, motion blur, etc.)

• Image warping or 3D movements in image layers

• Image layers that use progressive JPEG images (Flash can’t handle progressive 
JPEG images)

• Layer masking

• 3D layers

• Multiple audio tracks, or audio tracks other than MP3 format

How to Create Efficient Flash Files
When you’re creating an animation with the intent to produce an SWF file as output, 
there are several things to keep in mind. An important concern with SWF files is 
keeping the file size down. 

A new layer is optimized to start with, but depending on the effects you apply, that 
optimization can go away. The following things will “de-optimize” a layer. Note: a 
non-optimized layer will still export to Flash, it just won’t be nearly as efficient.

• 3D camera movements (this will de-optimize all layers in the project, so it should 
be avoided if possible when targeting SWF)

• 3D layer rotation (X or Y rotation, or perspective rotation)

• Layer shear

• A group layer that has 3D rotation or shear will cause all of its sub-layers to be 
non-optimized

• Uneven scaling in the X and Y directions

• Point animation

• Bone animation is a common cause of non-optimized layers. What’s happening 
is that because Flash doesn’t have a bone system like Moho, Moho needs 
to export a lot of extra information for Flash to be able to produce the same 
effect. One way to use bone animation and to stay optimized is to attach a 
vector layer to a single bone, instead of letting the bones warp all the points in 
the vector layer. The vector layer will then remain optimized. While you can’t 
do this in all cases, sometimes you can break up a character into multiple body 
parts - some parts will be warped with the bones, and some will be attached to 
a single bone. At least some parts of the character can remain optimized.

Here are some other things to think about when exporting to SWF:
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• Consider using a lower frame rate (12 fps, for example) for your animation. 
Fewer frames means a smaller file.

• If some of your layers can do without any animation at all, or just layer 
translation/scaling/rotation (background scenery, props, background 
characters, etc.), that can save a lot of space.

• If most of a layer is stationary, except for one small object, move that object 
into its own layer if possible. Example: a character who is waving his arms, but 
is otherwise still - move the arms into a separate layer from the rest of the body. 
The body will remain optimized and take up much less space.

• If an object sits still for a time with no animation, consider replacing it with a non-
animated object for that time period.

What to Avoid
If your goal is to create a SWF animation, there are some things you should try to 
avoid. Besides the effects that just are not possible to export, you should try to avoid 
the following effects if possible. These are all things that can be exported - it’s just 
that they make for a less efficient SWF file. Of course, you won’t want to avoid all of 
these things all of the time. However, if you plan your animation carefully, and use as 
few of the following effects as possible, the resulting SWF file will be smaller, and will 
load quicker over the web.

• 3D camera moves - no Flash optimization is possible when you’re moving the 
camera around in 3D. Simple side-to-side pans and zooms are OK, but when 
you start using camera pan/tilt, Flash efficiency goes down the drain.

• Try to use as few control points as possible in your vector artwork.

• The freehand tool and the insert text dialog can generate a lot of points, 
resulting in a big SWF file.

• Limit the use of variable-width lines. It’s easy to overwhelm Flash with the 
complexity of variable-width lines, making the resulting SWF file play back 
unpredictably. Read “Flash Movie Size Limit” at http://kb2.adobe.com/cps/144/
tn_14437.html for more information. If possible, only use variable-width lines in 
SWF-optimized layers.

• Avoid compound shapes (two adjacent circles filled as one, shapes with holes, 
or figure 8’s).

Exporting Still Images
Finally, you can export an animation as a sequence of numbered still images. This 
option is not used very often, but sometimes for certain post-processing tasks, you 
may prefer to work with a sequence of separate still image files. You can choose 
between JPEG, BMP, PSD, Targa, or PNG.

Exporting Sequential SVG Files (Pro only)
To export sequential SVG files (either through the Export command or the Moho 
Exporter), choose SVG from the format popup in the Export Animation dialog. 
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Image-based features that work only on rendered images in Moho (such as layer 
blur, layer shadows, and so on) will not be exported to the SVG files.

The progress bars will display render progress. Sequenced files will appear in the 
directory that you selected. Each file can be brought into Adobe Illustrator (or 
another vector editing program).

SVG export does not support all features found in Moho 13.5:

• You can output vectors, bone features, physics, colors, styles, and gradients. 

• Image-based features like layer blur, layer shadow, and other features that work 
like pixel filters on a layered image are not supported in the SVG export.

• Masking is limited. 

• Images can be exported, but it is not possible to warp them. 

 Exporting Sequential SVG files.

Export Animation with Previous Settings
After you export an animation once, you can use the File > Export Animation with 
Previous Settings command to render another animation without having to specify 
animation settings again. The new file will be rendered with the settings that were 
previously used.

By default, Moho will notify you when a file of the same name 
already exists in the location that you are exporting to. 

You can disable this alert in the General tab of the Preferences 
dialog. Uncheck the When exporting alert on file conflict option to 
suppress the alert.
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Export FBX (Pro Only)
The File > Export FBX command exports your Moho project in FBX format so that you 
can import it into other 2D or 3D applications that support the FBX file format. No 
export options are provided. After choosing this command, you will be prompted to 
specify a folder and filename for the export.

Many Moho commands (point binding, curvatures, bone 
stretching, etc.) that are not supported in FBX format. 

When designing files for FBX export, we recommend that you use the 
View > FBX Preview command to preview your project before 
export. For additional information on how to address unsupported 
features, see “FBX Preview Mode (Pro Only)” on page 491

Export OBJ (Pro Only)
If your scene contains 3D objects, including those that you have converted from 
2D to 3D with Moho’s 3D Conversion feature (see “3D Options (Pro Only)” on page 
250), you can use the File > Export OBJ command to save the objects to WaveFront 
OBJ format. You will be prompted to enter a file name and choose a location for the 
exported OBJ file.

If you import an OBJ file that has been exported from Moho 
into your 3D software, and some or all of the faces 

appear to be missing, it may be due to inverted normals. Select the 
missing faces and invert the normals in your modeler.

Export POV (Pro Only)
You can use the File > Export POV command to export 3D objects from Moho to 
POV format, which is compatible with POV-Ray, a free raytracing application that 
produces high quality 3D renderings. For more information about POV-Ray, see 
http://www.povray.org/.

Export Styles (Pro Only)
Choose the File > Export Styles command to save an Anime Styles Document. This 
command allows you to save all the styles from the current project, or only the styles 
used in the selected layer(s) in the current project. The styles will be saved with an 
.mohostyle extension. 

You can also simply open a styles document to export styles to 
the current project.

If your current document contains styles, but there are no styles 
used by the layer(s) that you select for a selected 

layers-only export, an empty styles document will be created.
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Export Frame to SVG
Choose File > Export > Export Frame to SVG to export the current frame in the 
timeline as an SVG vector file. You will be prompted to select a folder and enter a 
filename for the SVG file. 

You can also use the Export Animation dialog to export 
sequential SVG image files. Choose SVG from the 

Format menu, and set other render option settings as required. 

Upload to YouTube
The File > Upload to YouTube command allows you to upload your Moho animation 
to YouTube. After choosing the command you are prompted to locate the 
animation that you want to upload.

Upload to Facebook®
The File > Upload to Facebook command allows you to upload your Moho 
animation to your page on Facebook. After choosing the command you are 
prompted to locate the animation that you want to upload.

Before using this features, you will need to sign in to your 
Facebook account and authorize Moho as an 

application that can upload to your Facebook account.

After logging in to your Facebook account and choosing the Upload to Facebook 
command, your browser will display a screen that prompts you to allow the Lost 
Marble Software Video Uploader to upload files to your Facebook account. Click the 
Allow button to enable this feature, and then the upload will continue. You should 
only need to authorize the uploader the first time you use it

Moho Exporter
Choose FIle > Moho Exporter or use the keyboard shortcut Ctrl/Cmd+B to open the 
Export Queue window. This window allows you to easily add projects to the queue 
for final output. When you choose the File > Moho Exporter command, the Moho 
Export Queue window appears.
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 The Moho Exporter Window.

The Moho Exporter window consists of two main areas:

• Action buttons: The Action buttons provide quick access to common export 
tasks. The functions of these buttons are described in “Using the Moho Exporter 
Action Buttons” on page 421.

• Export List: The export list shows the items that are being sent to the export 
queue. See “Moho Exporter” on page 420 for additional information.

Using the Moho Exporter Action Buttons
The action buttons for the Export Queue appear in the upper section of the Moho 
Export Queue window. They serve the following functions:

• Add Files: Click the Add Files button to open the Add Files dialog, where 
you can select Moho files to add to the export queue. Navigate to 

the folder that contains the item or items you want to add, then click Open to 
add them to the export queue.

You can also add files to the Export Queue list by dragging and 
dropping files from Windows Explorer or Mac Finder.

• Remove: To remove items from the queue, highlight the file or files that you 
want to remove, and click the Remove button. 

• Duplicate Selected Item: Select one or more items in the Export Queue list, 
and then click the Duplicate button to duplicate selected items.

• Split Selected Item by Layer Comp: This button will be enabled when you 
select a queue item that contains layer comps. Click the button to 

separate the items in the queue list by layer comp. You can then delete the 
layer comps that you do not want to render.
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 Before splitting layer comps (top); after splitting (bottom).

• Settings: Click this button to open the Export Settings dialog, described in 
“Export Queue Settings” on page 424.

• Start: Press the Start button to begin rendering the items in the queue. The 
items will be output in the order in which they appear in the list.

• Pause: Press the Pause button to pause rendering output. Press again to 
resume rendering.

• Stop: Press the Stop button to completely stop rendering of the current 
item.

Using the Export List
The Export list contains a tabled list of the files that you send to the Export Queue. 
You can perform actions on one or more items in the list.

• To add items to the list, click the Add Files button, or drag and drop files from 
Windows Explorer and Mac Finder, or export files from the Library by right-
clicking a library file and choosing Add to Exporter from the context menu.

•  To delete items from the Export list, select one or more items, and press the 
Delete key, or click the Remove button at the top of the Moho Exporter.

• To reorder the list, select one or more items and drag the selection up or down 
to change the order that files will be rendered. Note that the Exporter will not 
allow you to position files above the top entry if it is currently being rendered.

• By default, the columns in the list are arranged as follows: Project, Format, 
Destination, Export File Name, and Layer Comp. You can rearrange the order of 
the columns by dragging one of the headers left or right in the list.

• Right-click an item in the Export List to display a context menu that allows you tp 
perform several tasks:
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 � Show In Explorer/Finder: Opens  Windows Explorer or Mac Finder to the 
folder in which the item is located.

 � Remove: Removes the selected item(s) from the Export list.

 � Duplicate: Duplicates the selected item(s).

 � Change Format: Allows you to change the output format for the selected 
item. For example, if you want to render an item in both MP4 and 
sequential image format, you can add the first copy of the file to the 
Export list and output that to MP4 format. Then Duplicate the item, and use 
the Change Format command to output the file as a series of sequential 
images.

 � Change Destination:: Use this command to choose a different folder to 
export the animation or image sequence.
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Export Queue Settings

 Before splitting layer comps (top); after splitting (bottom).

• Project Settings:

 � Path: Displays the path to the project that is added to the export list.

 � Start Frame/End Frame: Enter the start and end frames for your exported 
movie here.

 � Entire Animation: Press this button to reset the start and end frames to 
include all frames in the movie

• Output Settings:

 � Format: Select one of the supported movie formats from the Format 
chooser.
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 � Preset: Choose the desired preset for your renders. These are described in 
“Output Formats and Presets” on page 411.

 � Quality: When the preset allows for a quality option, select the desired 
quality from the chooser.

• Render Options:

 � Enable Multi-Threaded Rendering: Check this option to enable multi-
threaded rendering of your projects. 

 � Render at half dimensions: Check this box to render a smaller version of 
your movie. This makes rendering faster if you just want a quick preview, 
and is useful for making smaller movies for the web.

 � Render at half frame rate: Check this box to skip every other frame in the 
animation. This makes rendering faster, and results in smaller movie files.

 � Apply shape effects: If this box is unchecked, Moho will skip shape effects 
like shading, texture fills, and gradients.

 � Apply layer effects: If this box is unchecked, Moho will skip layer effects like 
layer shadows and layer transparency.

 � Reduced particles (Moho Pro only): Some particle effects require hundreds 
of particles to achieve their effect. Check this box to render fewer 
particles. The effect may not look as good, but will render much faster if all 
you need is a preview.

 � Antialiased edges: Normally, Moho renders your shapes with smoothed 
edges. Uncheck this box to turn this feature off.

 � Extra-smooth images: Renders image layers with a higher quality level. 
Exporting takes longer with this option on.

 � Do not premultiply alpha channel: Useful if you plan to composite your 
Moho animation with other elements in a video editing program.

 � Use NTSC-safe colors: Automatically limits colors to be NTSC safe. This is 
only an approximation - you should still do some testing to make sure your 
animation looks good on a TV monitor.

 � Variable line widths (SWF) (Moho Pro only): Exports variable line widths 
to SWF. See “What to Avoid” on page 417 for more information about 
variable width lines and Flash.

 � Animated GIF Options: This option is enabled after you choose Animated 
GIF from the Format menu described above. Click this option to choose 
the number of colors in the animated GIF, and to choose Dithering, 
Transparency, and Frame differencing options.

 � Overwrite existing files: Check this option to overwrite existing files if 
desired. If you choose not to overwrite existing files, a number will be 
appended to name of the new file to prevent overwriting the existing 
version.

 � Render layer comp: When you export layer comps with the Moho Exporter, 
the name of the layer comp will be added to the name of the output file. 
Check the option and select the layer comp you want to render.

• Destination: Options in the Destination section determine where your renders will 
be saved:
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 Destination options.

 � Export to: Allows you to export to the same folder as the project file, or to 
select a specific folder for the export.

 � Name:  Enter a name for the exported file in the field provided.

• Other Settings:

 � Choose a configuration to apply: Allows you to choose, edit, or create 
render configurations. Click the Edit Configurations button to create a new 
render configuration. If there are no custom configurations, the only choice 
will be Application Defaults. 

 � Save As Defaults: Click the button to save the present settings as the new 
export defaults.

After you complete your settings, click OK to render the output. Note that the OK 
button will be disabled if you are editing settings for an item that is currently being 
rendered.

Open Custom Content Folder
Opens your custom content folder in Explorer (Windows) or Finder (Mac).

Relaunch in (x)-bit Mode (Pro Only)
The Universal installer allows you to install Moho Pro in both 32-bit and 64-bit versions. 
The File > Relaunch in 32-bit Mode and File > Relaunch in 64-bit Mode commands 
allow you to switch between modes.

Quit
Quits Moho. Moho will prompt you to save any unsaved projects before closing.
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Chapter 19: Edit Menu

 Edit Menu (Pro-only features marked)

Undo
Choose this command to undo the last operation. You may undo up to 8 of your 
most recent editing operations in Moho.

You will not receive a warning when you undo an operation. You will be able to 
undo the operation by using the Edit > Redo command.

Redo
This command will redo the last operation that you “un-did” with the Undo 
command.

Cut, Copy, Paste
These are the traditional clipboard commands. They can be used together with the 
Draw editing tools for vector layers, and operate on the currently selected group of 
points or keyframes.
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When pasting keyframes, the Edit > Paste command pastes an exact copy of the 
keyframes. For example, if you copy keyframes that translate an object from a start 
point to an end point, and then move to a later frame and paste the keyframes in, 
the object will move back to the start point and repeat the same action.

Paste Relative
When using the Edit > Paste Relative command to paste keyframes that are copied 
into the clipboard, the pasted keyframes will continue animating the object from the 
last keyframe that was copied. In other words, if you copy keyframes that translate 
an object from a start point to an end point and then use the Paste Relative 
command to paste them later in the timeline, the object will continue from wherever 
it is at that point.

Clear
This command is the same as pressing the backspace or delete key: the currently 
selected object in the working area will be deleted from the project.

Copy Layer (Pro Only)
Places a copy of the selected layer into the clipboard so that you can paste it into 
the current document or another opened document.

Paste Layer (Pro Only)
After using the Edit > Copy Layer command, select the layer above which you want 
to paste the copied layer. Then choose Edit > Paste Layer to paste the layer in the 
clipboard above the selected layer.

Normalize Layer Scale (Pro Only)
There is a feature in Moho called Scale Compensation, which you can enable or 
disable in the General tab of the Layer Settings dialog (see “General Tab” on page 
207). When scale compensation is enabled, strokes get thinner as an object is 
scaled down, and bigger as you scale the object up.

There are times when you need to scale portions of a character down. For example, 
you have two eyes in a character, and you need to scale the larger eye down.
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 Two eyes of different sizes

However, when you scale the eye down, the stroke that surrounds the eye is much 
more narrow than the strokes used on the rest of the character. 

 The larger eye is rescaled

Though you can turn off scale compensation, this may not be desireable for your 
workflow. You also have the option to change the stroke width in the Style window, 
but if you have many cases where strokes are not uniform, it can be time consuming 
to manually enter numbers to make all the stroke widths uniform. 

The Normalize Layer Scale command allows you to quickly adjust the scale of the 
line widths. Select the layer or layers that have line widths that are out of sync, and 
then choose Edit > Normalize Layer Scale. The line width of the selected layers will 
automatically adjust to match the other layers.
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 After the layer scale is normalized

Reset Layer Scale Normalization (Pro 
Only)
Choose Edit > Reset Layer Scale Normalization to revert the selected layer(s) to their 
original scale before you applied the Normalize Layer Scale command. Strokes 
immediately revert back to their original scale.

Select All
Selects all the points in the active vector layer.

Select None
De-selects all the points in the active vector layer.

Select Inverse
Selects the opposite points in the active vector layer. Selected points will become 
de-selected, and de-selected points will become selected.

Select Connected
Selects all points that are connected to any other currently selected points. For 
example, if you have a complex shape like a character’s head, just select a few 
points on it, then choose this command: if all the points on the head are somehow 
connected together, the whole head will now be selected.

Edit Keyboard Shortcuts
The Edit > Edit Keyboard Shortcuts (or Moho > Edit Keyboard Shortcuts in Mac)
command opens the Keyboard Shortcuts dialog shown in the following figure.
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 The Keyboard Shortcuts Editor.

By default, the shortcuts that are built-in to Moho are displayed in their default 
configuration, in three categories: Menus, Tools, and Windows. Simply start typing a 
command or action name to scroll it into view and select it.

You cannot edit the default configuration. In order to create your own shortcut 
configurations, you’ll need to create a custom settings file.

The following options appear in the dialog:

• Current Settings: Displays the name of the shortcut configuration that is currently 
in use.

• New: Allows you to assign a name to a new shortcut configuration. Moho will 
notify you if the filename is too long. After you assign a name choose OK. Your 
new custom file will appear in the Current Settings list, and you can begin to 
assign your custom shortcuts.

• Delete: Select a custom shortcut configuration from the Current Settings list, and 
then click this button to delete it. You cannot delete the Default configuration 
file.
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• Restore Defaults: Restores all keyboard shortcuts to the default values assigned 
with the Moho installation.

• Action Filter: Enter the name of the action that you want to search for in the 
field provided. This will filter the list to show actions that contain the text that you 
enter.

• Shortcut List: Displays all shortcuts by category: Menu, Tools, and Windows. You 
can use the scrollbar at the right side of the shortcut list to scroll further down 
the list. The left side of the list displays a menu command, tool name, or window; 
and the right side of the list displays the associated shortcut if one is configured.

• Scroll To: Jumps to a specific shortcut category. The categories are named in 
the order in which they appear in the shortcut list. Select the desired category 
to jump to that location. The group will be scrolled as close to the top of the list 
as possible.

• Shortcut Suggestions: Click this button to have Moho suggest an unused 
keyboard shortcut.

• Done: Click the Done button when you are finished editing your shortcuts.

If the shortcut list is edited outside of Moho, the settings in the 
external file will be loaded from disk. If you are in the 

shortcut editor at the time, you will receive an alert before you 
reload them that the settings have been modified outside of the 
application.

Adding Shortcuts
To create a custom keyboard shortcut file, follow these steps:

If a user content folder is defined, Anime will save custom 
keyboard shortcuts files to a Keyboard Shortcuts folder 

in the user content folder. If names conflict with custom files saved to 
the default location, the user location will supercede the default 
location.

1. Choose Help > Keyboard Shortcut Editor to open the Keyboard Shortcut 
window.

2. If a custom configuration file has not yet been created, click the New button 
to assign a name for a new configuration file. Otherwise, select the custom 
configuration that you want to edit from the Current Settings dropdown list.

3. Scroll through the keyboard shortcut list until you find the menu command, tool, 
or window item that you want to modify. Click inside the shortcut field to edit it.

4. With the shortcut field selected, press the associated keys on your keyboard that 
you want to assign for the command.
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Customized shortcuts will override default shortcuts unless there 
is a conflict with a default. If a conflict with a default 

shortcut exists, the default shortcut will take precedence over the 
custom shortcut.

It is possible to create duplicate shortcuts. The editor will warn 
you when multiple actions have the same shortcut 

when you assign a shortcut that is already used by another action. 
When multiple actions use the same shortcut, the first enabled action 
found will be triggered.

 You will receive a warning when the keyboard shortcut that you enter is already in 
use.

Actions whose shortcuts are already used by other actions will 
appear with a red number that indicates how many 

actions already use that shortcut. Hover over the number to display 
a list of actions that use that shortcut. The number and tooltip only 
appear when editing custom shortcuts, and not when viewing 
default shortcuts.

5. After you are finished with your keyboard shortcuts, click Done to save the 
configuration file.

If you change your locale, there may be localized shortcuts 
that conflict with your custom shortcuts. Your settings 

will be updated to eliminate conflicts.

Switching from 32-bit to 64-bit or vice versa could potentially 
alter the shortcuts available and may lead to a conflict 

between default settings and custom settings. Your settings will be 
updated to eliminate conflicts.

If shortcuts have changed in the application since the last time you updated, a 
dialog will prompt you to update your custom shortcut list accordingly, or to use the 
new defaults.
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 Update Shortcuts dialog.

Preferences...
Mac users will find the Preferences command in the Moho 

menu category.

Brings up a dialog that lets you customize some aspects of Moho, such as the 
display colors used in the working area of the Moho window. Some of these features 
including Edit Colors and GUI Colors are only available in Moho Pro.
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General Tab

 General Tab (Pro only features marked)

• Automatically check for updates: When this option is checked, Moho will 
automatically check for updates upon startup. Uncheck this option if you prefer 
to manually check for updates.

• Use large fonts (restart required): Check this option to use larger fonts in the 
Moho interface. 

• Include factory content in the Library: This option is checked by default. When 
unchecked, factory content will not appear in the library. Content that is 
placed in your custom content folders or in other folders that you add to the 
library will still appear in the library.

• Confirm before moving Library items to the Recycle Bin: This option is checked 
by default, which causes you to confirm whether to send library items to the 
Recycle Bin/Trash after you press the Trashcan button in the library. When this 
option is not checked, items selected to be moved to the Recycle Bin/Trash will 
be moved there without confirmation.
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• Enable GPU: (Pro only) Check this option to enable GPU acceleration if it is 
supported by your hardware.

• Enable export/import hardware acceleration: (Pro only, Windows Only). If a 
media codec (such as H.264) supports hardware acceleration you can speed 
up the exporting process by turning GPU acceleration on if your hardware 
supports it. Turn this option off if your card does not support hardware 
acceleration. 

• Enable touch support: Turn this option on if you want to use Moho with a Wacom 
touch-enabled tablet. 

• Allow sending analytics information to Lost Marble: When this option is checked, 
Moho will send hardware information and feature usage statistics to Lost 
Marble. Analytics will not be sent until after the application has been properly 
activated/serialized.

• When exporting, alert on file conflict: When this option is checked, an alert 
will appear when you use the Export Animation or Export Animation with 
Previous Settings command and it encounters files of the same name. You will 
be prompted to rename, overwrite, or cancel the export. When this option is 
unchecked, previous versions will be kept, and new versions will be appended 
with a version number.

• Startup File: Allows you to start Moho with a default startup file, an empty 
document, or a specified project file.

• Max Render Cache Size: Enter the number of renders that you want to store 
your Moho render cache. The default setting is 100 images. In order to store 
these images, you must create a user content folder.

• Overwrite Preview Animation renders: When checked, previously created 
preview animations will be overwritten with the current one. When unchecked, 

• Poser Location (Pro Only): Allows you to specify the location of the Poser 
executable.

• Custom Content Folder: Allows you to specify a location in which to store your 
custom content. This content will be displayed in the Library Assets tab of the 
Library, in a root folder named Content Folder Library.
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Documents Tab

 Documents Tab (Pro only feature marked)

• Auto save for crash recovery: When turned on, Moho will automatically save 
your work every thirty seconds to a temporary file. If the application crashes, you 
can recover your work the next time you start the application. In the event that 
you are working on very large files and your workflow is slowed down by saving 
every thirty seconds, you can turn this option off to improve performance.

• Open and switch to new file after gather: If you gather a document when this 
option is checked, Moho will close the current document (the document that 
you gathered) and open the gathered document. If the preference has not yet 
been set, Moho will give you the opportunity to select the default preference 
the first time you gather a document.

• Confirm before reverting document: When checked, Moho will ask for 
verification before a document is reverted to the last saved version.

• Warn when file references change on document open: Allows you to enable 
or disable warnings that appear when project files have changed location. 
Uncheck the option to disable the warnings.



Moho 13.5
Users Manual 

438

Chapter 19: Edit Menu

• Warn when a document is converted to the new file format: Allows you to 
enable or disable notification that older project files will be converted to the 
new Moho file format.

• Save onion skin settings in document (Pro Only): Check this option if you want 
to save onion skin settings with your project file. If multiple users are working with 
the same scene at different times, it may be preferable to uncheck the option.

• Save and restore viewport settings in document: When checked, documents 
are saved with viewport state on. When this setting is enabled, if a saved 
document contains this information the viewport settings will be restored when 
the document is reopened.

• Document Preview Thumbnail Size: Moho can automatically generate 
thumbnails when you save your documents. The default maximum size for the 
thumbnails is 128x128 pixels. Other options are None (will not automatically 
generate a thumbnail), 256x256, 512x512, and 1024x1024.

Layers/Objects Tab

 Layers/Objects Tab
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• Auto Center New Layers: If the camera is in its default position (such as it would 
be in a new document) this option won’t do anything. The option will become 
noticeable if you have moved the camera (for example, if you are looking 90 
degrees to the left). If this option is unchecked in such a case, new layers will 
be centered at 0,0,0 and will be off-camera. If this option is checked in such 
a case, the new layers will appear centered in front of the current camera 
position.

• Show paths for new layers: Determines whether the paths (previously called 
construction curves) are displayed for new layers. They’re always shown for the 
selected layer, but usually hidden otherwise.

• Legacy curves for new layers: When checked, uses the old style curves, rather 
than the smoother curves found in Anime Studio 8 and later.

• Nearest neighbor sampling for new image layers: When an image is scaled up 
larger than its original size, Moho will try to smooth out the areas in between 
pixels to create a smoother image. Turn this option off if you want the enlarged 
image to appear blocky.

• Auto-assist with bone locking keyframes: Adds an extra keyframe when bones 
are locked or unlocked to prevent them from “drifting”.

• Auto-name new shapes: Shapes can be named by the user. If this is turned on, 
all bones and shapes get names like “1”, “2”, etc.

Moho names bones automatically as you create them. For 
more information, see “Add Bone” on page 90.

• Auto-scale imported vectors (Pro Only): Makes it easier to import multiple 
Illustrator files (for example, multiple body parts in a character). The imported 
files will all be in scale with each other when this option is checked. When this 
option is turned off, you may need to press the Esc key to automatically zoom in 
to the selected points after you import the files.

• Scale compensation for new layers: When a layer is scaled up (or down), its lines 
get thicker (or thinner) to match. If you don’t want this behavior, turn off this 
option. You can also control this on a per-layer basis in the Layer Settings dialog. 
This option controls it for any new layers you create.

• Enable note layer scaling: Allows note layers to scale along with other selected 
content. 

• Default Stroke Width: Choose the default stroke width that appears in the Style 
window.

• Default Fill: Choose the default fill color that appears in the Style window.

• Default Stroke: Choose the default stroke color that appears in the Style 
window.

Layers Window Preferences

• Auto-size Name column: When checked, the Name column in the Layers 
Window will automatically resize to accomodate the width needed to display 
the full layer name.
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• Enable inline layer naming: When checked you can click the Layer name in the 
to rename a layer in the Layers Window. When unchecked double-clicking will 
open the Layers Settings dialog, where you can rename the layer in the General 
tab.

• Search filter always shows parent layers of matching items: (Pro only) When 
checked (default), Layers Window searches will always display parent layers of 
items that are returned in search results so that context is preserved When not 
checked, search results will only return items that match the search filter.

• Show Timeline Visibility column: (Pro only) When checked, displays a column 
that allows you to selectively choose which layers will be visible in the Timeline.

• Show Label column: Enables or disables the display of the Label column.

• Show Visibility column: Enables or disables the display of the Visibility column.

• Show Kind column: Enables or disables the display of the Kind column.

• Show Quick Settings column: (Pro only) Right-click on the Quick Settings icon 
to set tags for the selected layer or layers. Click the Set button to apply the 
changes.

• Show Tags column: (Pro only) Enables or disables the display of the Tags column.

• Show Comments column: (Pro only) Enables or disables the display of the 
Layer Comments column. Click the word balloon icon to enter or display the 
comments. Then click the Set Comments button to apply the changes.

• Show Comments column: (Pro only) Enables or disables display of the Layer 
comments column.

• Enable Name column tooltips for layers: (Pro only): 

• Enable Tags column tooltips: (Pro only) When enabled, tooltips will be displayed 
when you hover over the Tags column.

• Enable Comments column tooltips: (Pro only) When enabled, tooltips will be 
displayed when you hover over the Comments column.
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Timeline Tab

 Timeline Tab

• Consolidate timeline channels: Instead of showing separate channels (point 
animation, bone animation, layer translation, layer rotation, etc.), this option 
groups all channels into one in the timeline palette. This is on by default in 
Debut, and off in Pro.

• Highlight frame 0: If on, a red box is drawn on the canvas if the current time is 
set to 0. This can be helpful to remind you when you’re working on frame 0 (the 
setup frame) vs. some other frame.

• Use SMPTE timecode: Shows time in the timeline using SMPTE timecode instead 
of frame numbers. SMPTE timecode looks like this: 00:02:34:07 That would be 0 
hours, 2 minutes, 34 seconds, and 7 frames.

• Show angles in degrees in timeline: Angle values (like layer rotation or bone 
rotation) are shown in radians in the timeline’s Motion Graph. This is because 
angle values in radians are smaller numerically and fit in better with other values 
in the graph. But if the user chooses to, they can display these curves using 
degrees with this option.
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Tools Tab

 Tools Tab

• Status bar at top of window: Shows the status bar at the top of the window, 
rather than the bottom. The status bar is where tools show their descriptions, like 
what modifiers keys do what, etc.

• Zoom with drag box: When this option is on, allows you to draw a box around 
the area that you want to zoom into, rather than using a continuous zoom.

• Enable drawing tools only on frame 0: Creation tools (Add Point, Freehand, 
Draw Shape, Add Bone) are only available on frame 0 if this option is on. 
Otherwise, they can be used at any time.

In Moho, there are certain tasks that can only be performed on 
Frame 0, many of which pertain to rigging. When you 

move to Frame 0 in your project, each layer will go to its own “Frame 
0,” regardless of where it starts in the project timeline. If a layer starts 
before Frame 0, you will now be able to make edits to that layer 
without moving it back into the project timeline.
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• Classic point editing keyboard shortcuts: This preference switches the shortcuts 
for point binding and de-selection. By default, this option is unchecked.

 � When this option is not checked, new shortcuts will be used:.  
The Enter key will be used for welding and creating shapes 
The Escape key will be used to deselect all objects 
The Spacebar will always be used to toggle playback. 

 � When this option is checked, legacy shortcuts will be used: 
The spacebar is used for welding and creating shapes 
The Enter is used to deselect all objects. 
The spacebar is also used in some cases to toggle playback. 

For a more detailed list, see “Classic vs New Shortcut Bindings” 
on page 540.

• Allow custom tool cursors: Turning on this option will just use the standard system 
arrow cursor, regardless of what tool is active on the canvas.

• Enable audio feedback: When welding points, you hear a “clicking” sound in 
Moho. Turning this option off will disable the click

Tool Layout Tab
The Tool Layout tab allows you to arrange the tools in the Moho tool palettes to your 
liking. In order to make changes to the default configuration, you must enable the 
Automatically update tools list when defaults change option located at the bottom 
of the Tool Layout tab. You also need to have a designated Content Folder for your 
tool scripts. After enabling the option, the other options in the tab will be enabled.
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 Tool Layout Tab

• Installed Tools: Click this button to add installed tools to the list.

• Add Group: Click this button to add tool groups to the list. 

Groups contain tools that are relevant to the current context, 
and appear on the Tool palette in the order that they 

appear in your tool preferences. 

• Rename: Click this button to rename the selected item to the new name 
entered in the text field.

• Add Spacer: Click this button to add a spacer in the tool list. This creates a blank 
square where a tool would normally appear in the list.

• Add Color: A color marker sets the background color behind the tools and 
groups that follow the color marker. The color will continue until another color 
marker is encountered in the list.

• Remove: Click this button to remove the selected item from the list.

• Move Up: Moves the selected item up in the tool list.
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The first item in the list must always be a group. 

• Move Down: Moves the selected item down in the tool list.

If you move a group, all of the tools in that tool group move 
with the group item. 

• Restore Factory Defaults: Click this button to reload the factory default tool 
configuration. You will be asked to confirm before the factory defaults are 
restored.

• Automatically update tools list when defaults change: When this option is 
checked, Moho will automatically integrate tool changes when your settings 
get out of date. Uncheck the option to update the _tool_list.txt file manually. 
The tool settings will be updated to add missing default groups and any tools 
that are missing from their default groups. Obsoleted default tools will be 
removed from the list. Moho will not use an outdated custom_tool_list.txt file. 

Editor Colors
Allows you to change the color scheme for the editor window, including various 
options for background and object colors. Press the Reset button to return to default 
application colors. The Default Stroke Width option allows you to specify the default 
Stroke Width setting that appears in the Style window.

 Editor Colors
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 Editor Colors

Appearance
Allows you to change the color scheme for the application, including various options 
for background, text, and widget colors. A preview of your changes appears in the 
Sample Widgets area as changes are made.

• Brightness: Use the Brightness slider to lighten or darken the color theme. .

• Highlights. Allows you to change the highlight colors used in the application and 
icons:

 � Dark Highlight: Use the color chip and eyedropper to select the highlight 
color used for dark backgrounds.

 � Light Highlight:  Use the color chip and eyedropper to select the highlight 
color used for light backgrounds.

• Default: Click this button to return to the default appearance.



Moho 13.5
Users Manual 

447

Chapter 19: Edit Menu

 GUI Colors

Using Custom Resource Images
The Custom Content folder now includes a subfolder named Shared Resources, 
where you can store your own custom resource images.

By default, the Moho resource images are stored within the application folder. For 
example, for Moho Pro, they are located in the following Windows folders:

• C:\Program Files\Moho 13.5\Resources

If you want to use custom resource images, we recommend that you do not replace 
the images that are located in the application folders. Instead, create your custom 
resource images, using the same filenames, formats (GIF, PNG, JPG, PSD, etc.) and 
dimensions as the originals in the application resource folders. Then place your 
custom images in the Shared Resources folder, located in your Custom Content 
folder, using similarly-named folder hierarchies. If the original application resource 
resides in a subfolder (such as ContentLibrary, Support, etc) in the application 
folder(s), you will need to create identically-named subfolders in your Custom 
Content folder and place the appropriate custom images there.
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 Create similarly-named subfolders in the Shared Resources folder in your Custom 
Content folder to store custom resource images

Application image resource formats and dimensions may 
change over time. If the resource images in the 

application change in format or dimensions, you will need to update 
your custom images to remain compatible.
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Chapter 20: Draw Menu

 Draw Menu

Insert Text...
Choose Draw > Insert Text or use the keyboard shortcut Command/Ctrl T to open the 
Insert Text dialog, which is described in “Insert Text” on page 130.
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Snap to Grid (Pro Only)
If the grid is turned on in the working area, then this command can be used to snap 
all selected points to the nearest grid intersection.

Reset Line Width (Pro Only)
Using the Line Width tool, you can adjust the width of a line at any point. Choosing 
this menu command will reset your custom line widths at any selected points.

Random Line Width (Pro Only)
Use this command to randomize the width of the line(s) through the currently 
selected points. You will be asked to specify the minimum and maximum width, and 
Moho will assign random line widths within that range.

You can use the Randomize button to randomize the transitions between minimum 
and maximum percentages.

 Random Line Width dialog.

Peak
This command creates a peaked (or hard) transition between the curves at the 
point that you click.

Smooth
This command smooths the transitions between the curves at the point that you 
click.
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Raise Shape
Select this menu item to raise a shape in the stacking order. This will move it in front 
of the next higher shape. The stacking order only applies to shapes within the same 
layer - all shapes in a layer will appear above any lower layers and behind any 
upper ones, regardless of stacking order. Note that if there is no shape overlapping 
the selected one, you may not see any change when this item is selected, even 
though the shape gets moved higher.

Press the Up arrow key on your keyboard to move the selected 
shape(s) one level toward the top.

Moho allows you to animate shape ordering on the timeline. 
Double-click the layer that contains the shapes you 

want to animate, and then enable the Animated Shape Order 
option in the Vectors tab of the Layer Settings dialog. See “Vectors 
Tab” on page 232 for more information. 

Lower Shape
Select this menu item to lower a shape in the stacking order.

Press the Down arrow key on your keyboard to move the 
selected shape(s) one level toward the back. 

Raise to Front
Works like Raise Shape, but raises the shape above all others in its layer.

Shift Up arrow will move the selected shape(s) to the top.

Lower to Back
Works like Lower Shape, but lowers the shape below all others in its layer.

Shift Down arrow will move the selected shape(s) to the 
bottom.

Trace Image
Moho has always allowed you to import black and white or color bitmap images 
and work with them. However, they are not as flexible as vector objects for several 
reasons. You can’t zoom in an infinite amount, you can’t bend them quite as much, 
and you can’t edit them. Moho includes Automatic Image Tracing, which allows 
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you to convert a bitmap image to a black and white vector object. Moho offers the 
following conversion types:

 � Black and white: Creates a black and white vector image.

 � Color (Pro only): Check this option if your source image is color and you 
want to create a vector image that is also color.

 � Photo Edges (Pro Only): Check this option if your source image is a line 
drawing and you only want to convert it to strokes; or if you want Moho to 
only draw strokes where one color meets another color.

For this feature to work its best, you should choose drawings that have bold lines, 
such as those created with a felt pen. Pencil sketches will be more difficult to trace.

After you import your drawing into an Image layer, you can use the Draw > Trace 
Image command to display the Trace Image dialog.

 Trace Image dialog.

The settings in the Trace Image dialog provide the following functions:

• Threshold: Adjusting the Threshold value can help remove gray areas from the 
conversion. Move the slider toward the left to decrease the threshold value 
(accept less gray), or toward the right to increase the threshold (accept more 
gray). If your image contains compression artifacts or subtle color gradients you 
can decrease the threshold value to make the conversion cleaner.
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 Low threshold (left); high threshold (right).

• Detail reduction: The Detail Reduction is set, by default, to accept the most 
amount of detail possible (the slider is fully toward the left). Move the slider 
toward the left to increase the amount of detail in the conversion. This creates 
more points in the vector layer, but appears more true to the original. Move 
the slider toward the right to decrease the amount of detail. This creates fewer 
points in the vector layer, but appears less like the original image.

 Maximum detail (left); reduced detail (right).
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• Fatten Lines: This option controls the width of the lines in the black and white 
drawing. Move the slider toward the left to decrease the width, and toward the 
right to increase the width.

 Default lines (left); thickened lines (right)

After you click OK, Moho traces the image and adds a new vector layer to the 
Layers Window. The image layer that contains the original bitmap image is turned 
off.

 A close-up of the traced result
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The Automatic Image Tracing feature remembers your last 
settings. If you are not quite happy with the results that 

you get, you can return to the Trace Image dialog and tweak your 
settings.

Tracing Color (Pro Only)
When you choose a Color conversion in Moho Pro, the following settings are 
available:

• Number of Colors: Move the slider toward the left to reduce the number of 
colors in the traced result. Move the slider toward the right to increase the 
number of colors. As you move the slider, the number of colors that will appear 
in the traced result will display above the slider.

 4 colors (left); 7 colors (right).

• Detail reduction: Move the slider toward the left to add more detail to the 
vector layer. This will increase the number of points in the object and make it 
harder to edit, but it will look more like the original image.
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 Maximum detail (left); reduced detail (right).

• Outlines: When converting to a Color vector layer, you can check this option to 
also convert outlines in the drawing, or uncheck the option to omit the outlines.

After you click OK, Moho traces the image and adds a new vector layer to the 
Layers Window. The image layer that contains the original bitmap image is turned 
off.

 The traced result.
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Tracing Photo Edges (Pro Only)
To create a vector image that only contains the outlines in your original bitmap, 
check the Photo Edges option at the top of the Trace Image dialog. You are 
presented with the following settings:

• Threshold: Move the slider toward the left to accept less outline, or toward the 
right to accept more outline.

Triangulate 2D Mesh
The Draw > Triangulate 2D Mesh command allows you to perform a Delaunay 
triangulation on a 2D vector or image layer. This feature can be used in conjunction 
with Moho’s Smart Warp feature to deform a 2D layer.  For additional information, 
see “Smart Warp Layers (Pro only)” on page 236.

Hide Selected Points
Sometimes when projects are complex and you have a lot of points and bones, 
you only want to work on one object or reshape it. When scenes are complex you 
sometimes select points in the group.

Select the object you want to work on, then choose Edit > Select Inverse to 
select all the points you want to hide. Then choose Draw > Hide Points to hide the 
selected points. The shapes are still there, but the points are hidden and you can’t 
accidentally select them.

Show All Points
Choose Draw > Show All Points to unhide the points that were previously hidden with 
the Hide Selected Points command.

Hide Shape
Hides the currently selected shape

Show All Shapes
Shows all shapes that have previously been hidden.

Freeze Points
After selecting points, choose this command to freeze all points so that they cannot 
be edited.
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Freeze Selected Points
Adds a keyframe at the current time for all selected points.

Freeze Visible Points
Adds a keyframe at the current frame for all points that are currently visible.

Reset Points
Moves the selected points back to their original positions, adding a new keyframe 
for them at the current time.

Reset All Points
Same as above, but moves all points in the layer back to their original positions, not 
just the selected ones.
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Chapter 21: Bone Menu

 Bone Menu

Release Points
This command detaches the selected points from any bones they may be bound to.

Flexi-Bind Points
This command binds the selected points to bones in such a way that they will 
influenced by all the bones in the parent bone layer, depending on the strength and 
region of influence of each bone. This results in more of a “squishy” type of motion 
when the skeleton is animated. This is the default behavior for all drawings in Moho, 
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so you usually won’t have to use this menu command - the points are probably 
already flexi-bound.

Release Layer
This command detaches the current layer from any bone it may be bound to.

Flexi-Bind Layer
This command binds the current layer to the bones in the parent layer in such a 
way that the child layer will influenced by all the bones in the parent bone layer, 
depending on the strength and region of influence of each bone. This results in more 
of a “squishy” type of motion when the skeleton is animated.

Release Layer And Points
Detaches selected points and layer from any bones that they are bound to.

Use Selected Bones for Flexi-Binding
Assigns the selected bones to the currently-selected layer in the Layers Window. For 
more information, see “Tutorial 3.5: Flexi-Binding” on page 136 in your Moho Tutorial 
Manual.

Create Smooth Joint for Bone Pair (Pro 
Only)
This command works on a pair of selected bones (for example, bones for the upper 
and lower arms, or upper and lower legs). The two bones also have to have a 
parent-child relationship, and start out in close to a straight line.

For more information about using bone pairs and smooth 
bending, see “Tutorial 3.6: Enhanced Bone Features (Pro 

Only)” on page 140 in your Moho Tutorial Manual.
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 Two bones (a parent and its child) are arranged in a straight line.

Applying this command on a pair of selected bones helps prevent a bend from 
collapsing when the child bone is bent. It is ideal for use with elbow or knee bends in 
a character.

 Before applying Elbow binding, the joint collapses when it is bent.

If you are using vector shapes, the collapsing can be remedied, in part, by using 
Smart Bones (discussed in “Smart Bones (Pro Only)” on page 103). However, Smart 
Bones only work on vector shapes. Elbow binding, on the other hand, works with 
either vector shapes (, or with scanned or imported images.
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To use this command, go to the Layers Window and select the layer that is controlled 
by the two bones. Then use the Select Bones tool to select two bones (the upper 
and lower arm bones in the case of this example). Next, select the layer that is 
controlled by the bone, and choose Bone > Create Smooth Joint for Bone Pair.

After you apply the command, you will notice an improvement in the elbow joint 
when you rotate the lower arm bone. There is a nice smooth bend around the joint, 
and it pinches together on the inside.

 After you apply Elbow binding, the joint bends more smoothly.

If you offset the bone and place it to the side of the object, the bend will be 
amplified. This is an easy way to create cartoon characters with rubbery arms.

 You can offset the bone from the artwork to amplify the bend effect.
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Use All Bones for Flexi-Binding
Reassigns the selected layer in the Layers Window so that it is controlled by all bones 
in the bone group, rather than by selected bones that were previously assigned with 
the Use Selected Bones for Flexi-Binding command.

Reset All Bone Rigging
Choose Bone > Reset All Bone Rigging to reset all bone rigging (including point 
binding, smooth joints, image warping) on the selected layer back to the defaults.

Hide Selected Bones
Select the bone or bones that you want to hide, and choose Bone > Hide Selected 
Bones. The bones and their associated keyframes will be hidden.

Hide/Show Shy Bones (Pro Only)
The Select Bones tool provides an option to identify a bone as a “shy bone.” 
Shy bones can be displayed or hidden as needed to reduce workspace clutter. 
Toggle this command on or off to show or hide all bones marked as “shy.” For more 
information, see “Select Bone” on page 82.

Hide Controlled Bones
Hides any bones that are set up to have their angle or position controlled by another 
bone. These types of bones are often not animated by the user (their animation is 
“automatic” through the control feature), and hiding them can clear up some of 
the clutter in the workspace. This function is not available when the time is set to 
frame 0.

Show All Bones
Use the Bone > Show All Bones command to redisplay bones that have previously 
been hidden with the Hide Selected Bones command.

Track Bone to Video
Allows you to link a bone to the tracking points that you defined with the Video 
Tracking tool. For a description of how to use this tool, see “Video Tracking” on page 
148.
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Make Smart Bone Dial (Pro Only)
The Create Smart Bone Dial command is an easier and more convenient way to 
set up smart bones. Smart bone creation involves several steps. You create a bone, 
give it a name, and set up actions and restraints for it. This command simplifies the 
process.

When you want to use the Create Smart Bone dial to set up your smart bones, the 
process is as follows:

1. Create the bone that you want to use as your smart bone control dial.

 Create your control bone.

2. Choose Bone > Make Smart Bone Dial.

3. The Create Smart Dial dialog appears, with the following settings:

 � Name: Assign a name that is descriptive of what the dial controls. For 
example, if you are creating a dial that gives your character an angry 
expression, name the bone Angry.

 � Minimum Angle: Enter the value that represents the minimum setting of 
the bone. You can use negative values to create the opposite state (for 
example, you can enter a value of -90 to create an expression that looks 
less angry, or happy).

 � Maximum Angle: Enter the value that represents the maximum setting 
of the bone. For example, you can enter a value of 90 to represent the 
maximum strength of the Angry expression.

 � Duration (Frames): Enter the number of frames over which you want 
the smart bone to travel from its minimum to maximum values. A higher 
number of frames creates a smoother range of motion.

 � Separate actions for positive and negative angles: When this option is 
checked, Moho creates a smart bone dial that works in both positive and 
negative angles. The neutral position will be “zero.” Uncheck this option to 
create a smart bone dial that works only in positive angles.
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 Enter your settings in the Create Smart Dial dialog.

4. Click OK. A bone appears on the screen, labeled with the name that you 
assigned in the Create Smart Dial dialog. The Actions window opens to display 
the associated action(s). Two actions will appear if you checked the Separate 
actions for positive and negative angles.

 The control dial and the associated actions appear in the window.
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The rest of the process is similar to that described in “Smart Bones (Pro Only)” on 
page 103. Scrub the timeline to the minimum setting and change the scene to the 
way you want it to appear when the bone is at its minimum value. Then scrub the 
timeline to the maximum setting (90) and change the scene to the way you want it 
to appear when the bone is at its maximum value.

 Modify the scene for the minimum and maximum dial settings.

Freeze Pose
Keyframing can be tricky sometimes for new users of Moho, or for those who are 
new to animation. For example, let’s say you move a left foot up on frame 12, and 
then down again at frame 24. At frame 36, you want the right foot to move up, and 
then down again at frame 48.

The problem is, the right foot will start to move up at frame 0, and then be fully up 
at frame 36. In reality, you want the right foot to move up from frame 24 through 36, 
and not from frame 0 through 36.

To accomplish this, you choose the Bone > Freeze Pose command at Frame 24. This 
sets a keyframe for every part in your animated character or object so that you are 
assured that the pose you want to use is correct for that portion of your animation. 
Then you set the keyframe that moves the right foot up at frame 36, and down 
again at frame 48.
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 Freezing a pose

Freeze Selected Bones
Sets a keyframe for all currently selected bones.

Freeze Visible Bones
Sets a keyframe for all bones that are currently visible in the project.

Reset Bone
Moves the selected bone back to its original position, adding a new keyframe for it 
at the current time.

Reset All Bones
Same as above, but moves all bones in the layer back to their original positions, not 
just the selected one.
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Chapter 22: Animation Menu

 Animation Menu (Moho Pro shown)

Allow Frame Skipping
Normally when playing back an animation, Moho will display each frame one at a 
time. Depending on the complexity of your animation, the display quality settings, 
and the speed of your computer, the animation may play back slower than its 
specified speed. Select this command to force the animation to play back at actual 
speed. In order to accomplish this, Moho may have to skip some frames to keep up 
to speed, so the animation will play back at the correct overall speed, but may not 
appear as smooth. The best way to see the animation at final speed and quality is of 
course to use the Export Animation command in the File menu.
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Enable Bone Dynamics (Pro Only)
Use the Animation > Enable Bone Dynamics command to preview bone dynamics 
on the canvas. Playback of bone dynamics is very accurate in Moho, but it can also 
cause animations to run slower as the more accurate dynamics are calculated.

When this option is unchecked, animation playback is faster, but will not preview 
the automatic bone dynamics animation. The dynamics will still appear in final 
renderings.

For more information about bone dynamics, refer to “Tutorial 3.3: Bone Dynamics” 
on page 120 in your Moho Tutorial Manual.

Reset All Layer Channels
Resets all channels in the current layer to their initial values, adding a new keyframe 
at the current time.

Consolidate Layer Channels
This command is similar to the Consolidate timeline channels preference (see 
“General Tab” on page 435) except that it allows you to consolidate the channels 
of individual layers in the timeline.

You can also right-click on a layer channel icon at the left side of the timeline to 
either consolidate or un-consolidate that layer channel.

 Timeline layer channels can be un-consolidated (top) or consolidated (bottom).

Set Layer Start Time
Offsets the start of an animation within a layer to the current selected frame.
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Align Layer with Camera
Allows you to rotate the selected layer to face the camera.

Select All Keyframes
Selects all the keyframes in the current layer. This is useful if you want to move all the 
animation in a layer forward or backward.

Rescale Keyframes...
With this command you can rescale a group of keyframes so that a portion of your 
animation takes more or less time.

 The Rescale Keyframes dialog.

Options included in this dialog are:

• Rescale entire document: Check this option to rescale all frames in the 
document.

• Start Frame: Enter the existing frame number at which to start scaling.
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• End Frame: Enter the existing frame number at which to end the scaling.

• New Start Frame: Enter the new target frame number for the start of the scaling.

• New End Frame: Enter the new target frame for the end of the scaling.

• Rescale the following channels: Check or uncheck the channels that you want 
to include or exclude from the scaling operation. The icons representing the 
various animation channels are described in the Timeline Window section.

Examples:

• To reduce the amount of time the animation takes (in other words, to speed it 
up), you could set the start frame (and new start frame) to 30, the end frame to 
60, and the new end frame to 45. (45 - 30 = 15, which is half as long as 60 - 30 = 
30)

• You can shift a section of your animation by changing the start time. For 
example, to shift the range of keyframes between 30 and 60, you could set 
the start frame to 30, the end frame to 60, the new start frame to 90, and the 
new end frame to 120. The duration will be the same (120 - 90 = 60 - 30), but the 
animation will take place between frames 90 and 120, instead of 30 and You 
can rescale a portion of the entire document by clicking the “Rescale entire 
document” checkbox.

• To rescale the current layer, select the animation channels that you want to be 
affected. For example, you may want to rescale the bone animation, but leave 
the layer rotation alone.

Copy Current Frame...
With this command you can copy values from the current frame in the timeline 
to any other frame in your animation. For example, if you position some objects in 
a way that you really like at frame 243, you can use this command to copy that 
position back to frame 0, to make it the starting position as well.
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 The Copy Current Frame dialog.

Add Keyframe
This command adds a keyframe for all channels in your project, at the currently 
selected frame.

Auto-Freeze Keyframes
The Animation > Auto Freeze Keyframes command serves as a toggle. When Auto 
Freeze Keyframes is enabled, all bones in a character will get a keyframe when 
any part is adjusted. The Auto Freeze keyframes command is helpful when you are 
animating a character or object and you want to ensure that poses are in a specific 
state in certain frames in your animation, 

You can also check the Auto Freeze Keys checkbox above the 
timeline to automatically freeze keyframes.

The Auto-Freeze Keyframes option is disabled when  you are 
editing a smart bone action.
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As an example, assume that you add keyframes to frame 20 that move the legs of a 
character. Then you move ahead to frame 40 and move the arms. 

 Legs animated at frame 20, arms animated at frame 40.

When you play the animation back from the beginning, you notice that both the 
arms and legs begin to animate, and that the arms are in a midway position at 
frame 20. The reason that this happens is because there is no keyframe for the arms 
at frame 20, so Moho starts interpolating the animation at frame 0.

When played back, arms are at mid-position at frame 20.

If you animate the character when the Auto-freeze keys option is enabled in the 
timeline, or when the Animation > Auto Freeze Keyframe is enabled, Moho will add 
keyframes for each bone in the character, thereby “freezing” the pose at any 
keyframe that a bone is moved. Now when you play the animation back, the legs 
will move from frames 0 through 20, and the arms will move from frames 21 through 
40.
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Auto Freeze Keyframes freezes poses for all bones in the character.

Clear Animation
Several commands allow you to clear keyframes from a single layer, or from all the 
layers in your project. Use the Animation > Clear Animation commands as follows:

• From Layer: Clears all animation keyframes from the current layer. A warning 
appears to notify you that animation will also be deleted from sublayers 
and asks if you want to continue. Choose Yes to clear the sublayers, No to 
keep keyframes in the sublayers, or Cancel to exit the dialog without making 
changes.

• From Layer After Current Frame: Clears keyframes from the currently selected 
layer, beginning with the frame after the currently selected frame and including 
all keyframes to the end.
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• From Layer Before Current Frame: Clears keyframes from the currently selected 
layer, beginning with the frame before the currently selected frame and 
including all keyframes to the beginning.

• From Layer At Current Frame: Clears the keyframes on the currently selected 
layer, only at the current frame.

• From Document: Clears all animation keyframes from the entire document.

• From Document After Current Frame: Clears keyframes from the entire 
document, beginning with the frame after the currently selected frame and 
including all keyframes to the end.

• From Document Before Current Frame: Clears keyframes from the entire 
document, beginning with the frame before the currently selected frame and 
including all keyframes to the beginning.

• From Document At Current Frame: Clears the keyframes in the entire document, 
only at the current frame.

Track Layer to Video
This command allows you to link a layer to tracking points that have been set up with 
the video tracking tool. For a complete description of the process, refer to “Video 
Tracking” on page 148.

Nudge Physics Object (Pro Only)
A nudge is an instantaneous force that affects a physics object in small or large 
amounts, depending on the setting in the Physics Nudge dialog. It can be a large 
force, but after the nudge keyframe, the object will start falling, or bouncing, or 
whatever the situation requires. It won’t keep going in the nudge direction forever.

 The Physics Nudge dialog.

For example, assume that when you play your animation back you see a red ball roll 
down and bounce to a stop against a block. You can position the timeline shortly 
after it stops, and then apply a large nudge (such as 10) that causes the ball to fly 
off again to the left. Smaller nudge values cause objects to wobble.

Mute Audio
Mutes the soundtrack when playing back your project in Moho, but the soundtrack 
is still a part of the project. Just un-mute it to hear it again.
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Restart Audio Track
Starts the audio track in the selected track over again from the beginning. This allows 
you to add repeats in the audio track.

Audio Level
Opens a dialog that allows you to enter a numerical value for the audio level.

Restart Movie
Starts the video in the selected track over again from the beginning, allowing you to 
add repeats in the video track.
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Chapter 23: Scripts Menu (Pro 
Only)

 Scripts Menu

The Scripts menu contains commands that are provided by script files or plug-
ins. Moho includes several scripts for a variety of different tasks, and you can also 
download more scripts written by other Moho users. These scripts are all written in 
the Lua programming language - if you’re interested in creating your own scripts, 
feel free to examine the scripts in the scripts/menu sub-folder in the Moho program 
folder.

The scripts in this menu are divided into several sub-menus, according to their 
function:

3D
The scripts in this menu are used to create or manipulate 3D models.
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Auto-Scale
When you import a 3D OBJ file into your scene, it may be way out of scale with the 
Moho scene. For example, a building may be so large that the Moho camera is 
inside it, or off to one side, and you don’t really see anything on import. This script 
centers the object and scales it to an appropriate size for the default Moho camera.

Cube
Creates a new 3D layer that contains a simple cube. The color of the cube is 
determined by the current fill and line colors.

Rotate X
Rotates the current 3D layer 90 degrees around the X axis. This can be useful when 
importing a 3D model if the model’s “up” direction is not the same as Moho’s - just 
use this command (and the other rotate commands) to align the model properly.

Rotate Y
Rotates the current 3D layer 90 degrees around the Y axis.

Rotate Z
Rotates the current 3D layer 90 degrees around the Z axis.

Torus
Creates a new 3D layer that contains a simple torus (donut). The color of the torus is 
determined by the current fill and line colors.

Camera
These scripts are used to move the camera around and to create camera-related 
effects.

Handheld Camera
Adds noisy interpolation to the camera animation channels to simulate a handheld 
camera.

Orbit Camera...
Adds animation to the camera to cause it to rotate around the current scene. You 
can specify how long this should take, how far out the camera should be, and the 
direction of rotation.
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Draw
These scripts can be used to create vector objects in Moho.

Animated Strokes
Animates the existing stroke around an object, along a specified number of frames.

Apply Sketchy Effect
Applies a sketchy effect to the outline of the shape.

Auto Weld
Finds vector points that are near each other and welds them together. Only 
operates on selected points. This can be useful if you have accidental gaps in a 
drawing, or sometimes when working with imported Adobe Illustrator files.

Erase All Vectors in Group
Erases the contents of all vector layers in a selected group.

Gear
Automatically generates gear shapes. You can specify the number of cogs and 
the inner radius. You can also create tapered or non-tapered cogs, and choose an 
option to create the gear in a new layer.

Polygon...
Draws a polygon shape in either the current vector layer, or a new layer. Uses the 
current fill and line colors to color the polygon.

Random Point Colors
Assigns random points colors to all vector objects.

Remove Bad Fills
This script fixes “leaky” fill shapes.

Remove Sketchy Effect
Removes the sketchy effect from a project. 
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Simplify Curve
Reduces the number of points in a curve by removing points which are calculated 
to be “unnecessary” to maintain the shape of the object. This makes it easier to edit 
your shapes later.

Split Curve
Automatically inserts points into selected curve segments, allowing you to modify 
existing shapes.

Star...
Draws a star shape in either the current vector layer, or a new layer. Uses the current 
fill and line colors to color the star.

Toggle Legacy Curves
Turns on old style curves, which are less smooth than the new curve style. However, 
this is beneficial for use with files created in older versions of Anime Studio.

Zig Zag
Creates zig-zagged shading between two selected curves. You can control the 
number of spikes, curviness, and randomness.

Image
These scripts can be used to process image layers.

Fisheye
Turns a fisheye image into a curved, wide-angle surface that can be panned 
around with the camera tools.

Spherical Panorama
Converts a spherical panorama image into a 3D sphere that can be viewed from 
any angle with the camera tools.

Layer Effects
These scripts can be used to generate special layer effects.

Layer Trail...
Creates an animated trail effect that follows the origin point of the current layer.
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Magic Lines
Allows you to create a number of curves and apply this script to create an effect. 
For example, you can use the Freehand tool to draw several curves that represent 
smoke or swirly magic lines, and then run the script to create a smoky or magical 
effect.

Perspective Shadow...
Automatically creates a pseudo-3D shadow effect for the current layer.

RT: Break Apart Shapes
Offers a number of different options in how you can break apart the shapes on a 
layer. You can put each shape in its own layer and group them together or put all 
shapes in one layer creating separate geometry for each shape. Additional options 
allow you to select filled shapes only, and to name layers according to group names 
or shape names. This script is very useful when working with physics.

Particle Effects
These scripts can be used to create particle effects like smoke, fire, or rain. Many of 
these effects can be time-consuming to render, so be aware of that if you plan to 
use several of them in a single animation. Also, even though they can be exported 
to Flash, these effects can be too complex for the Flash player to play at full speed. 
Plus, without the blur effects these scripts use, they won’t look very good in Flash. 
These effects are really useful only if you plan to export to a movie or still image 
format, not Flash.

Energy Cloud...
Creates a blobby glowing cloud effect.

Explosion...
Creates an explosion effect. The explosion starts at the current frame, and will fade 
to a smoke cloud over time.

Rain
Inserts a falling rain effect.

Smoke...
Inserts a plume or cloud of smoke.
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Snow
Creates a falling snow effect.

Sparkles...
Inserts a cluster of spiraling sparkles. This effect is very effective if you bind it to 
another moving object - for example, the end of a magic wand.

Script Writing
This menu contain utility scripts that can be used as examples for writing your own 
scripts. If you don’t plan to write your own scripts, you can completely ignore this 
menu.

Alert Test
Demonstrates how a script can use an alert box to provide some information to the 
user.

Automation Test
Shows how you can write a script that will open or save a document, create a new 
document, and render a document. The script opens all documents in a given 
directory and renders a frame for each one.

Error Test
This script intentionally creates a runtime error. The purpose is to show how the Lua 
Console appears to display the error. When you write your own scripts, the console 
window will be very helpful when tracking down errors.

List Channels
Shows how a script can iterate through all of the animation channels in a layer. You 
can access every animateable parameter in the layer.

Load Data File...
This script is a demonstration of how a Lua script can read data from an external 
file. It doesn’t do anything useful itself, but it could be used as a starting point if you 
wanted to write a script to import some kind of custom data.

Print Moho API
Prints out all functions, constants, and global variables that Moho provides through 
its scripting interface. This is not meant to be the documentation for Moho’s scripting 
interface, but some script writers may find it useful.
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The Resources > Support > Extra Files folder in your Moho Pro installation folder 
contains Lua scripting documentation that you might find useful.

Moho merges user scripts and factory scripts internally at 
runtime. If you name a user script in the same 

corresponding folder (tools, utility, etc) with the same name as a 
factory script in the corresponding location, the user script will be 
preferred over the factory script. User scripts that do not replace 
factory scripts are loaded after factory scripts, as previously 
supported, unless a different order is specified in the active _tool_list.
txt file for tool scripts.

The _tool_list.txt factory default file now begins with a line that is 
similar to this:

/* anime_version 9010000 (9.1.0 rev 0) */

If you have a _tool_list.txt file in the user scripts/tools location that 
begins with this line, and the version number is the same or higher 
than the factory default version, your user _tool_list.txt will be used 
instead of the factory file.

If the version is missing or lesser than the factory default, the factory 
default will be used and a copy of the factory default will be saved 
to the user folder with the name _reference_tool_list.txt.

The _reference_tool_list.txt file is not for editing. It is a reference 
to use when updating your custom _tool_list.txt for the 

current version. This allows new tools and other changes to be 
accounted for when you make your customizations. When the 
factory defaults version changes, a new copy of this file will be saved 
for you to reference.

Print Globals
Prints out all global variables currently defined in Lua.

Print Test
A simple example that shows how you can print output in a Lua script. The printed 
output will appear in the Lua Console window. Printing data in the console window 
is not generally useful when your script is delivered to regular Moho users, but can be 
very helpful when writing a script to track down bugs.
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Sound
The scripts in this menu use sound to control some part of an animation.

Bone Audio Wiggle...
This script uses the volume of a sound file that you select to animate the angle of the 
currently selected bone. Use this script to make a character or object move in sync 
with a sound.

Layer Audio Wiggle...
Use this script to make a layer move in sync with a sound.

Text
Allows you to add credits or spinning text to your projects.

Credits
Allows you to select a text file that contains your credits. You can specify font, 
duration for each screen, delay between screens, and number of frames for fade.

Number Sequence
Adds a sequence of numbers based on the number of frames in your animation.

Spinning Text
Creates 2D or 3D spining text. Several settings provide control over length, rotation, 
translation, opacity, and scale. Some presets are provided.

Tiling
These two scripts allow you to create a repeating texture pattern to fill the 
workspace. These tiled surfaces can be animated.

Visibility
These scripts affect the visibility of a layer - for example, causing it to fade in and out.

Collapse Layers
Allows you to animate the collapsing or uncollapsing of layers contained in a group 
layer.
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Fade...
Causes the current layer to fade in or out over a specified number of frames. If you 
want a layer to appear or disappear suddenly, it is better to change the value of the 
layer’s visibility channel. However, this script should be used when you want a layer 
to appear or disappear more gradually.

Unroll Shapes
If you have a vector layer that contains several shapes, you can run this script to 
“unroll” or expand the shapes out from nothing in a cascade. Unroll Shapes can also 
be used in combination with Elastic or Bounce interpolation for interesting effects.

Wavy Fade...
This script combines the Fade effect above with the Wavy effect below. It can only 
be used with vector layers.

Warp
This set of scripts is used to distort the contents of a vector layer, applying various 
animated warping effects.

Black Hole...
Causes the selected points in a vector layer to swirl around in an inward spiral 
motion towards the origin point of the layer.

Wavy...
Causes the selected points in a vector layer to move in a wavy or underwater style.

Other Popular Scripts
Opens your web browser to www. animestudioscripts.com, where you can 
download popular scripts written by other members of the Moho user community.

Scripting Documentation
Opens your web browser to www.animestudioscripting.com, where you can view 
the latest scripting documentation.

Install Script
The Install Script command can be used to automatically install user scripts. The 
script folder must be laid out with the following hierarchy in order to install:
My Script Folder
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  menu
  tool
  ScriptResources
  utility

The items in the folder should reflect the location in the scripts 
folder (found in your user content folder). Script writers 

should adapt their script distribution to this hierarchy so that the script 
will install through this feature.

If you replace an existing item with the Install Script command, 
the existing items will be moved to a scripts subfolder 

named Uninstalled Items x-x-x where x is the date. If you 
perform multiple installations that replace existing items on the same 
day, each of the uninstalled items folders generated after the first will 
also have a number appended to the folder name, starting at 1 and 
incrementing per folder.
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 View Menu (Pro-only features marked)

Reset
Resets the view of the working area to the starting pan and zoom values. Use this 
command when you want to jump back to the original view of the project.
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Zoom In
Use the View > Zoom In command, or the keyboard shortcut Command/Ctrl = 
(equal sign) to zoom in closer to the elements in your scene.

Zoom to Layer
Zooms the workspace view to fit all contents of the current layer. The existing 
Shift+Home shortcut will continue to work independently of this menu item.

Zoom to Selection
Zooms the workspace view to fit selected items. The existing Alt+Home shortcut will 
continue to work independently of this menu item.

Zoom Out
Use the View > Zoom Out command, or the keyboard shortcut Command/Ctrl - 
(minus sign) to zoom out farther from the elements in your scene.

Direction (Pro Only)
This sub-menu lets you select a direction to view your scene from. The default view 
is through the camera - however, sometimes when you’re working on a scene with 
a 3D layout, you may want to view the scene from a different point of view. Options 
are Camera, Front, Top, Right, Back, Bottom, and Left.

Enable Grid (Pro Only)
Toggles display of the grid on and off. A checkmark appears beside the command 
when the grid is displayed.

Grid Settings (Pro Only)
Displays the Grid Settings dialog, which allows you to set the number of pixels 
between each grid space. Default is 20 pixels.

Enable Grid Snapping (Pro Only)
When the grid is turned on, control points will snap to the nearest grid intersection 
as you draw them and move them around. Check this menu command to enable 
grid snapping. When unchecked, you can use the grid as a visual guide, without it 
interfering in your drawing.
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Show 3D Axes (Pro Only)
Toggles the display of the 3D Axes on and off in the document window.

Video Safe Zones (Pro Only)
This command turns on the display of NTSC “safe zones”. When creating output 
for video, it is important to keep important action and titles within the safe zones, 
because most televisions cut off some portion of the outside of the picture. (The 
inner rectangle is the safe zone for titles, and the outer one for important action.)

Show Rule Of Thirds
This command will toggle a change in the display to show the output area split into 
thirds.

Show Output Only
This command will hide all artwork that lies outside the final output rectangle. This 
makes it easy to visualize the final staging for your shot. Of course, it’s hard to edit 
what you can’t see, so be sure to turn this option off when you need to edit an 
object that lies outside the visible area of the project.

Open documents also appear as a list at the bottom of the View menu. Select a 
document in the list at it will appear in the view port area.

The following shortcuts allow you to cycle through open documents:

• To switch to the next open document, press Ctrl Tab (Windows) or Alt Tab (Mac).

• To switch to the previous open document, press Ctrl Shift Tab (Windows) or Alt 
Shift Tab (Mac).

Show Play & View Controls
Toggles the display of the play controls and other toolbar settings that appear 
above the timeline.

Show Timeline Options
Toggles the display of the timeline options toolbar (the area between the Play and 
View controls and the timeline ruler).

Timeline Channels (Pro Only)
Reintroduced the timeline channel dialog for giving users control over which 
channels to show in the timeline.



Moho 13.5
Users Manual 

490

Chapter 24: View Menu

Enable Onion Skins (Pro Only)
Choose this command to toggle the visibility of onion skins. Alternatively, you can 
click the Enable Onion Skins button in the timeline toolbar.

 Enable Onion Skins

Select Tracing Image (Pro Only)
Use this command to select a tracing image to display in Moho’s editing view. This 
image will not appear in your final output - it’s just used as a tracing guide to help 
you draw your artwork in Moho.

Show Tracing Image (Pro Only)
Use this command to show or hide the tracing image that you have added to the 
scene using the Select Tracing Image command.

Show Curves (Pro Only)
Use this command to globally show or hide the curves in your scene.

Auto Hide Curves (Pro Only)
When checked, Moho will automatically hide curves when you use drawing tools 
that do not affect curves. This helps reduce onscreen clutter while you draw. 
Uncheck this option if you prefer to display curves at all times.

Fade Unselected Layers (Pro Only)
This option allows you to easily identify the layers and objects that you are working 
on, without having to turn other layers off. When this option is off, all layers in the 
current project will be displayed normally. When this option is turned on, any layers 
or children of layers that are not selected will be grayed out.
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Active Switch Layer (Pro Only)
When this command is enabled, Moho will display both the active child as well as 
the selected layer in a switch group.

You can Alt-click the child of a switch layer in the Layers 
Window to activate it.

Design Mode (Pro Only)
Returns the project to Frame 0, where you can add new layers, draw vector shapes, 
change bone rigging, and so on. Moho will remember the frame that you were 
previously on before choosing the command. If you choose the command again 
after adding the desired elements at Frame 0, you will return to the frame that was 
current before you applied the command the first time.

Return to Mainline (Pro Only)
If you have the Actions window closed, allows you to return to the mainline faster.

FBX Preview Mode (Pro Only)
The View > FBX Preview Mode command allows you to preview your Moho project 
before you use the File > FBX Export command to export to another 2D or 3D 
application that supports the FBX format (such as Unity or Autodesk products).

It is important to note that the FBX file format does not support all of the features 
found in Moho, such as point animation, curvatures, point bindings, and other similar 
features. Any features that are supported in Moho but not supported in FBX format 
will not be exported.

While working in FBX Preview mode, you can play back or scrub through your 
project to view the animation as it will appear in other applications that support 
FBX file format. You may notice that some parts are left behind when the character 
animates, or that things are not bending and stretching as they should. This gives you 
the opportunity to make modifications that will help improve performance in other 
applications. When you turn FBX Preview mode off after making changes (such as 
changing point binding to flexi-binding), the project will play back using the original 
methods, but the changes that you made while working in FBX preview mode will be 
carried over.

The following general comments address Moho features that are not compatible 
with FBX format:

• Vector layers will be exported as though they are images.

• Remember that when designing a project for FBX output, everything is about 
flexi-binding. Other binding methods will produce undesirable results in FBX 
format.
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• Characters that use features like point binding, point bending, curvatures, 
and other similar features will not move in the same way when exported as 
an FBX file and imported into another application. You will need to modify the 
characters using some of the following recommendations.

• If a character uses point binding methods to link bones to vector layers, use 
the Bone > Use Selected Bones for Flexi-Binding command to remove the point 
binding. Select only the bones that you want to use to animate a selected body 
part, and then apply the command. Repeat this for any body part that uses 
point binding. Make sure to preview again in FBX Preview Mode to see the result 
of the change.

• Use the Bone Strength tool to verify bone strengths for each of the body parts to 
make sure they are not being under- or over-affected. Adjust bone strengths as 
needed before exporting the project.

• Bone scaling and stretching is not supported in FBX format.

Stereo (Pro Only)
If Enable Stereo (Red/Blue)Rendering is enabled in the Project Settings dialog (see 
“Project Settings...” on page 385), this command makes it easier to preview and 
reposition your 3D objects for stereo rendering.

Show Document Tabs
Open documents appear as tabs in the main window. You can show or hide the 
document tabs with the View > Show Document Tabs command, or by using the 
shortcut Command/Ctrl Shift J.
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 Window Menu

Tools
Shows/hides the Tools window. The Tools window is shown by default when you start 
Moho. Tools are discussed in the section beginning with “Moho Tools” on page 31.

Layers
Shows/hides the Layers Window. The Layers Window is shown by default when you 
start Moho. See “Chapter 10: Layers Window” on page 165.

Timeline
Shows/hides the Timeline window. The Timeline window is shown by default when 
you start Moho. See “Chapter 16: The Timeline Window” on page 332.

Style
Shows/hides the Style window. The Style window is shown by default when you start 
Moho. See “Chapter 13: Style Window” on page 256.
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Switch Selection
Choose Window > Switch Selection to open the Switch Selection window. This 
window provides a preview of switch layers that can be added to the timeline. For 
more information, see “Using the Switch Selection Window” on page 193. 

Docking
Use the Window > Docking commands, or their equivalent shortcuts, to dock or 
undock the Tools, Layer, Timeline, or Style windows. When undocked, you can move 
them to another location or to a second monitor.

The docked window size and floating window size are maintained independently so 
that each can be adjusted to suit its content.

Actions (Pro Only)
Shows/hides the Actions window. The Actions window is hidden by default when you 
start Moho. See “Actions Window (Pro Only)” on page 366.

Blend Morphs
You can use the Window > Blend Morphs command to blend poses (or morph 
targets) together to create a combination pose or morph. This feature in Moho is 
very easy to use.

Moho Debut does not allow you to create actions for blending, 
however you will be able to blend poses contained in 

content that is created by others. When you first create a character, 
you’ll notice that the Window > Blend Morphs command may not be 
available. This is because you need to use a character that has 
morph targets that you can use for blending.

Moho Pro allows you to both create and blend poses. See 
“Creating Morphs (Pro Only)” on page 370.

To blend your morphs, begin by moving to the frame at which you want the new 
morph to appear.

Next, choose the Window > Blend Morphs command. The Blend Morphs dialog 
appears. The sliders in this dialog are named the same as the morphs you created in 
the Actions window. Adjust the sliders until you get a combination of the morphs that 
you want to keep. Then click OK to set the new combination.

The Default slider is associated with the default state of the 
object at Frame 0. To blend the other morphs with this 

default state, check the Relative Blend option.
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 Use the Blend Morphs dialog to combine your morphs together in any combination of 
values.

You can then advance to other frames in your timeline, and use the Blend Morphs 
command to create new combinations throughout the timeline. As you scrub 
through the timeline, you should then see morphs blend from one to the other.

You can select which animation channels to copy to a new frame, or you can copy 
everything in the document by selecting the “Copy entire document” checkbox. 
There doesn’t need to be a keyframe at the current frame in order to copy the 
current value. This command will copy the current value, whether it is a keyframe or 
an interpolated in-between value.

An important note about bones: if you position a skeleton 
system during your animation, and try to copy that 

pose back to frame 0, the bones themselves will take on that pose at 
frame 0, but anything bound to the bones (points in vector layers, 
warped images, other sub-layers) will not take on that pose. This is 
because frame 0 is a setup frame - bones are set up at frame 0, but 
they have no influence over other objects at frame 0. If you’re trying 
to copy a pose back to frame 0 in order to set up an initial pose, 
consider copying it back to frame 1 instead - frame 1 is actually the 
beginning of the animation, and the bones will influence other 
objects starting at frame 1.

Keyframe
Use the Window > Keyframe command to apply changes to a selected group of 
keyframes. For more information about the Keyframe dialog, see “Editing Keyframe 
Settings” on page 353.

Layer Settings
Opens the Layer Settings dialog, discussed in “Chapter 12: Layer Settings” on page 
205.
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Poser Parameters (Pro Only)
Opens the Poser Parameters dialog, which allows you to rotate or scale Poser 
objects that are imported into your scene. For more information, see “Chapter 8: 
Special Tools” on page 142.

Library
Displays the Library window, which is discussed in “Chapter 14: The Library Window” 
on page 289.

Audio Recording
Displays the Audio Recording window, which is discussed in “Audio Recording” on 
page 365.

Character Wizard
Displays the Character Wizard, described in “Chapter 15: The Character Wizard” on 
page 304.
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 Help Menu

Help
Opens this document, the Moho User’s Manual.

Tutorials
Opens the PDF version of the Moho Tutorial Manual, which is installed on your hard 
disk.

Online Tutorials
Opens a web browser with Moho online tutorials. Internet connection will be 
required.
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Community Forums
Opens your web browser to the Lost Marble forum, where you can communicate 
with your peers and ask for help on any topic related to Moho and animation. The 
forum is extremely large with over ten thousand registered members.

Technical Support
Opens your web browser to the Lost Marble website where you can access FAQ’s, 
see answers to common issues, get help from a customer service representative etc.

Online Video Gallery
Opens your browser to a page that displays some of the animations that have been 
created with Moho. This is a great place to get inspired and see what others have 
created with Moho.

Download Bonus Content Pack
Navigates to the Bonus Content Pack page on Content Paradise. You will need a 
Content Paradise account and a valid Moho serial number to obtain the content.

Buy Content
Help speed up your animation workflow with ready to use content. Buy content from 
Content Paradise. Internet connection will be required.

Upgrade to Professional Version 
(Debut Only)
Upgrade from Moho to Moho Professional. Internet connection will be required. To 
see the differences in the two products, see “Product Comparison” on page 359.

Check For Updates
Check to see if there are any updates for Moho. Internet connection will be 
required.

Deactivate License
Choose this command to deactivate the license before you uninstall Moho, or if you 
want to activate the license on another computer.
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Update License
If you have previously licensed Moho with a Moho Debut license and have since 
acquired a Pro license, you can use this command to update your local license from 
Moho Debut to Moho Pro. A Moho Pro serial number is required. After entering your 
new serial number you will be prompted to restart the application. 

License Manager
Opens your browser to a page where you can manage your Moho and other Lost 
Marble product activations.

Register Your Product
Register your product to receive information on updates and upgrades. Internet 
connection will be required.

Welcome Screen
Opens the Welcome Screen.

About Moho
Displays some information about your Moho installation, including which version of 
Moho you’re running.

About Scripts
Displays some information about all the scripts currently loaded by Moho. All of 
Moho tools, and all the entries in the Scripts menu are implemented in a scripting 
language called Lua. Although some programming/scripting experience is required, 
Moho users are welcome to write their own scripts to extend Moho’s built-in features.



Moho 13.5
Users Manual 

500

Chapter 27: Moho 13.5 New Features

Chapter 27: Moho 13.5 New 
Features

Animating foreshortening and complex actions are easier than ever!

Inspired by Da Vinci’s Vitruvian Man drawing, Vitruvian Bones (or V-bones) is a new 
and powerful way to rig your characters. The intuitive V-bones system allows you 
to alternate different drawings and sets of bones in one single layer. For instance, 
you can have different sets of heads, each with its own controllers. Or just draw the 
same limb in different perspectives and Vitruvian bones will allow you to group and 
animate them on the fly just by switching from one to the next. V-bones can be 
applied to any part of the body. You can even switch between entirely different 
bodies, all in the same bone layer!  This unique approach to Vitruvian bones makes it 
easier to have a rigged character with the appeal of traditional animation.

Create a Vitruvian Group

To understand the basics. Let’s create a simple Vitruvian Group in an empty file.

First, be sure to be in frame 0.

Change the name of the empty vector layer in the project to ‘Arm 1’  and use the 
drawing tools to create an arm.

Now create a second vector layer, name it ‘Arm 2’ and draw the same arm, but in a 
different pose.
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So now you have two arms, each one in its own vector layer.

Go to the Layers window, create a Bone layer and drag both arms inside of it.

Your layers should look similar to this:

Select the Bone layer and then the Add Bones tool (A) and create one bone for the 
body and then bones for each arm.

Even when we will see only one arm at the time, just rig your character as it has two 
arms.

You need to be sure both arms are children of the main body bone:
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Once you have your bones created, Moho needs to know what bones should move 
and bend each arm. This step is not always necessary when you are creating a rig, 
but it’s crucial for Vitruvian bones to work.

To give the software this information we will use the selective Flexi-Binding option.

Luckily, it’s a simple and quick process.

Select the ‘Arm 1’ vector layer.

Now use the Select Bone tool and select the three bones related to that arm.

You can use the Rectangle selection, lasso mode or hold Shift + clicking to add 
bones to the selection.

Hold Ctrl and click over a bone if you need to remove it from the selection.

So now you have the ‘Arm 1’ layer selected and also the bones that should move 
that layer.

Go to the Bone menu and click on ‘Use selected bones for Flexi-Binding’ (or simply 
press Ctrl+Shift+F in Windows or Cmd+Shift+F in macOS)
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These bones will look bold everytime that vector layer is selected. This means that 
these bones are the only ones that will move that specific layer.

Now select the ‘Arm 2’ layer and repeat the same process: Select the bones and go 
to Bone -> Use Selected Bones for Flexi-Binding

In this exercise, we are only creating two different arms, but you can repeat the 
same process for as many limbs as you’d like to have in your character.

Now go to the Tools bar and use the Vitruvian Bones tool. This tool works very similar 
to the Select Bone tool, but also allows to create Vitruvian Groups.

To do it, simply select the first bone of each arm
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And then click on the Group button

You will notice one arm will disappear and the other one will have a special design. 
This design means this is a Vitruvian Bone.

To test it, simply select any bone from the arm and then go to the Active Bone menu 
in the Vitruvian Bones toolbar

This menu shows you the names of the bones (in this case they have the default 
names, but you can rename the bones if you want). Depending on which one you 
select, that arm will appear on the screen.
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Tip:

You can also change the Active Bone by simply pressing Alt+D or Alt+C as many 
times as you need.

This method is much quicker and works without the need of using the Vitruvian Bone 
tool.

As far as one of the bones of the arm is selected, you will be able to use it.

(And, unrelated to this section, this shortcut also work with Switch Layers)

As you can see, the design of a Vitruvian Bone looks different to the rest of bones, 
with a semi-circle and two lines at the bottom.

This design will help animators know when they have the option to animate Vitruvian 
Bones.

Rigging Vitruvian Bones

Although Vitruvian Bones need to be set up with the ‘Use Selected Bones For Flexi-
Binding’ menu in order to work correctly, you are not limited to that option.

After you use that menu, you can still Bind points or Entire layers to specific bones, 
create Smart bones for joints or control Levers and use any tool you would normally 
use for rigging a character.

As you can see here, this character is using Point Binding for the arm:
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Also, Vitruvian bones are not limited to one layer. You can attach as many layers as 
you want to Vitruvian Bones and they can be anywhere inside of the Bone layer.

So, for instance, an arm can be split in two layers: Arm and Forearm. Then the arm 
can be behind the body layer and the forearm in front of it, as you can see here:

Animating Vitruvian Bones

Basic concepts of the timeline:

To animate with Vitruvian Bones, it’s very important to understand some basic 
concepts of Moho’s timeline:

For most of the channels, there’s a white and a red channel.

The red channel only shows the keyframes of the element you have selected at the 
moment.

The white channel shows you keyframes of any of the elements that have movement 
in the selected layer.



Moho 13.5
Users Manual 

507

Chapter 27: Moho 13.5 New Features

So, as a summary:

The red channel works to modify and re-time specific movement

The white channel is useful to modify and re-time all the elements at once.

Animating with Vitruvian Bones

When you start animating Vitruvian Bones, you will notice some new channels 
appearing in the timeline. These are special channels and behave a bit different 
from the rest.

First, you will notice the Vitruvian Bones channels. These channels will appear every 
time you change the Active Bone on a Vitruvian Bones Group (by using the tool 
menu or the Alt+D and Alt+C shortcuts):

Vitruvian Bones

Every time you change the Active Bone of any Vitruvian Group during your 
animation, this channel will show you a Keyframe at that frame.

Selected Vitruvian Bones

This channel is very similar to the previous one, but it only shows the keyframes of the 
Vitruvian Group selected at that moment.

If you select a bone that is part of a Vitruvian Group, this channel will show 
keyframes every time you change the Active Bone of that specific Vitruvian Group.

You also will see the Vitruvian Bones Consolidated channels:

Vitruvian Bones Consolidated

This channel shows a general summary of every Vitruvian bone animated.

If any of the Vitruvian Bones in the Bone layer has a keyframe (it can be in Rotation, 
Scale, Translation, Flip or any bone animation channel), a keyframe will also appear 
in the Vitruvian Bones Consolidated channel.

This channel is very important, because it shows the entire animation in the timeline, 
even for bones that are not visible at the time.
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This allows to modify and re-time an entire animation easily.

Selected Vitruvian Bones Consolidated

This channel is very similar to the previous one, but it only shows the keyframes of the 
Vitruvian Group selected at that moment.

If you select a bone that is part of a Vitruvian Group, this channel will show 
keyframes in the frames where any of the bones of that group has keyframes.

This channel is especially useful if you want to modify the animation in a specific 
group. For instance, all your animation is working fine, but the left Arm is moving too 
slowly. Then you can modify the keyframes of this channel to adjust the timing of the 
entire group at once.

Look at this example:

 

The VItruvian Bones Consolidated channel shows there’s animation at frames 6, 12 
and 18. This is a general summary that shows that in frames 6, 12 and 18 the Vitruvian 
Bones are animated.

 

The Vitruvian Bones channel shows that one or more Vitruvian Active Bones have 
been changed in frames 6 and 18.
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The Selected Vitruvian Bones Consolidated channel shows that the bone selected 
(right arm of the character) is part of a VItruvian Group and that that group has 
keyframes in frames 6 and 12. This Vitruvian arm is not moving at frame 18, so there’s 
no keyframe there.

 

The Selected Vitruvian Bones channel shows that the bone selected (right arm of 
the character) is part of a Vitruvian Group and that specific group has changed the 
Active Bone only in frame 6.

Disabling Vitruvian Bones Groups

If you want to see and edit all the bones and content from a Vitruvian group, you 
can temporarily disable that group.

This option is very useful to make changes on the overall design, add Smart Bones or 
make adjustments on the animation.

Just use the Vitruvian Bones Tool, select one bone from the Vitruvian Group you want 
to disable and uncheck the Enabled box in the toolbar

Disabled
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You can also Disable or Enable every Vitruvian Group from a character by going to 
the menu

Bone -> Disable All Vitruvian Bones

Bone -> Enable All Vitruvian Bones

All Vitruvian Bones Disabled:

Adding and Removing Bones from a Vitruvian Group

If you want to Add a bone chain to an already created Vitruvian Group,

• Use the Vitruvian Bone tool

• Select one of the main bones from the Vitruvian Group you want to edit
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• Holding shift, add the chain of bones you want to add to the selection

• Press the + button to add the chain to the Vitruvian Group 
 

• If you want to remove a chain of bones from a Vitruvian Group

• Use Vitruvian Bones tool

• Select the main bone of the chain you want to remove from the group

• Press the - button

Wind Dynamics

Wind is the newest addition to the powerful and easy to use Physics toolset Moho 
offers. Take absolute control over the strength, direction and turbulence of wind and 
make your scenes come alive in minutes. Give your backgrounds and characters 
new life with Wind Dynamics!

To use wind, you must select a Bone layer and be sure you are at frame 0.

Use the Select Bone tool (B) and select one or more bones you want to react with 
Wind

In this case, we want the hair to automatically move with the wind, so we select all 
the bones related to the hair

Now in the Select Bone toolbar, open the Bone Constraints window and activate 
both  Bone Dynamics and Wind
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Now the bones are ready to receive the wind.

Press Close in the Bone Constraints Window and now select the Wind Tool

A red Arrow will appear over the layer

This arrow shows how the wind is moving in real time and makes it easier to know 
what values to choose next.

Wind Values

With the Wind tool you can edit these four values

• Direction: This shows the direction of the Wind in degrees. A value of 0 means 
the wind will be fully horizontal and pointing to the right. Making the number 
smaller or bigger, will make the wind rotate clockwise or counterclockwise.

• Strength: This value shows how strong the wind is. A value of 0 means no wind at 
all and 100 is the maximum amount. 
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When you modify this value, you will see the Red Arrow becomes shorter or 
longer, depending on the number.

• Turbulent amplitude and Turbulent frequency: These two values are related to 
each other and they modify and animate the angle and strength of the wind to 
give the sensation of turbulence. 
 
Without turbulence, the bones reacting to the wind can look unnatural, 
because their movement will be very flat, with no small variations. 
 
A higher value for Turbulent amplitude means the angle and strength of the 
wind will change more dramatically during the animation. 
 
A higher value for Turbulent frequency means those changes in angle and 
strength will occur more often, so the wind can jump from very strong to very 
weak in a few frames. And the same will happen with its angle.

Using right click or the mouse wheel to modify the values

You can edit these and any numeric values in Moho by using the mouse wheel or 
pointing the cursor over the number and drag right click to the left or right.

Holding Shift or Ctrl (Cmd in macOS) while doing it, you can make the change of 
values bigger or smaller.

Testing Wind in real time

To check how the Wind is affecting your characters, background elements or props, 
you can simply hit play in the timeline and then modify the wind values using the 
technique explained above.

Moho will show you in real time how the new values are affecting the bones with 
Wind Dynamics applied.

The red arrow will also be updated automatically, making easier the Wind 
adjustments.
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Animating Wind

There are three new channels for Wind:

• Wind Direction

• Wind Strength

• Wind Turbulence

If you modify these values at any frame, a keyframe will be created there.

The values for Wind Direction and Wind Strength can be edited in the Motion Graph 

You can also copy and paste Wind keyframes between different bone layers.

Bones properties

The Dynamics properties for each bone can also be modified.

If you use the Select Bone tool and select one or more bones, you can open the 
Bone Constraints window and change the values there too.
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Depending on the values you pick for Torque, Spring and Damping, the reaction of 
the bone to the wind will be different

• Torque Force: Defines how big will be the movement

• Spring Force: Defines how much the movement will bounce. The smaller the 
value, the softer the movement will be

• Damping Force: Defines how long it will take to the bone to go back to its initial 
angle. The bigger the value, the less time it will take.

Perspective warp and Quad warp

Animate backgrounds, props and characters in perspective with the new 
Perspective Mesh.

Just create a shape with four points, attach it to any image or vector layer and 
animate it.

This simple but powerful mesh can be used in combination with triangular meshes, 
making Moho more flexible than ever.

Creating a True Perspective Mesh

With Moho, you can create Meshes of 4 points and use them to animate any vector 
or image in true perspective.

The process to do this is very simple. Let’s say you have a vector layer with a map:
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To create a Perspective mesh, create a new Vector Layer and call it ‘mesh map’

In the ‘mesh map’ layer, draw and fill a rectangle covering the entire map

Now, since we don’t want to see the rectangle, but only use it as a Mesh, go to the 
Layers window and double click the ‘mesh map’ layer to open its properties.

Then check Hide in editing view and Don’t render this layer and click OK.

The rectangle will become invisible.

Open the Layer properties of the ‘map’ layer, go to the Vectors tab, select ‘mesh 
map’ as Smart warp layer and click OK.
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You are done!

Now to test the mesh, go to any frame different to frame 0 and use the Translate 
points tool to move the points in the mesh map layer.

You will see how the perspective changes while you move them.

Tip: Perspective mesh only works if the shape of the mesh is valid. That the mesh 
won’t work if you fold it over itself.

For instance. This shape will work well, because it’s a valid perspective
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This shape instead is illegal, because it doesn’t follow the logic of perspective, so it 
won’t work

Quad warp

Quad warp works in a similar way to the perspective mesh, but it works to create 
better characters expressions, head turns, 3D effect or any modification over a 
vector or bitmap character.

Again, to create a Quad warp mesh is very simple.

Let’s create a mesh for this character
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First, create a vector layer and call it ‘mesh fox’

Now use the Add Points tool to create draw a mesh over it 

To make the mesh you need to consider this

• The mesh must be bigger than the content. Otherwise, anything that is not 
inside of the mesh won’t work well or won’t be shown in the animation

• The mesh must be created using shapes of 3 or 4 points

Once you have your mesh done, you need to paint every single shape there. But 
don’t worry, we have a script that does it automatically!

This script was generously donated by the Moho beta user Paul Cheshire (thanks 
again, Paul!)

So, be sure you have the ‘mesh fox’ layer selected and go to the Menu

Script -> Draw -> Fill Quad Mesh
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The script will automatically create a shape for every quad and triangle in the mesh.

If there’s any issue with the mesh, you will get an error message and will able to see 
where is the issue:

In this case, there’s a point in the eye that invalidates that part of the mesh, because 
it has 5 points instead of 4.

To fix it, simply remove the point and run the script again.

Once the mesh is ready, you need to open the Properties of the ‘mesh fox’ layer, 
check Hide in editing view and Don’t render this layer and click OK.
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Now open the Properties of the image layer of the head, go to the Image tab, 
select ‘mesh fox’ as its smart warp layer and click OK.

Now the head is ready to be animated!

Some tips about rigging characters with meshes:

• You can assign the same mesh to as many layers as you want.

• You can even assign a mesh to another mesh, so you can have two or more 
levels of movement

• If a bone is moving a mesh and also an image/vector controlled by it, be sure 
to use the Bind Layer tool to bind both layers to the same bone. Doing this 
can avoid problems like having a layer moving twice as fast, which happens 
because the layer is moved in the same direction by both the bone and the 
mesh layer.
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Animating Quad warp meshes

Once you have everything setup, animating quad meshes is very simple. Just use the 
Translate Points tool (T) to move the points of the mesh.

You can also use the Magnet Tool (X) to nudge several points at the same time.

To modify the size of the magnet, just hold Alt in the keyboard and drag the mouse 
or pen left or right.

You can also try simpler meshes for objects and characters 
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Comparison

The differences between Moho Debut and Pro

Feature Comparisons
Feature Moho Debut Moho Pro

Realistic Motion Blur No Yes
Bone Rigging Yes Yes
Smart Bones No Yes
Frame-by-Frame Animation No Yes
Animation Length 2 minutes (3000 

frames)
Unlimited

Motion Tracking 3 points Unlimited
Audio Tracks 2 tracks Unlimited
Video Tracks 1 track Unlimited
Physics No Yes
Poser scene import No Yes
Layers Yes Yes
3D layer and object support No Yes
Layer Referencing No Yes
Animated Shape Ordering No Yes
Morph targets Read Only Read and create
Automatic image tracing Black and white only Black and white, 

color, and edges
Particles Read only Read and Create
Import Photoshop Files Yes (1) Yes (2)
Real-time media connection No Yes
Patch Layers Read only Read and create
3D Video rendering No Yes
Global Rendering Styles No Yes
Scripting No Yes
Layer Outline Yes Yes
64-bit Architecture No Yes
GPU Acceleration No Yes
Wacom Multi-Touch Support Yes Yes
Character Wizard Yes Yes
Render Cache Yes Yes
Separate Moho Exporter Process No Yes
Separate Render Process No Yes
Preview Animation No Yes
Multiple Document Support (Tabs) Yes Yes
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Keyboard Shortcut Editor Yes Yes
Automatic Update Checking Yes Yes
Activation, Serialization, and License 
Management

Yes Yes

(1) Layered using Moho script

(2) Import directly through File menu.

Usability Features
Feature Moho Debut Moho Pro

New Graphics User Interface X X
New Library X X
Absolute and relative path file handling X

XMP metadata for projects and assets X
Personalized templates for workspaces X

Window Menu
Feature Moho Debut Moho Pro

Tools X X
Beginner Mode Tools X
Layers X X
Timeline X X
Style X X
Actions X
Library X X
Audio Recording X X
Poser Parameters X
Character Wizard X X (1)

(1) Character Wizard in Pro lets you use and create reusable actions that can be 
applied to any character created with the Wizard.

Vector Drawing Features
Feature Moho Debut Moho Pro

Bezier Handles for Vectors View only View and edit
Improved Freehand, Blob Brush, and Paint 
Bucket

X X

Smart Warp for Images and Vectors X
Text X X
Select Points X X
Transform Points (Translate, Scale, and Rotate) X X
Add Point X X
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Hide/Show Points X X
Delete Edge X X
Curvature X X
Freehand X X
Color Points X X
Multi-brushes X X
Blob Brush X X
Eraser X X
Point Reduction X X
Rectangle X X
Oval X X
Arrow X X
Shear Points X X
Shear Points Y X
Perspective Points H X
Perspective Points V X
Bend Points H X
Bend Points V X
Noise X
Magnet X
Snap to Grid X
Reset Line Width X
Random Line Width X
Variable Width Curve X X

Vector Modifiers
Feature Moho Debut Moho Pro

Peak X X
Smooth X X
Flip Points Horizontally X X
Flip Points Vertically X X

Fill Features
Feature Moho Debut Moho Pro

Select Shape X X
Select Multiple Shapes X X
Create Shape X X
Paint Bucket X X
Delete Shape X X
Line Width X X
Hide Edge X X
Stroke Exposure X
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Curve Profile X
Texture Transparency X

Fill Modifiers
Feature Moho Debut Moho Pro

Lower Shape X X
Raise Shape X X
Color Points X X

Bone Features
Feature Moho Debut Moho Pro

Pin Bones X X
Auto-Freeze Pose X X
Auto-colored bones while doing Point Binding X X
More bone and layer colors X X
Ignore IK constraint X
Select Bone X X
Transform Bone Tool (Translate, Scale, and 
Rotate)

X X

Add Bone X X
Hide/Show Bones X X
Reparent Bone X X
Bone Strength X X
Manipulate Bones X X
Bind Layer X X
Bind Points X X
Offset Bone X X
Bone Physics X
Bone Constraints X
Smart Bones X
Smart Bones Setup X
Color Bones X X
Bone Labels X
Nested Layer Controls X X
Animated Bone Targets X
Animated Bone Parenting X
Bone Flipping X

Layer Features
Feature Moho Debut Moho Pro

Select Switch window X X
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New Layers window X X
Filters for easy Layer Search X
Set Origin X X
Transform Layer X X
Switch Layer X X
Rotate Layer X X
Rotate Layer Y X
Shear Layer X X
Shear Layer Y X
Particle Layer X
Follow Path X X
Poser X (1)
Image Masking X X
Video Tracking X (2) X
Audio Layers X (3) X
Vector Shape Selector X X
Undo/Redo Layers X X
Layer Comps X
Layer Colors X X
Flexi Binding X X
Depth Shifting X
Fade Unselected Layers X
Multiple Layer Editing X X
Colorize Layer X X
Frame-By-Frame Animation X
Layer Referencing X
Animated Shape Ordering X
Group with Selection Layers X
Normalize Layer Scale X

(1) Requires Poser 7 or newer

(2) Limited to 3 tracking points

(3) Limited to 2 audio layers

Layer Modifiers
Feature Moho Debut Moho Pro

Flip Layer Horizontally X X
Flip Layer Vertically X X

Layer Types
Feature Moho Debut Moho Pro

Vector X X
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Image X X
Bone X X
Switch X X
Group X
Group with Selection X
Particle X
3D X
Physics (Layer property) X
Note X
Audio X X
2D to 3D Layer Conversion X
Patch X
Text X X

Camera Features
Feature Moho Debut Moho Pro

Track Camera X X
Zoom Camera X X
Roll Camera X X
Pan/Tilt Camera X
Orbit Workspace X
Depth of Field X

Workspace Features
Feature Moho Debut Moho Pro

Pan Workspace X X
Zoom Workspace X X
Rotate Workspace X
Orbit Workspace X

Timeline Features
Feature Moho Debut Moho Pro

Edit Multiple Layers X
Mute channels X
Keyframes X X
Playback Controls X X
Animation Channels X X
Hide/Show Channels X X
Ruler X X
Onionskins X
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Graph Mode X
Smooth Interpolation X
Linear Interpolation X
Ease In/Out Interpolation X
Bezier Interpolation X
Step Interpolation X
Noisy Interpolation X
Bounce Interpolation X
Elastic Interpolation X
Stagger Interpolation X
Sequencer X X
Keyframe Hold Duration X X
Colored Keyframes X X

Action Features
Feature Moho Debut Moho Pro

Store Reusable Animation X
Edit Reusable Animation X
Delete Reusable Animation X

Style Features
Feature Moho Debut Moho Pro

Save Style X
Pattern Brush X (1) X
Blur X X
Threshold X X

(1) Pro version contains more brushes

Preferences
Feature Moho Debut Moho Pro

Options X X
Editor Colors X X
GUI Colors X X
GUI Color Themes X X

Project Settings
Feature Moho Debut Moho Pro

Save Project Settings X X
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Edit Dimensions X X
Background Color X X
Depth of Field X
3D Camera X
Stereo Rendering X
Sort Layers by Depth X X
Sort by True Distance X X
Noise Grain X
Up to 120 Frames/Second Maximum X X
Maximum export size (pixels) 900 x 900 9000 x 9000
Maximum number of frames 3000 Unlimited

Content
Feature Moho Debut Moho Pro

Built in Content X X
Third Party Content X X
3D Object X
Character Wizard X X

Scripts
Feature Moho Debut Moho Pro

3D X
Camera X
Draw X
Image Sequences X
Layer Effects X
Particle Effects X
Sound X
Warp X
Visibility X
Script Writing X

View
Feature Moho Debut Moho Pro

Grid X
Adjust Grid Size X
Side by Side View X
Over Under View X
Four-Way View X
Display Quality X
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Advanced Current Layer View X

Import/Export
Feature Moho Debut Moho Pro

Export Queue X
Actions Import/Export
2D FORMATS

JPEG Import/Export Import/Export
BMP Import/Export Import/Export
PSD X (1) X (2)
PSD (Layered) Export
PNG Import/Export Import/Export
TGA Import/Export Import/Export
EPS, AI, Tracing Image Import
Batch Image Export
Vector Export X
3D FORMATS

OBJ X
Poser Files and Scenes (Poser 7 and newer) X
SOUND FORMATS

WAV (Windows & Mac) X X
AIFF (Windows & Mac) X X
MP3 (Windows & Mac) X X
M4A (MPEG-4) X X
MOVIE FORMATS

SWF(4) Export Export
MOV (Mac and Windows) (5) Import/Export Import/Export
AVI (3) Import/Export Import/Export
MP4 Import/Export Import/Export
Sequential JPEG Export
Sequential BMP Export
Sequential PSD Export
Sequential PNG Export
Sequential TGA Export
Batch Movie Export Export
TV FORMATS

NTSC Format Export Export
PAL Export Export
HD movies Export
MOHO FORMAT

MOHO File Format X X
JSON-Based File Format X X
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MotionArtist File Support X X

(1) Layered using Moho script.

(2) Directly through File menu.

(3) AVI Import works on Windows, and on Macintosh systems depending on codecs. 
If you can play the AVI file in QuickTime on a Mac, you should be able to import it 
into Moho.

(4) SWF: Vector animations only; image layers can be used as long as they are not 
warped by bones. See “Exporting Flash” on page 414 for more information.

(5) MOV: If you are using a 64-bit Windows operating system, you will need to use the 
32-bit version of Moho Pro to export in MOV format.

Upload Features
Feature Moho Debut Moho Pro

Upload to Facebook® X X
Upload to YouTube™ X X

Optimization Features
Feature Moho Debut Moho Pro

Document Gathering X
64-bit Architecture X
GPU Acceleration X
Render Cache X X
Separate Moho Exporter Process X
Separate Render Process X
Preview Animation X
Multiple Document Support (Tabs) X X
Keyboard Shortcut Editor X X
Automatic Update Checking X X
Activation, Serialization, and License Management X X
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User Manual
The first source of help when using Moho is the manual that you are reading now. 
We have also included a Tutorial Manual that you can view by choosing Help > 
Tutorials from the Moho menus. If you’re just getting started and need some basic 
tips on how to use Moho, begin with “Quick Start” on page 2 in your Moho 
Tutorial Manual.

For more in-depth instructions on using Moho, the sections “Moho Windows” on 
page 158 and “Moho Menus” on page 375 go into great detail about performing 
specific tasks in Moho and what all the user interface elements are used for, 
respectively.

Moho on the Web
Another good source is the Lost Marble web site at http://mohoanimation.com. 
There you will find product information and a variety of tutorials. We plan to keep this 
updated with questions and answers and new sample files.

To view in-depth product descriptions, online video gallery, and more, visit http://
mohoanimation.com.

Moho Discussion Forum
Share tips and tricks with other Moho users on the online discussion forum: http://
www.lostmarble.com/forum/. Lost Marble staff members also participate in this 
online group, and are happy to share techniques and answer questions. News 
about the latest Moho updates is first posted to the online forum.

Email Support
You can also get your questions answered by email. If you have a question, feature 
request, or would like to report a bug, contact us at support@lostmarble.com. Please 
provide us with as much detail about your problem as possible, so that we can 
understand exactly what’s happening and more quickly come up with a solution for 
you.
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How to Work Quickly in Moho
Once you’ve been using Moho for a while, you’ll probably want to find ways to 
speed up certain operations. Luckily, Moho provides several shortcuts for common 
operations, such as activating tools, navigating the workspace, and entering data.

Menu Shortcuts
File Menu
Windows Mac Command
Ctrl N Cmd N File > New
Ctrl O Cmd O File > Open
Ctrl W Cmd W File > Close
Alt Ctrl W Alt Cmd W File > Close All
Ctrl S Cmd S File > Save
Ctrl Shift S Shift Cmd S File > Save As
Ctrl Alt Shift S Alt Shift_Cmd S File > Save All
Shift Ctrl P Shift Cmd P File > Project Settings
Shift Ctrl M Shift Cmd M File > Refresh Media
Ctrl R Cmd R File > Preview
Ctrl Shift R Shift Cmd R File > Preview Animation
Ctrl E Cmd E File > Export Animation
Alt Ctrl E Alt Cmd E File > Export Animation with
  Previous Settings
Ctrl B Cmd B File > Moho Exporter
Ctrl Q Cmd Q File > Quit
Shift Ctrl Y Shift Cmd Y File > Import

Edit Menu
Windows Mac Command
Ctrl Z Cmd Z Edit > Undo
Shift Ctrl Z Shift Cmd Z Edit > Redo
Ctrl X Cmd X Edit > Cut
Ctrl C Cmd C Edit > Copy
Ctrl V Cmd V Edit > Paste
Ctrl A Cmd A Edit > Select All
Ctrl I Cmd I Edit > Select Inverse

Draw Menu
Windows Mac Command
Ctrl T Cmd T Draw > Insert Text
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Ctrl Alt L Cmd Alt L Draw > Reset Line Width
Ctrl D Cmd D Draw > Random Line Width
Ctrl P Cmd P Draw > Peak
Ctrl M Cmd M Draw > Smooth
Shift Ctrl H Shift Cmd H Draw > Hide Shape
Shift Ctrl U Shift Cmd U Draw > Show All Shapes
Ctrl F Cmd F Draw > Freeze Points

Bone Menu
Windows Mac Command
Ctrl Shift F Shift Cmd F Bone > Use Selected Bones
  for Flexi-Binding
Ctrl F Cmd F Bone > Freeze Pose

Animation Menu
Windows Mac Command
Ctrl Shift N Shift Cmd N Animation > Nudge Physics 
Object

View Menu
Ctrl Alt 9 Cmd = View > Zoom In
Ctrl Alt 8 Cmd - View > Zoom Out
Ctrl G Cmd G View > Enable Grid
Shift Ctrl G Shift Cmd G View > Grid Settings
Shift Ctrl V Shift Cmd V View > Video Safe Zones
Ctrl J Cmd J View > Show Output Only
Ctrl L Cmd L View > Enable Onion Skins
Ctrl Y Cmd Y View > Select Tracing Image
Ctrl U Cmd U View > Show Tracing Image
Shift Ctrl C Shift Cmd C View > Show Curves
Shift Ctrl A Shift Cmd A View > Fade Unselected Layers
Shift Ctrl D Shift Cmd D View > Design Mode
Shift Ctrl 2 Shift Cmd 2 View > Stereo
Shift Ctrl J Shift Cmd J View > Show Document Tabs

Window Menu
Ctrl Shift E Shift Cmd E Window > Tools
Ctrl Shift K Shift Cmd K Window > Layers
Ctrl [ Cmd [ Window > Timeline
Ctrl ] Cmd ] Window > Style
Ctrl K Cmd K Window > Actions
Shift Ctrl L Shift Cmd L Window > Library
Shift Ctrl B Shift Cmd B Window > Blend Morphs
Shift Ctrl I Shift Cmd I Window > Layer Settings
Ctrl Alt E Cmd Alt E Window > Keyframe
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Alt Shift Ctrl E Alt Shift Cmd E Window > Docking > Tools
Alt Shift Ctrl K Alt Shift Cmd K Window > Docking > Layers
Alt Shift Ctrl T Alt Shift Cmd T Window > Docking > Timeline
Alt Shift Ctrl Y Alt Shift Cmd Y Window > Docking > Style

Keyboard Shortcuts
Many tools and features in Moho can be accessed quickly by pressing a single 
key. These shortcuts make working with Moho much faster than the regular method 
of moving the mouse to a toolbar and clicking a button, and are worth learning 
to reduce your drawing and animation time. However, all these features are also 
available through standard user interface elements (buttons and menus), so learning 
these shortcuts isn’t a requirement to using Moho.

These shortcuts are not the same as “menu shortcuts” listed 
above.

Main Window
Windows Mac Action
Alt Shift Ctrl E Alt Shift Cmd E Dock/Undock Tools Palette
Alt Shift Ctrl K Alt Shift Cmd K Dock/Undock Layers Window
Ctrl [ Cmd [ Open/Close Timeline
Ctrl ] Cmd ] Open/Close Style Window
Alt Shift Ctrl L Alt Shift Cmd L Reload Tools and Brushes
Shift Z Shift Z Activate Previous Tool
F5 F5 New Frame
F6 F6 Duplicate Frame
Shift F5 Shift F5 Delete Frame

Main/Current Editing View
Windows Mac Action
Alt Shift { Alt Shift { Rotate View Left
Alt Shift } Alt Shift } Rotate View Right

Layers Window
Alt D Alt D Activate Previous Switch Layer
  Child
Alt C Alt C Activate Next Switch Layer
  CHild

Style Window
Windows Mac Action
] ] Decrease Line Width
[ [ Increase Line Width
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Timeline Shortcuts
Windows Mac Action
Ctrl 1 Cmd 1 Set Interpolation Linear
Ctrl 2 Cmd 2 Set Interpolation Smooth
Ctrl 3 Cmd 3 Set Interpolation Ease In/Out
Ctrl 4 Cmd 4 Set Interpolation Ease In
Ctrl 5 Cmd 5 Set Interpolation Ease Out
Ctrl 6 Cmd 6 Set Interpolation Bezier
Ctrl 7 Cmd 7 Set Interpolation Step
Ctrl 8 Cmd 8 Set Interpolation Noisy
Ctrl 9 Cmd 9 Set Interpolation Cycle
Shift { Shift { Previous Selected Key
Shift } Shift } Next Selected Key
Alt Shift +(plus) Alt Shift +(plus) Zoom In
Alt Shift _ Alt Shift _ Zoom Out
Alt Shift A Alt Shift = Pan Up
Alt Shift Z Alt Shift - Pan Down
Alt Shift X Shift ~ Auto Zoom

Classic vs New Shortcut Bindings
There is a preference in the Tools tab of the Preferences dialog that allows you to 
choose between classic key binding or new key binding. For further information on 
this setting, see “Tools Tab” on page 442.

Depending on your setting, the following shortcuts will be affected:
Classic Binding New Binding Operation
Spacebar Enter/Return Weld Points
Spacebar Enter/Return Create Shape
Spacebar Enter/Return Bind Points to Bone
Enter/Return Escape Deselect points/bones/keyframes
Spacebar Spacebar Toggle Playback*
Home/Esc Home Reset View*
Home/Esc+Shift Home+Shift Zoom to Layer Contents*
Home/Esc+Alt Home+Alt Zoom to Selected Points*
Tab Tab Select Connected Points*
Hold spacebar while dragging mouse Pan workspace*

Tool Shortcuts
Many of the keyboard shortcuts in Moho are used to activate a tool in a toolbar. 
If you want to know whether a tool has a shortcut, hold the mouse over the tool, 
and watch the tooltip that appears. If the tooltip has a single letter at the end (ex: 
“Transform Points (T)”), then that key can be used as a shortcut to activate the tool.

The keyboard shortcut of Shift-Z toggles between the currently 
selected tool and the previous tool selection.



Moho 13.5
Users Manual 

541

Appendix D: Moho Shortcuts

Moho auto-reverts to the previous tool selection when a 
shortcut for a different tool is selected and held for two 

or more seconds, or if held and a mouse click occurs on the canvas 
before the shortcut is released.

 Press the T key to activate the Transform Points tool.

Draw Tools
Tool Shortcut Tool
G Select Points
T Transform Points
A Add Point
F Freehand
J Blob Brush
S Draw Shape
E Eraser
R Point Reduction
D Delete Edge
C Curvature
X Magnet
N Noise

Fill Tools
Tool Shortcut Tool
Q Select Shape
U Create Shape
P Paint Bucket
W Line Width
H Hide Edge
K Color Points

Special Tools
Tool Shortcut Tool
C Crop
A Video Tracking

Bone Tools
Tool Shortcut Tool
B Select Bone
T Transform Bone
A Add Bone
P Reparent Bone
S Bone Strength
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Z Manipulate Bones
I Bind Points

Layer Tools
Tool Shortcut Tool
M Transform Layer
O Set Origin
L Eyedropper

Camera Tools
Tool Shortcut Tool
4 Track Camera
5 Zoom Camera
6 Roll Camera
7 Pan/Tilt Camera

Workspace Tools
Tool Shortcut Tool
8 Rotate Workspace
9 Orbit Workpace

Common Shortcuts
Some keyboard shortcuts work all the time, and some only apply in while using 
certain tools in Moho: the sections below lists all the shortcuts and when they can be 
used.

The following keyboard shortcuts can be used at any time:

Keyboard Shortcut Function
Escape Automatically adjust the view to see everything in 

the active layer - hold the shift key to zoom in on 
the currently selected points

Home Reset the view to see the overall project
Enter/Return De-select all points
Tab Select all points that are connected to the current 

selection
Left Arrow Step back one frame in the timeline - hold shift to 

rewind
Right Arrow Step forward one frame in the timeline - hold shift 

to advance to end of animation
[ (left bracket) Decreases the line width setting in the Style 

window
] (right bracket) Increases the line width setting in the Style window

Working with Vector Layers
Keyboard Shortcut Function
Delete/Backspace Delete the currently selected points
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Spacebar Weld two points together - usually used with the 
Translate or Add Point tools

Working with Fill Tools
Keyboard Shortcut Function
Delete/Backspace Delete the selected shape
Spacebar Define a shape based on current selection
Up Arrow Raise selected shape up one level - hold shift to 

raise to top
Down Arrow Lower selected shape down one level - hold shift 

to lower to bottom

Working with Bone Tools
Keyboard Shortcut Function
Delete/Backspace Delete the selected bone (and any child bones)
Spacebar Bind points to selected bone
Up Arrow Select parent of current bone
Down Arrow Select child of current bone (only works if current 

bone has just one child)

Working with the Timeline Window
Keyboard Shortcut Function
Alt/Option+Left Arrow Previous Keyframe
Alt/Option+Right Arrow Next Keyframe
Alt/Option+Backspace Delete the selected keyframe(s)
Alt/Option+C Copy the selected keyframe(s)
Alt/Option+V Paste the previously copied keyframe(s)
Spacebar Play/stop the animation
Page Up When in graph mode, zoom in on the timeline - 

hold shift to move the graph up
Page Down When in graph mode, zoom out from the timline - 

hold shift to move the graph down
End When in graph mode, auto-zoom the timeline, 

based on the active animation channel
Ctrl/Cmd+Mouse Scroll wheel Zooms in/out from timeline

Working in the Layers WIndow
Keyboard Shortcut Function
Alt Click Alt-Click the child of a switch layer to activate it.
Alt+D When a switch layer is selected, this shortcut 

activates the previous switch layer.
Alt+C When a switch layer is selected, this shortcut 

activates the next switch layer.

Mouse Shortcuts
There are a few shortcuts that take advantage of the mouse, making work in Moho 
more convenient once you learn them.
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Workspace Navigation
The right mouse button can be used to navigate the main Moho workspace.

To pan the workspace, click and drag with the right mouse button.

If you hold down the spacebar while you click and drag any 
tool with the mouse, it will let you pan the workspace. 

This is similar to the panning navigation in Photoshop and other 
graphics applications.

• To zoom the workspace, hold the shift key while dragging left or right with the 
right mouse button. You can also zoom the workspace by rolling the mouse 
wheel back and forth over the workspace.

• To rotate the workspace, hold down the control key while dragging with the 
right mouse button.

• To fit the view to a selected layer, select the layer that you want to view in the 
Layers Window. Then press the Esc key to fit the selected layer into the view.

Timeline Scrubbing
To scrub the timeline in small increments, press Alt and roll the mouse wheel back 
and forth.

Numeric Fields and Angle Knobs
An easy way to make small adjustments in numeric text fields and angle knobs is 
to hold the mouse over the control and spin the mouse wheel back and forth. Of 
course, you can still enter values into a text field by typing them, but this method lets 
you make small adjustments and view the changes immediately.

• On a Windows PC, when using the mouse wheel to modify the value in a 
text field, holding the Ctrl key halves the increment, holding Shift doubles the 
increment.

• On a Macintosh, when using the mouse wheel to modify the value in a text field, 
holding the Cmd key halves the increment, holding Alt doubles the increment.

This feature may seem cute but unimportant. However, it’s actually very useful 
when working with the tool info panels in Moho. By using the mouse wheel, you can 
see your changes take effect immediately. If you enter the number by hand, the 
change won’t take effect until you press tab or enter. An especially helpful place to 
use this feature is when setting bone angle constraints - these numbers can be tricky 
to figure out, but spinning the mouse wheel you can see exactly what’s happening.

Finally, you can adjust the value of a text field by dragging in it side-to-side with 
the right mouse button. With a regular mouse, the mouse wheel is probably more 
convenient, but this feature was added specifically for animators working with 
tablets. A drawing pen usually has no mouse wheel, so right-dragging allows you to 
adjust the value of a text field without having to switch back to the keyboard.
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Multi-touch Support
Certain tools support Wacom multi-touch tablets and allow you to use multi-touch 
gestures to perform tasks in Moho. Red screen dots on screen identify the location of 
your fingers on the tablet. The following general notes apply to multi-touch features:

Use the Multitouch checkbox (located above the Timeline on 
the left side) to enable or disable Multitouch support.

If you experience problems accessing Wacom touch support, 
you should make sure you have the latest drivers 

installed, and restart Moho or your computer if needed.

If the currently selected tool does not support multi-touch, then the 
multi-touch events will be used to navigate the workspace.

• Multi-touch events can be used for workspace navigation, regardless of 
whether or not the current tool supports multi-touch events. Hold down the 
spacebar while using the multi-touch tablet to use it for workspace navigation.

• Multi-touch support is accessible through scripting, allowing users to write their 
own multi-touch scripts.

• Smoothing and zooming support has been enhanced to support multi-touch 
actions, and should also work better with the touch ring on Wacom tablets.

The following tables outline the tools that offer this support.

Draw Tools
Draw tools that support multi-touch actions are Transform Points, Select Points, 
Freehand, and Draw Shape.

Multi-touch Action Function
One-finger gesture Translates selected points
Two-finger gesture Scales or rotates selected points
More than two fingers Behaves similarly to two-finger gestures

Layer Tools
The Transform Layer tool supports multi-touch actions.

Multi-touch Action Function
One-finger gesture Translates selected layer
Two-finger gesture Scales or rotates selected layer
More than two fingers Behaves similarly to two-finger gestures
Four-finger drag Allows you to rotate an object in 3D
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Camera Tools
Camera tools that support multi-touch actions are Track Camera, Roll Camera, and 
Zoom Camera, and Pan Camera.

Multi-touch Action Function
One-finger gesture Tracks or Pans/Tilts camera
Two-finger gesture Rooms or zooms camera
More than two fingers Behaves similarly to two-finger gesture

Workspace Tools
Workspace tools that support multi-touch actions are Pan canvas, Scale canvas, 
and Rotate canvas.

Multi-touch Action Function
One-finger gesture Pans the canvas
Two-finger gesture Scales or rotates the canvas
More than two fingers Behaves similarly to two-finger gestures
Five fingers down on tablet Resets the canvas

Other Actions
Multi-touch Action Function
Two-finger double-tap Resets whatever property you are currently editing
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Format Preset Video 

Codec
Audio 
Codec

Resolution Comments

Image 
Sequence

JPEG n/a n/a n/a
BMP n/a n/a n/a
Targa n/a n/a n/a
PNG n/a n/a n/a
PSD n/a n/a n/a

M4V Apple M4V (H-264-
AAC)

H.264 AAC

MP4 MP4 (H.264-AAC) H.264 AAC
AVI
(Windows 
Only)

AVI (MJPEG)
AVI Movie (DV) 720x 480
AVI Movie 
(Uncompressed)

AVI (Video 
for Windows)
(Windows 
Only)

AVI Movie

QuickTime 
(Macintosh 
Only)

QuickTime (H.264-
AAC)
QuickTime (H.264-
PCM)
QuickTime (JPEG-
AAC)
QuickTime (ProRes 
422-AAC)
QuickTime (ProRes 
4444-AAC)

Supports exporting 
of frames that 
have Alpha 
channels

QuickTime (ProRes 
4444-ALAC)

Supports exporting 
of frames that 
have Alpha 
channels

QuickTime (PNG-
AAC)

Supports exporting 
of frames that 
have Alpha 
channels

Legacy 
QuickTime

QuickTime Movie

Flash Flash (SWF)

Writing Your Own Presets
Some third-party video editing and playing software installs codecs that are not 
furnished with Windows. Moho does not prompt you to choose a third-party codec 
when you choose AVI as an output format. 
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When you create a User Content folder, a Media Preset folder is created within it, 
based on the plugins that are supported for your product/platform. You can locate 
your own custom preset XML files in this folder to add them to the application. 

You have the ability to add your own presets in the <User Content Library>\Media 
Presets folder. Depending on the platform there should be two subfolders within the 
Media Presets folder. Those folders are used to differentiate the media libraries that 
are used to create video exports. On Windows the two folders are named:

• P1_MPMediaFoundation

• P2_MPDirectShow

On Mac the folders are:

• P1_MPAVFoundation

• P2_MPQuickTime

Preset files are XML files that define the output format, video codec, and audio 
codec of the output. The supported values for format and codec are dependent 
on the media library for the platform. While AV Foundation on the Mac may support 
exporting to the QuickTime ProRes codec, Media Foundation and DirectShow on 
Windows cannot. See online documentation for those media libraries to get an 
understanding of what export formats and codecs are possible.

The preset files are in the same format the application uses for presets. You can see 
example preset files by navigating to where Moho is installed and opening the files 
in a text editor. That is probably the best way to get an understanding of how preset 
files work. On Windows, the application preset files are locate here:

• <Install Folder>\Media Plugins\P1_MPMediaFoundation

• <Install Folder>\Media Plugins\P2_MPQuickTime

On Mac, you would need to open the application bundle (Show Package Contents) 
and navigate to one of these two folder locations:

• Moho Pro.app\Contents\PlugIns\P1_MPAVFoundation.pmp\Contents\
Resources

• Moho Pro.app\Contents\PlugIns\P2_MPQuickTime.pmp\Contents\Resources

You can view the XML files in your favorite text editor. To get your feet wet, what you 
may want to do is copy one of the preset files from the install folder or application 
bundle into the similar folder in the User Content Library folder. So for example if 
the preset file is named MP4.xml in the P1_MPMediaFoundation folder, you’ll want 
to name it something like My MP4.xml in the analogous <User Content Library>\
Media Presets\P1_MPMediaFoundation folder. In the Export Animation or Moho 
Exporter dialog, you’ll now see a menu item in the Format dropdown that says 
My MP4 with the same presets that are in the MP4 format. You can than tailor the 
presets to how you like.

One thing to keep in mind if you do keep a name of the XML the same as an 
existing preset file name (including application preset names), any presets that are 
defined there will be grouped with those same presets in the user interface. As an 
example, let’s say you create a My MP4.xml file in the P1_MPMediaFoundation 
folder and than create a My MP4.xml file with different configured presets in the 
P2_MPDirectShow folder. In the Export Animation or Moho Exporter dialogs, all the 
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presets across both media libraries will be grouped in the My MP4 Format drop down 
item.

 Please don’t ever directly modify the preset files in the install 
folder or application bundle. Use the user content 

library location. There are a couple reasons for this. The preset files 
will get wiped out if the software is ever upgraded. On Mac, 
modifying the files will break code signing of the application and will 
cause internal application issues with the Content Library.

The attributes for the MediaPlugin element in the XML file are as follows:

• name: The name of the preset as you want it to appear on the Format menu in 
the Movie Settings dialog (as shown in the following figure).

• extensions: The file extension(s) that are used with the preset.

• showUI: Displays the UI available for the codec.

• video element: Describes the parameters that will apply to the output video. It 
has the following optional attributes.

 � codec: The name of the video codec that will be used to compress the 
video

 � framerate: The number of frames per second, of the video you will create.

• audio element: Describes the parameters that will apply to the output audio. It 
has the following optional attributes:

 � codec: The name of the audio codec that will be used to compress the 
audio

 � samplerate: The sample rate for the audio (higher sample rates are higher 
quality)

 � channels: The number of channels in the audio file (1 for mono, 2 for 
stereo)

To create your own media presets, you will need to use a text or web page editor to 
create a file with an XML extension. The format of the XML file should be similar to the 
following:

<?xml version=”1.0” encoding=”utf-8”?>
<Presets>
 <MediaPreset name=”AVI (LAGS)” extensions=”avi” showUI=”true”> 
  <video codec=”Lagarith Lossless Codec” framerate=”30”/> 
  <audio codec=”pcm” samplerate=”44100” channels=”2”/>
 </MediaPreset>
 <MediaPreset name=”AVI (MS Video1)” extensions=”avi”>
  <video codec=”MSVC” framerate=”30”/>
  <audio codec=”pcm” samplerate=”44100” channels=”2”/>
 </MediaPreset>
 <MediaPreset name=”AVI (XVID)” extensions=”avi”>
  <video codec=”XVID” framerate=”30”/>
  <audio codec=”pcm” samplerate=”44100” channels=”2”/>
  </MediaPreset>
</Presets>
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 Additional presets added in the Movie Settings dialog.
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Appendix F: Moho Document 
File Format 

Introduction
With Anime Studio 11.0, the product team released a brand new document file 
format. The older .anme format was replaced with a new JSON-based format (file 
extension: .anime). Using a standard format like JSON made it easier to maintain a 
format that is both backward and forward compatible as newer versions of Moho 
are released. It can do that because the JSON format can organize data in a 
specific yet flexible hierarchy. This hierarchy can allow us to add, and in some cases 
delete data values without breaking the file format.

In order for the document to save space on user’s storage devices, the document 
format is also compressed in a container using the Zip file format. Since JSON is a text 
based format, Zip dramatically reduces its size on disk. 

One of the reasons we picked both JSON and Zip is they are both popular and 
widely used. That makes it easier for users to be able to use third party libraries 
and scripting languages to manage and manipulate the document if they feel 
inclined. For example, the scripting language Python has both JSON parsing and Zip 
compression decompression built-in. Using a small bit of scripting, it is quite easy to 
open, query, modify, and save an existing document. We’ll show an example of this 
later in the document.

In Moho 12, we changed the document file extension from .anime to .moho to keep 
with the renaming of the application from Anime Studio to Moho. This file extension 
change was mostly for cosmetic and branding reasons. Internally, the .moho file 
format works exactly as the .anime file format. 

One note about the pre-11.0 document format. Moho will continue to read the old 
format for the foreseeable future. We realize there is a lot of content out there. While 
the old format is considered deprecated, the application should continue to read 
and convert documents as old as Anime Studio 6.

Document Overview
If you were to try to open up a .moho file in a text editor or hex editor, you most 
likely wouldn’t understand what you were looking at. This is because the .moho 
format is using the Zip compressed file format as a container for the real data of the 
document.
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 Moho file is in compressed format.

Zip Container
Zip compression shrinks down the size of the data by looking for duplicated items in 
the document and replacing it with binary data that is significantly smaller than the 
original information. Since JSON is a text based format, the amount of compression 
we get is rather dramatic. We’ve seen document data reduce in size on disk from 
250 MB down to about 4 MB!

If you were to rename your MyMohoDocument.moho file to MyMohoDocument.
zip, you could expand the .anime file using any Zip decompression tool (eg StuffIt, 
WinZip, WinRAR, etc). One or two files should be created.

• Project.mohoproj is the main project. It defines all the main data about your 
Moho document including layers and styles. The whole next section will be 
about describing this document.

• preview.jpg is the project thumbnail image (optional).  It is created from the 
project canvas when the document is saved. This file is used by the thumbnail 
previewer on Windows and the QuickLook plugin on Mac. The reason the 
thumbnail is optionally in the archive is the image file will not be created if 
thumbnail creation is disabled in the Documents preferences. (See “Document 
thumbnail preview size”)

JSON Project Document (Project.mohoproj)
In order to understand how the Moho project document works, it is necessary to 
review some of the basics of JSON. Below is an example of the first lines of the 
project document. This document has been beautified to add whitespace and 
color.
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 The beginning of a project document.

JSON is a key-value based hierarchical file format. This means that you associate 
data values from the document by using a specific key. If you want to reference a 
particular bit of information in the document, you just have to search for its key. (In 
the screenshot above, the keys are in blue.) If you would like to find in the document 
what date the document was created, you’d just search the JSON for the “created_
date” key. The data value would be the time stamp. Key-value pairs together are 
considered “properties” of the format.

JSON Key/Value

“created_date”: “Fri Jan 22 17:59:49 2016”

The hierarchical part of JSON means that you can associate one or more pieces of 
document data by making it be a “parent” or “child” of that data. For example, 
Moho uses layers to define objects on the canvas (eg Vector, Image, Switch, etc). 
A vector layer may be described by many properties such as points, lines, curves. 
Those drawing types are in turn are described by even deeper properties such 
as their location on the canvas and how they can be animated. The JSON file 
format keeps track of all those properties by establishing a parent/child relationship 
between them. For example, this is a pseudo-hierarchical representation for a line in 
a vector layer:
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All Layers  > Vector Layer  > Line  > Line Properties

With JSON, you can also group related data into objects and lists. Objects use { } 
syntax and lists use [ ] syntax. An object groups properties together that are related 
into a unified concept. For example, if you wanted to define a background color 
based on it’s RGBA values, you may want to define it this way:

Background Color Object 

“back_color”: { 
 “r”: 234,
 “g”: 234,
 “b”: 234,
 “a”: 255
},

From the definition it becomes clear which properties are considered red, green, 
blue, or alpha by looking at its keys.

A list describes properties, objects, or even other lists that are usually the same type. 
The advantage of lists is that they are not fixed sizes. So you can define as many 
items as you need. Here is how you may want to define a list of layer comps:

Layer Comps Defined in a List 

“layercomps”: [“Background”,”Character 1”, “Character 2”, ... ]

(Note that the example above isn’t exactly how layer comps are defined in the 
.moho  file format. Properties were removed for brevity.)

Objects and lists are what make JSON a really powerful part of the format because 
to add new data, you just have to add a new property or object. Parsers that 
read and understand JSON typically ignore information they don’t understand. So 
let’s say we add in Moho 15.0 a new property with a key of “my_new_animation_
feature”. When Moho 13.5.0 opens that file, it just ignores that feature. This is good 
news if the new feature was not an integral feature of the document. If it is an 
important feature, you will have to use Moho 15.0 to make use of it.

XMP Sidecar document file

Starting in Moho 13.5.0, there is a new sidecar document file that is optionally 
created. This document is a XMP file, which is an Adobe document standard for 
storing metadata. XMP was chosen because it is supported by applications like 
Adobe Bridge.

The XMP sidecar file is not always created whenever you save a Moho project 
document. It is only created if you go into the Moho’s project settings and set tags 
or a comment for the project. Subsequent saves of the project document will then 
save the .xmp file.

Document Structure
Now that we have JSON basics under control, let’s start going through some of 
the guts of the format. Within the JSON document there are a number of different 
sections:

• Document Header
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• Camera Movements and Timeline Markers

• Styles

• Layer Comps

• Layer Definitions

• Document View State

Each section mostly correlates to the old .anme format. The big difference is that 
in the old format not all items used a key to define its value. On the surface, that 
means that the new JSON file format is a bit bigger and a bit more verbose than 
the old format. The positive is it typically makes it much more easier to find the data 
values you are looking for.

For those who wish to understand more about each of the document sections, they 
will be described in more detail below.

Document Header
The document header contains general or project -wide information about the 
document. It lives at the very top of the document. In the example below you 
can see that the header includes version information, a creation date, as well as a 
comment the application writes.

There are three versions specified in the header:

• major_version

• version

• rev_version

Moho can use each of these version numbers in different ways. “major_version” 
is the major document version. We hope this never happens, but if we have to 
change the file format so radically so that old versions of our software can’t read it, 
this number will increase. “version” is the document version. It is used mostly to let 
the application know that this document is newer or older than what the current 
application can open. If the version number is newer, a warning will be given to the 
user that the document has been created with a newer version of the document. 
Finally, rev_version is just a revision number. This revision number is used mostly for 
internal purposes.

The “project_data” object contains properties that are specific to this project. 
Most of these properties come directly from the Project Settings dialog (File >Project 
Settings) in the application.

• width/height   The project width and height in pixels (eg 720p or 480p) of the 
export

• start_frame/end_frame   The starting and ending frame of the animation

• fps   frames per second of the animation

• back_color   background color of the canvas

• depth_of_field/focus_distance/focus_range/focus_blur   depth of field properties
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Document Header 

“mime_type”: “application/x vnd.lm_mohodoc”, 
“version”: 1038,
“major_version”: 1,
“rev_version”: 0,
“comment”: “Created in Moho version 12.0, Copyright © 1999 2016 Lost 
Marble Software, Inc.”,
“created_date”: “Fri Jul 22 17:59:49 2016”, 
“project_data”: {
 “width”: 852,
 “height”: 480,
 “start_frame”: 1,
 “end_frame”: 48,
 “fps”: 24, 
 “back_color”: { 
  “r”: 234,
  “g”: 234,
  “b”: 234,
  “a”: 255
},
“noise_grain”: 0,
“pixelation”: 0, 
“antialiasing”: true, 
“depth_sort”: false, 
“distance_sort”: false, 
“depth_of_field”: false, 
“focus_distance”: 2,
“focus_range”: 1,
“focus_blur”: 0.050625,
“global_render_style_fill_style”: 0,
“global_render_style_line_style”: 0,
“global_render_style_layer_style”: 0, 
“global_render_style_minimize_randomness”: true, 
“stereo_mode”: 0,
“stereo_separation”:  1, 
“extra_swf_frame”: false, 
“color_palette”: “Basic Colors.png”, 
“soundtrack”: “”
}

Styles
All the global styles of the document are defined in this section. For each style there 
is a:

● name

● unique identifier

● line and fill color

● brush name

● brush properties
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Styles

“styles”: [
  {
    “type”: “Style”,
    “name”: “Dragon_Tongue_Shading”,
    “uuid”: “0ff99f9b-299b-4497-9f73-6c38dda5e952”,
    “define_fill_color”: true,
    “fill_color”: { ... }
    “define_line_width”: true,
    “line_width”: 0.001389,
    “define_line_col”: true,
    “line_color”: { ... }
    “line_caps”: 1,
    “brush_name”: “Brush504.png”,
    “brush_align”: false,
    “brush_jitter”: 6.283185,
    “brush_spacing”: 0,
    “brush_angle_drift”: 0,
    “brush_randomize”: false,
    “brush_merged_alpha”: false,
    “brush_tint”: true
  },
  {
    “type”: “Style”,
    “name”: “Dragon_Wing_Dark”,
    ...
  }
}

Layer Comps
Layer comps are used to focus on certain layers when composing or rendering. 
You can manage the creation, deletion, or updating of layer comps in the Layers 
Window.

Layer comps in the document are defined by three items:

• Name

• Unique identifier (UUID)

• A list of layer IDs

Layer Comps

“layercomps”: [
  {
    “name”: “Background”,
    “uuid”: “B85FA8AD-2CB1-43C4-89E5-3B86138CAC40”,
    “layer_ids”: [
      “DE907C68-CD6C-4353-A5C7-4D416E208BA7”
    ]
  },
  {
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    “name”: “Character 1”,
    “uuid”: “ABC86A51-B354-43E9-9D2C-5064D8DAD0B0”,
    “layer_ids”: [
      “11A8AB8B-F7A6-4E7B-987C-F08F546E95EF”,
      “75BAC57E-C083-470F-B812-09CF8F2AE032”,
      “DE907C68-CD6C-4353-A5C7-4D416E208BA7”
    ]
  },
  ...
],

The “layer_ids” key specifies a list of layer IDs that are UUIDs. In the layers section of 
the document, each layer has a unique layer ID.

Camera Movements and Timeline Markers
Camera movements and timeline markers are defined in the “animated_values” 
object.

Camera Movements and Timeline Markers

“animated_values”: { 
 “camera_track”: { ... },
 “camera_zoom”: { ... },
 “camera_roll”: { ... },
 “camera_pan_tilt”: { ... },
 “timeline_markers”: { ... }
},

Layer Definitions
The layers section of the document is undoubtably the largest section of any .moho 
document. Quite simply, it defines all of the layers and their attributes. Here are the 
current layer types:

• Vector Layer (aka Mesh Layer)

• Image Layer (includes image and movie types)

• Audio Layer

• Group Layer

• Switch Layer

• Bone Layer

• Particle Layer

• Note Layer

• Text Layer

• Patch Layer

• Poser Layer (aka Mesh 3D Layer)
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Each of the layers in the Project.mohoproj JSON file will have numerous properties 
associated with it. In fact it is too many to name in this document. There are some 
common properties like type, name, and unique ID, but then there will also be a 
number of layer specific properties. For example, an image layer requires that there 
be a path to the image file (eg MyPhoto.png).

Layers

“layers”: [
 {
 “type”: “ImageLayer”, 
 “name”: “Background”,
 ...
 },
 {
 “type”: “MeshLayer”, “name”: “Character 1”,
 ...
 },
 ...
}

Document View State (Optional)
In Anime Studio 11, a checkbox was added in the Documents Preferences to save 
the document view state within the document. Enabling “Save and restore view 
settings in the document” will add a new “documentviewstate” object. Documents 
that don’t save the view state, will just use the default values when they are opened.

An example view state property that can be saved with the document happens 
when you select View->Show Rule of Thirds in the main menu. Each time you open 
that document, the canvas will show the Rule of Thirds grid.

Document View State

“documentviewstate”: {
  “DocState_viewportSetting”: 1,
  “DocState_gridOn”: false,
  “DocState_gridStyle”: 0,
  “DocState_gridSize”: 20,
  “DocState_gridSnappingOn”: true,
  “DocState_showOutputOnly”: false,
  “DocState_showVideoSafeZones”: false,
  “DocState_showRuleOfThirds”: true,
  “DocState_viewPortLeftWidthPct”: 1,
  “DocState_viewPortTopWidthPct”: 1,
  “DocState_zoom0”: 0.9,
  “DocState_viewOffset0”: { ... },
  “DocState_rotation0”: 0,
  “DocState_stereo0”: false,
  “DocState_enableOutsideView0”: false,
  “DocState_outsideViewPitch0”: 0,
  “DocState_outsideViewYaw0”: 0,
  “DocState_outsideViewRadius0”: 0,
  “DocState_outsideViewAttn0”: { ... },
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  ...
  “DocState_playStart”: -1,
  “DocState_playEnd”: -1
}

Tips
Finding the Old Format within the New Format
The old .anme document format that was used in Anime Studio 10 and earlier was 
a custom format. While the format was text based, there were some format issues 
that made it difficult to add new properties without breaking the format. Since you 
just had to drag and drop a .anme file into a text editor, it was relatively trivial to 
make changes if you knew some basics about the format. The good news is that 
the new document format tries to mimic the sections of the old format. There was a 
Document Header, Layer Comp, Style, and Layer section to the document. If you 
have an older pre-11.0 .anme file, opened it Moho 13.5, converted the document 
to .moho and than compared the documents side-by-side, a lot would match up.  
The main big difference is every property now must have a key associated with 
values. That means that it should be easier to find a certain value in the document 
if you know it’s key. So if you want to change a value of an Image Layer, all you’d 
need to do is search for “ImageLayer” in the JSON file. Find the specific image layer 
if there is more than one. Then you just find the property that you want to change. 
For example, if you wanted to enable the Toon Effect on that image layer, you’d 
continue your search and look for the key “toon_effect”.

The keys may make the file format be more verbose looking, but the few times we 
have had to open up a document to check out a property, we find it easier to really 
drill down into what specific properties are.

There are two areas were it will actually be easier to understand in the new format 
than the old format.

1. Finding specific layers

2. Finding type information about that layer.

In the old format, layers were defined by an ID number. You’d used to have to 
search through the file and where a new layer was starting you had to know that a 
Image Layer started with 2 and than you could search for this:
layer_type 2
 {
 ...
 }

Here were all the ID numbers:

• Vector Layer = 1

• Image Layer = 2

• Group Layer = 3

• Bone Layer = 4
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• Switch Layer = 5

• Particle Layer = 6

• Note Layer = 7

• Poser/3D Layer = 8

• Audio Layer = 9

• Patch Layer = 10

• Text Layer = 11

In the new format each layer has a “type” key that has one of the following values:

• Vector Layer = “MeshLayer”

• Image Layer = “ImageLayer”

• Group Layer = “GroupLayer”

• Bone Layer = “BoneLayer”

• Switch Layer = “SwitchLayer”

• Particle Layer = “ParticleLayer”

• Note Layer = “NoteLayer”

• Poser/3D Layer = “Mesh3DLayer”

• Audio Layer = “AudioLayer”

• Patch Layer = “PatchLayer”

• Text Layer = “TextLayer”

No more searching by layer ID. Once you are in the JSON object for the layer, you 
then just navigate down to set its property. This should be relatively easy for top level 
properties of the layer (eg “name”, “path”). Note that most of the layers make use 
of complex properties. For example, a vector layer may be made up 100s of shapes. 
Those shapes may have 100s of points. Editing one of these points may be extremely 
difficult using just the document file.

Editing the New Format with a Text Editor
1. Copy the Moho document from MyMohoDocument.moho to a new file named 

MyMohoDocument.zip.

2. Expand the .zip file using a decompression tool like StuffIt, WinZip, WinRAR, or the 
Zip mechanism built into your machine.

3. There should be two files that are expanded: Project.mohoproj and preview.jpg

4. Beautify the Project.mohoproj file. (See below)

5. Open the Project.mohoproj file in a text editor.

6. Make your edits to the text file
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7. Zip the Project.mohoproj using a compression tool like above. Make sure to 
choose the .zip format, not 7z or RAR.

8. Name the archive MyModfiedMohoDocument.zip

9. Once zipped, rename the document to MyModifiedMohoDocument.moho.

10. Try and open in Moho.

In step 4 you will most likely need to “beautify” or “pretty” up the Project.mohoproj 
file before it is edited in the Text Editor. In order to save space on the user’s 
computer, the Project.mohoproj file had all unnecessary whitespace characters 
(spaces, tabs, new lines) removed by Moho when saved. Beautifying means that 
you are adding all that back in just so that it will be easy to edit. There are a number 
of tools that will do this for you. In the section below, there will be links to beautifiers. 
The sample code provided below also show how to beautify programmatically. 

There is no need to remove all of the whitespace/newline characters after making 
your edits in step 6. The next time that the document is saved, the whitespace will 
again be removed.

In step 7, it is not necessary to Zip the preview.jpg file. This is purely optional. The 
thumbnail preview will be regenerated the next time the document is saved.

Also in step 7, keep in mind that some Zip tools use their own Zip format for 
compression (eg WinZip). Make sure you specify in the application preferences the 
most “portable” version of the .zip format. That is usually LZ compression.

Editing the New Format with a Scripting Tool
Editing the new document format with a scripting tool follows the same general path 
as manually editing from the section previous. The difference is you can automate 
the Zip compression/decompression as well as the browsing/editing of the JSON. At 
the bottom of this document there are two Python scripts that you can use as an 
example. Other scripting languages have support for Zip and JSON, either through 
builtin support or by using a library.

Scripting Pseudo Code

// Unzip the .moho file
...

// Open the Project.mohoproj file
...

// Use the JSON parser to look for 1 or more keys
...

// Print/Edit the values for the key(s)
...

// Close the Project.mohoproj file
...

// Zip the Project.mohoproj back to the original .moho file
...
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Tools for Beautifying JSON
With Moho removing all of the whitespace and newline characters from  the 
document, it will be necessary to beautify to text to make it easier to search for keys 
and values. Here are a list of tools we use within Lost Marble to help beautify.

• JQ   JSON Query Utility   Command line tool for Mac or Windows 

• BBEdit or TextWrangler JSON Text Filter Beautifier (Mac only) 

• JS Beautifier (Web)

• JSON Beautifier & Formatter (Web) 

• JSON Beautifier (Web)

Recommended JSON Editors
JSON editors can help you visualize a JSON file by syntax coloring and collapsing lists 
and objects.

• JSON Editor Online (Web)

• Notepad++ with JSTool plugin (Windows) 

• Xcode (Mac)

• BBEdit or TextWrangler (Mac)

Keep in mind that JSON is just text. So it can be opened with your favorite text editor. 
It might not have syntax coloring, but it can get the job done.

Python Scripts
Below are two Python 2.x scripts. The first one just extracts 1 or more .moho files to 
JSON. MyMohoDocument.moho become MyMohoDocument.json.

Extract to JSON

#!/usr/bin/env python
“””Extract To JSON - Takes 1 or more .moho file and converts it to 
JSON
   extract_to_json.py <.moho files>
“””
import os
import os.path
import json
import shut
import sys
import zipfile
  
def ExtractToJSON(mohopath, beautify = False):
   if (not os.path.exists(mohopath)):
      print ‘ERROR: %s does not exist’ % mohopath
      return
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   # Get the folder and the file name for the path
   folder, mohofilename = os.path.split(mohopath)
   print ‘Extracting from ‘ + mohofilename + ‘...’
 
   # Open the .moho file
   with zipfile.ZipFile(mohopath) as zip_file:
      # Iterate over all of the items in the zip file
      for item in zip_file.namelist():
         filename = os.path.basename(item)
 
         # skip everything except the .mohoproj file, which is JSON
         if filename != ‘Project.mohoproj’:
            continue
         # Create the extracted .json path name
         filename, ext = os.path.splitext(mohofilename)
         filename += ‘.json’
         jsonpath = os.path.join(folder, filename)
         # Load the JSON from the zip file and dump it beautified to 
the .json path
         source = zip_file.open(item)
         if (beautify):
            json_obj = json.load(source)
            json.dump(json_obj, file(jsonpath, “wb”), sort_
keys=False)
         else:
            shutil.copyfileobj(source, file(jsonpath, “wb”))
  
def Usage():
   print ‘%s <.moho files> - Extract .moho to JSON’ % os.path.
basename(sys.argv[0])
  
def perform():
   numArgs = len(sys.argv)
   if numArgs == 1:
      Usage()
      return
  
   for mohopath in sys.argv[1:]:
      ExtractToJSON(os.path.normpath(mohopath))
  
if __name__ == ‘__main__’:   
  perform()

This second script allows you to list, extract or update an existing .moho without even 
opening the file.

Manipulate a .moho file

#!/usr/bin/env python
“””moho_util - Manipulate a .moho file
   Commands are list, extract, and update.
   list prints the paths of image and audio layers.
   extract saves the Project.mohoproj to a desired location.
   update replaces existing paths with the one supplied.
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   moho_util.py -h |command| for help.
“””
import zipfile
import json
import argparse
import os
import sys
 
def extractProject(mohoFile):
    “””Return the Project.mohoproj extracted from a zip file as a 
string.”””
    zf = zipfile.ZipFile(mohoFile)
    for filename in [ ‘Project.mohoproj’ ]:
        data = zf.read(filename)
 
    return data
 
def writeProject(mohoFile, projectData):
    “””Write data back into Project.mohoproj in a zip file”””
    zf = zipfile.ZipFile(mohoFile, mode=”w”)
    zf.writestr(‘Project.mohoproj’, projectData)
 
def printLayerInfo(layer):
    “””Print the path of an image or audio layer.”””
    if layer.has_key(‘image_path’):
        print “image:”, layer[‘image_path’]
 
    if layer.has_key(‘audio_path’):
        print “audio:”, layer[‘audio_path’]
 
def updateLayerInfo(layer, update):
    “””Replace the path of an image or audio layer.”””
    if layer.has_key(‘image_path’):
        path = layer[‘image_path’]
        layer[‘image_path’] = path.replace(update[0], update[1])
 
    if layer.has_key(‘audio_path’):
        path = layer[‘audio_path’]
        layer[‘audio_path’] = path.replace(update[0], update[1])
 
def isContainerLayer(layer):
    “””Return True if the layer is a group or switch layer.”””
    type = layer[‘type’]
    return type == “GroupLayer” or type == “SwitchLayer”
 
def iterateContainerLayer(groupLayer, update=None):
    “””Iterate a group or switch layer descending into sub groups 
and updating or printing layers otherwise.”””
    for layer in groupLayer:
        if isContainerLayer(layer):
            iterateContainerLayer(layer[‘layers’], update)
        else:
            if update:



Moho 13.5
Users Manual 

566

Appendix F: Moho Document File Format 

                updateLayerInfo(layer, update)
            else:
                printLayerInfo(layer)
 
 
def iterateLayers(path, update=None):
    “””Iterate the root project layers.”””
    projectPath = path
    projectData = extractProject(projectPath)
 
    if len(projectData) > 0:
        jsonData = json.loads(projectData)
        layers = jsonData[‘layers’]
        iterateContainerLayer(layers, update)
        if update:
            writeProject(projectPath, json.dumps(jsonData))
            iterateContainerLayer(layers)
 
def extractProjectFile(mohoFile, projectFilepath = None):
    “””Iterate Project.mohoproj to projectFilePath.”””
    jsonData = extractProject(mohoFile)
 
    if len(jsonData) > 0:
        jsonData = json.loads(jsonData)
        if projectFilepath:
            output = file(projectFilepath, ‘wb’)
        else:
            output = file(‘Project.mohoproj’, ‘wb’)
 
        json.dump(jsonData, output, sort_keys=False, indent=4)
    else:
        parser.error(“Project.mohoproj is empty”)
 
         
 
def perform():
    parser = argparse.ArgumentParser(description=”Open a .moho file 
and print and/or update the paths of image and audio layers”)
    subParsers = parser.add_subparsers(help=”commands”, 
dest=”command”)
    parser_list = subParsers.add_parser(“list”, help=”list image and 
audio paths in Moho project document (.moho).”)
    parser_list.add_argument(‘path’, help=”path to Moho project 
document”)
 
    parser_extract = subParsers.add_parser(“extract”, help=”extract 
Project.mohoproj from Moho project document (.moho).”)
    parser_extract.add_argument(‘path’, help=”path to Moho file”)
    parser_extract.add_argument(‘projectFile’, metavar=’project 
file’, help=”path to save Moho project document”)
    parser_extract.add_argument(‘-b’, ‘--beautify’, action=”store_
true”, help=”beautify the project document”)
 



Moho 13.5
Users Manual 

567

Appendix F: Moho Document File Format 

    parser_update = subParsers.add_parser(“update”, help=”update 
image and audio paths in Moho project document (.moho).”)
    parser_update.add_argument(‘existing’, help=”existing path(s) in 
file”)
    parser_update.add_argument(‘new’, help=”path to replace existing 
path(s) with”)
    parser_update.add_argument(‘path’, help=”path to Moho project 
document”)
 
    args = parser.parse_args()
 
    path = os.path.abspath(args.path)
    if not os.path.exists(path):
        parser.error(“%s does not exist.” % path)
 
    if not path.endswith(“.moho”):
        parser.error(“%s is not a Moho (.moho) project document.” % 
path)
 
    updateInfo = None
    if args.command == “update”:
        updateInfo = (args.existing, args.new)
 
    if args.command == “extract”:
        extractProjectFile(path, os.path.abspath(args.projectFile))
    else:
        iterateLayers(path, update=updateInfo)
 
if __name__ == ‘__main__’:
    perform()
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Appendix G: Command Line 
Renderer (Pro Only)

Introduction
Starting in 5.1, Anime Studio Pro introduced a command-line interface to its 
rendering engine. This interface is different than the Export Animation or Moho 
Exporter renderers in that users can launch renders without needing to interact with 
application windows or buttons. It is a perfect environment for users who would like 
to automate the rendering of their Moho projects without the need to do repetitive 
work of setting up application dialogs. 

Usage
To use Moho for command-line rendering, here is an example of the simplest 
command:

Syntax:

Moho Pro x64.exe -r MyScene.moho

Explanation:

The command tells Moho to render the file MyScene.moho and to produce a 
rendered output file in the same folder as the project file (more on that below). 
It can be used directly from a Windows Command Prompt, OS X Terminal, or 
integrated into whatever scripting environment you choose (eg. Poser, Ruby, Bash).

Windows and Mac OS X have some specific quirks when using 
Moho from the command-line. Be sure to read 

“Platform Notes” on page 577 to learn about your particular 
platform.

Main Options
The following are the main options for the renderer:

-r or -render

Syntax:

-r <moho project file> or -render <moho project file>
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Explanation:

This is the only required option. It tells Moho to render the given project file and then 
quit. The Moho project file can be a .moho project or one of the legacy document 
formats (.anime, .anme, or .moho) back to version 4 of the format.

-f <format>

Syntax:

-f <format>

Explanation:

This tells Moho what format to render the output as. Valid formats are any of the 
presets specified in the Export Animation dialog. Here are the some examples that 
work on both Mac and Windows:

• JPEG

• TGA

• BMP

• PNG

• PSD

• QT

• MP4 (H.264-AAC)

• Animated GIF

• SWF (Flash)

The video, Animated GIF, and SWF formats generate a single output file, while the 
other formats create numbered sequences of still images. If you don’t specify a 
format on the command-line, the default format used will be “MP4 (H.264-AAC)”.

-o or -output

Syntax:

-o <output> or -output <output>

Explanation:

Specifies an output file or folder. The output file should include the file extension of 
the desired output format. If the output format is PNG the output should be named 
something like MyScene.png.

If you skip this option, the output file will automatically have the same name as the 
input file, but with an extension matching the format you choose. For example, if 
you are rendering a file named MyScene.moho to a format of “MP4 (H.264-AAC)”, 
the output will be placed in the same folder as the document file with the name 
MyScene.mp4.
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If a folder is specified instead of a file name, the output will be placed within the 
folder with a name matching the document file and the appropriate output 
extension.

-start <frame number>

Syntax:

-start <frame number>

Explanation:

Specifies the starting frame to render. If omitted, Moho will start rendering at the 
document’s start frame (usually 1).

-end <frame number>

Syntax:

-end <frame number>

Explanation:

Specifies the last frame to render. If omitted, Moho will render up through the last 
frame of the document.

-v or -verbose

Syntax:

-v or -verbose

Explanation:

Runs the rendering job in “verbose” mode. In this mode, Moho will print out the 
render option values along with messages about its status. This includes an estimate 
of the time remaining in the rendering job.

-q or -quiet

Syntax:

-q or -quiet

Explanation:

Runs the renderer in “quiet” mode. “quiet” mode disables all command-line output, 
both information and errors. “quiet” mode overrides “verbose” mode. This option 
was introduced in Anime Studio Pro 9.5.

-log <logfile>

Syntax:

-log <logfile>
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Explanation:

Specifies a log file for the render. Information and errors that are normally shown as 
command-line output are instead logged to the log file. This option was introduced 
in Anime Studio Pro 9.5.

Render Options
The following options control rendering options, just like you see in the Export 
Animation or Moho Exporter dialog in Moho Pro. Most of the options can be turned 
on or off with a value of yes or no. If an option is not specified, the render will perform 
the default.

-multithread or -multithreaded

Syntax:

-multithread <yes|no> or -multithreaded <yes|no>

Explanation:

Used to turn on or off multithreaded rendering. If multi-threaded rendering is on, the 
render will use up to 5 threads  (4 image frame threads + 1 movie encoding thread) 
to render your output files. Set this option to no if you wish to increase the system’s 
performance while a render is taking place. The default is yes.

-halfsize

Syntax:

-halfsize <yes|no>

Explanation:

Render the output at half size. If the project dimensions of the document is set to 
720p (1280x720), the output dimensions of the render would be 640x360 when using 
this option. This option is useful if you want to get a quick overview of your scene as it 
will dramatically reduce the time it takes to render. The default is no.

-halffps

Syntax:

-halffps <yes|no>

Explanation:

Render at half frame rate. If the project frame rate is set to 30 FPS, the output format 
would be 15 FPS when using this option. The default is no.
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-shapefx

Syntax:

-shapefx <yes|no>

Explanation:

Render shape effects. The default is yes.

-layerfx

Syntax:

-layerfx <yes|no>

Explanation:

Render layer effects. The default is yes.

-fewparticles

Syntax:

-fewparticles <yes|no>

Explanation:

Use reduced particles. The default is no.

-layercomp

Syntax:

-layercomp <comp name>

Explanation:

Render a specific layer comp defined within the document.

If AllComps or AllLayerComps is specified as the comp name, all layer comps will 
be exported during one run of the renderer. It is highly recommended that you use 
either -addlayercompsuffix OR -createfolderforlayercomp when specifying 
these comp names, otherwise multiple layer comp exports could overwrite each 
other.

The recommended way to render all layer comps in Moho 13.5 
is AllComps or AllLayerComps).

This option was introduced in Anime Studio Pro 10.0.

-aa

Syntax:

-aa <yes|no>
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Explanation:

Antialiased edges. The default is yes.

-extrasmooth

Syntax:

-extrasmooth <yes|no>

Explanation:

Extra-smooth images. The default is no.

-premultiply

Syntax:

-premultiply <yes|no>

Explanation:

Premultiply alpha. The default is yes.

-ntscsafe

Syntax:

-ntscsafe <yes|no>

Explanation:

NTSC safe colors. The default is no.

-variablewidths

Syntax:

-variablewidths <yes|no>

Explanation:

Variable line widths (only applies to SWF format). The default is no.

Examples
Here are a couple of examples exports using the render options:

Syntax:

Moho\ x64.exe -r MyScene.moho -o C:\output\preview.mp4 -f “MP4 
(H.264-AAC)” -start 12 -aa no -halfsize yes
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Explanation:

Reading the options left-to-right, the command above will render (on Windows) 
the file “MyScene.moho”, creating the result “C:\output\preview.mp4”, in MP4 
format, starting at frame 12 (and continuing to the document’s end frame), with no 
antialiasing and at half the file’s normal pixel dimensions.

Syntax:

Moho\ x64.exe -r MyScene.moho -start 124 -end 124 -f PNG

Explanation:

The command above renders a single frame of the file “MyScene.moho”, frame 124 
(the start and end frames are the same. The result is in PNG format. Since no output 
file is specified, the output file will be same as the input file, but with an appropriate 
extension for the format chosen - in this case the output file would be automatically 
named “MyScene.png”.

Regarding QuickTime: When rendering from the command line, Moho will use the 
codec and codec settings that you last used in Moho’s Export Animation or Moho 
Exporter dialog. So, to change the QuickTime settings used by the command line 
mode, you need to render a QuickTime movie (even a short, tiny one) in those 
dialogs, entering the settings you wish to use.

Other Options
Most of the following options are not directly exposed within the user interface of 
Moho, but can help organize or change the quality of your renderered output:

-addformatsuffix

Syntax:

-addformatsuffix <yes|no>

Explanation:

Append the format name to the file name of the output path. This option is not 
new. It was available in 9.5. I just wanted to point it out here. An example of this is 
if you specified a format of “MP4 (H.264-AAC)”, the output file would be named: 
MyAnimation-MP4 (H.264-AAC).mp4. The default is no. This option was introduced 
in Anime Studio Pro 10.0.

-addlayercompsuffix

Syntax:

-addlayercompsuffix <yes|no>

Explanation:

If -layercomp is specified, adds a layer comp suffix to the rendered file name(s) 
(e.g. MyScene-LayerCompName.mp4). The default is no. This option was introduced in 
Anime Studio Pro 11.2.
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-createfolderforlayercomps

Syntax:

-createfolderforlayercomps <yes|no>

Explanation:

If -layercomp is specified, the rendered file(s) will be created in a subfolder of the 
output path (-output) or output folder (-outfolder). The subfolder’s name will be the 
layer comp name (e.g. C:\output\LayerCompName\MyScene.mp4). The default is 
no. This option was introduced in Anime Studio Pro 11.2.

-videocodec

Syntax:

-videocodec <number>

Explanation:

The number is the fourcc value for the QuickTime codec. This option ONLY works with 
a format of quicktime (aka qt or mov). Here is a list of FOURCC codes, not all work 
with QuickTime:

http://www.fourcc.org/codecs.php

The FOURCC code must be converted to a 32-bit integer before being passed to the 
command-line. I’ll try and come back to this post and add the common values for 
the FOURCC codes that QuickTime supports. Also in 10.1, we will see about making 
-videocodec more user friendly so that you can specify something like “H.264” or 
“Animation” instead of this ugly integer number.

Specifying -videocodec does not work with the “QuickTime” 
presets on Mac. (e.g. “QuickTime (H.264-AAC)”)

-quality

Syntax:

-quality <number>

Explanation:

The quality of the export. This option ONLY works with a format of quicktime (aka qt 
or mov). Quality is a number between 0 and 5. The default is 3.

0 = Minimum Quality

1 = Low Quality

2 = Normal Quality

3 = High Quality

4 = Max Quality

5 = Lossless Quality
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Specifying -quality does not work with the “QuickTime” presets 
on Mac. (e.g. “QuickTime (H.264-AAC)”)

-depth

Syntax:

-depth <number>

Explanation:

The pixel depth of the export. This option ONLY works with a format of quicktime (aka 
qt or mov). The value defaults to 24, but for some codecs like Animation that support 
an alpha channel, you can specify a depth of 32.

Specifying -depth does not work with the “QuickTime” presets 
on Mac. (e.g. “QuickTime (H.264-AAC)”)

Examples
Here are a few examples using these options:

Syntax:

Moho\ x64.exe -r MyScene.moho -layercomp “AllComps” 
-createfolderforlayercomp yes

Explanation:

All defined layer comps in the project file MyScene.moho will be rendered in one 
pass of the renderer. If the layer comps were named Background, Character 1, 
Character 2, the output paths will be named this:

Background\MyScene.mp4

Character 1\MyScene.mp4

Character 2\MyScene.mp4

An alternative to -createfolderforlayercomp is -addlayercompsuffix:

Syntax:

Moho\ x64.exe -r MyScene.moho -layercomp “AllComps” 
-addlayercompsuffix yes

Explanation:

Again, all defined layer comps will be rendered, but instead of separate folders, a 
suffix will be added to the output files to prevent a name collision. The output paths 
would be named this:

MyScene-Background.mp4

MyScene-Character 1.mp4

MyScene-Character 2.mp4
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And simply:

Syntax:

Moho\ x64.exe -r MyScene.moho -layercomp “Character 1”

Explanation:

Only the “Character 1” layer comp will be rendered. The name of the output file 
will be MyScene.mp4 as -addlayercompsuffix and -createfolderforlayercomp was 
not specified.

Platform Notes
Windows Notes
On Windows, the Moho executable is named Moho Pro x64.exe or Moho Pro Win32.
exe, but you can type in either “Moho\ x64”, “Moho\ Win32”, “Moho\ x64.exe” 
or “Moho\ Win32.exe”.

Also, Windows GUI programs are normally unable to print output to the command 
line. So, when running Moho in command-line rendering mode, you will need to use 
the -log option

If you prefer a UNIX-style command line, try out the free Cygwin tools, which include 
a bash shell for Windows:

http://www.cygwin.com/

Mac Notes
On Mac OS, GUI applications are wrapped up in “bundles”. The Moho application 
you see in the Finder is actually a folder containing lots of little files. What this means 
is that to run it from the command-line, you need to do things a little differently. 
Instead of this:

Moho\ x64.exe -r MyScene.moho

You need to use this command:

Moho.app/Contents/MacOS/Moho -r MyScene.moho

Or, if the Moho folder is not in your path, use this command (the full path to Moho):

/Applications/Moho.app/Contents/MacOS/Moho -r MyScene.moho

Other than that, Moho runs very nicely in command-line mode on the Mac.
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