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 Moho Tutorials
In this manual, we will walk you through various aspects of using Moho. This is 
the perfect place to start if you’ve never used Moho before. Even if you’re an 
experienced Moho user, this version of Moho has some big changes, so we 
recommend reading through the tutorials again.

The best way to get started is to read all the tutorials in the Basics section in order. 
Each of these tutorials builds on skills learned in the earlier ones, and one-by-one will 
get you up to speed with Moho’s basic drawing and animation techniques. Once 
you’re comfortable working in Moho, then you can move on to the other tutorial 
sections. You don’t have to read them all (although that probably wouldn’t hurt), 
but choose the ones that address the specific techniques you want to learn about.

When you first start Moho, you will be prompted to create a 
Custom Content folder in a location that you specify. The 

tutorial files that are used in this tutorial manual will get installed in 
that Custom Content folder. You can find them by going to your 
Content folder, and looking for the Tutorials sub-folder. If you’re 
having trouble with a tutorial, try opening the corresponding Moho 
file to see what it should look like.

If you did not create a custom content folder at startup, you 
can create one any time by choosing Help > Set Custom 

Content Folder.

Once you’ve finished the tutorials, you should be comfortable enough to continue 
on your own. However, the tutorials won’t teach you how to use every feature of 
Moho - the rest of this manual is a reference that covers Moho’s features in detail, 
and is recommended reading to be able to use the full power of Moho.
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Quick Start

Tutorial 1.1: A Quick Run-through
This tutorial quickly runs through the major features of Moho, without going into too 
much detail. The purpose here is more to give an overview of how Moho works, 
rather than to teach you how to use any specific features. In this tutorial, we will 
draw and animate a very simple object.

Moho has several groups of tools, used for different types of tasks. Some of these 
tools are used to create new objects, and others are used to modify and animate 
existing objects. The basic Moho tool groups are: Draw, Fill, Bone, Layer, Camera, 
and Workspace.

This tutorial introduces a few of the Draw, Fill, and Layer tools, while the following 
tutorials focus specifically on each of the tool groups.

Drawing a Simple Shape
Launch Moho by double-clicking the Moho icon, or selecting the Moho shortcut in 
the Start menu (Windows). When you create a new Moho project, the application 
starts off looking something like this:

 The Moho Interface

Choose File > New to create a new project, and then click the current tool icon (just 
beneath the File menu), to select Reset All Tools. This puts all tools at their default 
settings so that you can follow along with this tutorial.
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 Reset all tools.

Select the Draw Shape tool by clicking on it in the toolbar.

Select the Oval shape from the Draw Shape tool options.

The Style panel on the right side of the Moho interface allows you to select fill and 
stroke colors for the shapes you draw. To select a fill color, click the Fill color square 
to open a color palette, or click one of the color squares in the Swatches palette. 
Alternatively you can click one of the colors in the Color Swatch palette. Select the 
fill color you want to use, and click OK.

 Changing the fill color

Press the Shift and Alt keys while you drag from the center of the workspace to 
create a circle shape. The Shift key forces the shape to be a circle, rather than an 
oval; and the Alt key centers the circle around the point that you first clicked. Try to 
keep the circle within the blue rectangle (this rectangle represents the visible area of 
your project). Note that the circle will automatically fill with color when the Auto Fill 
option is checked as shown in the previous figure.

If you’re not happy with your circle, just select the Edit > Undo command from the 
menu bar. Your circle should look something like this:
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 Your first Moho drawing

Changing the Color of Your Shape
If you want to change the fill color, choose the Paint Bucket tool from the Fill 
toolbar. The Fill option changes only the Fill color; the Stroke option changes 

only the Stroke color; and the Both option changes both the Fill and the Stroke color 
to those that you have selected in the Style window.

 Paint Bucket options

Select a new color from the Style panel, similar to the way that you selected the 
color in the previous steps. Then click inside the shape to change the color(s).

 The Fill color is changed with the Paint Bucket.

Simple Animation
When you animate in Moho, you move objects around and set up keyframes - 
points in time at which an object has a certain position. At points in time between 
keyframes, Moho automatically computes the position of all objects.
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Near the top of the Timeline window is a ruler that displays frame numbers in the 
animation. Click the number 36 to set the current time to frame 36.

 The Timeline

Next, choose Edit > Select None from the menu bar.

Pick the Transform Points tool from the Draw toolbar. Click and drag the 
bottom point of the circle upward to distort the circle into a shape that looks 

like this:

 Moving a single point

Now use the Transform Layer tool from the Layer section of the Tools panel to 
rotate the layer.

To rotate the object with the Transform Layer tool, click and 
drag in the area between the two bounding boxes that 

surround your object. Rotate the object into a position similar to the 
one below:
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 Rotating an entire layer

Back in the timeline, click frame number 72 in the ruler to change the current time. 
Next, select Draw > Reset All Points from the menu bar to move all points back to 
their original positions. In the tool options area at the top of the main window, press 
the Reset button to reset the rotation of the entire layer.

 Click the Reset button to reset the rotation of the layer.

Finally, we’ll shorten the length of the animation from its default length of 240 frames. 
In the Timeline window, enter 80 in the second number field. This will shorten the 
length of the animation to 80 frames.

 Shorten the animation to 80 frames.

Congratulations, you’ve made an animation! Press the play button near the bottom 
of the main window to watch it go. When you’re done, press stop. OK, so it probably 
won’t win any film awards, but you’re off to a good start learning Moho.
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 Playback controls.

Here’s what your finished animation should look like (approximately). Press the Play 
button below to see the result.

Click this link to view a brief video of the finished results of your 
project.

You’ve learned how Moho has different groups of tools for different operations, 
and even how to use a few of those tools. You can experiment more on your own, 
maybe adding more keyframes. When you’re ready to learn more, move on to 
“Tutorial 1.2: Drawing Simple Shapes” on page 7.

Tutorial 1.2: Drawing Simple Shapes
In this tutorial you will learn how to draw simple shapes in Moho. The following 
tutorials will build on what you start drawing in this tutorial.

Creating a Background
Launch Moho by double-clicking its icon. Or, if Moho is already running, choose File 
> New to create a new project, which opens in a new document tab.

Click the current tool icon (just beneath the File menu), to select Reset All Tools. This 
puts all tools at their default settings.

 Reset all tools.
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In the Tools window, click the Draw Shape tool to activate it. Then select 
the Rectangle option.

From the Style window, select a brown color for the Fill color as shown below.

 Select a brown fill color.

Click and drag in the working area to create the rectangle shown below:

 Draw a simple rectangle.

This shape is going to be the start of some rolling hills. So far, these hills look 
kind of flat, so let’s fix that. Pick the Add Point tool from the toolbar.

Click on the top edge of the rectangle and drag the mouse upwards:
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 How to add a point to an existing shape.

You should have something now that looks like the picture below. If this isn’t what 
you got, select the Edit > Undo menu item and try again. Be sure to click on the line 
that forms the top of the rectangle and drag upwards from there.

 Drag the new point upward.

Let’s add another curve to the hills by clicking a little more to the right and dragging 
downwards:



Moho 13.5
Tutorial Manual 

10

Quick Start

 Add a second point and drag it downward.

To keep things organized, it’s a good idea to name the layers in a Moho project. 
Double-click this layer (the only one so far) in the Layers window.

 Accessing a layer’s properties.

In the dialog that appears, type in “Hills” for the layer name and click the OK button.

 Rename the layer.

After creating the hills, choose Edit > Select None to deselect any selected 
points. Then click the Select Shape tool in the Fill section of the Tools panel, 

and click the fill on your hills.

The Style window will display the settings for the fill: its color, its line width and color, 
and the styles used to display it. To remove settings that you have used in previous 
projects, click the Reset button to reset the fill colors to their default settings.
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 Click the Reset button.

Set the line width to 1. Then choose Gradient from the Effect menu to open the 
Gradient dialog.

If you want to change the gradient settings later, click the 
details button (...) to the right of the Effect pop-up menu.

 The Style Window
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When you select the Gradient fill style, Moho automatically opens up the gradient 
settings dialog. The Linear gradient type is automatically selected for you.

 Linear gradient.

•	 To set the left gradient color, double-click the left square at the bottom of the 
gradient bar to open the Color Picker. Select a green color and click OK to 
return to the Gradient dialog.

•	 To set the center gradient color, double-click the middle square at the bottom 
of the gradient bar to open the Color Picker. Select a darker green color and 
click OK to return to the Gradient dialog.

•	 To set the right gradient color, double-click the right square at the bottom of 
the gradient bar to open the Color Picker. Select a brown color and click OK to 
return to the Gradient dialog.

When your colors are selected, the Gradient settings should appear as shown below. 
Click OK to return to the scene.

 Gradient settings.

To see the gradient preview more easily, click outside the hill to deselect the fill. 
You’ll notice a line with a filled circle at one end, which represents the start color of 
the gradient (green in our example). The empty circle at the other end represents 
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the end color of the gradient (brown in our example). You can adjust the position of 
these indicators to control the blending and direction of the gradient.

 Final result.

In our example, the gradient starts with brown on the bottom (empty circle) and 
ends with green on the top of the hill (filled circle). The angle tilts slightly toward the 
left as shown below.

Choose the File > Save As... command from the menu and save the project under 
the name “Tutorial 1.2”.

In “Tutorial 1.3: Drawing Complex Shapes” on page 13 we’ll 
continue working on this scene by adding more complex 

shapes.

Tutorial 1.3: Drawing Complex Shapes
This tutorial follows on the previous one, and teaches you how to draw more 
complex shapes. You can either continue with the project you created in Tutorial 
1.2, or you can open a file provided for you named “Tutorial 1.2”. This file can be 
found in the “Tutorials/1 - Basics” subfolder within your custom content folder. The file 
you’re starting this tutorial with should look something like the following:
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 Starting point.

Creating a New Layer
Click the New Layer button in the Layer window to create a new layer. In the popup 
menu that appears, choose “Vector”.

 Create a Vector layer.

You can assign the name “Clouds” to the new layer when you create it, or double-
click this new layer and rename it “Clouds” in the Layer Settings dialog.

 Rename the layer Clouds.

Now select the Add Point tool.

Click the Reset button in the Style panel to reset the colors to their default. 
Set the line width to 1.
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 Reset colors and set line width to 1.

Click to set the start point for a new line segment. Without releasing the mouse, drag 
the cursor and release the mouse to create the end of the segment. The finished 
segment is shown below.

 Add a line segment.

Next, click on the end of the new line segment and drag to stretch the curve out like 
this:
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 Add another segment to the end of the curve.

Do this a few more times until you have the curve below:

 Several more segments added.

The key point to remember is in order to extend a curve, you need to click on one 
of its endpoints and then drag the mouse to where you want the new point to be. 
Remember, if you make a mistake at any time, just choose the Edit > Undo menu 
command.

Now we’re going to add a second puff to the cloud. Move your mouse to the point 
just before the end of the previous segment. The “Auto Weld” option for the Add 
Point tool should be turned on by default. When turned on, the node will turn green 



Moho 13.5
Tutorial Manual 

17

Quick Start

when you can automatically weld the new segment to the existing one. When Auto 
Fill is turned on, the cloud will automatically fill with color when the shape is closed.

 Add a new curve at this point.

Click on the second to last point in the curve, and drag down and to the right, as 
shown below. When you use the Add Point tool on a point that is in the middle of a 
curve, what happens is that you start a new curve that is automatically welded to 
that point in the first curve. These two curves are permanently joined at that point, 
which becomes important when we get to filling the shape with color. Here’s what 
your project should look like after adding the new curve segment:

 A new segment welded to an existing curve.
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Add some points to the end of this new curve to get the shape below. Remember, 
to add a point to the end of a curve, click just on the last point of that curve.

 More new points.

Finally, add two or three more points at the beginning of the original curve. When 
you add the last point, drag it over to the right and line it up with the next to last 
point of the second curve before letting go of the mouse. Moho will automatically 
weld those points together and fill the cloud with color to get the final shape below:

 Finished cloud.

Sometimes it can be hard to follow this sequence of steps - let’s take a moment to 
watch a movie of the cloud being created in Moho. Pay special attention to where 
the mouse is clicked in order to weld the two curves together.
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Click this link to view a brief video of how to draw the clouds..

We will add a line effect to make the cloud a bit softer. In the Style window, check 
the Advanced button to display the advanced style options. Select ‘Soft Edge’ from 
the Stroke Effect pop-up menu. Accept the default settings and click OK.

 Soft Edge effect.

Now would be a good time to select the File > Preview command to see what your 
final result looks like:
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 The rendered cloud.

A Second Cloud
Let’s make another cloud. With the Clouds layer selected, choose Edit > 
Select All from the menu. Now choose Edit > Copy, followed by Edit > Paste. 

Next, pick the Transform Points tool from the toolbar.

In the working area, click and drag to the right to move the new cloud away from 
the original. (When you paste an object from the clipboard, it is positioned directly 
on top of the original.)

 Duplicated cloud.

Use the Transform Points tool to resize this new cloud, making it larger or 
smaller than the original, as preferred (here we make ours larger).
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The Transform Points tool can resize an object both vertically and horizontally, and 
will scale whether or not the object is selected beforehand. In this case, we don’t 
really want to change the cloud’s shape like that. With the Transform Points tool 
active, click and drag one of the corner handles that appears around the cloud, 
thus making it smaller or larger without changing its overall shape. Continue using 
the Transform Points tool until you get the new cloud in a position you like.

 Second cloud scaled and positioned.

To deselect all of the points in the cloud, use the Edit > Select None command, or 
press the Enter key, or click outside the cloud to de-select the points.

Now you can use the Transform Points tool to click and drag individual points to 
reshape the second cloud.

In this case, since only one point is selected at a time, the Transform Points tool is 
used to re-shape the cloud, not move the entire object. Just re-shape a few points 
here and there so that the two clouds don’t look exactly the same.
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 Modify some points.

Plant a Tree
Good - we’re moving right along, but this scene needs some plant life. Add a new 
layer to the project by clicking the new layer button in the Layer window. Again, 
choose “Vector” from the popup menu. Name it “Tree”.

 Rename the layer to Tree

Select a brown fill color from the Style panel. Set Stroke Width to 4, and set the effect 
to  <plain>.
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 Select a brown fill color.

Using the Add Point tool, along with the welding feature, draw a shape that 
resembles the trunk of a tree.

Here are a few things to remember as you go: First, you can always use the Edit > 
Undo command to back up if you make a mistake.

Second, you can switch to using the Transform Points tool to reshape part of 
the object, even if you haven’t finished drawing the whole thing yet.

Third, the Transform Points tool lets you pick individual points by clicking on them - if 
you want to get rid of a point, but it’s too far back to use undo, select it with the 
Transform Points tool and press the backspace or delete key on your keyboard.

Feel free to be creative with your tree trunk, you don’t really have to stick to the 
sample below.
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 Draw a tree trunk

There are a few tools that may be useful when building your tree that 
haven’t been introduced yet. The Pan Workspace and Zoom 

Workspace tools can be used to move around the workspace.

Note that these tools are not used to manipulate your drawing - they just let you 
move your view so that you can focus in on a particular area of interest. To reset 
your view to its original position, select the View > Reset command from the menu 
bar.

Another useful tool is the Curvature tool. Using this tool, you can click and 
drag on a point to adjust how round or pointy the curve is as it passes 

through that point.

 Use the Curvature tool to adjust the curves.

The last thing we’ll add in this tutorial is some greenery to the top of the tree. The 
shape for the treetop will be similar to the clouds, so follow similar steps to create it, 
but there is one tricky part. Because the treetop overlaps the trunk of the tree, it can 
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be easy to click on the wrong part and add a new point to the trunk instead of the 
treetop.

There are two ways to avoid this problem.

•	 One, use the Pan and Zoom tools to move in close to the top of the tree so that 
it’s easier to avoid clicking on the wrong thing.

•	 The second approach is to draw the treetop off to the side where there’s plenty 
of empty space. Then, when the treetop is finished, drag it back into position at 
the top of the tree. 

•	 For the second approach, when you’re ready to move it back into position, 
use the Transform Points tool and click to select one point on the treetop. Then 
use the Edit > Select Connected command to select the rest of the treetop. 
Finally, drag the treetop into place, and use the Transform Points tool to resize it 
if necessary.

Select a nice leafy green fill color in the Style panel. Set the line width to 4, you’ll see 
why later.



Moho 13.5
Tutorial Manual 

26

Quick Start

 Select a green fill color and set line width to 4.

Use the Add Point tool to draw your treetop. Here’s the kind of look we’re going for:
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 The treetop.

Choose File > Preview to see how the treetop looks. Notice how the ends of line 
segments look kind of squared off and blocky. We’ll fix that using Moho’s variable 
line width feature.

Exit the render window and press Enter to de-select all points in the treetop.

Now, using the Line Width tool, click on each of the points in the treetop that 
is at the end of a line segment. The area that the Line Width tool affects is 

indicated by a semi-transparent red circle. The default width is .5, which is quite 
large. Decrease the width to around .1 or less to obtain finer control over the area 
that you want to affect.

 Changing line width.

Choose File > Preview again, and notice how the endpoints are now nicely tapered. 
This feature isn’t limited to endpoints - experiment with using it on other points along 



Moho 13.5
Tutorial Manual 

28

Quick Start

a curve. Also, try dragging the Line Width tool back and forth to make lines thinner 
or thicker.

 The completed background.

”Tutorial 1.4: Bone Setup” on page 28 will move into using 
bones to control a character, and you’ll learn how to set up 

some animation controls to make things move.

Tutorial 1.4: Bone Setup
This tutorial builds on the results of the previous two, teaching you how to add bones 
to a character. You can either continue with the project you created in Tutorial 1.3, 
or you can open a file provided for you named “Tutorial 1.3”. This file can be found 
in the “Tutorials/1 - Basics” subfolder within your custom content folder.

Bones are an important tool you can use in Moho to help make animation easier. If 
you think of drawings in Moho (like the ones you made in previous tutorials) as soft 
rubber, then bones can be thought of as stiff wires inside the rubber that help you 
move and position objects. Bones are never displayed in a final rendering, they’re 
just used as tools during the animation process.

Bones are not absolutely necessary for animation. They are very helpful for animating 
certain types of motion as we’ll show in this and the next tutorial, but there are other 
ways to animate in Moho as well. As you gain experience using Moho, you’ll learn 
when bones are appropriate and when they’re not.

Importing an Object
Launch Moho and open the project from the last tutorial.
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 Starting point for this tutorial.

As you build a Moho project, there are times you may want to re-use objects you 
created before. There’s an easy way to do this, and we’ll use it now to add a 
character to the project.

Select the File > Import > Moho Object... command. In the file dialog that appears, 
navigate to your Moho custom content folder. From your custom content folder, 
locate the Tutorials/1 – Basics folder and open the file “Tutorial Extras.” A dialog will 
open asking you which object you want to use from this project:

If you have not yet created a custom content folder, choose 
Help > Set Custom Content Folder to create one. See “Creating 

a Content Folder” on page 16 in your Moho Users Manual in your 
Moho Users Manual).
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 Insert Object dialog.

Select the layer named “Frank” on the left side of the dialog. On the right side, you’ll 
see a preview of Frank. Click OK. A new layer will be added to your project. This 
layer is a copy of the layer Frank from the “Tutorial Extras” project. Frank is fully drawn 
and filled in - you can see what the scene really looks like now by selecting File > 
Preview.

 Frank added to the project.

Adding Bones
Lets give Frank some bones to make him easier to animate. In the Layers window, 
click the new layer button. In the popup menu that appears, choose “Bone”. 
Rename this new layer “Skeleton.”

Drag the Frank layer upwards “into” the Skeleton layer. This step is very important 
- you will know that you’re dragging the Frank layer to the correct place when the 
Skeleton layer becomes highlighted. Finally, click the Skeleton layer to make sure it’s 
active. When this is done, the Layer panel should look like this:
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 Add a bone layer named Skeleton (top) and drop Frank inside the layer (bottom).

Make sure the layer “Skeleton” is selected in the Layer panel. Click the eyeballs icon 
on the left side of the Tree, Clouds, and Hills layers to temporarily hide them.

 Hide the Tree, Clouds, and Hills layers.

Finally, use the Pan and Zoom tools to zoom in on the contents of this layer. Your 
window should now show something like this:
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 Zoomed in on Frank.

With the Skeleton layer selected, add a bone to Frank by selecting the Add 
Bone tool and clicking and dragging upwards as shown below:

This will be the main control bone - you could think of it as Frank’s spine. It should look 
like this:

 First bone added.
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Click and drag out three more bones as shown below. It’s important that you draw 
these three bones in order from top to bottom: thigh, shin, and foot.

 Right leg bones.

When a bone is selected, it is drawn in the highlighted color, red.

When you add a new bone, it becomes the “child” of the currently selected bone. 
The parent-child relationship for bones means that the child can move around 
without affecting the parent, but if the parent moves, the child will move with it. This 
is why it was important to draw the previous three bones in order: the thigh bone’s 
connected to the spine bone, the shin bone’s connected to the thigh bone, and 
the foot bone’s connected to the shin bone (at least in Frank’s body).

When a bone is selected, it’s displayed in red. Its parent also gets displayed 
differently: in blue. The parent is highlighted like this for your information - sometimes 
you may connect bones in the wrong order and looking for the blue parent bone 
can help determine where things went wrong.
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 A current bone and its parent.

OK, let’s add bones to the other leg. But first, we need to select the spine 
again so that the second leg will also be attached to it. Use the Select Bone 

tool and click on the spine to select it.

Next, use the Add Bone tool to add three bones to the other leg as shown 
below:

 Left leg bones.
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Testing Bones
There’s a bone tool that lets you test how your skeleton structure is working. 
Let’s try that now. Select the Manipulate Bones tool and click and drag any 

of the bones you created. Try dragging several of the bones around to see what 
happens.

 Moving Frank’s legs.

Notice that Frank automatically moves with the bones. You may have also noticed 
that Franks looks quite “squishy” - when you move either of his legs, his head 
changes shape as well. The next step is to clean this up a bit by telling Moho which 
parts of Frank should move with which bones.

When you are on Frame 0, the Manipulate Bones tool doesn’t permanently 
move the bones. Click the Select Bone tool and all the bones will snap back 

into their original places.

Adjusting Bone Strength
When you use a bone layer to control a character, every bone in the skeleton has 
some influence on every part of the character. We saw that in Frank - when you 
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move one of the legs, even the head moves a bit. This influence is strongest closest 
to each bone, so the head only moves a little bit, not as much as the leg itself.

We don’t really want to see Frank’s head move much at all when his legs move. 
Luckily, there’s a way to control this: bone strength. Each bone has a “strength” 
value that controls how large its region of influence is. What we’ll do next is adjust 
the strength of the bones that control Frank.

Select the Bone Strength tool and take a look at the bones.

Each bone has a semi-transparent region highlighted around it. (You also 
saw these regions when using the Manipulate Bones tool.) These regions show you 
the influence of each bone in the skeleton. A bone has the most influence inside its 
shaded region.

 Regions of influence.

With the Bone Strength tool active, click and drag side-to-side on each of the bones 
in Frank’s skeleton to adjust its strength. The goal here is to adjust the region of each 
bone so that it just encloses the corresponding section of Frank’s body. For example, 
the region around the shin bone should just enclose the shin, and not much more. 
Don’t worry about being too precise - pretty close is good enough. For Frank’s 
head, don’t make the bone region enclose the entire head - that would make the 
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bone too strong. Adjust the bone strengths so that they look approximately like the 
following:

 Adjusted bone strengths.

Testing Bones (Again)
Once you adjust bone strengths, it’s a good idea to test the skeleton again 
to make sure everything works correctly. Pick the Manipulate Bones tool from 

the toolbar and click and drag on Frank’s shin bones just above the ankle.

If everything was set up correctly, Frank should be able to move like this:
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 Bones in action.

Play around - move Frank’s bones around into various positions and get a feel 
for manipulating the skeleton. “Tutorial 1.5: Animation” on page 38 will cover 
animation, and you’ll learn how to make objects move around over time.

Tutorial 1.5: Animation
This tutorial continues on from the previous three, moving into the animation features 
of Moho. You can either continue on with your project from the previous tutorial, or 
you can use a file that has been created for you - it’s named “Tutorial 1.4” and it’s 
located in the “Tutorials/1 - Basics” subfolder within your custom content folder.

There are three basic ways to animate objects in Moho:

•	 animating an entire layer,

•	 using bones to animate parts of an object,

•	 animating the individual points on an object

These three types can be combined to make very complex animations. This tutorial 
will walk you through all three types of animation.

Open your previous project (or the “Tutorial 1.4” file) in Moho. Make sure all the 
layers are visible by clicking to turn on each layer in the Layers window.
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 Turn on all layers.

Your window should look something like this:

 Starting point for this tutorial.

Layer Animation
Layer animation is the most simple way to make objects move around in a Moho 
animation. It’s limited in the way you can move the objects, but in some cases it’s all 
you need. Layer animation moves an entire layer around as if it were painted on a 
pane of glass.

Click the Clouds layer in the Layers window to activate it. Next, set the current time 
to frame 72. This is done in the Timeline window. To set the time, scroll the timeline 
panel sideways (if necessary) until you see the number 72 in the ruler at the top. Click 
on the number 72 and the time marker will jump to that frame, as shown below:
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 Time set to frame 72.

If you do not see multiple channels in the timeline, you may 
have Moho set to collapse them. Choose Edit > Preferences, 

and uncheck the “Consolidate timeline channels” option in the 
Options tab. This displays all animation channels in the timeline.

In Moho, an important concept is to learn the importance of 
frame zero. At the far left end of the timeline is a frame marked 

zero. When the time is set to zero, you are in Moho’s creation mode. 
For now, you should only draw, add bones, or create other objects 
at frame zero. When Moho is at any other frame, you are animating 
the objects you have created. As you get more comfortable with 
Moho, you can choose to draw objects at other frames, but for now 
it’s best only to create new objects when the time is set to frame 
zero. You can switch back to frame zero at any time by pressing the 
rewind button, or by clicking on the number 0 in the timeline. For 
now, leave the time at frame 72.

Select the Transform Layer tool from the toolbar.

Click and drag to the right in the working area to move the cloud layer to 
the right. You can press the Shift key, if desired, to constrain the movement to a 
straight line.:
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 Moving the cloud layer.

Notice that a marker appeared in the timeline at frame 72. (You may have to scroll 
downwards to see the marker.) This marker represents a keyframe - a point in time 
at which the layer has been given a position. There are several animation channels 
displayed in the Timeline panel. This keyframe appeared in the Layer Translation 
channel, because that’s what type of action you just performed - you translated 
(moved) a layer.

 The new keyframe.

Try out the animation so far: press the play button at the bottom-left of the main 
window. The animation loops when it reaches the end (in this case frame 240). When 
you’ve seen enough, press the stop button.

If you prefer, you can shorten the length of the animation to 72 frames, so that it will 
loop back to the beginning once it reaches the last keyframe. Simply change the 
total number of frames to 72 as shown below.
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 Shorten the length of the animation to 72 frames, if desired.

Bone Animation
Bone animation uses skeleton structures to move an object around. You got a good 
feel for how bones work in the previous tutorial when you used the Manipulate Bones 
tool. When animating bones you use very similar tools.

Activate the Skeleton layer by clicking its entry in the Layer panel.

 Activate the Skeleton layer.

Set the time to frame 12 by clicking the number 12 in the Timeline window. (You may 
have to scroll the Timeline window before you can see the number 12.)

Now, pick the Manipulate Bones tool in the toolbar. Click and drag the 
bones in Frank’s legs until they are positioned as shown below:
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 Move Frank’s legs up at Frame 12

Note that the Manipulate Bones tool works differently at frame 12 than it did at 
frame 0 in the previous tutorial. At frame 0, this tool is used to test a bone system, and 
doesn’t permanently modify the bones. However, when you are animating bones 
(at any frame other than 0), the bones do hold their new position.

Next, pick the Transform Bone tool. Click on Frank’s spine bone and drag it 
downwards a bit:

To transform the bone, drag from the bottom control point on 
the bone. For more information about the control points in the 

Transform Bone tool, see “Transform Bone” on page 92 in your 
Moho Users Manual.
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 Lower Frank’s entire body.

Next, set the time to frame 24 and choose the Bone > Reset All Bones menu 
command. Press the play button to watch your animation, and press stop when 
you’re done.

 Reset all bones at Frame 24.

When you played back the animation, you probably noticed that after frame 24, 
Frank doesn’t move any more. You could add more keyframes by setting the time 
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to some later frame and moving Frank’s bones some more, but let’s try out Moho’s 
animation looping feature.

In the timeline, you should see a group of keyframes at frame 24. These keys 
represent bone movement (the spine bone moving up and down) and bone 
rotation (the bending legs). Drag a rectangle around these keyframes to select 
them:

 Select bone keyframes at frame 24.

Next, right-click on one of these selected keys. A popup menu will appear. Select 
“Cycle...” from the popup menu.

 Select Cycle

What you’re telling Moho is that you want these keys to cycle back to an earlier 
point in the timeline. A dialog will appear asking you what frame to cycle back to - 
enter the settings shown below. You’re telling Moho that on this keyframe, the bone 
movement should cycle back to frame 1.
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 Cycle settings.

Close the Keyframe dialog and press the play button to see the difference. An 
animation channel with cycling turned on will repeat its animation over and over 
indefinitely. Typically this would be used for some kind of background element, not 
a foreground character like Frank, but it’s a great time saver. In the timeline you can 
see an indication of the cycling in the bone channels:

 Cycling indicated in the timeline.

Point Animation
Using point animation, you drag around individual points (or groups of points) on 
an object. In theory, you could animate the same types of motion as with bone 
animation - bones just save you a lot of work. Point animation is more typically used 
when you want to change the shape of some object.
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Click the Clouds layer in the Layer panel to activate it.

 Activate the Clouds layer.

Pick the Transform Points tool from the toolbar.

Press the enter key on your keyboard to make sure no points are selected. 
Finally, click the Jump to End button to jump to the end of the animation.

 Jump to End button.

Click and drag individual points on the clouds in small amounts, just to reshape 
the clouds a bit. This will cause the clouds to change their shapes slightly from the 
beginning of the animation to frame 72.
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 Change the shape of the clouds on the last frame.

Use the play and stop buttons to see the result.

Importing Animation
Remember how the Frank layer was imported into the project in the previous 
tutorial? Well, imported layers can also contain animation.

First, return to Frame 0 in your animation.

 Return to frame 0.

Select File > Import > Moho Object.... When prompted, locate the/Tutorials/1-Basics 
folder (in your custom content folder), and open the file “Tutorial Extras.”In the dialog 
that pops up, select the Beach Ball layer and click OK.
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 Import the beach ball.

A bouncing beach ball will appear in your project. Press the play button to watch it 
go. It bounces all right, but it’s not really in the right position.

Switch back to frame zero (press the rewind button in the timeline) to set the ball’s 
initial position.

Using the Transform Layer tool, drag the beach ball to a better location.

 Repositioned beach ball.

You can also use the Transform Layer tool to resize the ball. (Drag one of the 
corner handles of the scale control box to resize the beach ball the same 

amount in width and height.) Press the Play button to view the final animation.
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 Play the final animation.

You now have a pretty good grasp of how to draw, fill, set up bones, and animate in 
Moho. Feel free to jump right in and start working with Moho. Or, you can read more 
tutorials that dig deeper into specific topics.



Moho 13.5
Tutorial Manual 

51

Drawing

Drawing

Tutorial 2.1: Welding
As you learned in the Quick Start tutorials, Moho features an Auto Weld feature 
that automatically welds shapes and segments together when your cursor reaches 
a point that you can weld to. However, there are cases where you may want to 
manually weld points together.

When drawing in Moho’s vector layers, the concept of “welding” points is very 
important. These tutorials will show you examples of how (and why) points can be 
welded, and will go on to show you some examples of good and bad welds you 
can do in Moho.

When you weld two points together in Moho, Moho really is combining those 
two points into one. There are a couple reasons to do this: First, welding the two 
endpoints of a curve together creates a closed curve. Second, if two shapes join 
up at a particular point, and you want them to remain joined during an animation, 
then welding those points together will guarantee that those two shapes will remain 
joined.

How to Weld Points
There are two ways to weld points in Moho: manually and automatically.

To manually weld two points together with the Transform Points tool, first 
uncheck the Auto-weld option for the tool.

 Auto-weld option unchecked

Drag one point on top of the other and press the Enter key. Here’s an example of 
this method. Although you can’t see the keyboard in the example, keep in mind 
that the Enter key was pressed at the moment when the two points overlap. After 
welding, notice how the two points move as one.

Click this link to view a brief video of Welding Example #1.
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 Before Enter key is pressed (left). After Enter key is pressed (right)

The second method of welding is automatic. For automatic welding to work, be 
sure that the Auto-weld checkbox is turned on in the tool options area when the 
Transform Points tool is active:

 Make sure Auto-weld is on

Using this method, when you drag a curve endpoint on top of another point , the 
point turns green when it can be welded automatically. Let go of the mouse to 
automatically weld the points together.

Here’s an example of automatic welding. In this case, the Enter key was not pressed 
to initiate the weld - as soon as the mouse is released, the two overlapping points 
are automatically welded together.

Click this link to view a brief video of Welding Example #2.

 Automatic welding

Here’s another example of automatic welding. Remember that only a curve 
endpoint can be automatically welded. However, the point that it is welded to does 
not need to be an endpoint:

Click this link to view a brief video of Welding Example #3.
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Automatic welding also works with the Add Point tool.

When you add a new point, you can drag it around as if you were using the 
Transform Points tool. As long as the new point you added is a curve endpoint, it can 
be automatically welded to another point. If the new point is not an endpoint, you 
can still weld it to another point manually by pressing the Enter key when it overlaps 
another point.

 Add Point tool with Auto-weld option on

Besides welding two points together, Moho can weld a point to the middle of a 
curve segment. This can be done with either the automatic or manual welding 
methods.

Click this link to view a brief video of welding example #4.

 Welding to a curve segment
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Why to Weld Points
OK, so that covers welding points, but why do you want to weld points again? The 
main reason is to create fillable shapes. In order to fill a shape with color, that shape 
should be completely closed, either by overlapping lines or by shapes that are 
welded together so that there are no gaps in the shape that you want to fill.

 A non-closed shape

By welding the two endpoints together, we can create a closed shape that can 
then be filled:

 A closed shape that can be filled
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Examples of Good Welding
Let’s look at some examples of good welding choices. First, the following two points 
could be welded to create a single, continuous curve:

 Joining two curves

The next case shows the classic case of welding a curve closed to create a fillable 
shape:

 Closing a curve

Next, we show a shape made up of several curves. Notice that a closed, fillable 
shape does not need to be made up of a single curve. The shape below, after 
welding, is made up of three curve segments, but is still closed and can be filled with 
color:
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Joining multiple curves into a single closed shape

 The welded and filled shape

Finally, the example below shows two circles lined up side-by-side. The two side 
points of the circles have been welded together so that when they move around 
during an animation they remain joined. If those points were not welded, moving 
them in sync like this would require a lot of extra work.

To maintain the separate colors in the two circles, Auto Fill is 
turned off before welding the two circles together at a 

common point.

Click this link to view a brief video of the joined circles.
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Examples of Bad Welding
Typically, when you weld together two points, one of them should be a curve 
endpoint. This isn’t always true, but most often it is. If you find yourself welding 
together two points and neither is an endpoint, take a moment to think whether the 
weld is appropriate. Here’s an example of a bad choice of welding. Suppose you 
had the following two shapes and you were considering welding the pairs of circled 
points:

 Before welding the marked points

Although Moho will let you perform those welds, it isn’t really a good idea. What you 
would end up creating is a shape with lots of little holes in it. Along the section of 
curves that you welded together are little bubbles that make it impossible to fill the 
two main shapes:

 Bad welding
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Instead, a better approach is to just move the two shapes closer together without 
any welding at all. In this case, welding the two shapes together doesn’t have any 
benefit.

 Fill the shapes without welding them together

Another approach in this situation would be to cut the top shape apart with 
the Delete Edge tool and then weld the remaining endpoints to the lower 

shape. First, cut the top shape apart:

 Cut the redundant curve away

Then, weld the newly-created endpoints onto the lower shape. With this approach 
you don’t end up with a double curve all welded together. The resulting shape is 
much cleaner and easier to work with:
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 Weld the new endpoints

Tutorial 2.2: Drawing Shapes with Holes
Drawing shapes with holes is very easy in Moho, but many new users don’t realize 
that this can be done. There’s really no trick at all - just follow the basic rules for 
creating a fill.

Reminder of Fill Rules
As a reminder, let’s consider the rules for creating a fill shape: A fill must be 
composed of closed curves that define the border of the shape. So, as an 

example, below is a valid fill shape.
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 A basic fill shape

Creating Holes
So a fill shape is defined by the curves on its border. If we want to create a hole, 
then all we need to do is create curves that outline the shape of the desired hole(s). 
Below we’ve added some extra curves before creating a fill shape:

 New curves added

Once you’ve set up curves to define the shape of the hole, all you need to 
do is select the outline and the hole(s) using the Create Shape tool. Notice 

that Moho automatically identifies the inner curves as borders of holes in the shape. 
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There’s nothing in particular you have to do, just draw the holes and Moho will know 
what to do with them. When you’ve selected all the correct points, press the Enter 
key to finalize the shape.

 Selected points for filling

Finally, here is the resulting shape. (The Line Width tool was used to narrow the width 
of the outline at the corner points.)

 The finished shape

Here’s another example of a shape with a hole:
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 Another shape with a hole

Tutorial 2.3: Hidden Edges
When drawing more complex objects like faces, you will often run into situations 
where you want an outline to only go partway around a shape. There’s an easy way 
to accomplish this in Moho.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
2.3 and it’s located in the Tutorials > 2 - Draw subfolder within your custom content 
folder. Open this file in Moho and you should see something like this:

 Starting point for this tutorial
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Hidden Edges
The drawing we’re working with could be the beginning of a character’s 
face. In this face, the nose and ear are separate shapes from the main head 

outline. The general shape looks OK, but where the separate parts join up we don’t 
want to have lines separating them. To fix this, activate the Hide Edge tool.

There are two edges we want to eliminate from this drawing. Click on these two 
edges as shown below. If you don’t see an immediate result, try dragging the mouse 
across the lines in question to make sure you hit them.

 Edges to click on

After clicking on these edges, they should disappear from view, and the result should 
be as follows:

 After hiding the edges
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The Hide Edge tool works by simply hiding the selected edges of an outline. It does 
not affect the underlying curve - the curve is still there, you just can’t see the outline 
on that particular section of the curve. Because it works on the outline, and not 
the curve itself, be sure you only use the Hide Edge tool after you’ve created the 
outlines. Otherwise, with no outline, you would not see the result of hiding some 
edges.

The other thing to know about the Hide Edge tool is that you can also un-hide 
edges. If you change your mind, or hide the wrong edges, just click on a hidden 
edge to re-show it.

Finishing Touches
If you hide the edges of a thicker line, you’ll often end up with abrupt ends to the 
outline. You can see this below:

 Blocky curve ends

A nice way to finish off these endpoints is to use the Line Width tool. With this 
tool, click on the endpoints to set their width to 0. You can also click and 

drag to adjust the width of any other points you choose. After cleaning up the 
endpoints, you should get a result like this:
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 Tapered endpoints

Tutorial 2.4: Varying Line Widths
Moho allows you to change the width of a stroke at any point along the curve. Line 
width information is stored as a percentage value, rather than as an absolute value.

You can use varying line widths to create outlined shapes that maintain consistency 
when they are bent and animated.

Start With a New Project
Create a new project. In the Style window, select a color that you want to 
use for the outline color. Set the width of the stroke to around 100. Use the 

Add Point tool to draw a three-point curve. Bend the curve slightly, like an arm.
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 A simple three-point curve bent like an arm

Switch to the Create Shape tool, and make sure that the line is selected. Then press 
the Create Shape button in the toolbar to change the curve to a shape.

Next, switch to the Line Width tool to increase or decrease the width at the 
points until you have a shape resembling an arm. Your arm should look similar 

to the figure shown below.

 The curve reshaped to look like an arm

Now, select the points in the curve again with the Select Points tool, and use the 
Create Shape tool to create a second shape with the same curve.

Now you have two strokes that are superimposed directly on top of each other, with 
the top shape selected. You can use the top stroke as a fill, but you’ll need to make 
some adjustments.

Click to select the new stroke with the Select Shape tool. With the top stroke 
selected, change the stroke color to the color that you want to use for the fill 

of the arm (such as yellow, shown here).
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 Change the color of the top stroke

Reduce the width of the top stroke to a value between 90 and 95 (depending on 
how thick you want your “outline” to be). Your project should now look similar to the 
figure shown below.

 The curve reshaped to look like an arm

Remember that in this method, you are not working with a stroke and a fill. Instead, 
you are working with two strokes of different colors that are controlled by the same 
curve.

Now you can use the variable line width tool to adjust the width of both strokes 
at the same time, or make other transformations with the Transform Points tool to 
reshape or animate both curves at the same time. This allows you to quickly create 
character elements, such as arms or legs, which are easier to animate because they 
have fewer points to manipulate.
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Line width and transformation changes made on the points or curves affect both 
strokes at the same time.

Tutorial 2.5: Shape Ordering
In a Moho vector layer, shapes are ordered from back to front. This ordering 
determines which shapes will appear in front of or behind others. This tutorial will 
show you how to work with shape ordering.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
2.4 and it’s located in the Tutorials > 2 - Draw subfolder within your custom content 
folder. Open this file in Moho, and you should see something like this:

 Starting point for this tutorial
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As you can see, there are four shapes in this file. By the way they overlap one 
another, you can also tell their ordering. From back to front, there is a red shape, a 
green shape, a blue shape, and a yellow circle.

Raising and Lowering Shapes
If you want to change the order of some shapes, the first thing you need to 
do is select a shape to work with. Using the Select Shape tool, click anywhere 

on the red shape. It will become highlighted with a checkerboard to indicate that it 
is selected. Notice that you can also see it faintly beneath the other shapes - this is so 
that you can see the entire selected shape, even if it is normally obscured by other 
shapes.

 Selected shape highlighted

To raise the shape, press the Up arrow key on your keyboard. Notice that the red 
shape has now moved one step up in the layer order, above the green shape:
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 Raised shape

Right now, press the enter key to de-select all objects in the layer. The red shape will 
switch back to normal to indicate that it is not selected:

 De-select the shape

Next, use the Select Shape tool and click on the blue shape to select it.

Press the Down-arrow key twice to lower the blue shape below the red 
shape, and then below the green shape:
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 Lowered blue shape

You can also raise a shape to the top (above all others in that layer) or lower it to the 
bottom (behind all others in that layer). Select the green shape and hold down the 
Shift key while pressing the Up-arrow key. With a single key press, the green shape 
moves all the way to the top of the layer’s shape order.

Selecting Hidden Shapes
If you now press the enter key, the green shape will be de-selected. Notice that at 
this point the yellow circle is behind the green shape, and can’t be seen. You can 
still see the curves that make up the yellow circle, but the shape itself, being behind 
the green shape, is not visible:

 Hidden yellow circle
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Now we want to bring the yellow circle back to the front. Using the Select 
Shape tool, click on the yellow circle, even though it’s hidden.

As you may have expected, the green shape gets selected because it is in front:

 Selected green shape

Now comes the trick for selecting shapes lower in the ordering. Hold down the 
Ctrl key (Windows) or Cmd key (Mac) while pressing the down-arrow key. This tells 
Moho to pick the next deeper shape in the layer ordering at the same point you just 
clicked. The yellow circle will now be selected. It will be kind of faint to remind you 
that it is actually behind other shapes in the layer:

 Selected yellow circle

Finally, hold down the Shift key while pressing the up-arrow to bring the yellow circle 
all the way to the top of the layer ordering, making it fully visible once again:
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 Raised yellow circle

Tutorial 2.6: Brushes
Moho allows you to apply brush effects to outlines if you choose. It’s really easy to 
use brushes, and this tutorial will show you how.

Draw Some Freehand Curves
Start with a new, blank file in Moho. In the Style window, set the line width 
value to 16. Next, activate the Freehand tool. In the tool options area at the 

top of the main Moho window, adjust the settings for the Freehand tool to match 
those shown below:

•	 Variable Line Width: Use Pen Pressure

•	 Width Variation: 75%

•	 Taper Start: Checked, 20%

•	 Taper End: Checked, 20%

•	 Point Reduction: 50 (default)
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 Freehand settings

Draw two or three curvy lines using the Freehand tool in the editing view:

 Freehand curves
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Because of the line width set in the Style window, these curves should be rather 
thick. The tapering settings in the Freehand options should make the ends of these 
lines taper down to narrow points. If you select File > Preview now, the result should 
look pretty much like what you see in the editing view:

 Rendered curves

Close the rendering window, and use the Select Shape tool to select one of 
the curves:

 Selected curve

In the Style window, click on the box that currently says No Brush.

 No Brush
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In the brush dialog that appears, select one of the brush shapes that interests you - 
you’ll see a preview of the brush at the bottom of the dialog:

 Brush Dialog (Pro version shown)

Click OK to close the brush dialog, and select File > Preview again. In the rendered 
result you can see the applied brush shape:

 Rendered curves

Try applying other brush shapes and Stroke colors to the other curves:
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 Different brush shapes

(Pro Only) If you notice that your brush effects are not visible 
until you render or export your animation (brush shapes are not 

possible when exporting to SWF format), you can change the display 
quality to show the effects during editing. In the lower-right corner of 
the main Moho window is the Display Quality popup box. Click this 
box to open it. Turn on the Brushes checkbox. This will turn on brushes 
in Moho’s editing view:

Displaying brushes while editing requires a lot of computation and 
can slow Moho down, so it’s best to use this as a kind of preview, but 
not to leave it on all the time. When you’ve got the brushes how you 
like them, switch this display option back off.
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 Turn on Brushes preview option

 Brushes in editing view

Tutorial 2.7: Layer Masking (Pro Only)
This tutorial is more of a show & tell than a hands-on creation of an animation. We 
will demonstrate some examples of a powerful feature of Moho - layer masking. 
Layer masking can be used for all kinds of effects such as shadows, compositing, 
depth effects, transitions, and to simplify certain modeling and animation tasks.
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Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
2.6 and it’s located in the Tutorials > 2 - Drawing subfolder within your custom 
content folder. Open this file in Moho, expand the Masking Group layer in the Layers 
window, and you should see something like this:

 Starting point for this tutorial

This is a simple scene of a wall with a hole broken through it (a jailbreak maybe?). Set 
the current time to frame 24, and choose the File > Preview menu command. Notice 
how the spotlights spread across the hole as if it were a flat object as shown below:

 Spotlights shining across the hole

To make the spotlights more realistic, we can use Moho’s masking feature. Double-
click the Masking Group layer. In the Layer Settings dialog that appears, go to the 
Masking tab and set the Group Mask setting to Hide all as shown below and click 
OK.
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 Mask setting for the Masking Group layer

In the editing view, you’ll notice that the light no longer appears over the hole. This is 
because the masking mode we just set hides the areas of the light that fall within the 
area of the hole:

 Everything in the group is hidden

The setting that controls how the mask reacts is found in the next section of the 
Masking tab. Double-click the Wall layer to bring up the Layer Settings dialog. In the 
Masking tab, notice that the Layer masking value is set to + Add to mask as shown 
below. Click OK to exit the Layer Masking tab:
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 Mask setting for the Wall layer

What we’ve done is tell Moho to add the contents of the Wall layer to the visible 
region of all objects in the group. No other layers in the same group will be 
allowed to draw outside this visible region (the mask). If you temporarily turn off the 
Background layer, you’ll see that there is an actual hole in the wall. Because the wall 
acts as a mask, the spotlights cannot draw themselves in this area. You’re welcome 
to render out the entire animation as a movie to see the full, animated effect.

 The wall acting as a mask

Another Example - Simplified Modeling
Now open the file Tutorial 2.6_2. Take a look at the masking group in this project (in 
this case, the masking function is already turned on). In this example, the eyes are 
used as a mask, and the eyelids are forced to render themselves only inside the 
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eyes. This makes it much easier to construct and animate the eyelids, without having 
to worry about them spreading outside the eye region - with a mask layer, they 
can’t.

Eyes used as a mask

Another Example - Transition Effect
Finally, open the file Tutorial 2.6_3. This project uses a mask layer to cause a text 
object to fade into existence. Play back the animation, or export it as a movie, then 
play back the movie. In this example, a variation of the masking feature is used: 
the mask itself doesn’t have to be visible. In this case, the mask is a rectangle that 
gradually exposes the text, but we don’t really want to see the rectangle. To use an 
invisible mask, the Mask layer uses the + Add to mask, but keep invisible option in the 
Masking tab.

Masking text.
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Tutorial 2.8: Styles (Pro Only)
In this tutorial we’ll introduce Moho’s Style feature. A style in Moho is a set of shape 
properties, including fill and line color, line width, fill effects, etc. Once you’ve 
defined a style, you can apply it to as many shapes as you wish. The benefit to this is 
that later on you can easily change the color and appearance of those shapes just 
by changing a single style.

Start With a Sample File
To start off, we’ll take a look at a Moho file that already contains some styles. It’s 
named Tutorial 2.7 and it’s located in the Tutorials > 2 - Drawing subfolder within your 
custom content folder. Open this file in Moho, and you should see something like this:

 Starting point for this tutorial

(Don’t worry that the character is all split apart. This is part of the bone setup 
described in another tutorial. If you want to try switching to frame 1, you’ll see that 
the character snaps back together. Just be sure to go back to frame 0 before 
continuing.)

Let’s see what a style is all about. In the Style window, display the Advanced settings 
by clicking the Advanced option.
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Click the Advanced checkbox to display more style options.

Select Skin from the Styles popup menu. The Skin style will become selected in the 
Style window:
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 The skin style selected

Click the Fill color selector to change the Skin fill color. Pick any color you wish. 
Notice that the skin color updates instantly on all the body parts of the character, 
even though they are separate shapes and in several separate layers. Styles can 
be used throughout an entire Moho project, and are not limited to the shapes in a 
single layer.
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 Modified skin color

If we look at the Style window, there are three things to notice about the Skin style:

1: The Skin style defines a fill color. 2: The Skin style does not define a line color. 3: The 
Skin style does not define a line width. Because the Skin style does not define a line 
color or width, changing these parameters will not affect the shapes that use this 
style.
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 Skin style settings

Let’s try a style that does control the properties of a line. Select the Outline style from 
the Styles popup menu in the Style window. Notice that this style does define a line 
color and width, but does not define a fill color. Change the Line Color to green and 
Line Width to 8 as shown below, and assign a brush to the line:
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 Modified Outline style

Notice that the Outline style has been applied to all the shapes in the entire 
character. Regardless of their other settings (like fill color), all the shapes use the 
Outline style to draw their outlines:
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 New Outline style

How Styles Are Applied
Now let’s take a look at how styles are created and applied. Create a new Moho 
project file. In the Style window, select New from the Styles popup menu.

The Style window will now be editing the values for that style. Give the style a name 
(any name), and choose a fill and line color. Finally, set the line width to 8 or so. If 
you want to, you can also assign a brush and fill and line effects.
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Creating a new style

Next, create a simple shape in the main window - a circle, rectangle, or text object 
would be fine. Make sure that the shape is filled.
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 Create a simple shape

 The new style in the Styles menu.

If you want to apply a style to any other shape, use the Select Shape tool to 
click on your shape to select it. The Style window will update itself to show 

you the properties of the selected shape.

Select your style from either the Style 1 or Style 2 popup menu. This tells Moho to 
apply that style to the currently selected shape - you should see the properties of 
your style applied immediately in Moho’s editing view.

That’s it! As you’ve seen, it’s quite easy to create and apply styles in Moho.
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Tutorial 2.9: Simple 3D Construction 
(Pro Only)
Moho is primarily a 2D program, although it does have some 3D tools for positioning 
the camera and individual layers. Still, even if you position layers in a 3D landscape 
and fly around them with the camera, each vector layer is really just a 2D plane in a 
3D space.

While you can’t create 3D objects in the same way that you can in a dedicated 3D 
modeling program, Moho does allow you to position and rotate two-dimensional 
planes in 3D space and then fly around them. If you need a more complex 3D 
shape you can import a 3D object as described in “Tutorial 6.9: Using 3D Models (Pro 
Only)” on page 269. You can also create 3D objects using a 2D vector shape, as 
described in “Tutorial 2.10: 3D Shape Design (Pro Only)” on page 97.

This tutorial will show you how to build a simple cube in Moho. If you need a more 
complex 3D shape, you can import a 3D object file created in a separate 3D 
modeling program (described in another tutorial).

Start With a Blank File
For this tutorial, start with a new, blank project in Moho. The completed file is also 
available for you to examine if you wish. It’s named Tutorial 2.8 and it’s located in 
the Tutorials > 2 - Draw subfolder within your custom content folder.

Creating The Faces
The first step is to create the faces of the cube. In the initial, empty layer of 
your new project, use the Draw Shape tool to draw a square.

It’s important that the square be precise. Choose the View > Enable Grid command 
to turn on the grid. This will help you draw this square.

The square must be centered at the layer origin, must be truly square (not a 
rectangle), and should touch the top and bottom of the viewable area exactly. 
To draw the square, press the Alt and Shift keys concurrently, and click at the layer 
origin point. The Alt key will draw the square outward from the point at which you 
clicked, and the Shift key will constrain the rectangle to create a square with four 
equal sides.

What’s important for this square is that the corners are at (-1, 1), (1, 1), (1, -1), and (-1, 
-1) as shown in the following figure.

Don’t worry too much about the coordinates - if you use the grid, center the square 
at the origin, and make sure the top and bottom touch the top and bottom of the 
viewable area, the corners will be correct.
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 Start with a square

You can select the Transform Points tool and optionally enter the coordinates for 
each point manually in the tool options area.

 You can manually enter coordinates in the Tool Options area

Select the shape with the Select Shape tool. Then fill the square with a color of your 
choice and set its line width to 2.

In the Layers window, click the New Layer button. Create a Group layer, name it 
Cube, and put the layer with the square inside it. Duplicate the square layer five 
times and you should have a setup that looks like this:
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 Arranging the layers

Positioning Faces
Select the lowest layer in the group, Layer 1, and make the Transform Layer 
tool active.

We’re not going to actually use the Transform Layer tool, but making it active allows 
us to position a layer numerically. At the top of the main Moho window, in the tool 
options area, set the value of X to 0, Y to 0, and Z to 1. This changes the depth of the 
layer, bringing it forward toward the camera.

 Layer 1 depth setting

Now select Layer 2, and set its X to 0, Y to 0, and Z value to -1. You’ve just positioned 
the front and back faces of the cube.

 Layer 2 depth setting

The settings get a little more complex from here on out. Select Layer 3, and set its X 
value to 1. Y and Z remain at 0.
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 Layer 3 depth setting

Next, activate the Rotate Layer XY tool.

The tool area will reflect the rotation of the layer around the Y axis. Set the Y 
Rotation value to 90:

 Layer 3 rotated

Next up is Layer 4 - adjust it similarly to Layer 3. With the Transform Layer tool, set X to 
-1 and Y and Z to 0, and use the Rotate Layer XY tool to set the layer Y Rotation to 90.

 Layer 4 Depth Setting

 Layer 4 Rotation Setting

Layer 5 is next - use the Transform Layer tool to set its Y position to 1 and the X 
and Z positions to 0. Next, choose the Rotate Layer XY tool and set X Rotation 

to 90 degrees.

 Layer 5 Depth Setting

 Layer 5 Rotate Layer XY Setting

Finally, the last layer, Layer 6 - adjust it similarly to Layer 5. Use the Transform Layer 
tool to set X and Z to 0, and Y to -1. Then choose the Rotate Layer XY tool and set X 
Rotation to 90.

 Layer 6 Depth Setting
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 Layer 6 Rotate Layer XY Setting

At this point the cube is basically finished, but it’s a little too big to see in the 
workspace. Use the Transform Layer tool on the Cube group layer to make 

the entire thing a bit smaller.

It should look something like this:

 The finished cube

Depth Sorting
The final step required to finish the cube is to turn on depth sorting. Double-click the 
Cube layer to bring up the Layer Settings dialog. In the Depth Sort tab, turn on the 
checkboxes marked Sort layers by depth and Sort by true distance and click OK. 
The first checkbox tells Moho to draw the back faces of the cube first, then the front 
ones. The second checkbox is a different way of sorting the layers that is mostly used 
for 3D constructions like this cube.
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Try using the Orbit Workspace tool to view the cube from different angles. It 
should appear as a true 3D object.

You could now use the cube in a scene - using the Transform Layer and Rotate 
Layer XY tools to position it at an interesting angle, or to move it around during the 
animation.

 The finished cube, with depth sorting

Tutorial 2.10: 3D Shape Design (Pro 
Only)
Moho’s 3D Shape Design feature allows you to convert a 2D vector layer into a 3D 
object. To demonstrate this, begin with a new project.

Use the Add Point Tool or the Draw Shape tool to create one or more vector shapes 
in the layer. Your objects can also include holes. All of the shapes that you create 
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in the layer will be converted to 3D. Therefore, if you want some of the objects in 
your scene to remain two-dimensional, or if you want them to have different 3D 
properties, you will need to put them in separate layers.

Start with two 2D shapes in the same layer.

After you create your 2D artwork, open the Layer Settings dialog for that layer. 
Choose the 3D Options tab. You will find some options that allow you choose a 3D 
Conversion type. The choices are Extrude, Lathe, and Inflate, which are detailed in 
the following sections.

Options for 3D conversion

There are several settings that are common to each of the 3D conversion types. 
These options are similar to regular 3D layers, and they affect how the edges and 
shading appear in the 3D objects.
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Options for Extrude conversion

•	 Edges: Controls which edges should be shown, and whether you want to show 
them on Silhouettes, Materials, or Creases. By default, edges are shown for all 
three. Uncheck the edges that you do not want to display. When displaying 
creases, you can adjust the Threshold setting to control the number of creases 
that are displayed. The Edge Extension setting controls how far beyond the 
edge of the object that edges will be drawn. Increase the Extension setting to 
make the objects it look like they have been sketched.
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Edges options

•	 Shading: Choose between None (which gives the object a flat appearance), 
Smooth (which gives a smooth, more three-dimensional shaded look), Toon 
(which has stepped shading), or Hatched (which shades with a sketched line 
effect).

•	 Shading Color: To change the shading color of your 3D object, select Hatched 
from the Shading drop down menu, double click on the existing shading color 
and choose a different color from the color picker.

•	 Shading Density: To change the shading density of your 3D object, select 
Hatched from the Shading drop down menu, the input field for the shading 
density will be editable, enter a number from 0 to 100. Zero will be less dense 
whereas 100 will be more dense.

Extrude Conversions
When you choose the Extrude conversion, the 2D object is given a dimension of 
thickness: You can observe the thickness by using the Transform Layer tool in the 
Layer section of the tool box. You can increase or decrease the thickness of the 3D 
shape by adjusting the Thickness setting in the Style window.
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Extrude 3D Conversion

When paths are displayed, you can still edit the path to change the shape of the 3D 
object, and change its color. You can also add bones to the 3D layer as well.

You can still edit the path to modify the 3D shape.

Lathe Conversions
The Lathe conversion allows you to create a three-dimensional path by drawing 
a two-dimensional profile shape that is then projected in a 360 degree circular 
fashion. The rotation occurs around the origin point of the shape (represented by the 
crosshairs in the workspace area).

The following conditions apply when using lathe conversions:

•	 If the vector shape only has a stroke, the stroke color will be used for the lathe 
object, and the outline will be black.

•	 If the vector shape has a fill color, the fill color will be used for the lathe object. 
The stroke color will be used for the outline of the lathe object. An example is 
shown in the following figure.
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Original filled shape (top); resulting lathed object (bottom)

Inflate Conversions
Inflate is similar to Extrude, except that the edges are rounded, like a pillow. It also 
involves more computations than the Extrude option, so you will tend to see better 
results after you render it than you will during the preview.
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Two inflated shapes on the same layer.
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Bones

Tutorial 3.1: Bone Binding
The purpose of bones in Moho is to provide high-level objects that are easy to 
manipulate in place of moving around lots of individual points. In order for bones 
to do their job, vector control points and other objects must first be bound to the 
bones. There are three ways to bind objects to bones: automatic binding, manual 
binding, and layer binding. This tutorial will show you the difference between the 
three.

Start With a Sample File
For this tutorial, we’ll start with a project file that contains some artwork to get started 
with. It’s named Tutorial 3.1 and it’s located in the Tutorials > 3 - Bones subfolder 
within your custom content folder. Open this file in Moho, and you should see 
something like this:

 Starting point for this tutorial

Automatic Binding
The most common method of binding objects to bones is also the easiest - 
automatic bone binding. Whenever you draw new artwork in Moho (or import 
image files as image layers), those objects are set up for automatic bone binding. All 
you need to do is add the bones.

1.	 In the Layers window, click the New Layer button, and select Bone from the 
popup menu. Name the new bone layer Arm Bones and press Enter/Return to 
assign the name.
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 Create a new Bone layer (Pro shown)

2.	 Drag the Arm vector layer upward to move it into the bone layer:

 Arm layer placed inside a bone layer

Make sure the Arm Bones layer is selected, then activate the Add Bone tool.

In the main editing view, create two bones: the first one starting at the 
shoulder and ending at the elbow, and the second starting where the first left off 
and ending in the hand. And that’s all it takes for automatic bone binding.

 Create two new bones
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Use the Manipulate Bones tool to try moving the bones around. The arm will 
move with the bones automatically, since it was, well, automatically bound 

to them.

 Test moving the bones

This arm setup works pretty well as it is, but let’s try to refine it a bit. Double-click the 
Arm Bones layer to bring up the Layer Settings dialog. Go to the Bones tab, set the 
binding mode to Region binding, and click OK:

 Turn on region binding

Flexible binding (the default for new bone layers) uses a method of bone binding 
where every bone has some influence over every point in a vector layer. The 
farther away a point is from a bone, the less influence that bone has over the point. 
However, you can still experience some rubbery movement where a moving arm 
can cause a toe to twitch a little bit.

With region binding, on the other hand, every bone has a cutoff radius, 
outside of which it will not affect the movement of vector points. This can be 

used for cleaner movement, but requires a little extra setup. Now that region binding 
is in effect, activate the Bone Strength tool.

Around each bone you will see its region of influence. Vector points are controlled 
by the bone(s) whose regions overlap them. If a vector point is not within any region 
of influence, it will move with the closest bone. Using the Bone Strength tool, click 
and drag on each of the bones to resize its region of influence. The idea is to make 
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the regions just large enough to contain the body part that the bone is meant to 
control:

 Resized regions of influence

Don’t worry about the parts of the forearm that are outside the forearm bone’s 
region of influence - they will just move with the closest bone, which is in fact the 
forearm.

Use the Manipulate Bones tool again to try moving the arm. The movement 
should be a little cleaner than it was with flexible binding.

Manual Binding
Manually binding points to bones is a process that exists mostly for compatibility with 
older versions of Anime Studio. Automatic binding, combined with bone regions of 
influence is the easiest way to work with bones in Moho. However, there may be 
some times where you want more control over exactly which bones control which 
points.

To manually bind the arm points to bones:

1.	 Select the Arm vector layer.

 Arm Vector Layer

2.	 Use the Select Bone tool to select the upper arm bone:
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 Bind all points to the upper arm

3.	 Activate the Bind Points tool.

4.	 Drag a rectangle around all the points in the arm to select them, and press the 
Enter key to bind the selected points to the selected bone. When you click an 
bind points to a bone, you will notice the points in the arm will be colored the 
same color as the bone they are bound to. This helps you determine which 
points are bound to which bone. In the following figure, all of the points are 
colored yellow because they are bound to the arm bone.

 Bind all points to the upper arm

5.	 With the Bind Points tool still active, hold down the Alt key and click on the lower 
arm bone to select it. Notice the following:

	� When you select the lower arm bone, notice that no points are selected.

	� When you select a bone with the Bind Points tool, the points that are 
bound to that bone are also selected. Because there are currently no 
points bound to the lower arm bone, no points are selected.

6.	 Drag a selection rectangle around the points in the lower part of the arm, as 
shown below. Press the Enter key to bind the selected points to the selected 
bone:
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 Select the lower arm bones

You’re done - you have manually bound points to both bones in the arm. 
Now test it out with the Manipulate Bones tool.

Although this method does work for binding points to bones, we don’t really 
recommend it unless you have a special need to bind specific points to specific 
bones. You may have noticed that the arm doesn’t move so smoothly with manual 
point binding. This is because the points around the elbow only move with one bone 
or the other, and so stretch apart and get distorted. With automatic binding, on the 
other hand, the points around the elbow move under the influence of both bones, 
and so move more smoothly.

Manual point binding can also be very labor-intensive, especially when your artwork 
has lots of control points. Finally, automatic bone binding can be used to warp 
image layers, while manual binding can’t - another reason to stick with automatic 
bone binding (using either flexible or region binding mode).

Layer Binding
The last way to bind an object to a bone is to bind an entire layer to a single arm.

7.	 Make sure the Arm vector layer is still selected and activate the Bind 
Layer tool.

8.	 Click on the lower arm bone to bind the entire Arm layer to the lower arm bone.
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 Bind the Arm layer to the lower arm bone

9.	 Select the Arm Bone layer and use the Manipulate Bones tool to try 
moving the bones around. Notice that the entire arm moves rigidly with 

the lower arm bone - the entire layer is bound to that one bone.

This isn’t very useful for this particular arm, but binding a layer to a bone is useful 
when you want to attach an object to a character. For example, a switch group 
containing multiple mouth shapes can be attached to a bone in the head. Or, if you 
want to make a character hold an object in its hand, you might bind that object to 
the character’s hand bone.

Go Back to Automatic Mode
Let’s undo all of this extra binding and go back to automatic mode.

1.	 Reselect the Arm layer in the Layers window.

2.	 With the Bind Layer tool, click on some empty space in the editing view 
- this tells Moho to not bind the layer to any bone.

3.	 Select the Edit > Select All menu command to select all the vector points.

4.	 Choose the Bone > Flexi-Bind Points menu command to flexibly bind the points, 
as they were at the very beginning.



Moho 13.5
Tutorial Manual 

111

Bones

 Chose Bone > Flexi-Bind Points to flexibly bind points as originally set in the beginning.

5.	 Reselect the Arm Bone layer, and use the Manipulate Bones tool if you wish to 
confirm that the points are automatically bound again.

 The arm under bone control.

Click this link to view a brief video of the finished results of your 
project.

Tutorial 3.2: Bone Constraints
This tutorial demonstrates Moho’s bone constraint features. Bone constraints allow 
you to define limits on the way bones can move, simplifying your animation work. 
When used carefully, bone constraints can let the bone structures do some of the 
work for you.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
3.2 and it’s located in the Tutorials > 3 - Bones subfolder within your custom content 
folder. Open this file in Moho, and you should see something like this:
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 Starting point for this tutorial

This file contains two skeleton layers that have no constraints set up. We’re going to 
add constraints to these skeletons to show how useful they can be.

Angle Constraints
The first type of bone constraint is angle limits. By limiting the angle that a bone can 
rotate, you can prevent arms and legs from bending backwards.

6.	 Make sure the Arm layer is selected.

 Select the Arm bone

7.	 Use the Select Bone tool to select the bone in the Arm as shown below:
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 Select the lower arm bone

8.	 When the Select Bone tool is active and a bone is selected, the Bone 
Constraints popup box will be available in the tool options area of the main 
Moho window. Click the Bone Constraints popup to open it.

9.	 Adjust the settings as shown below. Specifically, turn on the Angle constraints 
checkbox, and set the min/max angle fields to -10 and 100.

 Set angle constraints

10.	 Click the Close button to close the constraints popup box.

11.	 Set the bone’s name to Forearm in the toolbar options.

 Name this bone Forearm

12.	 Once you’ve set up angle constraints, you can see them in the working 
area as two lines around the bone that indicate the minimum and 

maximum angles the bone is allowed to rotate between. Try using the 
Manipulate Bones tool and move the forearm - notice how Moho doesn’t allow 
you to move the bone beyond the minimum and maximum angles you set up.
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 Visual display of angle constraints

Here’s a handy little trick. Often, it can be hard to judge the 
correct numerical angles for bone constraints. There’s an easy 

way to adjust them if you have a mouse with a scroll wheel. Hold the 
mouse over the angle constraint you wish to change (in the Bone 
Constraints popup), and roll the mouse wheel up and down. The 
angle will change, and the display in the editing view will update to 
match. With this method, you can watch the display in the editing 
view and not worry so much about the actual numerical value.

Control Bones
The next type of bone constraint allows one bone to control the motion of another. 
This is a way to set up simple automatic animation.

13.	 Use the Select Bone tool to select the small bone above the upper arm:

 Upper forearm bone selected.

14.	 Bring up the Bone Constraints popup again, and select Forearm from the Angle 
control bone popup menu (this is why we named it earlier), and enter the value 
0.5 in the angle control field as shown below:
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 Angle control setup

15.	 We’ll do something similar for the small bone below the upper arm. Select that 
bone, and set Forearm as the angle control bone, but this time set the angle 
control value to -0.5.

Lower forearm bone selected.

16.	 Finally, use the Manipulate Bones tool again to move the forearm. 
Notice that now the muscles in the upper arm move automatically - this 

is what the Angle Control Bone does - it tells other bones to move automatically 
when it moves.
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 Upper Arm bones move automatically

Bone Locking
The third category of bone constraint is bone locking. When you lock a bone, you’re 
telling Moho that you don’t want it to move. Moho will try to keep the bone still by 
moving its parents as necessary to keep the bone in place. This isn’t always possible 
(depending on what else is happening in the animation), but it is still an extremely 
useful feature.

Bone locking is often used to keep a character’s feet from moving around on the 
ground. To do this, Moho needs to move the character’s legs automatically. Thus, it 
helps to use angle constraints to keep the knees from bending backwards.

Moho Pro offers some target bone features that help keep a 
character’s feet in place while moving bones above it. For 

more information about using target bones, see “Tutorial 3.6: 
Enhanced Bone Features (Pro Only)” on page 140.

1.	 Select the Frank w/Skeleton layer in the Layers window.
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Select the Frank w/Skeleton layer.

2.	 Use the Select Bone tool to select Frank’s left shin bone as shown:

 Select the left shin

3.	 Now set up angle constraints for this bone. The minimum angle should be -10, 
and the maximum should be 120:
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 Angle constraints for left shin

4.	 Now select the right shin, and set its angle constraints to -120 and 10.

 Angle constraints for right shin

5.	 Now that the legs are prepared, set the time to frame 24. Use the 
Transform Bone tool to drag Frank’s spine bone around a small distance. 

Notice that his feet move around and don’t stay in place.

6.	 Choose the Select Bone tool again. Go back to frame 0 and select the left foot 
bone:
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 Select the left foot

7.	 In the tool options area, turn on the Lock bone checkbox for this bone. Next, 
select the right foot bone and turn on Lock bone for it as well.

 Lock both foot bones

8.	 Now that the feet are locked, go back to frame 24, and use the 
Transform Bone tool again to drag Frank’s spine around.

9.	 Notice that now Moho tries to keep Frank’s feet locked to the ground. If you lift 
Frank too high, his legs will completely straighten out and his feet will lift from the 
ground - there’s really no helping that, the same thing would happen to you if 
you were lifted off the ground. You can try rotating the spine bone too and see 
how the skeleton reacts.
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 Locked feet

Bone locking is an animated parameter. You can turn on and 
off bone locking as many times as you want during an 

animation. This is especially useful when making a character walk - 
lock a bone as soon as a foot hits the ground, and unlock it just 
before the foot is to leave the ground for its next step.

Tutorial 3.3: Bone Dynamics
Moho’s bone dynamics system can be used to automatically move bones around 
in response to higher-level movement. Moho uses a physical simulation of springs 
to calculate dynamic bone movement, making it suitable for a wide range of 
movements, such as flabby body parts, bouncy hair, waving arms, etc.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
3.3 and it’s located in the Tutorials > 3 - Bones subfolder within your custom content 
folder.

1.	 Open the Tutorial 3.3 file in Moho. You should see something like this:
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 Starting point for this tutorial

2.	 Play back the animation to see what we’re starting with. The entire structure 
will tilt side to side and bounce up and down, remaining rigid the whole time. 
Only the vertical bone in the center of the skeleton is animated - all the others 
move with it because they are its descendants. Rewind the animation to frame 
0 when you’ve seen enough.

3.	 Use the Select Bone tool to select the top-left bone in the structure as 
shown below:

 Select this bone

4.	 In the tool options area at the top of the main Moho window, click the Bone 
constraints popup box to open it. In the popup box, turn on the Bone dynamics 
check box. This tells Moho to move the selected bone automatically according 
to the spring simulation.
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 Turn on bone dynamics

5.	 Select seven more bones (two in each of the arms), and turn on bone dynamics 
for each one.

Here’s a tip: you can leave the Bone constraints popup box 
open the whole time, just click on each bone in turn, then turn 

on bone dynamics for each one. If the Bone constraints popup box 
covers up some of the bones, you can pan the editing view by 
dragging with the right mouse button to expose the hidden bones. 
At this point, you should have turned on bone dynamics for every 
bone in the structure except the vertical center bone.

 All eight leg bones set

Play back the animation to see the difference. Now as the structure tilts side to side, 
the arms will bounce around in response to the movement of the center bone.

Adjusting Spring Parameters
So that shows the basics of how to use bone dynamics. Now let’s take a look at how 
you can make adjustments to the bounciness of the springs.

1.	 Select the top-left bone again, and re-open the Bone constraints popup box.
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2.	 Below the Bone dynamics checkbox are three parameters that allow you to 
fine-tune the effect. Set as follows:

	� Torque force to 4,

	� Spring force to 2

	� Damping force to 2

 Adjusting dynamics parameters for both bones in the top left arm

3.	 Select the bone’s immediate parent (the second bone in the top-left arm), and 
apply the same dynamics parameters.

A higher Torque force means that a bone moves more in 
response to its parent’s movement, Spring force determines 

how quickly it bounces back, and Damping force controls how 
quickly a dynamic bone stops moving (you can think of damping 
like friction). In this case, a high torque force means that the bone 
will move more strongly.

4.	 Next, select the two bones of the top-right arm (one at a time), and set the 
bone dynamics parameters to 2, 2, 5 (Torque, Spring, Damping). These settings 
will cause these bones to slow down their dynamic movement quickly - a high 
damping value is like making the bone move through a thick fluid.

Settings for top right arm bones
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 Set a high damping force on these bones

5.	 Finally, select the two bones of the bottom-left arm (one at a time), and set the 
bone dynamics parameters to 2, 4, 1 (Torque, Spring, Damping). The high spring 
force will cause this arm to bounce back very quickly.
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 Set a high spring force on these bones

6.	 Try playing back the animation again. As you watch the final animation, note 
the differences between the four arms. The top-left arm swings in a wide arc 
because it has a strong response to the parent bone’s movement. The top-
right arm’s movement is subdued because the damping force causes it to slow 
down more quickly. The bottom-left arm is very springy, and the bottom-right 
arm moves in accordance with the default bone dynamics settings.

Click this link to view a brief video of the finished results of your 
project.

Tutorial 3.4: Character Setup
In this tutorial, you will learn how to set up the bone system for a complex character. 
This will involve splitting a character apart, creating bones, adjusting bone strength, 
and putting the character back together.

Start With a Sample File and Split Apart the 
Character
For this tutorial, we’ll start with a project file that already has the artwork for the 
character drawn - you’ll just set up the bones. It’s named Tutorial 3.4 and it’s located 
in the Tutorials > 3 - Bones subfolder within your custom content folder.

To begin:

1.	 Open the Tutorials > 3 - Bones > Tutorial 3.4 file in Moho. There are six vector 
layers in this project, containing the body parts for this character. Although 
all the artwork could be drawn in one vector layer, it is often easier to draw a 
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character in multiple layers, arranging the body parts from back to front, as 
shown below:

 Starting point for this tutorial

 Starting point for this tutorial

2.	 In order to make bone setup easier, the first thing to do is split apart the 
character. Choose the Edit > Select All menu command. All the points in the 
right arm (your right, his left) should be selected.

3.	 Activate the Transform Points tool and drag the mouse to move the arm 
off to the side and up a bit:
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 Arm moved off to the side

4.	 Select the Head layer, and select all of its points with the Edit > Select All 
command. Move all of its points upward.

5.	 Repeat the process for the R Leg, L Leg, and L Arm layers of the character (skip 
the Torso layer). Select all points on each of those layers, and move the body 
parts away from the center, as shown below:

The reason we split apart the character is so that we can add 
bones to each part, while keeping the bones independent of 

each other. Later in the tutorial we’ll put the character back 
together again.
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 Body parts split apart

Add Bones
The next step is to add bones.

1.	 Add a new Bone layer to the project. Name the new Bone layer Skeleton. Move 
the new Bone layer to the top of the list if necessary.

2.	 Move all the vector layers into the new Skeleton layer, keeping the same order 
they are in now:

 Move all of the body part layers into the Skeleton bone layer.
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3.	 Double-click the Skeleton bone layer to open the Layer Settings palette. Switch 
to the Bones tab, and choose the Region Binding mode,

 Turn on Region Binding for the Skeleton layer.

4.	 Using the Add Bone tool, add two bones going up through the torso, 
starting with the bottom one:

 Two new bones

5.	 Next, add two bones to one of the arms, starting at the shoulder and going 
down.

6.	 Before you add bones to the second arm, use the Select Bone tool to reselect 
the upper torso bone. Then switch back to the Add Bone tool to add two bones 
to the other arm. This parents the second arm to the upper torso bone instead 
of continuing from the first arm.
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 Arm bones added

7.	 Use the Select Bone tool to select the lower torso bone. Then, select the Add 
Bone tool and add three bones to one leg, starting at the hip and moving down 
through the foot. Repeat the process for the other leg, making sure to reselect 
the lower torso bone first. The upper leg bones should be parented to the lower 
torso bone.

 Leg bones added

8.	 Use the Select Bone tool to select the upper torso bone, and then use the Add 
Bone tool to add one bone to the head.
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 Head bone added

9.	 The next figure shows the parenting of all the bones. The parenting 
arrows point from child bone to parent bone, and can be seen by 

activating the Reparent Bone tool:

 All the bones added
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Adjust Bone Influence
At this point, feel free to try using the Manipulate Bones tool to see how the 
bone system works so far. The body parts should mostly move how you would 

expect, but not totally cleanly - the next step is to clean up the bones’ influence.

1.	 Double-click the Skeleton layer in the Layers window to bring up the Layer 
Settings dialog.

2.	 Go to the Bones tab and set the binding mode to Region binding:

 Turn on region binding

When region binding is used, bones only move the points that 
lie in their region of influence. If a point is overlapped by 

multiple regions of influence, it will be affected by all the 
corresponding bones. If a point is in no bone’s region of influence, it 
will move with the nearest bone.

This is different from flexi-binding, where all bones affect all points. 
Flexi-binding can be quicker to set up, but leads to more rubbery 
motion, since moving a hand will always cause a little bit of 
movement in a foot. Region binding makes separate body parts truly 
separate.

3.	 For region binding to work, you need to adjust the region of influence for 
each bone. To do this, activate the Bone Strength tool to display the 

bones’ regions of influence:
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 Initial regions of influence

4.	 Using the Bone Strength tool, click and drag on each bone in turn to adjust its 
region of influence. The correct adjustment for a region of influence it generally 
to surround the points along that section of bone. The most important regions 
are at the joints - the knees and elbows and such. Those are the areas where 
the regions of two bones overlap, and points will bend under the control of 
both bones. For parts like this character’s head, the region of influence isn’t 
very important - since there’s just one bone, the points outside the region of 
influence will still move with that bone. Here’s how you should adjust the regions 
of influence (don’t worry about matching this exactly, just try to get kind of 
close):Adjusted regions of influence.
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 Adjusted regions of influence

5.	 Try using the Manipulate Bones tool again to test the bone setup. The 
character should move much more cleanly now - when moving an arm, 

for example, only that arm should move, and you should see no extra 
movement in other body parts.

Put the Character Back Together
The final step is to reassemble the character.

6.	 Activate the Offset Bone tool.

7.	 Click and drag on the top bone of each body part to move that part back into 
position. When each part is moved back into place, the character should look 
as shown in the following figure:

	� Move each arm by the upper arm bone

	� Move each leg by the thigh bone

	� Move the head by its single bone.
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 Re-assembled character

Frame 0 is considered the setup frame for bones. When the 
time is set to frame 0, the character will still appear split apart 

(unless you’re using the Offset Bone or Manipulate Bones tools). 
However, at other frames in the animation, the character will be re-
assembled according to how you used the Offset Bone tool.

8.	 Try moving the character around again with the Manipulate Bones tool. 
The body parts will still move independently, even though they now 

overlap. Because the bones were set up on a split-apart character, that 
character could be re-assembled while still keeping the body parts 
independent.
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 Final character

If you’re interested in taking a look at the final Moho file, it’s 
named Tutorial 3.4 Final and it’s located in the Tutorials > 3 - 

Bones subfolder within your custom content folder.

Tutorial 3.5: Flexi-Binding
Flexi-Binding

If you have changed the binding mode for any reason, you 
can double-click the Bone group in the Layers palette, and 

switch back to Flexible binding in the Binding Mode section of the 
tab. See “Bones Tab” on page 254 in your Moho Users Manual.

For any layer that is a child of a bone group, you can select a subset of the bones 
in the bone group and then choose Bone > Use Selected Bones for Flexi-Binding. 
This allows you to isolate the influence of a set of bones from the rest of the skeleton 
(such as a Right Arm bone affecting only the right arm). This reduces the need for 
you to separate artwork on Frame 0 and then put it back together again with the 
Offset Bone tool.

To illustrate how this works, assume you have drawn a character in 2D bitmap or 
format. A sample character is included in Tutorial 3.5.moho, which you will find in the 
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Tutorials > 3 - Bones subfolder within your custom content folder. The various body 
parts appear in separate layers in a layered Photoshop file that was imported into 
Moho.

A bone layer named Gramps appears at the top, and the layers for the different 
parts of the character are placed into the Bone layer. Then you use the bone tools 
to create a skeleton for the character so that you can animate it. An example for 
the character and skeleton are shown in the following figure.

 A layered character and its bones.

If you try to animate this layered character using standard flexi-binding, you find 
that the drawing distorts and stretches all the artwork. In previous versions of Anime 
Studio, you could break apart the bones and spread the artwork and bones apart, 
and then use the Offset Bone tool to put the parts together again, as described in 
“Tutorial 3.4: Character Setup” on page 125. However, sometimes it can be difficult 
to set up your character this way and it may not end up looking the way you want it 
to look.



Moho 13.5
Tutorial Manual 

138

Bones

 The character distorts when the bones are manipulated.

To set up the project so that the arm artwork is only affected by the arm bones:

1.	 Select the RArm layer in the Layers palette.

2.	 Use the Select Bone tool to select the bones you want to control the arm.

3.	 Choose Bone > Use Selected Bones for Flexi-Binding.
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 Assigning selected bones for Flexi-Binding.

4.	 Repeat the above steps for each of the layers in your character. In other words, 
in this example we choose the Head layer and flexi-bind selected bones to it, 
then do the same for the Torso, Left Arm, Right Leg, and Left Leg.
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 Improved bending.

Tutorial 3.6: Enhanced Bone Features 
(Pro Only)
This tutorial gives an overview of some of the enhanced bone features that you will 
find in Moho Pro. For this tutorial, we’ll start with a project file that already has the 
artwork for the character drawn and the skeleton is already set up. You’ll just focus 
on setting up these new features. The project is located in the Tutorials > 3 - Bones 
subfolder in your custom content folder, and it’s named Tutorial 3.6.

Mr. Bean’s skeleton is contained in a bone layer named Mr. Bean.psd. If you expand 
this layer you’ll see the artwork for each of the body parts beneath it.

The bones in the skeleton are labeled with generic bone labels. The table below 
shows which body parts each bone belongs to. You can optionally rename the 
bones, but renaming them will not be necessary for this tutorial. In addition, the table 
will show the new features that you will apply to the bone, where applicable.

Label Body Part Feature
B1 Hip Smooth Joint
B2 Head
B3 RUpperArm Smooth Joint
B4 RLowerArm Smooth Joint
B5 RUpperLeg Automatic Scaling, Squash and 

Stretch
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B6 RLowerLeg Target Bones, Automatic Scaling, 
Squash and Stretch

B7 RFoot Independent Angles
B8 LUpperLeg Automatic Scaling, Squash and 

Stretch
B9 LLowerLeg Target Bones, Automatic Scaling, 

Squash and Stretch
B10 LFoot Independent Angles
B11 LUpperArm Smooth Joint
B12 LLowerArm Smooth Joint
B13 Upper Torso Smooth Joint
RFootTarget -- Target Bones
LFootTarget -- Target Bones

Target Bones
In our first example, you’ll notice that two additional bones are created behind the 
character’s feet. These bones are named RFootTarget and LFootTarget, and they 
serve as target bones. These bones are not parented to anything. The purpose for 
these two target bones is to serve as a target point for each leg to point toward as 
the character moves.

 Two non-parented bones for the right and left leg targets.

If you press the Play button, you’ll notice that the target bones are already 
animated for a walk cycle. All you need to do is set up the legs so that they point to 
the targets while your character walks from left to right.



Moho 13.5
Tutorial Manual 

142

Bones

 The target bones are pre-animated for a walk cycle.

To attach the legs to the targets, follow these steps:

1.	 Select the bone layer (MrBean.psd) from the Layer palette, and then 
choose the Select Bone tool from the Bones tools. You don’t have to 

return to Frame 0 to assign a bone target, this can be performed on any frame.

2.	 Select bone B6 (the right shin bone) and click the Bone Constraints button in the 
options toolbar to open the Bone Constraints window.

3.	 From the Target dropdown menu, choose R Foot Target as the target for the 
right shin bone. You’ll notice that the leg will snap in place to point to the 
selected target. Leave the Bone Constraints dialog open for the next step.
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 Assign the R Foot Target bone to the right shin (B6).

4.	 Now select bone B9 (the left shin bone) and repeat the process, this time 
choosing L Foot Target from the Target menu. The left leg will snap into place to 
follow its target.

5.	 You’ll return to the Bone Constraints dialog it later in the next section, but for 
now, click Close so that you can preview the results.

6.	 Press the Play button, and now you’ll see that the character’s legs animate to 
follow the target bones.

Even if you move the body far away by translating the hip bone (B1), the legs and 
feet follow. The shins will still point to the targets even when the character is above 
the ground. The targets will remain on the ground.

The Manipulate Bones tool has been enhanced to work with target bones. Normally, 
the Manipulate Bones tool works with a chain of bones. When you transform one of 
the bones, the other bones in the chain follow it.

If the chain has a target in it, the Manipulate Bones tool can also move a target, 
making it easier to create walk cycles. It can also be used to have characters hold 
on to objects. If you click and drag the target it will move the target.
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Independent Angles
You’ll notice when you preview the results of the targets that the legs now follow 
those animated targets quite nicely! However, pay attention to the feet. Normally, 
if you move or rotate a parent bone, the child bone moves or rotates with it. And 
what you see in your animation is that sometimes the feet poke through the floor, 
while at other times the stiffness of the foot makes the walk look unnatural.

The Independent Angle constraint causes a bone to maintain its original angle 
as its parent bones are moved. It is a good solution if you want a foot to remain 
parallel to the ground as a character bends his thighs or shins. You simply apply the 
Independent Angle setting to each foot.

 The legs follow the targets, but the feet are angled unnaturally for a walk.

To set up independent angles on Mr. Bean, proceed as follows:

1.	 Select bone B7 (the right foot bone) and click the Bone Constraints button in the 
options toolbar to open the Bone Constraints window.
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 Check the Independent Angle option for both feet.

2.	 Check the Independent angle option. You should notice the foot will now return 
to its default angle (in other words, the same angle that the foot is in on frame 
zero).

3.	 Now, select bone B10 (the left foot) and check the Independent angle option 
for that foot as well.

4.	 Preview the results again to see how it looks.

 After applying independent angles the feet are parallel to the floor.
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Bones that have the independent angle setting are not locked 
at that angle, they only rotate independently of their parents. 

You can still manually rotate bones that have independent angles.

Squash and Stretch Scaling and IK Stretching
Normally, when you scale a bone, it scales in one direction. For example, if you 
increase the length of a forearm, the height or width of the arm is not affected.

With Squash and Stretch scaling, Moho tries to maintain some volume to the part 
that is affected by the bone. If a bone is stretched (lengthened), the width or height 
is decreased (squashed). Conversely, if a bone is shortened (squashed), the width or 
height of the affected object is increased (stretched).

 Squash and Stretch scaling applied to an arm.

Maximum IK Stretching has to do with bones that are locked or attached to targets. 
When a bone chain tries to reach for a target, if the target is too far away, the bones 
just point to it in a straight line. But if Maximum IK stretching has a value greater than 
1, the bones can stretch that extra amount to reach the target. So a value of 1.5 
means the bones can stretch 1.5 times their original length in order to reach the 
target. The user can always scale bones manually, but this stretching is automatic.

You can use these features quite effectively to create cartoony limbs. In the case of 
Mr. Bean, we’ll apply both of these features to his legs. This way, if you raise him off 
the ground, his legs will stretch to a certain point (#2 below), and then when that 
point is exceeded the feet will raise off the floor (#3 below).
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 Squash and Stretch scaling applied to leg bones.

To add Squash and Stretch scaling to Mr. Bean’s legs, follow these steps:

1.	 Select bone B5 (the right upper leg) and click the Bone Constraints button in the 
options toolbar to open the Bone Constraints window.

2.	 Check the Squash and Stretch scaling option. Leave the value in the text field 
set to 1. This will cause a bone to squash in the opposite direction by the same 
amount that an object is stretched.

3.	 Enter a value of 1.5 in the Maximum IK Stretching field. This will allow his legs to 
stretch to one and a half times their size before moving away from the targets.

4.	 Repeat steps 1-3 for the other bones in his legs: B6 (right lower leg), B8 (left 
upper leg), and B9 (left lower leg). Then click Close to exit the Bone Constraints 
dialog.
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 Squash and Stretch scaling and Maximum IK Stretching settings for the upper and 
lower leg bones.

Smooth Joints
The Bones > Create Smooth Joint for Bone Pair command allows you to select a pair 
of bones, and then creates a smooth bend between the two joints. While originally 
intended to improve bending on elbow and knee joints, you can also use it in other 
areas as well. We will use this on Mr. Bean’s arms, legs, and torso.

To add smooth bending to those areas on Mr. Bean, follow these steps:

1.	 With the Select Bone tool, click to select bone B5 (right upper leg), then Shift-
click to select bone B6 (right lower leg). This is your first bone pair.

2.	 In the Layers palette, select the R Leg layer. This is the part that will be linked to 
the two selected bones for smooth bending.

3.	 Choose Bone > Create Smooth Joint for Bone Pair. This completes the first 
smooth joint. You have four more to go.
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 The first bone pair is connected to the RLeg layer.

4.	 For the remaining four smooth joints, repeat steps 1-3 as described previously, 
using the following bone pairs and layers:

	� Select bones B8 (left upper leg) and B9 (left lower leg) and connect them 
to the L Leg layer.

	� Select bones B3 (right upper arm) and B4 (right lower arm) and connect 
them to the R Arm layer.

	� Select bones B11 (left upper arm) and B12 (left lower arm) and connect 
them to the L Arm layer.

	� Select bones B1 (hip) and B13 (upper torso) and connect them to the Body 
layer.

5.	 With all the bone pairs connected to their layers, your setup is complete. Play 
the project and watch how the character responds to all the new settings. Feel 
free to experiment further with the animation that you have completed to learn 
more about how you can apply these new features to other characters.

Click this link to view a brief video of the finished results of your 
project. https://www.producturlsupport.com/cgi-bin/cscgi.pl?f

=video&p=ASD&v=12.0&o=M&l=EN&vid=Circles



Moho 13.5
Tutorial Manual 

150

Bones

Tutorial 3.7: Animated Bone Targets 
(Pro Only)
This tutorial will give you an overview of how animated bone targets can be 
configured in Moho.

1.	 Open Tutorial 3.7.moho, located in the Tutorials > 3 - Bones subfolder in your 
custom content folder.

2.	 Click the Targets layer to make it the active layer. Hide the other layers by 
clicking the Eye icon if necessary.

.Select the Targets layer and hide other layers if necessary.

3.	 You’ll notice two bones labeled Target and Target 2. Scrub through the 
animation to see them moving in different cycles. However, there is nothing 
parented to them yet.

4.	 Rewind back to the beginning and play through one cycle of the Target bone 
(frames 1-24). You’ll notice the Target moves toward Target 2 from frames 1-12, 
and returns back to the original point from frames 2-24.

5.	 At Frame 24, switch to the Select Bone tool and click on the “shin” bone. You 
want to target this bone to Target. You can do this in one of two ways:

	� Click the Bone Constraints menu button, and choose the Target from the 
Target menu.
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.Choosing the target from the Bone Constraints options window.

	� Or, switch to the Reparent Bone tool. Press the Ctrl (Windows) or Command 
(Mac) key while you click on the Target bone. A target icon will appear on 
the bone.

.Ctrl/Command click the Target bone with the Reparent Bone tool.

6.	 Continue to scrub through the timeline starting from frame 24. You’ll notice 
that the shin bone now follows the target. When you pass Frame 72 you will see 
Target 2 move toward the first Target. Advance to frame 108, where Target and 
Target 2 overlap.

7.	 At the point where the two targets overlap, you want to reparent the shin bone 
to Target 2. With the Reparent Bone tool selected, hold down the Ctrl (Windows) 
or Command (Mac) key and click Target 2 to assign the new target.
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.At Frame 108, Ctrl/Command click the Target2 bone with the Reparent Bone tool.

8.	 Continue to advance through the animation to see that the shin bone has 
switched targets.

While it isn’t strictly necessary, it is recommended that you wait 
until the target bones overlap before you change the parent. 

Otherwise, you might see unintended skipping or jumping when the 
targets are switched.

9.	 Replay the animation, and notice the following:

	� From Frames 1-24, nothing is targeted.

	� At Frame 24, the shin bone is targeted to Target, and the “leg” bones 
follow this target until frame 108 is reached.

	� At Frame 108, the shin bone is switched to Target 2. The following 
animation shows the result.

Click this link to view a brief video of the finished results of your 
project.

10.	 Choose File > Save As to save the project under a different filename. You will 
find a completed copy of this tutorial saved as Tutorial 3.7 Finished.moho.

Tutorial 3.8: Animated Bone Parenting 
(Pro Only)
In this tutorial you’ll work with three chains of bones. There is a ball in a vector 
layer which is bound to the top bone in the chain on the left. When you play the 
animation you see that the left chain dips down to the floor and the ball follows it. 
The other two bone chains bend around toward and away from each other. You’ll 
reparent the ball to the other bone chains during the course of this tutorial.
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To follow this tutorial, you can either continue from the point at 
which you left off in Tutorial 3.7, or start with the Tutorial 3.7 

Finished.moho project in your User Content folder.

1.	 Open Tutorial 3.7 Finished.moho, located in the Tutorials > 3 - Bones subfolder in 
your custom content folder.

2.	 Select the Parenting layer to make it active, and hide the other layers if 
necessary.

.Select the Parenting layer and hide the other layers.

3.	 You will see three chains of bones. There is a ball in a vector layer which is 
bound to the top bone in the chain on the left. When you play the animation 
you see that the left chain dips down to the floor and the ball follows it. The 
other two bone chains bend around toward and away from each other.

4.	 Advance the timeline to frame 24, where the ball is touching the floor. Activate 
the Reparent Bone tool. Then click on the background to remove the current 
bone parent.
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.Click an empty place in the document with the Reparent Bone tool.

5.	 Now advance the timeline further, and you will see that the ball remains on the 
ground.

6.	 At frame 48, the middle bone chain reaches the ball. Click the top bone in the 
middle bone chain with the Reparent Bone tool to assign it as the parent to the 
ball.
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.At frame 48, click the top bone in the middle chain.

7.	 Advance the timeline further and you will see the ball attached to the second 
bone chain. It starts moving toward the third bone chain at the right of the 
scene.Advance to frame 72, where the middle and right bone chains meet.

8.	 At frame 72, click the top bone on the right bone chain with the Reparent Bone 
tool to select it for the new parent.
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.Click an empty place in the document with the Reparent Bone tool.

9.	 Advance the timeline to Frame 96. Click the background with the Reparent 
Bone tool to remove the current parent.

10.	 Play the entire animation. Your results should be similar to the following 
animation. You will find a completed copy of this tutorial saved as Tutorial 3.8 
Finished.moho.

Click this link to view a brief video of the finished results of your 
project.
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Tutorial 3.9: Isolating Bones from 
Parenting (Pro Only)
When you assign a parent to a bone, Moho takes a snapshot of the parenting 
at that state. You can animate a bone that is on top of the parented bone (with 
independent angles, for example). But you typically don’t want to animate the 
bone that does the parenting because it has a snapshot taken of it and animation 
changes to the parent can cause unexpected changes in in the animation.

If you’re animating bones by hand, you should avoid animating the bone that 
another bone is parented to. Instead, use small bones to isolate the animation as 
shown in this example.

To follow this tutorial, you can either continue from the point at 
which you left off in Tutorial 3.8, or start with the Tutorial 3.8 

Finished.moho project in your User Content folder.

1.	 Start with the project that you completed with the previous lesson, or open 
Tutorial 3.8 Finished.moho, which is located in your User Content folder.

2.	 Select Layer 3 as the current layer, and hide the other layers in the project.

.Select the Parenting layer and hide the other layers.

3.	 Scrub through the timeline. You’ll notice at frame 24 that the two outer arms 
reach down to the shorter arms in the middle. Then they move up again at 
Frame 36.

4.	 The two bone chains in the middle are already set up with bone dynamics, 
which are used in this tutorial in place of manual animation. The inner bone 
chains bounce in a springy manner. The inner left and right bone chains are 
identical except that the bone chain on the inner right has a small bone at the 
bottom. This bone will be used for parenting of the inner right bone chain so that 
you can understand the advantages of isolating bones in parenting.
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.The small bone for the inner right bone chain will be used for parenting.

5.	 Move to frame 24. Click the bottom bone in the middle left chain with the 
Select Bone tool. 

6.	 Now switch to the Reparent Bone tool, and click the the top bone in the bone 
chain at the farthest left. In this bone chain, the bone dynamics will simulate 
what will happen when you try to animate bones that have a parent assigned.

.The lower bone in the inner left chain is parented to the top bone in the far left chain.

7.	 Now we’ll work with the set of bones at the right, which have the extra 
small bone that we will use for parenting. This small bone will help isolate the 
animation of the bone chain from the parenting. While still at Frame 24, select 
the small bone with the Select Bone tool.

8.	 Next, switch to the Reparent Bone tool and click the top bone in the bone 
chain at the farthest right.
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.The small bone in the inner right chain is parented to the top bone in the far right 
chain.

Play the animation back. You’ll notice that when the animation reaches Frame 
24, where the reparenting took place, there is a sudden change in the angle 
of the bone that was reparented in the chain on the left side. This is due to the 
mathematics in the physics because it’s getting a sudden surge of springy action. 
You don’t see this effect on the chain on the right side because it is isolated by the 
small bone that was assigned as the parent. In this case, the small bone gets a the 
sudden change in angle, but it isolates that change from the bones in the inner right 
bone chain.
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Tutorial 4.1: Image Layers
This tutorial introduces another type of layer in Moho: Image Layers. Image layers 
are a way of including artwork created in other programs in a Moho project. Any 
application that can produce image files can be used with Moho: photo editors, 3D 
modeling programs, natural media painting programs, the list goes on...

An image layer in Moho contains a single image file that can be used as a 
background, or combined with a bone layer to build a character. Although they’re 
called Image layers, an Image layer can also make use of a movie file as its source. 
Image layers and vector layers can be mixed and matched in the same project.

Alpha Channels
You’ll notice that the images used in this tutorial do not appear rectangular. This is 
because they make use of an alpha channel to mark some parts of the image as 
transparent. We recommend using PNG images with Moho because they support 
full alpha channel transparency. You’ll need to use an image editing program (like 
Adobe Photoshop) to create images with transparency.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
4.1 and it’s located in the Tutorials > 4 - Images subfolder within your custom content 
folder.

Open the Tutorials > 4 - Images > Tutorial 4.1 file in Moho. This project is almost 
complete as it is. The only thing that’s missing is the dancer’s left hand.

9.	 Expand the Hula Girl layer in the Layers window, and you should see something 
like this:

 Starting point for this tutorial
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10.	 Click on the layer named L Arm (we want the new layer to be just above the 
left arm).

11.	 Click the New Layer button in the Layers window to create a new layer. In the 
popup menu that appears, choose Image.

Create a new Image layer (Pro shown)

12.	 Moho will prompt you to select an image file. Choose the Moho/Tutorials > 4 - 
Images > l_hand.png image in your custom content folder.

13.	 In the Layers window, assign the new layer the name L Hand. At this point, your 
Layers window should look like this:

 Left hand added
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 The new hand

14.	 You’ll notice that new image layers are centered in the workspace, so 
the dancer’s hand is not yet properly aligned: To position the arm 

properly, use the Transform Layer tool to drag the left hand into position at the 
end of the left arm. Allow for a little overlap between the two parts at the 
elbow:

 Left hand in position

15.	 The last step is to attach the new part to the dancer’s skeleton. Select 
the Bind Layer tool, and click on the lower arm bone on the dancer, as 

shown below:



Moho 13.5
Tutorial Manual 

163

Images

 Bind the image layer to the forearm

You’re done! To see the animation in action, press the Play button. Of course, we 
skipped over the process of building and animating the skeleton, but the basics of 
working with skeletons were covered in previous tutorials - all of that information 
applies when using bones with image layers.

Click this link to view a brief video of the finished results of your 
project.

Tutorial 4.2: Image Warping
This tutorial demonstrates Moho’s image warping feature. This feature allows you to 
use a skeleton to distort an image. In this way, you can animate photographs, hand-
drawn artwork, or anything you can get into an image file in a flexible way.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
4.2 and it’s located in the Tutorials > 4 - Images subfolder within your custom content 
folder.

Open the Tutorials > 4 - Images > Tutorial 4.2 file in Moho.

1.	 Expand the Skeleton layer in the Layers window, and you should see something 
like the following figure. The Skeleton bone layer contains two sub-layers: an 
image layer (statue.png) and a vector layer (vector sample).
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 Starting point for this tutorial

2.	 Click the Play button in the timeline to play back the animation. Notice that 
only the vector layer moves with the skeleton. The reason that the image layer 
isn’t moving is that it hasn’t been connected to the bones yet (as the vector 
layer has been).

 Only the vector layer moves

Using Image Warping
To warp the image layer with the skeleton, continue with the project as follows:

1.	 Double-click the statue.png layer, and go to the Image tab in the Layer Settings 
dialog. Turn on the checkbox marked Warp using bones and click OK.
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Turn on the Warp using bones option

2.	 In the Layers window, turn off the visibility for the vector sample layer (it is only 
an example, and we don’t want it in the final animation).

Hide the vector sample layer

3.	 Play back the animation again, and you should now see the image moving with 
the skeleton:
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 Image warping

Notice the horizontal bone at the base of the statue. This bone 
doesn’t move at all in the animation, so why is it even there? 

When using image warping, the image is distorted by all the bones in 
the skeleton, and the nearest bone to any part of the image has the 
most influence. We don’t really want the base of the statue to move, 
so an easy way to prevent this is to add a bone in the area we want 
to remain still, and not animate it. Another trick you might use when 
warping images is to break up an image into logical parts (for 
example, make the arms and legs of a person separate images from 
the main body). Then, use different skeletons to control the various 
re-assembled parts. This way, a leg bone can’t have any influence 
over an arm.

Tutorial 4.3: Image Textures
In this tutorial you will learn how to use images as textures to add detail to a 
character.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
4.4 and it’s located in the Tutorials > 4 - Images subfolder within your custom content 
folder.

1.	 Open the Tutorials > 4 - Images > Tutorial 4.4 file in Moho, and you should see 
something like this:
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 Starting point for this tutorial

2.	 Play back the animation to see what’s going on.

3.	 Be sure to rewind the animation to frame 0 before you continue with the next 
section.

Paint the Textures
What you’re going to do is hand paint some texture details to go on this character. 
The first step is to paint some textures to go on this headless animal’s body.

1.	 Select the File > Preview menu command to create a full-quality view of the 
animal’s current state.

2.	 In the popup menu at the bottom of the Render window, select Copy To 
Clipboard.



Moho 13.5
Tutorial Manual 

168

Images

 Copy the render to the clipboard.

3.	 Start up your favorite image editing program (we recommend Adobe 
Photoshop) and create a new document the same size as the Moho project 
(320x240 in this case). Paste the copied image into the new document.

4.	 Create a new layer in your image editing program and paint some kind of 
texture details onto the animal’s body parts. It’s very important that the texture 
be on a layer of its own. If you’re using Photoshop, the layer arrangement would 
look something like this:

 Layers in Photoshop

5.	 Paint whatever details you want. Here’s an example of something you might 
paint in your image editor. Don’t worry about painting outside the lines:
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 Painted on texture

6.	 When your texture is finished, get rid of the background layers so that only the 
texture is left with a transparent background (you’re still working in Photoshop or 
similar program at this point):

 Background removed

7.	 You need to save the texture as three separate files. For each version of 
the texture, delete the parts of the texture that are not attached to the 
corresponding body parts. Save the images in PNG format, since PNG properly 
stores the transparent background. Examples of the three textures are shown in 
the figures that follow.

	� Save an image for the back legs. Name the file back_tex.png.

	� Save an image for the torso. Name the file body_tex.png.

	� Save an image for the front legs. Name the file front_tex.png.
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8.	 After you save your images, you can close the image editor. It’s time to bring 
the textures back into Moho.

 Back legs texture. back_tex.png

 Body texture. body_tex.png
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 Front legs texture. front_tex.png

If you’re having trouble creating the image textures, we have 
provided some files for you to examine. Look at the file Tutorial 

4.4 Texture.psd, located in the Tutorials > 4 - Images subfolder within 
your custom content folder - this is the Photoshop file. Also, look at 
the files back_tex.png, body_tex.png, and front_tex.png, which are 
the finished texture files.

Import Textures
To import your painted textures in Moho, follow these steps:

1.	 In the Layers window, highlight the Back Legs layer. The image file that you 
import will be placed above this layer.

2.	 Create a new Image layer and select back_tex.png as the source image. The 
new image layer appears in the layers list.

3.	 Select the Body layer as the current layer. Create another image layer for 
body_tex.png . The new layer should appear above the Body layer.

4.	 And finally, select the Front Legs layer, and create a third image layer for front_
tex.png. The new layer appears above the Front Legs layer. Here’s how the new 
image layers should be arranged:



Moho 13.5
Tutorial Manual 

172

Images

 Three new image layers

 Textures applied in Moho

Use Masking for Clean Edges
At this point, the textures are finished and in place, but they are a little messy, and 
go outside the bounds of the actual body parts. The final step is to clean up the 
texture edges using layer masking.

1.	 Double-click the Skeleton layer in the Layers window to bring up the Layer 
Settings dialog. Go to the Masking tab, and set the group mask to Hide all:
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 Turn masking on for the group

2.	 Next, double-click the Back Legs vector layer to bring up the Layer Properties 
dialog for that layer. Go to the Masking tab, and set the masking mode to + 
Clear the mask, then add this layer to it. What this masking mode does is make 
all objects invisible, except where this layer has solid areas. So, the back_tex.
png image layer will only be visible directly on top of the Back Legs vector layer, 
preventing the texture from going outside the lines of the back legs.

 Set the masking mode for the Back Legs layer
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The Back Legs layer with mask

3.	 Repeat step 2 for the Body and Front Legs vector layers. Set the masking mode 
to + Clear the mask, then add this layer to it, just like you did for the back legs. 
At this point, all the textures should be forced to stay inside the lines:

 Textures cleaned up with masking

4.	 Play back the animation again and you’ll see the image layers warp along with 
the vector layers in response to bone movement.
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Tutorial 4.4: Animating a Talking Head 
(Pro Only)
This shows you an easy way to animate a photograph to create a cheesy talking-
head effect. The quality of the result will depend a lot on the photograph you start 
with and how the bone system is set up.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
4.3 and it’s located in the Tutorials > 4 - Images subfolder within your custom content 
folder.

1.	 Open the Tutorials > 4 - Images . Tutorial 4.3 file in Moho. The project contains 
an image layer enclosed in a bone layer. Bones have already been set up to 
control the mouth region, and extra bones have been set up around the border 
of the image to hold the rest of the head still. You should see this:

Starting point for this tutorial

2.	 In the Layers window, click to select the reagan.png layer.

3.	 Select the Manipulate Bones tool and press the Alt key while you use it to 
drag the bone at the lower right side of the mouth in the reagan.png 

layer. Notice that the other mouth bones move as well - they have been set up 
using bone constraints to move in sync with the lower-right bone.

Normally, the Manipulate Bones tool rotates bones. However, 
when a bone does not have a parent (as is the case with the 

mouth bones in this project), the Manipulate Bones tool translates 
the bone by default. Pressing the Alt key while using the Manipulate 
Bones tool on bones that have no parent will allow you to rotate the 
mouth bone.
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 Moving the mouth

Adding Sound and Motion
Now we’ll add a soundtrack to this animation.

In the Layers window, click the New Layer icon and create a new Audio layer.

1.	 When prompted, pick the reagan.wav file from the Moho/Tutorials > 4 - Images 
folder.

2.	 Press the Play button in the timeline. The audio file will now play back with the 
project - try playing it back if you like.

3.	 The next step is to add some animation in sync with the soundtrack. 
Select the Mouth Bones bone layer, and activate the Select Bone tool. 

Make sure the bottom-right bone in the mouth is selected (it probably already is 
at this point).

4.	 In the timeline, set the current time to frame 1.

5.	 Select the Scripts > Sound > Bone Audio Wiggle menu command. This is a script 
that uses the volume of an audio file to control the angle of a bone.
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 Bone Audio Wiggle script

6.	 The Bone Audio Wiggle dialog allows you to choose the sound file that you want 
to use. Select the same reagan.wav file you used for the soundtrack. You can 
only select one audio file if there are multiple sounds in your scene.

 Bone Audio Wiggle dialog

7.	 There are two additional settings in the Bone Audio Wiggle dialog. Set the Max 
angle to 180, and keep the Frame Step setting at 2. This creates keyframes 
at every other frame. Click OK to exit the dialog. The script will run and add 
keyframes to the timeline for the selected bone. Because the other bones are 
controlled by the selected one, the whole mouth will move.
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 Keyframes for Bone Audio Wiggle
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Animation
After all the preparation time drawing your objects, assigning fill colors, and setting 
up bones, you move on to animating them. This is where things actually start to 
move around.

Animating in Moho is based on the concept of keyframes. A keyframe is a point 
in time where you position some object (either a point, a bone, or an entire layer). 
A keyframe tells Moho exactly where that object should be and when. Keyframes 
are set up at important moments in time - typically where an object begins moving, 
stops moving, or changes direction. Between keyframes, Moho automatically 
calculates how to move an object so that it gets from one keyframe to the next in 
the amount of time allowed between the keyframes.

To create a keyframe, just set the current time to whenever you want the keyframe 
to occur, then move the object to the desired position. Controlling the current time 
and working with keyframes after they’ve been created is discussed in “Chapter 16: 
The Timeline Window” on page 332 in your Moho Users Manual.

You can animate several types of motion in a Moho project, and they can each be 
used alone or in combination. 

•	 The first type is point motion. Point motion very basic - it just involves moving 
individual points around in time. Point motion is good for small distortions to 
an object where you want something to look soft and flexible (turning up 
the corners of a mouth into a smile, bulging out a belly, etc.). You can move 
a shape in any way you want with point animation, but it might require 
manipulating a lot of points - in many cases bone animation can simplify the 
job.

•	 Bone animation involves setting up a skeleton system for an object and then 
moving the skeleton around. By carefully constructing a skeleton, you can easily 
move a character around like a puppet.

•	 Layer animation is for very simple, large-scale motion. When you move a layer, 
everything in it moves together. This doesn’t give you a lot of flexibility as far as 
what you can animate this way, but it’s a good way to get certain effects. If 
you want an entire group of objects to pan side to side or zoom in or out, then 
layer animation is the tool to use.

The keyframes you define are visible in the Timeline, starting at frame 1. Frame 0 
is a special frame in a Moho project - the original placement of all your objects is 
stored at frame 0. If you want to modify an object’s original shape or position, or add 
new objects, this should be done at frame 0. Whatever you do to an object in later 
frames can never affect an object’s original shape and position, so even if you think 
you really screwed something up, you can always delete some keyframes and get 
back your original drawings.

This chapter has a useful hands-on overview of how to animate in Moho, using each 
type of motion (point, bone, and layer). Once you’ve mastered Moho’s animation 
tools, animating is a simple job of repeatedly using the tools you already know, 
keyframe by keyframe.
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Tutorial 5.1: Automatic Lip-Sync
This tutorial uses Moho’s Switch layers to show you how to perform instant, automatic 
lip-syncing. A switch layer contains multiple sub-layers, but only one of the sub-layers 
can be displayed at a time. This makes it very useful for lip-sync animation: each sub-
layer can be a mouth shape for a different sound.

The method of lip-sync described in this tutorial is quick and easy, though not always 
super-accurate (but give it a try - it may be accurate enough for your animation).

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
5.1 and it’s located in the Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.1 file in Moho, expand the Mouth 
layer in the Layers window, and you should see something like this:

 Starting point for this tutorial

2.	 Examine the sub-layers in the Mouth layer. Notice that from bottom to top 
they range from closed to wide open. This is the basic setup for automatic lip-
syncing. The number and names of the sub-layers don’t matter, as long as the 
lowest one is closed and the highest one is wide open.
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 Layers in the Layers window

3.	 Next, add the audio file that will go along with the lip-syncing. Choose the File 
> Import > Audio File menu command and select the Tutorials > 5 - Animation > 
MaryLamb-Man.wav file in your custom content folder.

Make sure that you select the File > Import > Audio File 
command from the lower section of the file menu. This differs 

from the File > Import > Audio command in the upper section of the 
menu, which is used to open files in the Moho library.

 File > Import > Audio File command (Pro shown)

4.	 Play back the animation now to hear the result. You’ll notice that the mouth 
doesn’t move yet. Stop the playback before proceeding.

5.	 Double-click the Mouth layer. When the Layer Settings dialog opens, click the 
Switch tab:
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 Layer settings for the mouth

6.	 Click the Select audio sync source button to select the file that will control the 
Switch layer. In the file dialog that appears, select the file MaryLamb-Man.wav. 
Click the dialog’s OK button.

That’s it! The audio file was analyzed and keyframes were attached to the Switch 
layer. When the audio is quiet, Moho activates the lowest layer (the closed mouth), 
and when the audio is loudest, Moho uses the highest layer (the wide open mouth). 
In between, Moho switches on the in between mouths. Play back the animation 
to see and hear the result. In general, because automatic lip-sync is based on the 
actual sound in the audio file, it is important to use an audio file without background 
noise or music.

Click this link to view a brief video of the finished results of your 
project.

Tutorial 5.2: Phoneme Lip-Sync
This tutorial covers another method of animating lip-sync. With this method, the 
lip-sync is based on phonemes. Phonemes are the basic building block sounds that 
make up words. When you do lip-sync based on phonemes, it requires you to break 
down the words of dialog into their basic sound elements.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
5.2 and it’s located in the Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.2 file in Moho.

2.	 Expand the Head layer in the Layers window, and you should see something like 
this:



Moho 13.5
Tutorial Manual 

183

Animation

 Starting point for this tutorial

3.	 This project is almost complete. The only thing apparently missing is the 
animation for the character’s mouth. Play back the animation. The mouth is 
there (it’s a switch layer), but no animation data has yet been assigned to it, so 
it doesn’t move.

4.	 Double-click the Mouth layer. When the Layer Settings dialog opens, click the 
Switch tab:

 Options in the Switch tab

5.	 Click the Select audio sync source button to select the switch data file that will 
control this switch layer. In the file dialog that appears, select the file vista.dat 
located in the Tutorials > 5 - Animation subfolder within your custom content 
folder.
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The Mouth layer contains all the mouth shapes needed to 
speak any phrase. You can examine the Mouth layer to see the 

sub-layers it contains. Each sub-layer is named after a different 
phoneme. You can use any set of phonemes you choose. The 
mouth shapes in this mouth are based on the same default set used 
by a great (and free) lip syncing program that we recommend: 
Papagayo (http://www.lostmarble.com/papagayo/) is a good 
place to get started. To make the mouth speak a different phrase, 
just create a different animation data file in Papagayo, and select it 
into the mouth layer as we just did for the vista.dat example.

6.	 To hear the sound along with the animation, choose the File > Import > Audio 
File command from Moho’s menu and select the vista.wav file located in the 
Tutorials > 5 - Animation folder.

7.	 Now, when you play back the animation in Moho you will hear the audio that 
goes with the lip-sync. Also, if you export the animation as a movie, the audio 
will be included in the movie file.

If you plan to export your animations to Flash (SWF) format, you 
will need to use MP3 audio files instead of WAV audio files. In 

addition, if you plan to render to SWF format, you can only use a 
single audio file in the project.

Click this link to view a brief video of the finished results of your 
project.

Tutorial 5.3: Cycling
It is possible in Moho to automatically cycle a section of animation, repeating it 
over and over as many times as you wish. Cycling is a special type of keyframe 
interpolation, and this tutorial will show you how to set it up.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
5.5 and it’s located in the Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.5 file in Moho.
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 Starting point for this tutorial

2.	 In the timeline, you can see that the top layer, Red Blinker, has two keyframes in 
the Layer Visibility channel. The layer becomes invisible at frame 36, and visible 
again at frame 48. This is also shown by the red background in the timeline 
during the layer’s invisible period:

 Starting point for this tutorial

3.	 You can play back the animation to see what’s going on. Basically, the red light 
starts off turned on, then it shuts off for a while and finally turns back on.

4.	 Using cycling, you can make the light blink over and over. Right-click on the 
second keyframe (the one at frame 48), and in the popup menu that appears, 
select Cycle.... You’re telling Moho that after this keyframe, you want the 
animation to cycle back to an earlier point in the animation. A dialog will 
appear asking you the specifics of the cycling. Select the Absolute (cycle back 
to this exact frame) option, and then enter 12 as shown below:
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 Cycle settings

5.	 When you close the cycle dialog, the timeline will update to show the cycle. 
There are three changes you will see:

	� The keyframe in question will change to a left-pointing arrow to indicate 
that it cycles backwards.

	� A long red arrow will point back to the point in the timeline that the visibility 
channel is cycling back to.

	� Later in the timeline you will see other sections with red backgrounds to 
indicate that the layer is invisible during those periods:

 Cycling reflected in the timeline

6.	 You can play back the animation again to see the result. The Red Blinker layer 
will flash on and off multiple times, even though you didn’t add any more 
keyframes - the Layer Visibility channel is just cycling back and repeating a 
section of animation over and over again.
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7.	 Let’s try adjusting the cycle duration. In the Timeline window, hold down the 
Ctrl key (Windows) or Cmd key (Mac) while you click and drag on the second 
keyframe (the one that cycles). As you drag the mouse side-to-side, you’ll see 
that the cycle duration changes, as the arrow that points back from the cycling 
key gets longer and shorter. Adjust the cycle duration so that the keyframe 
cycles back to frame 24:

 Adjusted cycle duration

8.	 If you play back the animation now, you’ll see that the light blinks more quickly 
now, since the cycle duration is shorter.

9.	 Finally, to break a cycle, all you have to do is add another keyframe when 
you want the cycle to end. Set the current frame to 102, right click in the Layer 
Visibility channel, and select Add Keyframe from the popup menu that appears. 
The new keyframe will appear, and at that point the cycling will end. Play back 
the animation to confirm this.

 New keyframe at frame 102
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Conclusion
Cycling can be used in any animation channel in Moho. Any keyframe can be 
made to cycle back in time by setting Cycle as the key’s interpolation method. You 
can cycle a channel all the way back to the beginning of an animation, or just back 
a few frames. Cycling will repeat itself forever or until a new keyframe is reached.

Tutorial 5.4: Animation Curves (Pro 
Only)
Introduction
This tutorial introduces the graph mode of Moho’s timeline. Graph mode allows 
you to inspect an animation curve plotted as values on a graph. Looking at things 
this way can help with evaluating acceleration, changes in direction, and other 
properties of motion.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
5.3 and it’s located in the Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.3 file in Moho.

2.	 We’re interested in the Skeleton layer here - make sure it is the active layer.

The skeleton here is partially animated - go ahead and play it 
back to see what you’re starting with. In case you were 

wondering, only the lowest vertical bone in the skeleton is actually 
animated. The other bones are using bone constraints to follow the 
motion of the lowest bone.

Motion Curves
Continue with your project as follows to work with the motion curves:

3.	 Rewind the animation to frame zero, and use the Select Bone tool to 
select the lowest vertical bone as shown below:
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 Select the lowest bone

4.	 In the Timeline window, click the Motion Graph tab. Click the Selected Bone 
Angle channel icon - this is the channel icon on the left side of the timeline, and 
looks like this:

 Click the Selected Bone Angle icon

5.	 A single click turns on the display of the channel in the graph. A double-click 
makes the channel active for editing. Double-click the channel to continue.

By default, not all channels are visible, since this would just 
cause too much visual clutter in graph mode. For similar 

reasons, only one channel can be active for editing in graph mode. 
Double-clicking a channel’s icon makes it active for editing.

6.	 Now, press the End key on your keyboard - this rescales the graph to 
accommodate the currently active channel, in this case the selected bone 
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rotation channel. After all of these adjustments to the graph, it should look like 
the following figure.

7.	 In the graph you can see three keyframes. These are just like keyframes in 
the normal timeline, but instead of just being spread out along a horizontal 
line (time), they are also spaced vertically (value). Between the keyframes, a 
curve is drawn that represents the value of the selected bone’s rotation angle. 
Looking at this curve, you can tell that over the first second (frames 1 to 24), the 
bone rotates from an angle of 1.57 to an angle of about 1.05 (we don’t care 
about the exact values). Then, in less than half a second it rotates back again.

 Graph mode

In the timeline’s graph mode, angles are displayed in radians so 
that they’ll be closer in magnitude to other values like 

translation and scale. However, if you want to see curves displayed 
in degrees you can tell the timeline to do that in Moho’s preferences 
dialog.

8.	 Now we’re going to edit the bone’s motion by modifying the graph. First, set the 
current time to frame 48 and choose the Bone > Reset Bone command.

9.	 Press the Page Down key to give yourself some room in the graph to work (you 
may need to turn off your Num Lock key).

10.	 Next, click the keyframe at frame 33 and drag it upwards slightly as shown 
below.
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 Move a keyframe

11.	 Next we’re going to add a new keyframe directly on the graph. Right click 
on the graph around frame 37. In the popup menu that appears, select Add 
Keyframe. A new keyframe will appear on the graph - drag it to the location 
shown:

 Add a new keyframe

12.	 Let’s add three more keyframes like the previous one. Add these keys at frames 
40, 43, and 46. You don’t need to set the time to the frame you want to add a 
key to - just right-click at the correct frame and add the new key. Don’t worry if 
the key isn’t exactly at the frame you wanted, since you can easily drag it into 
position. Move these new keys so that the curve looks like this:

What this wiggling curve represents is sort of a springy back-and-forth motion 
that decreases over the span of just over half a second. You could have 
animated this using the normal timeline and the bone rotation tool, but this gives 
you another way to understand the motion you’re creating.
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 The final graph

13.	 Play back the animation to see what it looks like.

Tutorial 5.5: Sorting Layers by Depth 
(Pro Only)
This tutorial shows you some of the 3D-related features of Moho. Moho allows you 
to move layers in three dimensions to create an accurate simulation of depth. In 
addition, Moho has the option of sorting layers by depth, allowing layers to move in 
front of and behind each other during the course of an animation.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
5.4 and it’s located in the Tutorials > 5 - Animation subfolder within your custom 
content folder.

Open the Tutorials > 5 - Animation > Tutorial 5.4 file in Moho. You should see 
something like this:
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 Starting point for this tutorial.

This file contains two layers and a simple animation of a circle moving back and 
forth in front of a square. Try playing back the animation to see what it looks like.

Creating Depth
Now we’re going to try moving a layer in 3D - towards and away from the camera.

1.	 Set the current frame to 12 and activate the Transform Layer tool.

2.	 Make sure the Circle layer is active. Now, while holding down the Alt key, drag 
downwards in the editing area. You’ll see the circle get larger - this is because it 
is moving closer to the virtual camera. The Alt key modifies the Transform Layer 
tool to move a layer forward and back. Drag the Circle layer until it looks about 
like this:

 Circle moved forward
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3.	 In the tool options area at the top of the main Moho window, notice the 
value of the Z field. It should be somewhere around 1.0 (the exact value isn’t 
important here). Positive depth (or Z) values are closer to the camera (in 
the direction out of your screen), while negative values point away from the 
camera (into the screen).

4.	 Next we’ll try moving the circle away from the camera. Set the current frame 
to 36. Again holding down the Alt key, use the Transform Layer tool and drag 
upward in the editing area. Keep going as the circle gets smaller (farther away), 
until it looks like this:

5.	 The Z value in the tool options area should now be close to -1.0. Try playing back 
the animation again - the circle should now grow larger and smaller as it moves 
towards and away from the camera. However, it always appears in front of the 
square. As it moves farther away, it should be going behind the square, which 
brings us to the next section.

 Circle moved backward

Sorting Layers by Depth
If you do move layers forward and back, as in this tutorial, you may also want layers 
to move behind and in front of each other. Moho can do this automatically - all you 
need to do is to turn on a single checkbox.

Select the File > Project Settings menu command. In the Project Settings dialog that 
appears, turn on the Sort layers by depth checkbox and click OK. This tells Moho to 
ignore the layer ordering in the Layers window, and instead draw layers in order from 
furthest to nearest.
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 Sort layers by depth option

1.	 Play the animation again, and you’ll see that the circle is drawn behind the 
square during the time that it is farther away.

2.	 To get a clear idea of what’s going on, use the Orbit Workspace tool to 
turn the scene to an oblique angle. If you play back the animation from 

this point of view, you can clearly see the circle moving forward and back as it 
moves around the square.

3.	 Once you have a good view, activate the Transform Layer tool to display the 
path of the Circle layer’s motion.

 View from above
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A note about depth sorting: The checkbox we turned on to sort 
the layers by depth only sorts the top-level layers in a Moho 

project. If you want to sort the sub-layers in a group, double-click the 
group layer to bring up the Layer Settings dialog. There you will find a 
tab labeled Depth Sort - in this tab is a checkbox that you can turn 
on to depth-sort the sub-layers of the group.

Tutorial 5.5.1: Animated Layer Ordering
You can also use animated layer ordering to animate objects moving in front of or 
behind other layers. In the following example you’ll learn how this works.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.5.1 file in Moho. You should see 
something like the following image.

 Starting point for this tutorial

2.	 This project consists of three different shapes in a layer named Shapes. Double-
click the Shapes group in the Layers palette to open the Layer Settings dialog.

3.	 In the Depth Sort tab, check the Enable animated layer order option and click 
OK. This will apply the setting to all of the selected layers.
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 Enable Animated Layer Order in the Layer Settings dialog

4.	 Advance the timeline to frame 24, and drag the Circle layer to the top layer in 
the group in the Layer Settings dialog. Your project should now look as follows.

 Circle appears on the top at frame 24

5.	 At frame 48, move the star to the top layer as shown below.
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 Star appears on the top at frame 48

6.	 Finally, at Frame 72, move the Square back to the top as shown below.

7.	 Set the total number of frames in the animation to 72. The frame counter should 
read Frame 72 of 72.

 Square appears on the top again at frame 72

8.	 Now press the Play button. You’ll see the layer order of the three shapes change 
over time.
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Tutorial 5.6: Actions (Pro Only)
In Moho Pro, actions are little clips of animation that are associated with a layer (or 
group of layers). Using actions, you can create reusable animation for movements 
that you expect to use over and over again. In this tutorial you will learn you how to 
use actions.

Start With a Sample File
For this tutorial, we’ll start with a project file that already has some actions set up. It’s 
named Tutorial 5.6 and it’s located in the Tutorials > 5 - Animation subfolder within 
your custom content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.6 file in Moho. You should see 
something like this. (Don’t worry - the split-apart character is just part of the 
bone setup process):

 Starting point for this tutorial

2.	 Let’s take a look at the actions for this character. Select the Window > Actions 
menu command to bring up the Actions window. It should appear as shown 
below:

Each item listed in the Actions window is a clip of animation that this character 
can perform. The first entry in the list, --- Mainline --- is kind of special. Mainline is 
not an action - it represents the main timeline for the animation, the one that will 
ultimately be exported as your final movie.
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 Actions for this character

3.	 To view or edit an animation, double-click it in the Actions window. Let’s do 
this now with the Step action. After double-clicking Step, a little red arrow will 
appear next to it in the Actions window. This indicates that Step is the currently 
active action.

Also notice that the Timeline window has changed. The background changed 
color to indicate that you’re working with an action, not the main animation. 
Finally, some keyframes appeared in the timeline - these are the keys for the 
Step action.
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 Activate the Step action

4.	 Press the playback button to watch this action, and stop it when you’ve seen 
enough.

5.	 Try playing back the other actions as well. For each one in turn (Wave, Squat, 
and Bend), double-click the action’s name to activate it. Then, play back its 
motion to see the result.

6.	 When you’ve watched them all, double-click Mainline to go back to the main 
animation’s timeline.

Using Actions
Now that we’ve seen which actions the character can perform, let’s try using them 
in an animation.

Make sure that Mainline is active in the Actions window.

1.	 Set the current frame to 3, and click once on the Wave action. Be sure to just 
click once - Mainline should still be active with an arrow next to it, and Wave 
should be highlighted:
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 Click once on Wave

2.	 Now that Wave is selected, we can insert it into the main timeline. Click the 
Insert Reference button at the top of the Actions window.
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 Inserting a reference to the Wave layer

When you insert an action by reference, Moho will use that action’s motion in 
the timeline. If you later modify the action, those changes will be reflected in the 
main timeline. As you can see, the timeline has been updated to indicate that 
the Wave action was inserted, plus it shows how long the Wave action lasts:

 Wave action inserted into the timeline

3.	 Actions can also be overlapped. Set the current time to frame 12.

4.	 Click once to select the Squat action in the Actions window.

5.	 Finally, click the Insert Reference button to insert the Squat action. Notice 
that the timeline now shows both actions (with the Squat action adding four 
channels in the timeline). Play back the animation to see how these two actions 
overlap.
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 Inserting a reference to the Squat layer

 Wave and Squat actions overlapping

6.	 Let’s overlap three actions now. Go to frame 40, and insert references to three 
actions: Wave, Squat, and Bend. One after another, click once on the action 
then click the Insert Reference button . Play back the animation now and see 
how the character performs the three actions together, starting at frame 40.
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 Wave, Squat, and Bend Overlapped

7.	 Let’s try repeating an action a few times. Go to frame 66, and insert the Step 
action.

8.	 Then go to frame 78 (at the end of the first step action) and insert the step 
action again.

9.	 Do this once more at frame 90. The step action should now appear three times 
in sequence in the timeline:

 Step repeated three times

10.	 The last thing we’ll do is move the character off screen. Set the current 
frame to 66. Then select the Transform Layer tool and click inside the 

scene to set a keyframe.

11.	 Finally, set the current frame to 102, and the total number of frames to 102, then 
use the Transform Layer tool to move the character to the left off screen:
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 Character translated off screen

Tutorial 5.8: Creating a 3D Scene (Pro 
Only)
This tutorial will show you how to build and move around in a 3D scene in Moho. 
Moho isn’t a full 3D program - layers in Moho are 2D planes that exist in a 3D space. 
However, by positioning these 2D layers carefully, and moving around them using 
the 3D camera, you can create a convincing 3D environment.

For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
5.8 and it’s located in the Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.8 file in Moho.

This file has some simple artwork that we’ll use to build a 3D scene. The layers in 
this file are set up as shown:
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 Starting point for this tutorial

The editing view should look like this to begin with:

 Starting point for this tutorial

Creating a Ground Plane
The first step in creating our 3D scene is to set up the ground plane.

Select the Background layer - this layer has already had a simple terrain drawn onto 
it, we just need to position it correctly.

1.	 Activate the Rotate Layer XY tool, and in the tool options area at the top 
of the main Moho window, enter an X rotation angle of -90. Even though 

the Background layer is just a flat 2D object, it can still be rotated and 
positioned in true 3D space:

 Adjusting X rotation
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2.	 Next, activate the Transform Layer tool, and in the tool options area, 
enter -0.25 as the Y value:

 Adjusting position

3.	 Finally, with the Transform Layer tool, enter 5, 5, 5 in the tool options area 
as the layer’s scale values:

 Adjusting scale

What these settings do is to rotate the Background layer so that it lies down 
horizontally, lower it a bit, and spread it out wide to cover a large area. Perfect 
settings for a ground plane. The scene should now look like this:

 Ground in position

Arranging Foreground Objects
The next step is to create and position foreground objects. A simple tree has already 
been created for you - let’s set it up in 3D.

1.	 Often, positioning objects in 3D can be easier done from an overhead 
view. Use the Orbit Workspace tool to rotate the view of the scene so 

that it looks something like this (partial view shown).

2.	 (Notice the little blue wedge in the scene - this represents the camera.)
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 View from above

3.	 Now select the Tree layer, and make the Transform Layer tool active. 
Double-click the Tree layer. The Layer Settings dialog opens.

4.	 In the Options section of the General tab, select the Rotate to face camera 
popup and choose Pivot Y Axis (you’ll see why this is important later).

 Layer Settings options

5.	 With the Transform Layer tool selected, in the tool options area, set the 
Position X value to -3.25, and the Z value to -2.25. The tree will be moved 

to the far corner of the scene:
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 Moving the tree

6.	 OK, that’s one tree - now add several more. In the Layers window, click the 
Duplicate layer button to duplicate the Tree layer, and set new values for the X 
Position and Z Position. Any values for X and Z Position will do, as long as they’re 
roughly in the range between -3 and 3.

7.	 Repeat the process several more times, just scattering trees across the 
landscape. Keep going until you’ve created about 12 more trees. Position them 
all over the place - close to the camera, far away, behind it, etc. When you’re 
done you should have a small forest:

Now the reason for the Rotate to face camera checkbox may be clear. The 
Tree layer (and all of its duplicates) automatically turns to face the camera - 
notice how each tree is turned in a slightly different direction. This makes sure 
the camera always has a full view of that layer. This may not always be what 
you want, but for scenery objects, it can be a good trick, especially when the 
camera starts moving.
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 A forest

Here’s a trick: if you have a mouse with a scroll wheel, instead 
of typing in numbers for the X and Z values, try holding the 

mouse over those text fields and turning the wheel. The value in the 
field will change, and you can watch the layer move - just keep 
turning the wheel until the layer is where you want it.

8.	 The last step to finish off the forest is depth sorting. Double-click the Foreground 
group layer. In the Layer Settings dialog, click the Depth Sort tab. Turn on the 
Sort layers by depth checkbox and click OK. Now all the tree layers in this group 
will be sorted according to their distance from the camera.

Moving the Camera
Now that we’ve got a filled-in scene, lets take a tour.

Select the View > Reset menu command. You are now looking at the scene from the 
camera’s point of view:
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 Camera view

9.	 Set the current frame to 48 and activate the Track Camera tool. While 
holding down the Alt key, click and drag downward in the editing area. 

(The Alt key tells the Track Camera tool to move the camera forward and 
back.). Keep dragging downward until you’ve moved forward almost to the 
edge of the ground layer.

 Forward movement

10.	 Now activate the Pan/Tilt Camera tool. Hold down the Shift key and 
drag to the side to turn the camera around. (The Shift key prevents you 

from rotating the camera up and down.) It doesn’t matter where you turn to - 
just point the camera in an interesting direction:
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 Pan/Tilt Camera Tool - Turn the camera.

11.	 Set the current frame to 96, and use the Track Camera tool to move 
forward again (be sure to hold down the Alt key to move forward).

12.	 After moving forward, turn the camera in a new direction with the Pan/
Tilt camera tool (be sure to hold down the Shift key). Continue this process 
(advance the current time, move forward, and turn the camera) as much as 
you want, taking a little tour of your 3D scene.

13.	 When you’ve moved around as much as you want, try playing back the 
animation. While playing back the animation, use the Orbit Workspace tool to 
view the scene from above.

14.	 There are two things to notice here:

	� First, if you activate the Track Camera tool again, the path of the camera 
is visible when viewing the scene from above. If the path is not visible, 
check the Show Path option in the Track Camera tool status bar. This can 
be useful when planning out camera moves.

	� Second, watch how the trees turn during the animation to always face the 
camera. That way, the camera never catches an edge-on view of any 
tree, which would kind of spoil the 3D effect.
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 View from above

Feel free to experiment with more camera moves, or to add objects of your own to 
the scene.

Tutorial 5.9: Basic Physics (Pro Only)
Moho features a physics engine that allows objects to collide with and bounce off of 
each other.

Physics will only work with objects that are filled.

Creating the Objects
A Moho project can contain objects that are not affected by physics, as well as 
objects that are affected by physics. The deciding factor between the two types 
of objects is a group layer that holds the objects that physics are applied to. Any 
objects not contained within this group are unaffected by the physics properties.

In the first steps in this tutorial, you’ll create a base object Group layer that holds 
three objects, on three different layers.

To create a physics simulation,

1.	 Create a new project. Add a new Group layer in the Layers window. The new 
layer will be named Layer 2.
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 Create a new Group layer (Layer 2)

2.	 Drag the existing Layer 1 into the new group layer. On this layer, use the Add 
Point tool with the Sharp Corners option checked to create a base shape that 
the physics objects will collide with.

 Create a Base object in Layer 1 and drag it into Layer 2

3.	 With layer 1 selected, add another vector layer (which will be named Layer 2 by 
default - rename it Layer 3). It will automatically be added to the Group layer. 
Use the Draw Shape tool to draw a circle on this layer. This will be one of the 
shapes that collide with Layer 1.

4.	 Add another vector layer (Layer 4) to the Group layer, and create a rectangle 
with the Draw Shape tool on this layer.



Moho 13.5
Tutorial Manual 

216

Animation

 Three objects in the Group layer

Enabling Physics
You now have a scene with a group that contains three objects: a base object, and 
two additional objects that will bounce against it. The first thing you need to do is 
enable physics in the Group layer that holds these objects.

Select the Group layer (Layer 2) and open the Layer Settings dialog. Click the 
Physics tab to display the following settings:

 Enable physics for the Group layer

	� Enable physics: Check this option to turn the physics simulator on.

	� Gravity direction: Use the directional slider to point to the direction from 
which gravity is originated. By default, the direction is straight down (270 
degrees). 0/360 degrees is at the 3:00 position of the dial.

	� Gravity magnitude: Controls the strength of the gravity. Lower values make 
the gravity less forceful (objects are lighter) and higher values make the 
gravity more forceful (objects are heavier).
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5.	 Click OK to close the Layer Settings dialog. Your group layer is now configured 
to use physics

Creating a Collision Base
After you enable physics in the Group layer as described in the previous section, 
your next step is to assign one of the objects as a stationary collision base for the 
others to collide against. Otherwise, the gravity in the Physics engine will cause all of 
the objects to drop off the screen.

6.	 Select the base layer (Layer 1) in the Group layer. This is the object that the 
other objects will collide against. Open the Layer Settings window to the Physics 
tab. You will see the following settings:

	� Enable Physics: This option should automatically be turned on if it is in a 
Group layer that has Physics enabled. If you uncheck the option, physics 
will not work on the current layer.

	� Non-moving object: Check this option to make the current layer stationary. 
When this option is checked all of the other options in the Physics tab 
become disabled

7.	 Click OK to return to the scene

 Check the Non-Moving Object option to create a stationary base object

Configuring Physics Objects
After you create one or more stationary objects, you then configure the properties 
for the other objects that will bounce against them. In the case of the scene that we 
have created, these objects are the circle and the rectangle. Start with the circle 
first, and then the rectangle, and proceed as follows

1.	 Select the circle layer (Layer 3) inside the Group layer. Open the Layer Settings 
window to the Physics tab. You will see the following settings:
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 Physics Settings for Non-Stationary objects

	� Enable Physics: This option should automatically be turned on as described 
in the previous section.

	� Non-moving object: Leave this option unchecked for the circle and 
rectangle layers.

Leave the remainder of the settings at their default values for 
the circle and rectangle layers. The functions of the additional 

settings follow.

	� Start asleep: Check this option if you want an object to stay still until 
something else bumps into it. To demonstrate how this works, compare two 
versions of the project.

	� Lifetime (frames): A physics object will fall, bounce around, etc. for the 
duration of its lifetime (number of frames). After that time, it will be sent 
back to its initial starting position, where it will start bouncing around 
again. A lifetime of zero means the object will never be sent back to its 
starting point. The Lifetime setting is useful for something like a hillside of 
falling boulders. Instead of creating hundreds of boulders, you can create 
a dozen or so and set the lifetime to the length of time it takes for the 
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boulders to fall from the top of the hill to the bottom. If the top and bottom 
of the hill are offscreen, this will look like an endless number of boulders 
falling down the hill.

	� Initial direction: Works in conjunction with the Initial Speed setting below. 
If given an initial speed of something more than zero, a physics object will 
start flying out in the designated direction at the specified speed.

	� Initial speed: Controls the speed at which physics objects move in the 
designated direction. Faster speeds allow you to create objects like bullets, 
rockets, etc.

	� Density: The default Density setting is 1. Decrease this setting to make 
objects more responsive to collisions. Increase the setting to make objects 
less responsive to collisions.

	� Friction: A contact force between two surfaces that controls how much 
they slow each other down when they touch. High friction objects (like a 
brick sliding on concrete) will generally slow down faster than low friction 
objects (blocks of ice).

	� Springiness: When two objects collide, their springiness values define how 
much they will bounce apart. A basketball bouncing on a floor would 
have a high springiness value, while a stick of butter would have a low 
springiness value.

	� Pivot on origin: This option sets an axle around the object’s origin point. 
When another object collides with an object that is set to pivot, the object 
will spin around its origin rather than topple over.

	� Motor speed: Works in conjunction with motor torque, which follows. The 
motor speed is the number of degrees per second the object will rotate 
(it can be negative to rotate backwards). Depending if the object bumps 
into obstacles or there are other influences, it may not actually rotate at 
that speed, but in a zero gravity setup with no collisions, that will be the 
speed of rotation.

	� Motor torque: Motor torque controls the strength of the motor. With low 
torque, when a motorized object bumps into other objects it may come 
to a stop, depending on the size and density of the obstacles. With a high 
torque, it will tend to push obstacles out of its way. Even with no obstacles, 
if a motorized object is unbalanced (off center of its origin), a low torque 
setting may mean that it can even lift itself up.

2.	 Press Play to see what happens. The circle falls straight down and stops at the 
ground.

3.	 Rewind the project to frame zero, and use the Transform Layer tool to move the 
circle so that it is just above the left pillar of the collision base, as shown in the 
following figure. Also position the circle so that the bottom center is past the 
edge of the column.
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4.	 Press the Play button again to observe how the circle moves. This time, it should 
collide with the rectangle, and the rectangle will respond to the collision.

5.	 Experiment with additional settings to learn more about how they affect your 
objects.

Additional Comments
You can also apply physics to bone layers. The physics are applied to the region of 
influence of the bone. See “Bone Physics (Pro Only)” on page 101 in your Moho 
Users Manual.



Moho 13.5
Tutorial Manual 

221

Animation

Tutorial 5.10: Using Frame by Frame 
Layers for Animation (Pro Only)
Moho offers additional features that make frame by frame animation much easier. 
In this tutorial you’ll create a similar inchworm animation using the new Frame by 
Frame Animation Layer features found in Moho. 

There are two different ways that you can create frame by frame animation layers:

•	 After you create a switch layer and place a vector layer inside of it, double-
click the switch layer to open the Layer Settings dialog. Select the Switch tab, 
and check the Frame-by-frame drawing option. Now the Switch Layer knows 
that it is being used for frame by frame animation.

•	 Or, from the menu in the Layers window, choose Frame by Frame to create a 
new Frame by Frame layer. This accomplishes the above method in a single 
step. Moho creates a new switch layer, sets it up for frame by frame animation, 
and places the first vector layer inside of it. You’ll use this method in the tutorial 
that follows.

To complete this tutorial, follow these steps:

1.	 Choose File > New to create a new Moho project.

2.	 In the Layers palette, choose Frame By Frame to create a new Frame by Frame 
layer. Name the new layer Inchworm. When this layer is selected, all of the 
drawing tools become available. You will not need to expand the Inchworm 
layer and draw on the individual frames while you are working in a Frame by 
Frame Animation layer. You’ll also see some new controls above the timeline. 
From left to right, these controls are used to Add a frame, Delete a frame, or 
Duplicate a frame. You can also enter a frame by frame advance interval, if 
desired, to represent the number of frames that you want to advance in the 
timeline each time you add a new frame.

 Create a Frame by Frame animation layer named Inchworm

 Frame by Frame controls in the timeline toolbar: Add frame, Delete frame, duplicate 
frame, and advance interval.
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You can use shortcuts to accomplish the same functions as the 
Frame by Frame controls in the timeline toolbar. Press F5 to add 

a new frame/layer, Shift+F5 to delete one, and F6 to duplicate the 
current frame/layer and advance to the next frame.

3.	 Select the Blob Brush. Set the brush radius to .13.

 Set Blob Brush radius to .13

4.	 From the Style window, select a medium green for a fill color, and a dark green 
for the stroke color. Set the stroke width to 10.

 Choose a green fill color, dark green stroke color, and set stroke width to 10

5.	 On Frame 0 (Layer 1), draw an inchworm that is almost flat to the ground.
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 First layer of inchworm

6.	 Press F5 to create a new frame/layer to the Inchworm switch layer. This will also 
advance the time by one frame

7.	 Turn on the Onion Skin feature by clicking the Enable Onion Skins button in the 
toolbar area above the timeline. This will allow you to see the outline of the 
previous frame.

 Enable Onion Skins so that you can see the outline of the previous layer

8.	 Now on Frame 1 (Layer 2) draw another inchworm that is raised in the middle, 
remembering to also consider that its length is shorter due to volume. The 
second frame should look something like the following figure.
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 Second layer of the inchworm

9.	 Press F5 again and draw another version of the inchworm that has its middle 
raised a little more. Repeat this a few more times, drawing successive 
inchworms on Frame 2 (Layer 3), Frame 3 (Layer 4), and Frame 4 (Layer 5). The 
examples of each are shown below.

 Third, fourth, and fifth layers of inchworm
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10.	 In frames 5 through 8, you will create frames that move the inchworm back 
toward the flat to ground position. Again, press F5 as you advance through 
Frame 5 (Layer 6), Frame 6 (Layer 7), Frame 7 (Layer 8) and Frame 8 (Layer 9). 
Examples of each layer are shown below.

 Sixth, seventh, eighth and ninth layers of inchworm

If you expand the Inchworm layer at this point, you will see 
Layers 1 through 9 in the Inchworm Frame by Frame Animation 

layer. After looking at the layers, collapse the Inchworm layer again 
and keep it selected for the following steps.

11.	 Now you can go back with the Freehand tool and add the details to the layers 
that are already there. Select the Freehand tool from the Draw tools. Verify that 
the following options are selected:

	� Auto Weld: On

	� Trim Start: Checked

	� Trim End: Checked

	� Auto Close: Unchecked
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	� Auto Fill: Unchecked

	� Auto Stroke: Checked

	� Merge Strokes: Checked

 Freehand tool options

12.	 Return to Frame 0 in the timeline and add your details to the layer, similar to the 
following figure.

 Add details to the first inchworm layer, then add similar details to the other eight layers

13.	 Now move to Frame 1 to add similar details in that layer. Continue on, adding 
the details to the remaining frames in the Inchworm Frame by Frame layer 
(make sure to include the last layer, Layer 9, which appears on Frame 8).

If you find the onion skin outlines too distracting, you can turn 
them off in the toolbar above the timeline.

14.	 Now you can use any of Moho’s standard retiming tools to change the timing 
if it moves too fast for you. For this project, choose Animation > Rescale 
Keyframes. In the Rescale Keyframes dialog, check the Rescale entire 
document option, and then enter 16 in the New End Frame field. This will cause 
the animation to move at half its current speed. 
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 Rescale the keyframes to make the inchworm move slower

15.	 Now click Frame 18 to make it the current frame. Choose Animation > Add 
Keyframe. Moho will ask you if you want to add keyframes to the sublayers too. 
Choose Yes.

 Add keyframes to the Inchworm layer and sublayers at Frame 18.

16.	 Now select the keyframe at Frame 18. Right-click again and choose Cycle. The 
default option is Absolute and it is set to cycle back to frame 1. Instead, change 
the value so it cycles back to frame 0. Then exit the dialog.
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 Cycle keyframes at frame 18.

 Cycle Frame 18 back to Frame 0.

17.	 Press the Play button to watch your Inchworm crawling on the screen. Your 
inchworm animation should be similar to the following.

18.	 Save the project under a filename of your choosing. A finished version of the 
project is included in your User Content folder as Tutorial 5.10 finished.moho.
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Tutorial 5.11: Animated Shape 
Ordering (Pro Only)
In “Tutorial 2.5: Shape Ordering” on page 68 you learned the basics about how to 
select and move shapes above or beneath others in the same layer. In this tutorial 
you’ll follow steps that are slightly modified from Tutorial 2.5 to learn how to use 
animated shape ordering to make these changes over time.

To begin, follow these steps:

1.	 Open Tutorial 5.11.moho, which is located in the Tutorials > 5 - Animation folder 
in your User Content folder. This is a renamed version of the file that you started 
with in Tutorial 2.5.

2.	 Double-click Layer 1 to open the Layer Settings dialog. Switch to the Vectors 
tab, and check the Animated shape order checkbox. Click OK to close the 
Layer Settings dialog.

 Enable the Animated shape order option in the Vectors tab.

3.	 Advance in the timeline by clicking frame 12.

4.	 With the Select Shape tool, click anywhere on the red shape. It will 
become highlighted with a checkerboard to indicate that it is selected.

5.	 Press the Up arrow on your keyboard twice, to move the red shape immediately 
behind the small yellow circle.
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 Raised shape on Frame 12

6.	 At Frame 18, use the Select Shape tool to click on the blue shape to select 
it. Press the Down-arrow key twice to lower the blue shape below the green 
shape:

 Lowered blue shapeat Frame 18

7.	 Now advance to Frame 24. Click the green shape with the Select Shape tool, 
and hold down the Shift key while you press the Up-arrow key. The green shape 
moves all the way to the top of the layer’s shape order.
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 At Frame 24, move the green shape to the top.

8.	 Press Enter to deselect all shapes. You’ll find that the yellow circle becomes 
hidden.

9.	 Now we want to bring the yellow circle back to the front. Using the Select 
Shape tool, click the Green shape to select it. Then press the down arrow once 
to move it back one level.

10.	 Click the yellow circle with the Select Shape tool to select it.
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 Raised yellow circle at Frame 30

11.	 Scrub through the timeline to see the shape ordering changing over time.
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Tutorial 6.1: Shadow Tricks
This tutorial shows you how the layer shadow options can be used to create visual 
effects other than shadows. Glows and outlines are the two possibilities we’ll look at.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
6.6 and it’s located in the Tutorials > 6 - Effects subfolder within your custom content 
folder.

Open the Tutorials > 6 - Effects > Tutorial 6.6 file in Moho. Render this file to see what it 
looks like to start with:

 Starting point for this tutorial

Basic Layer Shadow
Before we try any tricks, let’s take a look at a basic layer shadow.

1.	 Double-click the only layer in this file, Layer 1, to bring up the Layer Settings 
dialog.

2.	 Go to the Shadows tab, and leaving all the other settings alone, turn on the 
Shadow on checkbox. Click OK to dismiss the dialog.
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 Default shadow settings

3.	 Try rendering the scene again, just to be sure that you have an idea what a 
regular layer shadow looks like in Moho:

 Layer shadow

Layer Glow
Now we’ll change the shadow settings to create a glow effect.

Double-click Layer 1 again to bring up the Layer Settings dialog. Change the Layer 
Shadow settings to match the values below:
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 Glow settings

	� An offset of 0 means the shadow will be centered under the layer that is 
casting it. With an offset of 0, the shadow direction has no significance.

	� A high blur value of 16 gives the glow a nice soft edge.

	� The expansion parameter tells Moho to expand the shadow, making it 
bigger than the layer itself. Without expansion, the glow would just barely 
extend beyond the edge of the layer.

	� The exact color you choose is not important - just be sure to make the color 
opaque (Alpha = 255). A transparent glow may be too faint to see.

	� Render the scene again, and it should look like this:

 Layer glow.
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Layer Outline
Let’s change the shadow options once again to create an outline effect. Some 
styles of animation use a heavier outline around the outside of objects than for 
interior lines. Adjusting the layer shadow values in the right way can make this style 
very easy to accomplish.

Double-click Layer 1 again to bring up the Layer Settings dialog.

1.	 Change the Layer Shadow settings to match the values below:

	� Again, we use an offset of 0 to keep the shadow centered under the layer.

	� A blur value of 0 is used to keep a hard edge on the shadow.

	� The expansion parameter is used in this case to set the width of the outline 
effect.

	� For this effect, it’s important to make the color totally black and totally 
opaque (Alpha = 255) to match the interior lines.

 Outline settings.

2.	 Render the scene again, and it should look like this:
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 Layer outline

Tutorial 6.2: Camera and Depth Effects
This tutorial demonstrates Moho’s camera tools. These tools allow you to move an 
entire scene around as if you were pointing a camera at it. With a little setup work, 
you can even create different layers of depth in the scene.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
6.7 and it’s located in the Tutorials > 6 - Effects subfolder within your custom content 
folder.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.7 file in Moho, and you should see 
something like this:

 Starting point for this tutorial
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2.	 This file contains a few layers of simple scenery that we will move the 
camera across. To do this, select the Track Camera tool and drag 

the mouse around in the main editing area.

3.	 Notice how all the layers move together, even though they aren’t grouped. 
When you move the camera around, it affects all the layers in a project. In the 
tool options area at the top of the main Moho window, click the Reset button to 
reset the camera.

Creating Depth
Now we’ll introduce some depth into the scene.

1.	 Activate the Transform Layer tool and select the layer called Right Hill.

2.	 In the tool options area at the top of the main Moho window, change the Z 
value to -1 and press Enter. Below you can see where to set the Z value for the 
layer.

Setting a layer’s Z value

3.	 Now select the Left Hill layer, and set its Z value to -2. Finally, select Sky, and 
set its Z value to -20. When you’re finished, your scene should look similar to the 
following figure.

 Right Hill, Left Hill, and Sky layers moved on the Z plane

4.	 Try dragging the Track Camera tool around again and notice the 
difference. It’s like driving in a car - nearby objects go by quickly, while 

distant objects seem to move slowly.
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5.	 In the tool options area at the top of the main Moho window, click the Reset 
button for the Track Camera tool to reset the camera.

In Moho Pro, try dragging the Orbit Workspace tool around 
the workspace. This tool allows you to examine your scene in 

3D, from outside the view of the virtual camera. In this case, notice 
how the different layers are spaced apart in the Z direction - this is 
what creates the sense of depth from the camera’s point of view. 
The camera itself appears as a small blue wedge pointing in the 
direction of view.

6.	 When you’ve seen enough, select the View > Reset menu command to go 
back to the default camera view.

Animating Camera Movement
Now we’ll try animating the camera.

1.	 Make sure the current frame is set to 0, and select the Zoom Camera 
tool.

2.	 Enter a setting of 45 in the Vertical field of view (degrees) field in the tool settings 
area. 

3.	 Next, select the Track Camera tool.

4.	 Drag to the left in the main editing area until you set up a view that looks about 
like this:

 Camera view at frame 0

5.	 Next, set the current frame to 72, and drag to the right. This will pan the camera 
to the left - keep going until you have a view that looks like this:
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 Track to the left

6.	 Press the Play button in the timeline to play back this simple camera animation. 
Notice how the layers of the project seem to pass in front of and behind each 
other. This is a simple way in Moho to create a sense of depth.

Click this link to view a brief video of the finished results of your 
project.

Tutorial 6.3: Moon and Clouds Effect
This tutorial shows you how to create the effect of clouds moving in front of a moon. 
Layer masking and blurring is used to create an effect that is not only good for a 
moon and clouds, but may inspire you to think of new ways to use layer masking.

Examine a Finished Animation
For this tutorial, we’re going to examine an animation that is completely finished.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.9 file in Moho. The layers in this file are 
arranged as shown below:
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 Starting point for this tutorial

2.	 This animation relies on masking and blurring effects that aren’t apparent in 
Moho’s editing view. To see what the final effect is, either export the animation 
as a movie. (Because blurring is a key part of this effect, exporting to SWF is not 
an option - SWF export does not support blurs.)

 The final result

Notice that the moon appears sharp until the cloud moves in front of it. Then, the 
parts of the moon obscured by the cloud become blurry. This effect is easy to 
achieve using layer masking.

How It’s Done
There are two parts to this effect. First, there are actually two moons in the 
animation:

•	 The Moon layer is the regular, sharp version of the moon you see in Moho’s 
editing view.
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•	 Two layers up is the Blurry Moon layer - this is a duplicate of the Moon layer, with 
some layer blur applied.

The trick is to control which moon is visible at which point in time in the final exported 
movie. To do this, we use layer masking.

Try double-clicking each of the layers in turn to bring up the Layer Settings dialog - 
then, go to the Masking tab. You’ll find that the Sky group has masking turned on 
- by default, all objects are invisible. The Moon layer is set to be immune to masking, 
while the Cloud layer adds to the layer mask.

The result of these mask settings is that first the Moon layer is drawn - this is the 
regular, sharp moon - and is not affected by any masking. Next, the Cloud layer is 
drawn on top of that. When the cloud moves in front of the moon, it covers up the 
moon. Finally, the Blurry Moon layer is drawn on top of the cloud. Because of the 
mask, the blurry moon only appears on top of the cloud, it is not visible outside of the 
cloud object. Even though the blurry moon is in front of the clouds, the effect looks 
like the moon shining from behind the clouds.

Here’s another example of the same technique. In this case, we see a character 
who appears to be blurred by the smoke passing in front of him. The exact same 
blurring and masking trick is used as in the case of the moon:

 Another example of blurring and masking

Tutorial 6.4: Particles (Pro Only)
This tutorial demonstrates Moho’s particle layers feature. Particle layers are used to 
create effects made up of many small objects flying around. This includes effects like 
water, smoke, and swarms of insects.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s already started. It’s named Tutorial 
6.1 and it’s located in the Tutorials > 6 - Effects subfolder within your custom content 
folder.
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1.	 Open the Tutorials > 6 - Effects > Tutorial 6.1 file in Moho, and you should see 
something like this:

 Starting point for this tutorial

2.	 There are four layers in this file, each containing a small gray blob-shaped 
object. You can zoom in to look more closely at these objects.

 A smoke particle

3.	 These blobs will be used to create a smoke effect, using a particle layer. If you 
examine these blobs, you’ll see that they are all semi-transparent, and have the 
soft edges fill effect applied to them. In addition, the blobs all have a simple 
animation applied to them - over the course of 48 frames, they spread out 
horizontally. Play back the animation to see this happen.

Using A Particle Layer
1.	 In the Layers window, create a new Particle layer. Particle layers are kind of like 

Group layers - they can contain sub-layers.

2.	 Drag all four of the original layers into the particle layer, and your project should 
look like this:
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 New particle layer

3.	 Play back the animation and see what we’ve got so far. The particles should be 
flowing, although they don’t look much like smoke at this point.

4.	 Next, double-click the particle layer to bring up the Layer Settings dialog. Click 
the tab marked Particles. In this area, set the following values and click OK:

	� Lifetime (frames): 48

	� Orient particles: unchecked

	� Velocity: 0.3

	� Velocity spread: 0.05

	� Acceleration: Turn knob to point to the right, or enter 5

	� Rate: 0.5
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 Particle settings

These settings tell the particle system that each particle should last for 48 frames 
after being created, and that the particles should not rotate to follow the 
direction they are moving in. Their initial velocity is moderately slow, and there is 
a gentle acceleration to the right (a soft breeze).

5.	 Play back the animation now, the motion of the particles should look more like 
the flow of smoke from a smokestack.

6.	 Export the animation to see how the blur and semi-transparent effects combine 
to create a smoky appearance. The reason four different particle types were 
used is that each has a different gray level, and combining them leads to a 
mottled, dirty effect.
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 A rendered example

7.	 Save the tutorial under a new filename so that you can use it in the next tutorial.

Tutorial 6.4.2: Custom Particle 
Generators (Pro Only)
Normally, Moho starts with a simple circle as a particle generator. As you learned 
in the previous tutorial, you control the particles in the Particle Options dialog. 
The source width, height, and depth settings control the area where particles are 
generated.

You can add a shape beneath the particle layer and drag that shape into the 
particle layer. This can be used for a wide variety of effects ... grass blowing in the 
wind, fire coming from a log in the fireplace. Basically, any shape that appears in the 
bottom-most layer in the particle stack can be used as a particle generator.

In this tutorial you’ll modify the file that you saved at the end of the previous tutorial. 
You’ll learn about how you can use custom shapes as particle generators.

1.	 If you have not saved the project after completing the previous tutorial, you will 
find a completed version in your Moho Content folder. Open the Tutorial 6.4_2 
file located in the Tutorials > 6 - Effects subfolder.

2.	 In the Layers palette, create a new vector layer. Here, we call the new layer 
New Generator.
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 Create a new layer for your particle generator shape.

3.	 Draw any shape that you desire in the new layer. Here we’ll keep it simple, and 
will add a star shape with the Draw Shape tool.

 A shape added to the new layer.

4.	 Drag the new layer into the Particle group, positioning it at the bottom of the 
layers within that group.

 Drag the generator shape into the Particle group and place it at the bottom.
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5.	 Now, select Layer 5 in the Layers palette. Initially, you’ll notice that this new 
shape becomes part of the particle mixture, which isn’t what you want to 
happen.

 Initially the new shape becomes part of the particle mixture.

6.	 To fix this, double-click the Particle group layer (Layer 5) and switch to the 
Particles tab in the Layer Settings dialog. Check the Use base layer as source 
option.

 The Use base layer as source option turns the bottom-most layer into a particle 
generator.

7.	 Now the particle layer will look at the lowest layer in the stack and use that 
shape to generate the particles.
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 The particles are emitting from the star.

Later you can modify the shape, and the particles will automatically follow the new 
shape.

Tutorial 6.5: Particle Tricks - Grass and 
Crowds (Pro Only)
This tutorial shows how to use particle layers for something other than swarming 
insects, smoke, or fireworks. Using the correct settings, particle layers can also be 
used to produce clusters of many objects, but without making them fly around like 
particles usually do. Fields of grass and crowds of people are just two possibilities that 
we’ll explore.

Start With a Sample File
To get started quickly with this tutorial, start by opening the project file named 
Tutorial 6.2, located in the Tutorials > 6 - Effects subfolder within your custom content 
folder.

Open the Tutorials > 6 - Effects > Tutorial 6.2 file in Moho. This file has a particle layer 
that we’ll modify to simulate a field of grass. The layers in this file are set up as shown:
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 Starting point for this tutorial

The editing view should look like this to begin with:

 Starting point in editing view

8.	 The particle layer Grass in this file is currently set up with the default settings for a 
particle layer. The sub-layers (Layer 1 - Layer 6) are each a single blade of grass. 
Each one has a slightly different color and shape to create variety.

9.	 If you play back the animation, you’ll see that the default particle layer settings 
aren’t very good for a field of grass - the grass particles fly up in the air and then 
sink downwards. All we have to do is make a few small changes to get the grass 
to look right.

Changing Particle Settings
1.	 Double-click the Grass layer to bring up the Layer Settings dialog. Click the 

Particles tab to access the settings for the particle layer.
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Below we describe why each of the settings is set the way it is. 
Any settings that aren’t mentioned below don’t matter for this 

situation (for example, orient particles doesn’t matter since the 
particles have no velocity).

2.	 Change the settings to match the ones below and click OK.

 Grass particle settings

	� Particle Count: 500. We need a lot of particles for a field of grass

	� Preview Particles: 20. In the working view, only show a few particles in order 
not to slow down Moho

	� Lifetime (frames): 0. A lifetime of zero means that particles will never die out 
(disappear).

	� Source width: 3. Make the source nice and wide to cover the width of the 
screen

	� Source height: 0. It’s a flat field of grass, so the height is zero

	� Source depth: 1. Spread the particles out in the Z direction for a feeling of 
depth
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Besides scattering particles in the Z direction, when source 
depth is set to a non-zero number, the particle layer will sort 

particles according to depth - this is very important for the kinds of 
animations we’re working with in this tutorial. We wouldn’t want far 
away blades of grass to appear in front of closer ones.

	� Velocity: 0. Set to zero to prevent the grass blades from flying around

	� Velocity Spread: 0. Set to zero to prevent the grass blades from flying 
around.

	� Acceleration: 0. Zero acceleration, again to prevent the grass blades from 
flying around

	� Rate: 0. Again to prevent the grass blades from flying around

	� Randomize playback: Checked. Plays back the blades’ animations 
randomly, otherwise they would be in sync.

Randomize playback makes the grass look better than if all the 
blades were moving in sync, but it can be even more important 

when working with a crowd of people, as we’ll see later in this 
tutorial.

3.	 OK, the grass is almost finished. All we need to do is use the Transform 
Layer tool to move the Grass layer downwards (on Frame 0) so that it sits 

on the ground:

 Grass lowered into place

In preview mode, it doesn’t look like much, so you may want to try playing back the 
result and rendering it out as a movie file:
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 Final render

Tutorial 6:5.2: Crowds, Particles, and 
Depth of Field (Pro Only)
Now we’ll show how to use the same general techniques to simulate a crowd of 
people. Also in this tutorial you’ll learn how to set up depth of field.

1.	 Open the file named Tutorial 6.2_2, located in the Tutorials > 6 - Effects subfolder 
within your custom content folder. There’s nothing you need to change in this 
file in regards to the particle effects, it just shows another example of using 
particle layers.

The default size of this project is 320 x 240 pixels. If you want a 
larger sized preview image when working on this tutorial, 

choose File > Project Settings and select another preset that renders 
a larger preview (such as NTSC D1).

1.	 The Crowd layer has the same basic settings we used for the field of grass, only 
using fewer particles. Note the following:

	� Each of the sub-layers in the crowd was created from one layer with a 
simple cycling animation.

	� This one layer was duplicated and had some colors changed just for 
variety.

	� The Randomize playback setting for the particle layer is really important 
for this crowd - if it was turned off, then each character in the crowd 
would move in sync with all the others (you can try this yourself). This may 
be desirable in some cases, but here we want each character to move 
independently, even though they all have the same basic movement.
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 A crowd as particles

Depth of field is enabled in the Project Settings dialog - that’s why some of the closer 
or farther characters appear a bit blurry. But we’ll use some Moho enhancements to 
fine tune the depth of field effect.

Moho provides a visual indication that can help you set up Depth of Field more 
easily. To continue with the tutorial, follow these steps:

2.	 Use the Pan and Orbit workspace tools to view the scene at an angle, similar to 
that shown below. You’ll notice a box in the middle of the scene.

 Use the Orbit Workspace tool to view your scene in 3D view

3.	 Choose File > Project Settings to open the Project Settings dialog. You can 
quickly adjust the settings if you click in the text field and use your mouse scroll 
wheel to increase or decrease the values. As you adjust the Focus Distance and 
Focus Range settings in the dialog, you’ll notice the box indicator changing in 
the scene:
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 Increase or decrease the depth of field settings as you observe the position and size 
of the box indicator.

	� Focus distance: This is the area that you want to focus on. It’s represented 
by the center line in the box. Decrease the setting to bring the focus 
distance closer, and increase the setting to move it farther from the 
camera.

	� Focus range: This is the range of the scene that will go from sharp to blurry 
when viewed through the camera. The deeper the box gets, the more 
slowly the scene will get out of focus. Higher settings will make the box 
deeper.

4.	 Choose View > Reset to return the scene to the default camera view.

5.	 Choose File > Preview to generate a preview image. After you complete your 
project, you can render an animation to see how it all comes together.
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 A preview of your settings.

Tutorial 6.6: Using Pre-made Particle 
Effects (Pro Only)
This tutorial shows how you can use the included scripting commands to make use of 
pre-made particle effects like smoke or explosions.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
6.3 and it’s located in the Tutorials > 6 - Effects subfolder within your custom content 
folder.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.3 file in Moho.

2.	 Expand the Rocket Group layer in the Layers window, and you should see 
something like this:

 Starting point for this tutorial.
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3.	 Try playing back the animation to see what we’re starting with - it’s just a simple 
animation of a rocket flying around the screen for a little while. When you’ve 
seen enough, rewind the animation back to frame 0.

Add the Smoke Effect
Now we’ll add a smoke trail behind the rocket.

Select the Scripts > Particle Effects > Smoke... menu command. A dialog will appear 
asking you to customize the smoke effect. Use the settings shown below for the 
smoke and click OK:

 Smoke settings

4.	 The smoke script will then generate a bunch of layers that make up the smoke 
effect. The combined layers will end up grouped together in a group layer 
called Smoke. Move this new Smoke layer into the Rocket Group layer, just 
below the Rocket layer. The Smoke layer should end up positioned like this:

 Smoke layer added to group

5.	 The final step is to move the smoke into place. Activate the Transform 
Layer tool and move the Smoke layer so that it sits just behind the rocket. 

The smoke itself won’t immediately move until the animation is updated, so 
watch the origin of the Smoke layer and line it up behind the rocket. Feel free to 
zoom in close to get a better view:
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 Smoke layer moved into position

That’s it! You can now export the animation as a movie file to see the fully rendered 
result. Some of the particle effects in the script menu, including smoke, can take a 
long time to render. In “Tutorial 6.7: Speeding Up Particle Effects (Pro Only)” on page 
259 we’ll show you a way to speed up complex particle effects.

 The final result
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Another Effect - Sparkles
Here’s an example of another particle effect - the Sparkles script. A great use of this 
effect is for magic wands. The fully finished file can be opened in Moho if you wish. 
It’s called Tutorial 6.3_2. Here’s what the rendered result looks like:

 The Sparkles effect

Tutorial 6.7: Speeding Up Particle 
Effects (Pro Only)
In “Tutorial 6.6: Using Pre-made Particle Effects (Pro Only)” on page 256 we showed 
how you can use Moho’s included particle effect scripts to easily add effects like 
smoke and explosions. The only drawback to these effects is that they can take 
a very long time to render. In this tutorial, we’ll show you a way to speed up the 
exporting of complex particle effects.

Rendering an Image Sequence
For this tutorial, we’ll start by taking a look at a finished animation of an explosion 
effect.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.4 file in Moho. Our goal is to re-use this 
explosion in another Moho animation, but make it a lot faster for rendering. To 
do this, we’ll export the explosion animation as a PNG image sequence, using 
some special settings.

2.	 Choose File > Export Animation to open the Export Animation dialog.

3.	 Export the project animation using the following options:

	� Format: Image Sequence

	� Preset: PNG
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	� Quality: 90

	� Do not premultiply alpha channel: Checked

	� All other settings: Leave at default values.

 Export options

4.	 In the Destination section, choose the following options:

	� Click the Export To popup and select Choose Folder. Navigate to the 
folder into which you want to save the image sequence.

	� In the Name field, enter a root name for the animation sequence, such as 
Explosion.png.

5.	 Click OK to exit the Export Animation dialog. The render preview will show 
progress bars and sample frames as the image sequence renders. After the 
render is complete the preview window closes.

A rendered version of the explosion sequence can be found in 
the Tutorials > 6 - Effects folder. The PNG files are named 

Explosion_00001.png through Explosion_00035.png.
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Using Sequential Images in Image Layers
To work with the explosion movie, follow these steps:

1.	 Start a new Moho project file.

2.	 From the Layers palette, create a new Image Sequence Layer. 

 Create an Image Sequence layer

3.	 Moho will prompt you to select images for the sequence. As long as there is an 
unbroken numerical sequence, all you need to do is select the first image in the 
sequence (Explosion_00001.png, in our case).

4.	 After Moho imports the Image Sequence you will see the explosion in the 
project window, and the timeline will show a green arrow at the start of the 
image sequence, and a red arrow at the end of the image sequence.

 Image Sequence in the timeline.

5.	 Use the Transform Layer tool to move the explosion off to the side a bit:
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 Move the explosion layer

6.	 In the Timeline, use the Duplicate Layer button to duplicate the explosion a few 
times (five or more - you want to fill the project with explosions). 

7.	 On frame 0, select one explosion layer at a time. Use the Transform Layer tool to 
move them to random places in the timeline:

 Lots of explosions.

8.	 Switch to the Sequencer in the timeline, and adjust the start positions of the 
explosions so that they don’t start and stop at the same time:

 Stagger the start and stop times in Sequencer view.
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9.	 When you’ve got as many explosions as you want, export the animation to your 
final desired animation format.

Notice that even though the single explosion took longer 
render, this combined set of explosions renders much more 

quickly. This is because the explosion effect has already been 
created - for the combined effect, Moho just needs to composite 
several explosions together. Using this technique, you can greatly 
speed up the time it takes to export an animation that uses one or 
many complex particle effects.

Tutorial 6.8: Perspective Shadows (Pro 
Only)
In this tutorial you’ll learn a little trick to create perspective shadows. This trick 
depends on Moho’s layer masking feature, and uses it in a creative way.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost finished. It’s named Tutorial 
6.5 and it’s located in the Tutorials > 6 - Effects subfolder within your custom content 
folder.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.5 file in Moho, and you should see 
something like this:

 Starting point for this tutorial

2.	 Play back the animation to get an idea of what you’re starting with.

3.	 When you’ve seen enough, rewind the animation back to frame 0. What we’re 
going to do in this tutorial is give Lenny a shadow.

Moving a Layer Into Perspective
We’re going to create a shadow that matches Lenny exactly.

1.	 At Frame 0, start off by duplicating the Lenny Skeleton layer, using the Duplicate 
Layer button.

2.	 Move this new copy below the original Lenny Skeleton, name it Lenny Shadow.
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3.	 Add a new vector layer inside it as shown below. Make this new layer active, 
and name the new layer Shadow.

 New Lenny Shadow with Shadow layer

4.	 In the new Shadow layer, draw a simple rectangle that takes up about 2/3 of 
the left side of the visible area, as shown below. Choose Black for the Fill and 
Stroke colors if they aren’t selected already. The idea is to completely surround 
Lenny, with enough extra space for when he moves.

 Rectangle in Shadow layer

5.	 We’re going to temporarily hide the black shadow layer so that you can use 
the copy of Lenny to shear and reposition him for the shadow. To hide the black 
rectangle, click the Visibility icon to hide the Shadow layer as shown below.
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 Temporarily hide the Shadow layer

6.	 Next, select the Lenny Shadow bone layer and use the Shear Layer tool 
to shear the lower copy of Lenny so that he leans to the right as shown 

below: You can also enter an X value of .60 or thereabouts in the Shear Layer 
tool options in the status bar.

 Shear the lower copy of Lenny

7.	 Now use the Transform Layer tool to scale the Lenny Shadow layer down 
vertically. Be sure to leave it the same size horizontally - we just want it 

shorter vertically, as shown below:
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 Scale down the shadow layer

8.	 Next, use the Transform Layer tool to move the Lenny Shadow layer into 
position so that the back heels of the two Lennys line up like this:

 Position the shadow layer

The Trick
So far we have two copies of Lenny, with the lower one shifted into perspective. 
Here comes the trick with layer masking.

1.	 First, click the Visibility icon in the Shadow layer to make the sheared black 
rectangle visible again.

2.	 To turn on masking, double-click the Lenny Shadow layer and in the Masking 
tab, set the Group Mask setting to Hide all.
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 Mask settings for the Lenny Shadow layer

3.	 Next, double-click the Lenny layer and in the Masking tab, set the Layer 
Masking setting to + Add to mask, but keep invisible. The result of these settings 
is that the big black rectangle will now be masked against the shape of Lenny 
himself:

 Mask settings for the Lenny layer
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 The shadow mask effect

4.	 The final touch is to refine the appearance of the shadow. Double-click the 
Lenny Shadow layer. In the Layer Settings dialog General tab, set the Blur radius 
to 8 and Opacity to 50. That finishes the shadow effect - you can now export 
the animation as a movie file.

 The adjusted shadow, rendered

The final result is also included as a Moho project file. It’s called Tutorial 6.5 Final - 
take a look at it if you have any trouble following the directions above. It’s important 
when using this trick to animate your subject first before you add the shadow - that 
way the shadow will also be animated, leading to a more realistic effect.
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Tutorial 6.9: Using 3D Models (Pro Only)
Although Moho is primarily a 2D program, it is possible to import 3D models and use 
them in a Moho animation. This tutorial will show you some of the things you can do 
with 3D models in Moho.

Import a Basic 3D Model
First, we’ll try importing a basic 3D model.

1.	 Start Moho and create a new, empty project.

2.	 Next, select the File > Import > OBJ 3D Model menu command. Moho will 
prompt you to select a file - choose the file named 3dmodel.obj located in 
the Tutorials > 6 - Effects subfolder within your custom content folder. Moho will 
import the model into a new 3D layer, and you should see something like this:

 Imported 3D model

3.	 Use the Orbit Workspace tool to rotate around the scene. As you rotate 
around the object, notice that it never appears flat from any side (like a 

vector layer) - it is a true three-dimensional object.

This object was created in a program called Wings 3D (http://
www.wings3d.com). Whether you choose create models in 

Wings 3D or another 3D program, be sure to export them as OBJ files. 
OBJ is a common 3D file format that most 3D programs support, and 
is currently the only 3D format that Moho can import.

The colors of this model have been defined in the file 3dmodel.
mtl - this is a material file that Wings 3D created along with the 

model itself. You cannot change the colors of a 3D model within 
Moho. However, you can change the color and width of the outline 
in the Layer Settings dialog, under the 3D Options tab, discussed in 
“3D Options (Pro Only)” on page 250 in your Moho Users Manual.
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 Side view of 3D model

Using 3D Models in a Face
Next, we’ll show an example of how you can use a 3D model in the construction of 
a character’s face. One of the limitation’s of Moho’s 2D nature is that it is difficult to 
rotate a head in 3D space. Using a 3D model can solve this problem.

1.	 Open the file Tutorial 6.8 located in the Tutorials > 6 - Effects subfolder within 
your custom content folder. This is a completely finished animation - play it back 
to see what’s going on.
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 Face pointing up and right

 Now pointing down and left

2.	 Notice that unlike most faces in Moho, this one can freely turn from side to side. 
This is because the head and nose (the major 3D structures in a face) are built 
as actual 3D models. The mouth, eyes, and ears are all 2D vector layers that 
have been arranged in 3D space around the head.

3.	 The only other trick involved in getting this character’s head to work was sorting 
the head and ears. Notice that the main 3D head shape and the ears are 
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grouped together. This is so that those three shapes can be depth-sorted. As the 
head turns from side to side, one of the ears often needs to go behind the head 
layer and then come back in front, depending on the head’s angle. Depth 
sorting is used to easily accomplish this reordering.

Textures and Scenery
Moho can also make use of textures on 3D models. You can’t create the texturing 
within Moho itself, but if your imported 3D model uses texture maps, Moho will use 
them when it imports the model.

Now open the file Tutorial 6.8_2 located in the Tutorials > 6 - Effects subfolder within 
your custom content folder. This scene makes use of the 3D model simple_scene.obj, 
which in turn uses a texture map file:

 A textured 3D scene

One of the things you may notice in this scene is that the scenery has detailed 
shadows and shading on it. Moho does not provide lighting and shading for 3D 
models. Instead, these effects are part of the texture map for this 3D model. In this 
case, a separate 3D program was used to calculate the lighting effects and bake 
them into the texture map.

Of course, the other element in the scene is a regular Moho 2D animated character. 
Although this character is composed of 2D vector layers, it can be positioned in true 
3D space, so it is quite easy to integrate it into the 3D scene.
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Conclusion
We’ve looked at just a couple possible uses for 3D layers - with a little thought you 
can probably come up with many more. Keep in mind that Moho is still primarily a 
2D program, so don’t expect Moho to replace a true 3D modeling and animation 
program. However, for limited uses, like background scenery or a few parts of a 
character, 3D layers in Moho can be very useful.
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Layer Referencing (Pro Only)
Layer referencing allows you to create one or more layers that reference back to 
an original layer. If you make changes to the original layer, all layers that reference 
back to the original layer will be changed accordingly. The tutorials in this chapter 
will step you through some of the important and exciting capabilities of layer 
referencing.

Tutorial 7.1: Reference Layer Basics
In this tutorial you’ll learn some basic principles relating to layer referencing. You’ll 
begin with a project that is included in your User Content folder, and create several 
reference layers of the star in Layer 1.

1.	 Open Tutorial 7.1 Start.moho, located in the 7 - Layer Referencing folder in your 
User Content folder.

 A single layer in the Document window

2.	 The Reference Layer button in the Layers palette is clicked for each new 
reference layer that you want to create. Each time you click the Reference 
Layer button, it will create a copy of the original layer (similar to the Duplicate 
Layer button), except that this reference copy will refer back to the original 
layer. To create five additional instances of the star, simply click the Reference 
Layer icon at the top of the Layers palette. When you initially create a reference 
layer, it is placed directly on top of its original layer.
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 Reference Layer icon and five additional reference layers added to the scene.

3.	 After you make all your copies, select each layer one at a time and move 
them into position on Frame 0. Move the reference layers into position with the 
Translate Layer tool as shown below.

 Reference layers moved into position with the Translate Layer tool (layers 1-3 on top, 
layers 4-6 on the bottom).

4.	 When you make changes to the original layer (Layer 1) those changes will 
automatically be applied to each of the references. To demonstrate this, select 
Layer 1, and choose a new fill color in the Style window. That color change is 
automatically applied to Layers 2 through 6.

5.	 Reference layers also inherit other animatable properties such as translation and 
rotation. To demonstrate this, select the Transform Layer tool, and rotate layer 1. 
Now your project should look similar to the following.
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 The color and rotation changes of the original Layer 1 (selected) are applied to 
reference layers 2 through 6.

6.	 Other animateable changes are also replicated. For example, use the Transform 
Points tool to move one of the points in the star on Layer 1. That same point will 
move in the reference copies on Layers 2 through 6.

 Point transformations are also replicated on reference layers.

7.	 You’ll also notice that reference layers also inherit animated properties. To 
demonstrate this, click in Frame 24, and make some changes to animate some 
of the points in Layer 1.

8.	 Next, click on Frame 48 and animate more points in Layer 1.

9.	 Now go back and play the animation. All of the animated points play together.

10.	 Save this project as Tutorial 7.1 Finished.moho. A copy of this completed project 
is furnished in your User Content folder.
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Tutorial 7.2: Breaking and Updating 
Reference Layer Connections
In the previous tutorial you learned what happens when you make changes to the 
original layer in a project. Those changes are passed on to any layer that references 
back to that original layer.

In this tutorial, you’ll learn how you can break connections with the original layer 
when you make changes to a reference layer. You can either continue on from your 
previous tutorial, or open the Tutorial 7.1 Finished.moho file that is found in your User 
Content folder.

1.	 Continue from the project that you completed in the previous lesson, or open 
Tutorial 7.1 Finished.moho, which is located in your User Content folder.

2.	 Go back to Frame 0. Select Layer 4, which is one of the reference layers in the 
project. 

3.	 Click the star with the Select Shape tool, and then change the fill color in the 
Style window.

 Change the color of Layer 4, which is one of the reference layers.

4.	 Now, select the original layer (Layer 1), and click the star in Layer 1. Change its 
fill color in the Style window.

5.	 Now play your animation from the beginning. You’ll notice that even though 
the color of Layer 4 has changed, it still animates with the other layers.
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 Change the color of Layer 4, which is one of the reference layers.

Steps 3 through 5 demonstrate that when you change a 
reference layer, it will break the connection of that particular 

property with the original layer. In this case, the only connection that 
is broken is the Color property. The color connection has been 
broken between Layer 4 and the original layer, but the animation 
that you created in the previous steps will remain connected.

6.	 With the original layer selected, advance to frame 38 in the timeline.

7.	 Change the stroke color of the original layer. The stroke color change will be 
applied to all layers, including the layer that had the fill color changed. 

8.	 Play the animation again. The change in the stroke color will be animated.

 At frame 38, change the stroke color of Layer 1 (the original layer).

9.	 Now select Layer 4 again (the reference layer that has a different fill color). 
Make some structural changes on Frame 0, such as adding some points and 
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changing the shape. The the following figure shows some additional points 
added, and changes to the shape.

 At frame 0, add some points and change the shape of Layer 4.

10.	 Play the animation again. You’ll notice that Layer 4 still animates with the other 
layers, but the new points have broken the connection with the shape of the 
original layer and all the other reference layers that remain connected to its 
shape.

Layer 4 will still animate with the other layers, but the new points 
in Layer 4 have broken the connection with the shapes of the 

other layers that remain connected to the original layer. If you later 
make changes to the shape of original Layer 1, those changes will 
not be applied to Layer 5.

11.	 Notice in the Layers palette that Layer 4 (the reference layer that has been 
changed) has a different icon. The badge shows a red arrow to indicate that 
there is a mismatch with the original layer.

 The arrow in the reference layer icon is red to indicate there is a mismatch between 
Layer 4 and the original layer.

12.	 Right-click Layer 4 to view the menu options. Choose Update Layer Reference to 
open the Reference Update Options dialog.
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 Choose Update Layer Reference.

13.	 In this dialog you check or uncheck the items that you want to resync with the 
original layer. Some of the layer differences are already checked. Check the 
Replace Mismatched Vectors option to bring Layer 4 back in sync with the 
original layer.

14.	 Save this project as Tutorial 7.2 finished.moho. You will find a copy of this 
completed project in your User Content folder.

 Choose Replace mismatched vectors to bring the shape of Layer 4 back in sync with 
the original layer.
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Tutorial 7.3: Breaking and Updating 
Original Layer Connections
In the previous tutorial you learned how you can break and update connections 
between a reference layer and the original layer. You can also break connections 
between the original layer and all of the other reference layers.

To follow this tutorial, you can start where you left off at the previous tutorial, or open 
Tutorial 7.2 Finished.moho from your User Content folder.

1.	 With Tutorial 7.2 Finished opened, select the original Layer 1. At Frame 0, add 
some points to it with the Add Point tool, and change the shape a little with the 
Translate Points tool.

 At frame 0, add some points and change the shape of Layer 1.

2.	 You’ll notice that making this change breaks the connection with all of the 
other reference layers. The icons for the reference layers display a red arrow 
when the connections are broken.

 The reference layer icons turn red when you change the number of points in the 
original layer.

3.	 To reconnect one of the reference layers with the original layer, first select Layer 
2. Right-click the layer and choose Update Layer Reference.
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 Choose Update Layer Reference.

4.	 From the Reference Update Options dialog, choose Replace Mismatched 
Vectors again to bring Layer 2 back in sync with Layer 1. Now Layer 2 has the 
new shape of Layer 1.

 Choose Replace mismatched vectors to bring the shape of Layer 2 in sync with the 
new shape of the original layer.

5.	 Repeat steps 3 and 4 for each additional layer that you want to sync back 
up to the reshaped Layer 1. In our finished example, Layers 1 through 3 are in 
sync again, and Layers 4 through 6 are mismatched. You will find a copy of the 
finished project in your User Content folder, saved as Tutorial 7.3 Finished.moho.
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 At frame 0, add some points and change the shape of Layer 1.

As your scene and reference layers become more complex it 
can be difficult to determine which layer a reference layer is 

linked with. This is easy to remedy. Right-click on the layer that you 
are not sure of. Then choose Locate Original Layer. Moho will 
immediately select the original layer that the reference layer is 
connected with.

You can also turn a reference layer back into a normal layer. 
Right-click on a reference layer and choose Break Layer 

Reference. It will retain any properties that were added to the layer 
while it was referenced to the original layer.

Tutorial 7.4: Using Reference Layers for 
Masking
In this tutorial you will work with a file that contains an eyeball that consists of three 
layers: Eye, Pupil, and Lid.
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 The pupil and lid layers will need some masking to follow the shape of the eye.

The pupil and lid layers in this eye will have to be masked so that they follow the 
shape of the eyeball. We can use Masking on the Eyeball group to mask the layers 
so that the areas outside the Eye layer are hidden. Follow these steps:

1.	 Open Tutorial 7.4 Start.moho, which you will find in the 7 - Layer Referencing 
folder in your User Content folder.

2.	 Double-click the Eyeball group layer, and switch to the Masking tab. Set the 
Group Mask setting to Hide All. The bottom layer (Eye) is used for the mask, and 
the other layers (Pupil and Lid) are masked against it. However, you’ll notice 
that the lid does not have the same outline that the other layers do.

 Set the Masking on the Eyeball layer to Hide All.
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 The eyelid lacks an outline.

3.	 While the Exclude Strokes option in the Masking tab can be used as a 
workaround for this, Layer Referencing offers a more powerful alternative. 
First, Select the Eye layer, then click the Reference Layer button to create a 
reference layer named Eye 2. 

 Click the Reference Layer button to create a copy of the eye.

4.	 Move the Eye 2 reference copy up above all the other layers.

 Move the Eye 2 layer above the other eye layers.

5.	 Now, select the Eye 2 layer with the Select Layer tool, and turn off the fill for 
the eye. Now you have an outline that surrounds the entire eye as you would 
expect.
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 Select the Eye with the Select Shape tool, and turn off the fill.

Alternatively, you can leave the fill on but adjust the 
transparency of the fill layer so that you can see the other 

elements through the Eye 2 layer.

6.	 Now you can modify the shape of the original Eye layer with the Translate Points 
tool, and those changes will automatically be applied to the Eye 2 reference 
layer.

 When you change the shape of the Eye layer, the outline on the Eye 2 layer 
automatically follows the new shape.

7.	 Save the project as Tutorial 7.4 Finished.moho, if desired. A copy of the 
completed project is included in the 7 - Layer Referencing folder in your Moho 
User Content folders.
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Tutorial 7.5: Referencing External 
Documents
Assume that you are working on a project that is divided amongst several people 
You are the animator, and other members of the team include a character artist 
and a background artist. You work in different offices or in different parts of the 
country. Layer referencing offers a way that you can easily collaborate on your 
project, because you can reference external documents in a Moho project.

In the project that follows you (as the animator) will create a new document that 
references two other documents that you will find in the 7 - Layer Referencing 
folder in your User Content folder. These additional files represent the character and 
background art that other people are working on. In actuality, you’ll make some 
minor changes to these files to demonstrate how the changes will be reflected in the 
project that the animator is working on.

Layer referencing can also be used by a person who wants to 
use the same character in more than one project. This allows 

you to create your character once, and then reference it in as many 
projects as you like. Then you can change rigging or colors or make 
other changes in the original character file, and those changes will 
carry through to all the projects in which that referenced character 
is used.

Part 7.5.1: The Main Project Document
1.	 Create a new document. Choose File > Import > Moho Object, and choose the 

Background.moho file. 

2.	 When the Import Object dialog appears, select the Background (do not import 
the Future Work layer). Make sure you check the Import by reference checkbox 
in the Insert Object dialog.

 Check the Import by Reference option to import the working background.
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3.	 Click OK to import the background project, which is a quick sketch of the 
project that the background artist is working on. Moho inserts a reference copy 
of the document into your project. The icons in the Layers palette show a green 
arrow to indicate that an external file is referenced.

 The reference layer icon shows a green arrow to indicate a reference to an external 
document.

4.	 Now you can import the artwork that the character artist is working on. Choose 
File > Import > Moho Object again, and choose Character.moho. 

5.	 Make sure that the Character is checked, and also check the Import by 
Reference checkbox in the Insert Object dialog. Then choose OK to import the 
character.

 Check the Import by Reference option to import the working character.

6.	 Select the Character layer, and use the Transform Layer tool to move the 
character to the left side of the scene on frame 0.
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 Move the character to the left side of the scene.

7.	 Now add some simple animation to the camera using the Zoom Camera and 
Pan Camera tools, similar to that shown in the following figure.

	� Zoom and pan the camera closer and to the left side of the scene in frame 
0.

	� At frame 96, zoom out again and pan toward the right side of the scene.
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 Camera positions at frames 0 and 96.

8.	 Now you’ll work backward to add some simple animation to the arms and legs 
of the character, similar to the following figures:
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 Arms and Legs at Frame 96.

 Arms and Legs at Frame 78.
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 Arms and Legs at Frame 60.

 Arms and Legs at Frame 42.
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 Arms and Legs at Frame 24.

9.	 Now rewind and play the project to watch all your hard work.

10.	 Save your project at this point, to a file location and filename of your choice.

Part 7.5.2: Adding a New Layer to the Character
While you’ve been working on the animation, the other two people have been 
working on the background and character artwork. You get word that there are 
updates to the character. 

But to simulate the updates that have been made to the character, you’ll have to 
make a few simple changes to the character.moho file yourself. To simulate this:

1.	 Open the character.moho file, and select the L Leg layer in the Character 
group.

2.	 Create a new vector layer named Eyes.
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 Create a new Eyes layer in the Character.moho file.

3.	 Click the Reset button in the Style window to reset the stroke and fill properties 
to their default color and size. Then use the Draw Shape tool to add some simple 
eyes for the character.

 New character eyes.

The following step will overwrite the character.moho file that 
was furnished with Moho. If you want to save the original 

version, create a copy of character.moho and save it into your User 
Content folder as a different filename (such as character-bak.moho 
before you perform the next step.

4.	 Choose File > Save to save the project file, over the previous version. 
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5.	 You should now be able to see the changes in your project file that contains 
a referenced copy of this file. Go back to your project and you will notice that 
the reference layer icons now display red arrows instead of green arrows, to 
let you know that there has been a change to the original character file that is 
referenced in your project.

6.	 Right click the Character group and choose Update Layer Reference.

 Choose Update Layer Reference.

7.	 The Reference Update Options dialog asks how you want to handle the 
conflicts. You know the character has a new Eye layer, so you want to make 
sure that Add new/missing layers from the original source is checked. The other 
options in this dialog don’t really apply for the moment, but the options are:

 Reference Update Options.

	� Add new/missing layers from original source: Check this option if the 
original document contains new layers that do not exist in the document 
that references the original.
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	� Remove layers that don’t exist in the original: Check this option if the 
original document no longer has layers that currently exist in the document 
that references the original, because they were removed.

	� Replace mismatched vectors: Check this option if structural changes were 
made to the shapes in the original document (adding or removing points).

	� Replace mismatched bones: Check this option if changes were made to 
the bones in the original document.

8.	 Click OK to import the updated character into the scene. The eyes layer 
appears in your new document.

9.	 If you play back the animation you’ll notice that it is still intact.

 Play back the animation with the character changes.

Part 7.5.3: Rigging Changes
As you’re working on your animation you notice that the bending of some of the 
body parts looks a little less than desireable. For example, when you bend one of 
the arms you notice that the arm bend looks a little squishy and could use some 
touching up. So you let your “rigger” know that some updates are needed.



Moho 13.5
Tutorial Manual 

297

Layer Referencing (Pro Only)

 The character needs some bending improvements.

The rigger decides to add a smart bone that improves the bending of the arm. To 
simulate this change, you’ll create a Smart Bone action that improves the bending 
of the left forearm bone. To simulate the changes, follow these steps:

1.	 In the character.moho document, select the Character bone layer to activate 
the Bone tools.

2.	 Click the L Forearm bone with the Select Bone tool.

3.	 Choose Window > Actions, and click the New button to create a new smart 
bone action named L Forearm (the same as the bone you have selected). 
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 Create a Smart Bone action named L Forearm.

4.	 Advance to a frame other than 0 (such as Frame 48) and bend the character’s 
arm with the Manipulate Bones tool. Then use the Transform Points tool and the 
Curvature tool to improve the bending. Check the midway position as well, and 
makes some changes at Frame 24 if you feel it is necessary. 
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 Tweak bending with the Transform Points and Curvature tools.

5.	 Save these changes into the character.moho document. 

6.	 Return to your project, and you see the bending problem area on Frame 42. 
Select the Character bone group and choose Update Layer Reference. 

 Left forearm bending problem on Frame 42.
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7.	 In the Reference Update Options dialog, verify that Replace mismatched bones 
is checked, and then click OK to update the reference layer. You’ll notice the 
improved bending immediately.

 Check Replace mismatched bones.

 The improved joint bending appears in your project.

Part 7.5.4: Updating the Background
Now the background artist has finished his artwork for the background. The 
background.moho document contains some extra layers that have completed 
artwork for the background. To make the applicable changes, follow these steps:
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1.	 Open the background.moho file and expand the Future Work group. 

2.	 Move the wall, ground 2, and background layers into the Background group. 

 Move the Future Work layers into the Background group.

3.	 Select the Initial Sketch layer and delete it. Then save the background.moho 
document.

 Delete the Initial Sketch layer.

4.	 When you go back to the project document you notice that the reference 
layers for the Background have changed to indicate that there has been a 
change in the Background.moho document.

5.	 Right-click on the Background reference group, and choose Update Layer 
References. Because there are new items in the Background layer, and 
because you also deleted the Initial Sketch layer, you want to make sure that 
both Add new/missing layers from the original source and Remove layers that 
don’t exist in the original are checked. 
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 Reference Update Options dialog for new background.

6.	 After you press OK, you’ll see the Initial Sketch layer in your project go away, 
and the layers that were moved into place in the Background layer will appear 
in the background.

 The finished project.

7.	 Choose File > Save to save your finished version of the project. A completed 
version is located in your User Content folder, and is named Tutorial 7.5 Finished.
moho.
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Animating foreshortening and complex actions are easier than ever!

Inspired by Da Vinci’s Vitruvian Man drawing, Vitruvian Bones (or V-bones) is a new 
and powerful way to rig your characters. The intuitive V-bones system allows you 
to alternate different drawings and sets of bones in one single layer. For instance, 
you can have different sets of heads, each with its own controllers. Or just draw the 
same limb in different perspectives and Vitruvian bones will allow you to group and 
animate them on the fly just by switching from one to the next. V-bones can be 
applied to any part of the body. You can even switch between entirely different 
bodies, all in the same bone layer!  This unique approach to Vitruvian bones makes it 
easier to have a rigged character with the appeal of traditional animation.

Tutorial 8.1: Create a Vitruvian Group

To understand the basics. Let’s create a simple Vitruvian Group in an empty file.

First, be sure to be in frame 0.

Change the name of the empty vector layer in the project to ‘Arm 1’  and use the 
drawing tools to create an arm.

Now create a second vector layer, name it ‘Arm 2’ and draw the same arm, but in a 
different pose.
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So now you have two arms, each one in its own vector layer.

Go to the Layers window, create a Bone layer and drag both arms inside of it.

Your layers should look similar to this:

Select the Bone layer and then the Add Bones tool (A) and create one bone for the 
body and then bones for each arm.

Even when we will see only one arm at the time, just rig your character as it has two 
arms.

You need to be sure both arms are children of the main body bone:
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Once you have your bones created, Moho needs to know what bones should move 
and bend each arm. This step is not always necessary when you are creating a rig, 
but it’s crucial for Vitruvian bones to work.

To give the software this information we will use the selective Flexi-Binding option.

Luckily, it’s a simple and quick process.

Select the ‘Arm 1’ vector layer.

Now use the Select Bone tool and select the three bones related to that arm.

You can use the Rectangle selection, lasso mode or hold Shift + clicking to add 
bones to the selection.

Hold Ctrl and click over a bone if you need to remove it from the selection.

So now you have the ‘Arm 1’ layer selected and also the bones that should move 
that layer.

Go to the Bone menu and click on ‘Use selected bones for Flexi-Binding’ (or simply 
press Ctrl+Shift+F in Windows or Cmd+Shift+F in macOS)
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These bones will look bold everytime that vector layer is selected. This means that 
these bones are the only ones that will move that specific layer.

Now select the ‘Arm 2’ layer and repeat the same process: Select the bones and go 
to Bone -> Use Selected Bones for Flexi-Binding

In this exercise, we are only creating two different arms, but you can repeat the 
same process for as many limbs as you’d like to have in your character.

Now go to the Tools bar and use the Vitruvian Bones tool. This tool works very similar 
to the Select Bone tool, but also allows to create Vitruvian Groups.

To do it, simply select the first bone of each arm



Moho 13.5
Tutorial Manual 

307

Vitruvian Bones

And then click on the Group button

You will notice one arm will disappear and the other one will have a special design. 
This design means this is a Vitruvian Bone.

To test it, simply select any bone from the arm and then go to the Active Bone menu 
in the Vitruvian Bones toolbar

This menu shows you the names of the bones (in this case they have the default 
names, but you can rename the bones if you want). Depending on which one you 
select, that arm will appear on the screen.
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Tip:

You can also change the Active Bone by simply pressing Alt+D or Alt+C as many 
times as you need.

This method is much quicker and works without the need of using the Vitruvian Bone 
tool.

As far as one of the bones of the arm is selected, you will be able to use it.

(And, unrelated to this section, this shortcut also work with Switch Layers)

As you can see, the design of a Vitruvian Bone looks different to the rest of bones, 
with a semi-circle and two lines at the bottom.

This design will help animators know when they have the option to animate Vitruvian 
Bones.

Tutorial 8.2: Rigging Vitruvian Bones

Although Vitruvian Bones need to be set up with the ‘Use Selected Bones For Flexi-
Binding’ menu in order to work correctly, you are not limited to that option.

After you use that menu, you can still Bind points or Entire layers to specific bones, 
create Smart bones for joints or control Levers and use any tool you would normally 
use for rigging a character.

As you can see here, this character is using Point Binding for the arm:
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Also, Vitruvian bones are not limited to one layer. You can attach as many layers as 
you want to Vitruvian Bones and they can be anywhere inside of the Bone layer.

So, for instance, an arm can be split in two layers: Arm and Forearm. Then the arm 
can be behind the body layer and the forearm in front of it, as you can see here:

Animating Vitruvian Bones

Basic concepts of the timeline:

To animate with Vitruvian Bones, it’s very important to understand some basic 
concepts of Moho’s timeline:

For most of the channels, there’s a white and a red channel.

The red channel only shows the keyframes of the element you have selected at the 
moment.

The white channel shows you keyframes of any of the elements that have movement 
in the selected layer.
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So, as a summary:

The red channel works to modify and re-time specific movement

The white channel is useful to modify and re-time all the elements at once.

Animating with Vitruvian Bones

When you start animating Vitruvian Bones, you will notice some new channels 
appearing in the timeline. These are special channels and behave a bit different 
from the rest.

First, you will notice the Vitruvian Bones channels. These channels will appear every 
time you change the Active Bone on a Vitruvian Bones Group (by using the tool 
menu or the Alt+D and Alt+C shortcuts):

Vitruvian Bones

Every time you change the Active Bone of any Vitruvian Group during your 
animation, this channel will show you a Keyframe at that frame.

Selected Vitruvian Bones

This channel is very similar to the previous one, but it only shows the keyframes of the 
Vitruvian Group selected at that moment.

If you select a bone that is part of a Vitruvian Group, this channel will show 
keyframes every time you change the Active Bone of that specific Vitruvian Group.

You also will see the Vitruvian Bones Consolidated channels:

Vitruvian Bones Consolidated

This channel shows a general summary of every Vitruvian bone animated.

If any of the Vitruvian Bones in the Bone layer has a keyframe (it can be in Rotation, 
Scale, Translation, Flip or any bone animation channel), a keyframe will also appear 
in the Vitruvian Bones Consolidated channel.

This channel is very important, because it shows the entire animation in the timeline, 
even for bones that are not visible at the time.
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This allows to modify and re-time an entire animation easily.

Selected Vitruvian Bones Consolidated

This channel is very similar to the previous one, but it only shows the keyframes of the 
Vitruvian Group selected at that moment.

If you select a bone that is part of a Vitruvian Group, this channel will show 
keyframes in the frames where any of the bones of that group has keyframes.

This channel is especially useful if you want to modify the animation in a specific 
group. For instance, all your animation is working fine, but the left Arm is moving too 
slowly. Then you can modify the keyframes of this channel to adjust the timing of the 
entire group at once.

Look at this example:

 

The VItruvian Bones Consolidated channel shows there’s animation at frames 6, 12 
and 18. This is a general summary that shows that in frames 6, 12 and 18 the Vitruvian 
Bones are animated.

 

The Vitruvian Bones channel shows that one or more Vitruvian Active Bones have 
been changed in frames 6 and 18.
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The Selected Vitruvian Bones Consolidated channel shows that the bone selected 
(right arm of the character) is part of a VItruvian Group and that that group has 
keyframes in frames 6 and 12. This Vitruvian arm is not moving at frame 18, so there’s 
no keyframe there.

 

The Selected Vitruvian Bones channel shows that the bone selected (right arm of 
the character) is part of a Vitruvian Group and that specific group has changed the 
Active Bone only in frame 6.

Disabling Vitruvian Bones Groups

If you want to see and edit all the bones and content from a Vitruvian group, you 
can temporarily disable that group.

This option is very useful to make changes on the overall design, add Smart Bones or 
make adjustments on the animation.

Just use the Vitruvian Bones Tool, select one bone from the Vitruvian Group you want 
to disable and uncheck the Enabled box in the toolbar
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Disabled

You can also Disable or Enable every Vitruvian Group from a character by going to 
the menu

Bone -> Disable All Vitruvian Bones

Bone -> Enable All Vitruvian Bones

All Vitruvian Bones Disabled:
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Adding and Removing Bones from a Vitruvian Group

If you want to Add a bone chain to an already created Vitruvian Group,

•	 Use the Vitruvian Bone tool

•	 Select one of the main bones from the Vitruvian Group you want to edit

•	 Holding shift, add the chain of bones you want to add to the selection

•	 Press the + button to add the chain to the Vitruvian Group 
 

•	 If you want to remove a chain of bones from a Vitruvian Group

•	 Use Vitruvian Bones tool

•	 Select the main bone of the chain you want to remove from the group

•	 Press the - button 
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Tutorial 9.1: Wind Dynamics

Wind is the newest addition to the powerful and easy to use Physics toolset Moho 
offers. Take absolute control over the strength, direction and turbulence of wind and 
make your scenes come alive in minutes. Give your backgrounds and characters 
new life with Wind Dynamics!

To use wind, you must select a Bone layer and be sure you are at frame 0.

Use the Select Bone tool (B) and select one or more bones you want to react with 
Wind

In this case, we want the hair to automatically move with the wind, so we select all 
the bones related to the hair

Now in the Select Bone toolbar, open the Bone Constraints window and activate 
both  Bone Dynamics and Wind
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Now the bones are ready to receive the wind.

Press Close in the Bone Constraints Window and now select the Wind Tool

A red Arrow will appear over the layer

This arrow shows how the wind is moving in real time and makes it easier to know 
what values to choose next.

Wind Values

With the Wind tool you can edit these four values

•	 Direction: This shows the direction of the Wind in degrees. A value of 0 means 
the wind will be fully horizontal and pointing to the right. Making the number 
smaller or bigger, will make the wind rotate clockwise or counterclockwise.

•	 Strength: This value shows how strong the wind is. A value of 0 means no wind at 
all and 100 is the maximum amount. 
 
When you modify this value, you will see the Red Arrow becomes shorter or 
longer, depending on the number.

•	 Turbulent amplitude and Turbulent frequency: These two values are related to 
each other and they modify and animate the angle and strength of the wind to 
give the sensation of turbulence. 
 
Without turbulence, the bones reacting to the wind can look unnatural, 
because their movement will be very flat, with no small variations. 
 
A higher value for Turbulent amplitude means the angle and strength of the 
wind will change more dramatically during the animation. 
 
A higher value for Turbulent frequency means those changes in angle and 
strength will occur more often, so the wind can jump from very strong to very 
weak in a few frames. And the same will happen with its angle.
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Using right click or the mouse wheel to modify the values

You can edit these and any numeric values in Moho by using the mouse wheel or 
pointing the cursor over the number and drag right click to the left or right.

Holding Shift or Ctrl (Cmd in macOS) while doing it, you can make the change of 
values bigger or smaller.

Testing Wind in real time

To check how the Wind is affecting your characters, background elements or props, 
you can simply hit play in the timeline and then modify the wind values using the 
technique explained above.

Moho will show you in real time how the new values are affecting the bones with 
Wind Dynamics applied.

The red arrow will also be updated automatically, making easier the Wind 
adjustments.

Animating Wind

There are three new channels for Wind:

•	 Wind Direction

•	 Wind Strength

•	 Wind Turbulence

If you modify these values at any frame, a keyframe will be created there.

The values for Wind Direction and Wind Strength can be edited in the Motion Graph
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You can also copy and paste Wind keyframes between different bone layers.

Bones properties

The Dynamics properties for each bone can also be modified.

If you use the Select Bone tool and select one or more bones, you can open the 
Bone Constraints window and change the values there too.

Depending on the values you pick for Torque, Spring and Damping, the reaction of 
the bone to the wind will be different

•	 Torque Force: Defines how big will be the movement

•	 Spring Force: Defines how much the movement will bounce. The smaller the 
value, the softer the movement will be

•	 Damping Force: Defines how long it will take to the bone to go back to its initial 
angle. The bigger the value, the less time it will take.
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Perspective warp and Quad 
warp

Tutorial 10.1: Perspective warp and Quad warp

Animate backgrounds, props and characters in perspective with the new 
Perspective Mesh.

Just create a shape with four points, attach it to any image or vector layer and 
animate it.

This simple but powerful mesh can be used in combination with triangular meshes, 
making Moho more flexible than ever.

Creating a True Perspective Mesh

With Moho, you can create Meshes of 4 points and use them to animate any vector 
or image in true perspective.

The process to do this is very simple. Let’s say you have a vector layer with a map:
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To create a Perspective mesh, create a new Vector Layer and call it ‘mesh map’

In the ‘mesh map’ layer, draw and fill a rectangle covering the entire map

Now, since we don’t want to see the rectangle, but only use it as a Mesh, go to the 
Layers window and double click the ‘mesh map’ layer to open its properties.

Then check Hide in editing view and Don’t render this layer and click OK.

The rectangle will become invisible.

Open the Layer properties of the ‘map’ layer, go to the Vectors tab, select ‘mesh 
map’ as Smart warp layer and click OK.
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You are done!

Now to test the mesh, go to any frame different to frame 0 and use the Translate 
points tool to move the points in the mesh map layer.

You will see how the perspective changes while you move them.

Tip: Perspective mesh only works if the shape of the mesh is valid. That the mesh 
won’t work if you fold it over itself.

For instance. This shape will work well, because it’s a valid perspective
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This shape instead is illegal, because it doesn’t follow the logic of perspective, so it 
won’t work

Quad warp

Quad warp works in a similar way to the perspective mesh, but it works to create 
better characters expressions, head turns, 3D effect or any modification over a 
vector or bitmap character.

Again, to create a Quad warp mesh is very simple.

Let’s create a mesh for this character
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First, create a vector layer and call it ‘mesh fox’

Now use the Add Points tool to create draw a mesh over it 

To make the mesh you need to consider this

•	 The mesh must be bigger than the content. Otherwise, anything that is not 
inside of the mesh won’t work well or won’t be shown in the animation

•	 The mesh must be created using shapes of 3 or 4 points

Once you have your mesh done, you need to paint every single shape there. But 
don’t worry, we have a script that does it automatically!

This script was generously donated by the Moho beta user Paul Cheshire (thanks 
again, Paul!)

So, be sure you have the ‘mesh fox’ layer selected and go to the Menu

Script -> Draw -> Fill Quad Mesh
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The script will automatically create a shape for every quad and triangle in the mesh.

If there’s any issue with the mesh, you will get an error message and will able to see 
where is the issue:

In this case, there’s a point in the eye that invalidates that part of the mesh, because 
it has 5 points instead of 4.

To fix it, simply remove the point and run the script again.

Once the mesh is ready, you need to open the Properties of the ‘mesh fox’ layer, 
check Hide in editing view and Don’t render this layer and click OK.
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Now open the Properties of the image layer of the head, go to the Image tab, 
select ‘mesh fox’ as its smart warp layer and click OK.

Now the head is ready to be animated!

Some tips about rigging characters with meshes:

•	 You can assign the same mesh to as many layers as you want.

•	 You can even assign a mesh to another mesh, so you can have two or more 
levels of movement

•	 If a bone is moving a mesh and also an image/vector controlled by it, be sure 
to use the Bind Layer tool to bind both layers to the same bone. Doing this 
can avoid problems like having a layer moving twice as fast, which happens 
because the layer is moved in the same direction by both the bone and the 
mesh layer.
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Animating Quad warp meshes

Once you have everything setup, animating quad meshes is very simple. Just use the 
Translate Points tool (T) to move the points of the mesh.

You can also use the Magnet Tool (X) to nudge several points at the same time.

To modify the size of the magnet, just hold Alt in the keyboard and drag the mouse 
or pen left or right.

You can also try simpler meshes for objects and characters


